Обработка создания одноразовых купонов. 1С:Розница 2.2.9

Публикация № 919186

Отчеты - Розничная торговля

купоны скидки

6
Обработка заполняет "Состояние однократных скидок и купонов" номерами одноразовых купонов генерированным списком. Купоны раздаются покупателям и можно применять в маркетинге.

В программе 1С:Розница при покупке можно указать в чеке купон, что бы потом можно было пробить этот купон на кассе и получить скидку. В нем используется QR код, но не всегда есть сканер штрихкода итд. Купоны генерируются на основании чека, но такой удобный функционал не может быть не использован на полную. По этому сделали генератор купонов, который заполняет "Состояние однократных скидок и купонов" своими купонами.

Описание и Функции:

1. Период действия - заполняет период до которого действуют купоны.

2. Магазин - в котором будут действовать купоны.

3. Скидка - назначение конкретной скидки к купону.

4. Количество кодов - сколько кодов генерировать. 1 до 999

5. Длинна кода - длинна генерируемого кода от 1 до 99

6. Сгенерировать купоны - заполняет табличную часть номера сгенерированных купонов.

7. Удалить совпадения с регистром - проверяет Регистр сведений на дубли, если дубли есть, то удаляет их из списка.

8. Вывести список - стандартная команда формы, выводит список Купонов для печати или сохранения.

9. Создать купоны - производит запись в регистр "Состояние однократных скидок и купонов", при записи идет проверка из пункта (7)

Обработка создана на скорую руку, попробовать по этому открывается через "Файл" - "Открыть". 

Создана для 1С:Розница 2.2.9.20.

Купоны вводятся в РМК в разделе "Управл. скидки" - "промокод"

Новое в версии 1.1:

1. Ограничена длинна кода до 15 символов.

2. Проверка корректности заполнения полей Длинна Кода и Количество кодов.

3. Добавлена печать Штрих кода, встроенным методом 1С:Розница (МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода)

Новое в версии 1.2:

1. Добавлена информация об обработке.

2. Добавлена регистрация обработки в документе Маркетинговые акции.

6

Скачать файлы

Наименование Файл Версия Размер
Обработка создания одноразовых купонов. 1С:Розница v.1.2
.epf 13,51Kb
12.10.18
15
.epf 1.2 13,51Kb 15 Скачать
Обработка создания одноразовых купонов. 1С:Розница v.1.0
.epf 10,51Kb
11.10.18
1
.epf 1.0 10,51Kb 1 Скачать
Обработка создания одноразовых купонов. 1С:Розница v.1.1
.epf 12,47Kb
12.10.18
0
.epf 1.1 12,47Kb Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Migel86 12.10.18 12:13 Сейчас в теме
Хорошая обработка, довольно таки удобная.
2. artfa 40 25.02.19 18:25 Сейчас в теме
3. lordromanoff 27.03.19 12:00 Сейчас в теме
4. Voblhned 39 27.03.19 18:20 Сейчас в теме
(3) Вы 5 лет на сайте и не знаете этого или это риторический вопрос?
5. user890763 12.04.19 15:42 Сейчас в теме
А для Управление торговлей есть такое?
8. EliWalles 22.05.19 09:32 Сейчас в теме
Поддерживаю вопрос (5), интересует подобное расширение для УТ 11.4
6. rounder 170 06.05.19 16:06 Сейчас в теме
ошибку выкидывает Поле объекта не обнаружено МенеджерПечати
7. Voblhned 39 06.05.19 19:51 Сейчас в теме
(6) на какой версии вы открыли?
9. tezdal 15 26.06.19 11:22 Сейчас в теме
создает кучу дублей. сча полезу в код скажу из за чего
10. tezdal 15 26.06.19 12:09 Сейчас в теме
Предлагаю такой вариант, тоже подсмотрен у кого то

// генератор Случаного Купона
&НаСервере
Функция СоздатьКодНаСервере()
	
	ГСЧ = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
	
	КодКупона = "";
	Неиспользуемые = ":<=>?@;[\]^_`"; //исключения
	
	Пока СтрДлина(КодКупона) < Объект.ДлиннаКода Цикл        
		Набор = ГСЧ.СлучайноеЧисло(1,4);    
		Если Набор = 1 Тогда
			СлучайныйСимвол = ГСЧ.СлучайноеЧисло(0,9);    
		ИначеЕсли Набор = 2 Тогда
			СлучайныйСимвол = Символ(ГСЧ.СлучайноеЧисло(48,65));
		ИначеЕсли Набор = 3 Тогда
			СлучайныйСимвол = Символ(ГСЧ.СлучайноеЧисло(65,90));
		ИначеЕсли Набор = 4 Тогда
			СлучайныйСимвол = Символ(ГСЧ.СлучайноеЧисло(97,122));
		КонецЕсли;
		Если Найти(Неиспользуемые, СлучайныйСимвол) > 0 Тогда 
			Продолжить;
		КонецЕсли;
		КодКупона = КодКупона + СлучайныйСимвол;
	КонецЦикла;      
	Возврат КодКупона;    
КонецФункции
Показать


Плюсом можно нарисовать проверку дублей конечно.
11. Voblhned 39 26.06.19 19:20 Сейчас в теме
(10) можно и проверку сделать =)
12. user1192121 05.08.19 14:39 Сейчас в теме
В каком справочнике можно посмотреть созданные купоны и удалить не нужные?
13. fixin 3847 05.08.19 17:34 Сейчас в теме
(12) в РегистрСведений.СостоянияОднократныхСкидокИКупонов
т.е. Все функции - регистры сведений - Состояния однократных скидок и купонов.
Кстати, в рознице 2.2.5.23 нет еще этого регистра.
Оставьте свое сообщение