HTTP Сервисы: Путь к своему сервису. Часть 2

Публикация № 885287

Разработка - Инструментарий разработчика

HTTP-сервис API JSON IIS http web apache сервис Публикатор Линк PAPI Pretty API atom-xml XML oData Код состояния Get Post Patch

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 1». В этой части будет "Микс" из OData+HTTP-Сервис(Get)+СКД. Наш пример будет работать как в браузере, так и в написанной нами обработке. Работать будем с разными версиями платформ.

В первой части мы создали каркас для Get метода в расширении конфигурации. Как Вы помните, мы получали через один метод список или конкретный документ, давайте рассмотрим еще один инструмент, позволяющий без особого труда и без доработок конфигурации получать те же данные. Как Вы догадались, начнем разговор с OData, далее смиксуем OData с нашим сервисом который будет возвращать данные на основе СКД. 

Как и в предыдущей статье http-сервис будет в расширении конфигурации ERP 2.4.3.145 на платформе 8.3.10.2650, а вот посылать запросы и получать ответы будем в Демо конфигурации БСП 3.0.1.231 на платформе 8.3.12.1567. Специально чтобы версии платформы отличались.

Начнем.

Немножко про OData.

Для начала дам ссылки, где можно почитать про использование OData в 1с:

  1. Глава 17.2.1. Cтандартный интерфейс OData
  2. Приложение 12. Описание сущностей, предоставляемых через стандартный интерфейс OData
  3. Способы интеграции с 1С

Давайте кратенько пройдем по основным пунктам.

 
1 Как опубликовать OData? 

 В конфигураторе Администрирование/Публикация на веб-сервере...

 
2 Из чего складывается URL OData? 

http://host/base/odata/standard.odata/ПрефиксИмени_ИмяОбъектаКонфигурации_СуффиксИмени/Параметры?Параметры&УсловияОтбора

host – IP адрес или доменное имя веб сервера.

base – Имя базы. Указывается при публикации.

odata/standard.odata - Признак обращения к стандартному интерфейсу OData.

ПрефиксИмени - Представление объекта конфигурации для указания в URL (Объекты доступные в OData и их префиксы описаны в главе 17.2.1.4. Правила формирования имени ресурса, а так же можно посмотреть с помощью обработки Доступный состав стандартного интерфейса OData).

ИмяОбъектаКонфигурации - свойство Имя объекта конфигурации, как оно задано при разработке прикладного решения в конфигураторе.

СуффиксИмени - предназначено для уточнения имени ресурса и является необязательной частью имени. В качестве суффикса имени могут выступать следующие выражения:

  • Имя табличной части объекта;
  • Имя реквизита табличной части или набора записей;
  • Имя виртуальной таблицы регистра;
  • RowType;
  • RecordType.

Праметры и УсловияОтбора – В качестве параметров обращения выступают параметры в виде, принятом для HTTP-запросов: ?ключ=значение&ключ2=значение2.
При обращении к ресурсу могут использоваться специальные ключевые слова, имеющие специальное назначение:

  • $format - указывает, в каком формате необходимо получить данные. Если ключевое слово не указано, данные получаются в формате atom-xml.
  • $format=atom - возвращает данные в формате atom-xml.
  • $format=json - возвращает данные в формате json. Для указания того, что данные должны возвращаться в формате json, можно указать MIME-тип application/json в заголовке Accept HTTP-запроса на получение данных.
  • $metadata - указывает, что требуется получить описание стандартного интерфейса OData.
  • $filter - описывает отбор, применяемый при получении данных.
  • $select - описывает перечень свойств сущности, которые получаются при обращении к стандартному интерфейсу OData. 
 
 3 Какие HTTP-методы используется в OData?
  • GET - Получение данных;
  • POST - Создание объекта;

Обновление данных:

  • PATCH - в этом случае можно указывать только те свойств, которые необходимо обновить;
  • PUT - в этом случае необходимо указывать все свойства сущности;
  • DELETE - Удаление данных.

Лично я использую только GET, так как изменение, добавление и тем более удаление данных через OData считаю неправильным (потенциально опасным) для Учетных систем. Данные методы могут быть хороши для конфигурации разработанной например под мобильный клиент, ну или под сайт.

Давайте узнаем, сколько элементов в справочнике Склады в Демо конфигурации ERP 2.4.3.145.

Для этого мы будем использовать параметр $count. Наш запрос: 

http://127.0.0.1/DemoEnterprise2_4_3_145/odata/standard.odata/Catalog_Склады/$count

Как мы видим, получить данные не удалось. В чем же дело?

Дело в том, что начиная с версии платформы 8.3.5.1068 необходимо использовать метод УстановитьСоставСтандартногоИнтерфейсаOData для того чтобы объекты конфигурации были доступны для использования в OData. Давайте воспользуемся обработкой Доступный состав стандартного интерфейса OData и дадим доступ к нужному нам справочнику.

Проверяем наш запрос еще раз.

Как мы видим в конфигурации 49 элементов справочника Склады.

 

Давайте нарисуем сервис по получению остатков на складе, при этом в ЕРП мы будем брать за основу отчет «ОстаткиИДоступностьТоваров» и на основании СКД макета будем получать данные и возвращать их в формате JSON (Реализовано в версии 8.3.6.1977). Обращаться к сервису будем с помощью обработки из конфигурации на платформе 8.3.12.

Хочу сразу сказать json выбран из-за своей компактности, удобочитаемости и легкости работы с данным форматом.

 
Для примера сравните atom-xml и json, я вывел один и тот же элемент в этих форматах. 

Для начала нам нужно получить в обработку перечень складов (наименование и идентификатор), при этом склады должны быть элементами, не помеченными на удаление.

Проверим сколько таких элементов: http://127.0.0.1/DemoEnterprise2_4_3_145/odata/standard.odata/Catalog_Склады/$count?$select=Ref_Key,Description&$filter=DeletionMark eq false and IsFolder eq false&$format=json;odata=nometadata

38 это немного, нас это вполне устраивает, будем создавать на форме реквизит cклад, и заполнять список данными полученными по OData.

Создаем обработку «ПолучитьОстаткиИДоступностьТоваров.epf», добавляем форму и добавляем на нее реквизит «Склад» с типом строка и команду ЗагрузитьСклады

 
 Текст команды ЗагрузитьСклады
&НаКлиенте
Процедура ЗагрузитьСклады(Команда)
	ПолучитьСписокСкладовНаСервере();	
КонецПроцедуры
&НаСервере
Процедура ПолучитьСписокСкладовНаСервере()
	//Чистим список
	Элементы.Склад.СписокВыбора.Очистить();
	
	//В тестовых обработках так делать можно, но когда делаете в рабочей такие вещи НЕДОПУСТИМЫ!
	//Храните логины и пароли в недоступных для глаз местах! (https://its.1c.ru/db/v8std#content:2149184389:hdoc) 
	перПорт = 0;
	перСервер = "127.0.0.1";
	перПользователь = "Администратор (ОрловАВ)";
	перПароль = "";

	//Формируем запрос для OData
	перРесурсНаСервере = "/DemoEnterprise2_4_3_145/odata/standard.odata/";	
	перРесурсНаСервереФин = перРесурсНаСервере + 
	"Catalog_Склады?$select=Ref_Key,Description&$filter=DeletionMark eq false and IsFolder eq false&$format=json;odata=nometadata";
	
	Попытка
		Если перПорт <= 0 Тогда 
			HTTPСоединение = Новый HTTPСоединение(перСервер,,перПользователь,перПароль);
		Иначе 
			HTTPСоединение = Новый HTTPСоединение(перСервер,перПорт,перПользователь,перПароль);
		КонецЕсли;
		
		HTTPЗапрос= Новый HTTPЗапрос(перРесурсНаСервереФин);
		HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
		
		РезультатМассив = Новый СписокЗначений;	
		Если HTTPОтвет.КодСостояния = 200 Тогда 
			Ответочка = HTTPОтвет.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);	
					
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(Ответочка);
			Попытка
				ДопДанные = ПрочитатьJSON(ЧтениеJSON);
			Исключение
				ДопДанные = "";
			КонецПопытки;
				
			Если ТипЗнч(ДопДанные) = Тип("Структура") Тогда
				//Заполняем список Складов
				Если ДопДанные.Свойство("Ref_Key") и ДопДанные.Свойство("Description") Тогда 
					Элементы.Склад.СписокВыбора.Добавить(ДопДанные.Ref_Key,ДопДанные.Description);
				ИначеЕсли ДопДанные.Свойство("value") Тогда
					ДопДанные = ДопДанные.value;
					
					Если ТипЗнч(ДопДанные) = Тип("Массив") Тогда	
						Для Каждого элМассива из ДопДанные Цикл 
							Если ТипЗнч(элМассива) = Тип("Структура") Тогда
								Если элМассива.Свойство("Ref_Key") и элМассива.Свойство("Description") Тогда 
									Элементы.Склад.СписокВыбора.Добавить(элМассива.Ref_Key,элМассива.Description);	
								Иначе
									//Нет Ref_Key
								КонецЕсли;
							КонецЕсли
						КонецЦикла;
					КонецЕсли;
				Иначе
					//Нет Ref_Key
				КонецЕсли;	
			Иначе 
				//не смогли прочитать
			КонецЕсли;	

		КонецЕсли;
	Исключение
		Сообщить("Подключится к ERP не получилось: "+ОписаниеОшибки());	
	КонецПопытки;
	
	HTTPСоединение = Неопределено;

КонецПроцедуры

 

У реквизита Склад делаем РежимВыбораИзСписка

Первая часть сделана, давайте перейдем к нашему отчету в ЕРП.

Мы видим следующую картину:

Это значит, что при попытке программно получить данные из СКД в ДеревоЗначений мы получим ошибку.

 
 Ошибка при вызове метода контекста (Выполнить)

        МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновки, НастройкиКомпоновки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));

по причине:

Ошибка компоновки макета

по причине:

Ошибка генерации макета

по причине:

Не поддерживается вывод таблиц и диаграмм в универсальную коллекцию значений

Есть несколько путей решения данной проблемы, я пойду самым простым. В расширение добавлю отчет и создам в нем нужный мне макет.

Теперь можно создать новый метод «ОстаткиИДоступностьТоваровПоСкладу». Подготовлю почву под следующую часть данного цикла статей и создам модуль «PAPI_ОбработкаУниверсальныхМетодов»

 
 Код модуля PAPI_ОбработкаУниверсальныхМетодов
#Область Методы
Процедура ПолучитьОстаткиИДоступностьТоваровПоСкладу(СтруктураОтвет,СтруктураВхПараметров) Экспорт 
	//ПраметрыЗапроса - number
	Склад_Key = СтруктураВхПараметров.ПараметрыЗапроса.Получить("Ref_Key");

	Если не Склад_Key = Неопределено Тогда
		//Получаем Склад
		Попытка
			Склад = XMLЗначение(Тип("СправочникСсылка.Склады"), Склад_Key); 
		Исключение
			Склад = Неопределено;
		КонецПопытки;
		
		Если ЗначениеЗаполнено(Склад) Тогда 
			//Получаем схему компоновки и вариант отчета
			//СхемаКомпоновки = Отчеты.ОстаткиИДоступностьТоваров.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
			//ВариантНастроеки = СхемаКомпоновки.ВариантыНастроек.Найти("ОстаткиИДоступностьТоваров");	
			СхемаКомпоновки = Отчеты.PAPI_ХранилищеМакетов.ПолучитьМакет("СКД_ОстаткиИДоступностьТоваров_HTTP");
			ВариантНастроеки = СхемаКомпоновки.ВариантыНастроек.Найти("ОстаткиИДоступностьТоваровНеТаблица");
			НастройкиКомпоновки = ВариантНастроеки.Настройки;	
				
			//Взято из модуля отчета.ОстаткиИДоступностьТоваров "ПриКомпоновкеРезультата"++	
			ТекстЗапроса = СхемаКомпоновки.НаборыДанных.Основной.Запрос;

			ТекстЗапроса = СтрЗаменить(
				ТекстЗапроса, 
				"&ТекстЗапросаВесНоменклатуры", 
				Справочники.УпаковкиЕдиницыИзмерения.ТекстЗапросаВесУпаковки("Набор.Номенклатура.ЕдиницаИзмерения", "Набор.Номенклатура"));
					
			ТекстЗапроса = СтрЗаменить(
				ТекстЗапроса, 
				"&ТекстЗапросаОбъемНоменклатуры", 
				Справочники.УпаковкиЕдиницыИзмерения.ТекстЗапросаОбъемУпаковки("Набор.Номенклатура.ЕдиницаИзмерения", "Набор.Номенклатура"));

			СхемаКомпоновки.НаборыДанных.Основной.Запрос = ТекстЗапроса;
			//Взято из модуля отчета.ОстаткиИДоступностьТоваров "ПриКомпоновкеРезультата"--                           	
					
			ПрараметрОтбора = НастройкиКомпоновки.Отбор.Элементы;
			СкладПолеКомпоновки = Новый ПолеКомпоновкиДанных("Склад");
			Для Каждого СтрокаОтбора из ПрараметрОтбора Цикл 
				Если СтрокаОтбора.ЛевоеЗначение = СкладПолеКомпоновки  Тогда
					СтрокаОтбора.Использование 	= Истина;
					СтрокаОтбора.ВидСравнения 	= ВидСравненияКомпоновкиДанных.Равно;
					СтрокаОтбора.ПравоеЗначение = Склад; 	
				КонецЕсли;
			КонецЦикла;	
						
			КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
			
			МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновки, НастройкиКомпоновки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
				
			ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;     
			ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,,,Истина);
			
			ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;     
			ДеревоЗначений = Новый ДеревоЗначений;     
			ПроцессорВывода.УстановитьОбъект(ДеревоЗначений);         	
			ПроцессорВывода.Вывести(ПроцессорКомпоновки);
				
			//Обходим дерево и формируем РезультатОтвет
			РезультатОтвет = Новый Массив;
			Для Каждого ВерхнийУровеньДерева Из ДеревоЗначений.Строки Цикл	
				Для Каждого ПодчиненныйУровеньДерева Из ВерхнийУровеньДерева.Строки Цикл	
					Если ЗначениеЗаполнено(ПодчиненныйУровеньДерева.Номенклатура) 
						И ТипЗнч(ПодчиненныйУровеньДерева.Номенклатура) = Тип("СправочникСсылка.Номенклатура") 
					Тогда 
						РезультатОтвет.Добавить(Новый Структура("ИмяЗначение,Артикул,Guid,ДоступноСейчас,Остаток",
						ПодчиненныйУровеньДерева.Номенклатура.Наименование +
							?(ЗначениеЗаполнено(ПодчиненныйУровеньДерева.Характеристика),
								","+Строка(ПодчиненныйУровеньДерева.Характеристика),""),
						ПодчиненныйУровеньДерева.НоменклатураАртикул,
						XMLСтрока(ПодчиненныйУровеньДерева.Номенклатура),
						ПодчиненныйУровеньДерева.ДоступноСейчас,
						ПодчиненныйУровеньДерева.ВНаличии));
					КонецЕсли;	
				КонецЦикла;
			КонецЦикла;
				
			//РезультатОтвет в JSON
			ПараметрыJSON	= Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " " , Истина, ЭкранированиеСимволовJSON.Нет, Ложь, Ложь, Ложь, Ложь);
			ЗаписьJSON		= Новый ЗаписьJSON;
			ЗаписьJSON.ПроверятьСтруктуру = Истина;
			ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);

			ЗаписатьJSON(ЗаписьJSON, РезультатОтвет);
			Результат = ЗаписьJSON.Закрыть();
				
			СтруктураОтвет.ДанныеОтвета = Результат;
			
			СтруктураОтвет.Вставить("ФорматОтвета",PAPI_ОбщиеПроцедурыИФункции.ФорматОтветаJSON());
		Иначе
			PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Не заполнен или неверно заполнен параметр ""Ref_Key""",ложь,"");	
		КонецЕсли;	
	Иначе
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Отсутствует параметр ""Ref_Key""",ложь,"");	
	КонецЕсли;	
КонецПроцедуры	
#КонецОбласти

 

Так же добавим модуль PAPI_ОбщиеПроцедурыИФункции

 
 Код модуля PAPI_ОбщиеПроцедурыИФункции
//Заполняем структуру ответа
Процедура ЗаполнитьСтруктуруОтвета(СтруктураОтвет,КодОтвета,ТекстОшибки,Отработало,ДанныеОтвета) Экспорт
	СтруктураОтвет.КодОтвета 	= КодОтвета;
	СтруктураОтвет.ТекстОшибки	= ТекстОшибки;
	СтруктураОтвет.Отработало	= Отработало;
	СтруктураОтвет.ДанныеОтвета = ДанныеОтвета;	
КонецПроцедуры


#Область ФорматыОтвета
Процедура ВозвращаемНужныйФорматОтвета(Ответ,СтруктураОтвет) Экспорт
	
	Если СтруктураОтвет.Свойство("ФорматОтвета") Тогда 
		ФорматОтвета = СтруктураОтвет.ФорматОтвета;
	Иначе
		ФорматОтвета = "";
	КонецЕсли;	

	Если ВРег(ФорматОтвета) = Врег(ФорматОтветаJSON()) Тогда 
		Ответ.Заголовки.Вставить("Content-Type","application/json; charset=utf-8");
	Иначе 	
		Ответ.Заголовки.Вставить("Content-Type","text/html; charset=utf-8");
	КонецЕсли;
КонецПроцедуры

Функция ФорматОтветаJSON() Экспорт 
	Возврат "JSON";	
КонецФункции
#КонецОбласти

 

Подредактируем модуль PAPI_ОбработкаМетодовGET, добавим в него новый метод "ОстаткиИДоступностьТоваровПоСкладу" и уберем процедуру "ЗаполнитьСтруктуруОтвета"

 
 Код модуля PAPI_ОбработкаМетодовGET
//Функция экспортная, специально чтобы можно было отлаживать как по HTTP(https://its.1c.ru/db/metod8dev#content:5756:hdoc)
//Так и через внешнюю обработку
Функция PAPI_ОбработкаМетодовGET(СтруктураВхПараметров) Экспорт
	//структура ответа. Собственна нужна для формирования ответа
	СтруктураОтвет = Новый Структура("ДанныеОтвета,Отработало,ТекстОшибки,КодОтвета","",Истина,"",200);
	
	//Переправляем на нужный метод
	Если ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("Список") Тогда
		
		ПолучитьСписок(СтруктураОтвет,СтруктураВхПараметров);	
		
	ИначеЕсли ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("Документ") Тогда

		ПолучитьДокумент(СтруктураОтвет,СтруктураВхПараметров);
		
//Получаем доступные остатки по складу в формате JSON	
	ИначеЕсли ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("ОстаткиИДоступностьТоваровПоСкладу") Тогда
		
		PAPI_ОбработкаУниверсальныхМетодов.ПолучитьОстаткиИДоступностьТоваровПоСкладу(СтруктураОтвет,СтруктураВхПараметров);	
		
	Иначе
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,501,"Отсутствует Метод " + ?(СтруктураВхПараметров.ИмяМетода=Неопределено,"",СтруктураВхПараметров.ИмяМетода),ложь,"");
	КонецЕсли;
	Возврат СтруктураОтвет;	
КонецФункции

#Область Методы
Процедура ПолучитьСписок(СтруктураОтвет,СтруктураВхПараметров)
	Результат = "Расходная накладная, 1, 01.01.2014
	|Расходная накладная, 2, 01.01.2014";
	СтруктураОтвет.ДанныеОтвета = Результат;
КонецПроцедуры	

Процедура ПолучитьДокумент(СтруктураОтвет,СтруктураВхПараметров)
	//ПраметрыЗапроса - number
	ПарНомер = СтруктураВхПараметров.ПараметрыЗапроса.Получить("number");

	Номер = Число(?(ПарНомер=Неопределено,0,ПарНомер));
	Если Номер > 2 Тогда
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Отсутствует документ с номером: " + Номер,ложь,"");
	Иначе	
		Если Номер = 1 Тогда
			Результат = "Расходная накладная, 1, 01.01.2014";
		Иначе
			Результат = "Расходная накладная, 2, 01.01.2014";
		КонецЕсли;
		СтруктураОтвет.ДанныеОтвета = Результат;	
	КонецЕсли;
КонецПроцедуры	

#КонецОбласти

 

Добавим одну строчку в обработчик метода Get.

 
 Код PrettyAPIGET
Функция PrettyAPIGET(Запрос)
	СтруктураВхПараметров = Новый Структура;
	//Получаем имя метода
	перИмяМетода  = Запрос.ПараметрыURL["ИмяМетода"];    
	//Помещаем имя метода в структуру
	СтруктураВхПараметров.Вставить("ИмяМетода",перИмяМетода);  
	
	//Забираем параметры из запроса
	ВхПараметрыЗапроса = Новый Соответствие;
	Для каждого Параметр Из Запрос.ПараметрыЗапроса Цикл
        ВхПараметрыЗапроса.Вставить(Параметр.Ключ,Параметр.Значение);
    КонецЦикла;
	СтруктураВхПараметров.Вставить("ПараметрыЗапроса",ВхПараметрыЗапроса);
	
	//Передаем входящие параметры (Модуль для метода GET)
	СтруктураОтвет = PAPI_ОбработкаМетодовGET.PAPI_ОбработкаМетодовGET(СтруктураВхПараметров);
	
	//Создаем ответ с кодом состояния
	Ответ = Новый HTTPСервисОтвет(СтруктураОтвет.КодОтвета);
	Если СтруктураОтвет.Отработало Тогда 
	    Ответ.УстановитьТелоИзСтроки(СтруктураОтвет.ДанныеОтвета,КодировкаТекста.UTF8);
	Иначе
		Ответ.УстановитьТелоИзСтроки(СтруктураОтвет.ТекстОшибки,КодировкаТекста.UTF8);
	КонецЕсли;	
	
	//В зависимости от формата меняем "Content-Type"
	PAPI_ОбщиеПроцедурыИФункции.ВозвращаемНужныйФорматОтвета(Ответ,СтруктураОтвет);
	
	Возврат Ответ;
КонецФункции

 

На этом подготовка ЕРП окончена. Проверим через браузер результат, выполним следующий запрос:

http://127.0.0.1/DemoEnterprise2_4_3_145/hs/PrettyAPI/V1/ОстаткиИДоступностьТоваровПоСкладу?Ref_Key=3ae74af9-e911-11e6-b7b5-bcaec56cc144

Наш сервис готов! Давайте теперь дорисуем обработку и будем подводить итоги.

Добавим в обработку реквизит "Результат" с типом строка. В него мы просто будем выводить текст ответа.

Добавим ТаблицуЗначений "ОстаткиИДоступность":

  • Наименование (Строка)
  • Артикул (Строка)
  • Доступно (Число(15,3))
  • Остаток (Число(15,3))
  • Идентификатор (Строка)

Добавим команду "ПолучитьРезультат"

 
 Код команды ПолучитьРезультат
&НаКлиенте
Процедура ПолучитьРезультат(Команда)
	ОчиститьСообщения();
	Если Не ЗначениеЗаполнено(Склад) Тогда 
		Сообщить("Склад не заполнен!");
		Возврат;
	КонецЕсли;	
	
	ОстаткиИДоступность.Очистить();
	ПолучитьРезультатНаСервере();
КонецПроцедуры
&НаСервере
Процедура ПолучитьРезультатНаСервере()
	перПорт = 0;
	перСервер = "127.0.0.1";
	перПользователь = "Администратор (ОрловАВ)";
	перПароль = "";

	//Формируем запрос для OData
	перРесурсНаСервере = "/DemoEnterprise2_4_3_145/hs/PrettyAPI/V1/";	
	перРесурсНаСервереФин = перРесурсНаСервере + 
	"ОстаткиИДоступностьТоваровПоСкладу?Ref_Key="+Склад;
	
	Попытка
		Если перПорт <= 0 Тогда 
			HTTPСоединение = Новый HTTPСоединение(перСервер,,перПользователь,перПароль);
		Иначе 
			HTTPСоединение = Новый HTTPСоединение(перСервер,перПорт,перПользователь,перПароль);
		КонецЕсли;
		
		HTTPЗапрос= Новый HTTPЗапрос(перРесурсНаСервереФин);
		HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
		
		РезультатМассив = Новый СписокЗначений;	
		Если HTTPОтвет.КодСостояния = 200 Тогда 
			Ответочка = HTTPОтвет.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);	
			Результат = Ответочка;	
			
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(Ответочка);
			Попытка
				//ДопДанные = ПрочитатьJSON(ЧтениеJSON, Ложь);
				МасДопДанные = ПрочитатьJSON(ЧтениеJSON);
			Исключение
				МасДопДанные = "";
			КонецПопытки;
				
			Если ТипЗнч(МасДопДанные) = Тип("Массив") Тогда
				Для Каждого ДопДанные из МасДопДанные Цикл 
					//"ИмяЗначение","Артикул","Guid","ДоступноСейчас","Остаток"
					Если ДопДанные.Свойство("ИмяЗначение") 
						И ДопДанные.Свойство("Guid") 
						И ДопДанные.Свойство("ДоступноСейчас") 
						И ДопДанные.Свойство("Остаток") Тогда
						новСтрока = ОстаткиИДоступность.Добавить();
						
						новСтрока.Наименование 		= ДопДанные.ИмяЗначение;
						новСтрока.Идентификатор		= ДопДанные.Guid;
						новСтрока.Доступно		 	= ДопДанные.ДоступноСейчас;
						новСтрока.Остаток		 	= ДопДанные.Остаток;
						новСтрока.Артикул           = ?(ДопДанные.Свойство("Артикул"),ДопДанные.Артикул,"");
					КонецЕсли;
				КонецЦикла;	
			Иначе 
				//не смогли прочитать
			КонецЕсли;	

		КонецЕсли;
	Исключение
		Сообщить("Подключится к ERP не получилось: "+ОписаниеОшибки());	
	КонецПопытки;
	
	HTTPСоединение = Неопределено;
КонецПроцедуры

 

Внешний вид формы:

Проверяем результат:

Вторую часть заканчиваю. Мы рассмотрели с Вами как можно смешивать разные технологии. Я думал, в этой части поговорить про другие методы, но вышло громоздко, поэтому в следующей части поговорим о других методах и длительных операциях.

Статьи из данного цикла:

HTTP Сервисы: Путь к своему сервису. Часть 1

HTTP Сервисы: Путь к своему сервису. Часть 3

HTTP Сервисы: Путь к своему сервису. Часть 4

Скачать файлы

Наименование Файл Версия Размер
Расширение с http-сервисами из примера
.cfe 23,20Kb
13.08.18
13
.cfe 0.0.2 23,20Kb 13 Скачать
Обработка из примера: ПолучитьОстаткиИДоступностьТоваров.epf
.epf 8,65Kb
13.08.18
15
.epf 1.0.0 8,65Kb 15 Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Хороший заказчик - плохой заказчик

Статья no Нет файла Россия Бесплатно (free) О жизни

Лайфхак о том, как стать легендарным клиентом.

13.09.2019    5468    dsdred    24       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Самый примитивный HTTP-сервис в мире

Статья Программист Нет файла v8 Бесплатно (free) WEB

Пошаговый пример создания простейшего HTTP-сервиса, который генерирует HTML-страницу для поиска товара, а также реализует асинхронное получение данных из базы.

12.09.2019    11773    YPermitin    26       

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    13256    4    m-rv    86       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Модель объекта

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Инструментарий разработчика

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    5789    1    vadim1980    4       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    20674    8    tormozit    44       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Редактор объектов информационной базы 8.3

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.37 от 14.12.2019

2 стартмани

23.01.2019    14611    179    ROL32    29       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    29561    237    informa1555    198       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Навигатор по конфигурации базы 1С 8.3

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.51 от 08.01.2020

3 стартмани

28.10.2018    20816    211    ROL32    63       

HTTP Сервисы: Путь к своему сервису. Часть 4

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 3». В предыдущих частях мы уже о многом поговорили. В этой части поговорим про размер сообщений, о файлах, о порциях и немножко, о регламентах.

1 стартмани

28.09.2018    16543    20    dsdred    13       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    12209    12    RocKeR_13    16       

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    21731    38    dsdred    13       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    19153    25    informa1555    26       

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    28655    17    kalyaka    16       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

HTTP Сервисы: Путь к своему сервису. Часть 1

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    51590    22    dsdred    24       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    22333    86    m-rv    57       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    33028    31    dsdred    36       

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    20567    10    wowik    3       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    33235    77    kalyaka    34       

Доступный состав стандартного интерфейса OData

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Работа с интерфейсом

Обработка позволяет настраивать состав объектов метаданных, доступных через стандартный сервис OData API.

1 стартмани

06.04.2018    14263    103    dsdred    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Заполняем по шаблону (по умолчанию)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    20104    20    mvxyz    17       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    28389    63    rpgshnik    48       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    27459    25    agent00mouse    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    20773    52    kwazi    6       

Программное формирование форматированной строки в стиле html+inline CSS

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    23060    29    bonv    9