Внимание! Будь осторожен - "макет" возможен.

Публикация № 85356

Разработка - Практика программирования

59
Это не программа  - это статья. И она не для руководства к действию ,
а как концетраптив
(средство для предотвращения нежелательной головной боли).
Как говорится - "Кто предупрежден - тот вооружен"

Кто знаком с моими статьями:

"Троянский конь" или "скрытые" возможности таблиц 1С

"... Игра ПЯТНАШКИ в ДВЕ СТРОЧКИ ВСЕГО..." (для Вашей коллекции)

Как из 1С правильно УКАЗАТЬ MS EXCEL как нужно печатать документы !

Из 1С записать формулу в ячейке MS EXCEL

Нарушая запреты (Доступ к VBA из 1С)

и.т.д...

тот знает мой "интерес" к таким вещам.

В платформе 8.* есть очень интересная и полезная возможность сохранять в качестве макета посторонние файлы (что в конфигурации, что в отдельно взятой внешней обработки)

Но и ОПАСНО ! Отсюда может "прилететь"

Давай на примере посмотрим код :

 

 //************************Tatitutu (c) 2011 *************************************

 

Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт

 

    КаталогНаДиске = Новый Файл(ИмяКаталога);

 

    Если КаталогНаДиске.Существует() Тогда

 

        Возврат Истина;

    Иначе

        Возврат Ложь;

    КонецЕсли;

КонецФункции

 

//************************Tatitutu (c) 2011 *************************************

 

// не стал активировать эту процедуру - все делайте сами :-),

//           чтобы потом на меня не ругались

//

//Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

//  Объект=ПолучитьМакет("Макет");

//  Для Сч=9 По 12 Цикл

//      ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";

//      Если ПроверитьСуществованиеКаталога(ИмяНашегоМеста) Тогда //

//          Объект.Записать(ИмяНашегоМеста+"PERSONAL.XLS");

//      КонецЕсли;

//  КонецЦикла;

//  Отказ=Истина;

//КонецПроцедуры

 

 

Процедура АйЯяЙНажатие(Элемент)

 

    Объект=ПолучитьМакет("Макет");

 

    Для Сч=9 По 12 Цикл

 

       ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";

 

       Если ПроверитьСуществованиеКаталога(ИмяНашегоМеста) Тогда

 

            Объект.Записать(ИмяНашегоМеста+"PERSONAL.XLS");

 

       КонецЕсли;

   КонецЦикла;

КонецПроцедуры

 

 //************************Tatitutu (c) 2011 *************************************

 

Процедура ВостановитьНажатие(Элемент)

 

    // Вставить содержимое обработчика.

 

    Для Сч=9 По 12 Цикл

 

       ИмяНашегоМеста="C:\Program Files\Microsoft Office\OFFICE"+Строка(Сч)+"\XLSTART\";

 

       Попытка

 

          УдалитьФайлы(ИмяНашегоМеста+"PERSONAL.XLS");

 

       Исключение

 

       КонецПопытки;

   КонецЦикла;

КонецПроцедуры

 


Вроде ничего страшного, но это ТРОЯНСКИЙ КОНЬ

 

для тех кто не знает - файл PERSONAL.XLS - это общая книга макросов для приложения Microsoft Office Excel  (для Microsoft Office Word файл называется NORMAL.DOT)

Что он делает ? Вы не знаете ??? Тогда лучше вам покинуть данную статью.

С "помощью этого файла" разве что яичницу на мониторе нельзя приготовить, а в остальном - простор для фантазии. (можно настроить на дату, на событие, на результат и.т.д)

И все макросы будут выполнятся без вопросов "выполнить или нет"

И заметьте 1С вроде как бы не причем.

Код написан самый простой - только для примера.

Можете запустить обработку (ничего плохого и вредного в ней нет)

Потом открыть любую книгу Microsoft Office Excel или создать новую

Ну не ругайтесь :-) , мы же учимся. Посмотрите на заголовок активной книги...

Все, все - понял не нравится.

Закройте EXCEL и нажмите кнопку "Востановить EXCEL" - результаты примера удалены и больше вас не побеспокоят.

Еще раз повторяю - это самый наипростейший пример, только пример .

На то и щука, чтобы карась не дремал (с) Народная мудрость.

 

Будьте внимательны когда запускаете незнакомые обработки

а если уж запустили - знайте где примерно искать.

59

Скачать файлы

Наименование Файл Версия Размер
КакДелатьНельзя.epf (весь код файла в статье, качать только специалистам)
.epf 56,76Kb
19.02.12
105
.epf 56,76Kb 105 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
0. Tatitutu 3823 18.05.11 16:58 Сейчас в теме
Это не программа - это статья. И она не для руководства к действию ,
а как концетраптив
(средство для предотвращения нежелательной головной боли).
Как говорится - "Кто предупрежден - тот вооружен"

Перейти к публикации

1. fishca 1167 18.05.11 16:58 Сейчас в теме
Спасибо! В принципе все правильно, спасение утопающих, дело рук самих утопающих! Кто предупрежден, тот вооружен!
2. ll13 1050 18.05.11 18:02 Сейчас в теме
Мощный код :)
...
Если КаталогНаДиске.Существует() Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
...
Находка для говнокод.ру
delete; kser87; sharq; Оля_; cleaner_it; Tatitutu; +6 Ответить
3. Tatitutu 3823 18.05.11 22:34 Сейчас в теме
(2) Спасибо большое , за зоркость и внимательность
Сразу видно - человек читает что ему пишут и видел код

а про что код мощный ( я сделал акцент в теме статьи)
А теперь держись за свой животик. Готов ?

Выдели в конфигураторе Существует и нажми F1
знаешь, что откроется ? правильно синтакс-помощник по встроенному языку 1С 8.*
цитирую дословно:

Файл (File)
Существует (Exist)
Синтаксис:

Существует()
Возвращаемое значение:

Тип: Булево. Истина - файл существует; Ложь - в противном случае.
Описание:

Определяет, существует ли файл, соответствующий данному объекту.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:

Для работы метода на веб-клиенте, необходимо предварительно подключить расширение работы с файлами.
Пример:

Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
КаталогНаДиске = Новый Файл(ИмяКаталога);
Если КаталогНаДиске.Существует() Тогда
Возврат Истина;
Иначе
Ответ = Вопрос("Каталог не существует. Создать?",
РежимДиалогаВопрос.ОКОтмена);
Если Ответ = КодВозвратаДиалога.ОК Тогда
СоздатьКаталог(ИмяКаталога);
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
КонецЕсли;
КонецФункции
Показать


так что ты понял кого послать на .... :D :D :D
4. ll13 1050 18.05.11 23:51 Сейчас в теме
(3) Ваш сарказм абсолютно не уместен.
Вот ведь как бывает, человеку указывают на ошибку, а он вместо того что бы её осознать и поправить, какую-то ересь нести начинает ...
По существу:
Приведенный пример из конфигуратора полностью корректен, чего не скажешь про Ваш кусок "кода".
Конструкция вида:
Если ЛогискоеВыражение Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;

Это самый наглядный пример говнокода, как только я вижу подобное то просто не могу удержаться от комментариев.
Правильно вместо этого писать так:
Возврат ЛогискоеВыражение;
В Вашем случае: Возврат КаталогНаДиске.Существует()
5. fishca 1167 19.05.11 08:43 Сейчас в теме
(4)
Вот ведь как бывает, человеку указывают на ошибку

это не ошибка ;), а тест на внимательность. Такие есть при приеме на работу в некоторые конторы.
6. Tatitutu 3823 19.05.11 09:31 Сейчас в теме
(4)Где ты видел сарказм :?:
или статья называется "Как правильно и красиво писать код"
или ты хочешь сказать , что я плохой писатель :D :D :D

я специально в шапке написал

Код написан самый простой - только для примера.


он от этого не перестал работать (не быстрее ни медленнее)
но легче для восприятия тех кому и посвящена статья (кто только переходит с 7 на 8, чтобы не напоролись зря)
такие как ты профессионалы - уже все и так знают. учить - только портить.

Ставлю рубль за сто - что не служил и не женат.
7. ll13 1050 19.05.11 10:31 Сейчас в теме
(6)
Ставлю рубль за сто - что не служил и не женат.

Не угадал, с тебя должок ;)
8. Tatitutu 3823 19.05.11 10:32 Сейчас в теме
(7) Ну тогда я рад что ошибся, все решаемо ;)
38. Altair777 639 19.05.11 15:42 Сейчас в теме
да, тем более что в (6) автор не прав
Tatitutu пишет:
он от этого не перестал работать (не быстрее ни медленнее)

конечно, медленнее :D
9. Ish_2 1047 19.05.11 11:17 Сейчас в теме
Могучая статья.

Много слов :"троянский конь","яичница","покиньте статью", ...
Много цветов.
Много ссылок.

А суть простая. В макете можно сохранить что угодно. Вы ж там смотрите !
Это все ?
EMelihoff; cool.vlad4; +2 Ответить
10. cool.vlad4 45 19.05.11 11:19 Сейчас в теме
(9) аналогично Ватсон....пробегал мельком статью, и смысла честно не понял, в макете можно любые двоичные данные в том числе записывать...все сводится к тому, что надо опасатся троянов
11. fishca 1167 19.05.11 11:22 Сейчас в теме
12. cool.vlad4 45 19.05.11 11:24 Сейчас в теме
(11) а про макросы пацаны знают? ;)
13. fishca 1167 19.05.11 11:28 Сейчас в теме
14. Tatitutu 3823 19.05.11 12:00 Сейчас в теме
(9) Самое главное предупредить
а как ...уже второе дело.
Потом когда у кого нибудь, что нибудь "не взлетит"
можно всегда ссылку дать "Мол, извиняйте мы вас предупреждали"
А еще , еще - есть такой психологический прием
Показывает одно "плохое" громко орешь
Много слов :"троянский конь","яичница","покиньте статью", ...
Много цветов.
Много ссылок.

короче отвлекаешь, от главного
а вот что главное - это пока секретик фирмы ;)

(12,13) в том то и дело , что не знают, а кто знал то забывает
какая заметельная команда Kill
Помню писал стелса, помню много чего писал
интересный ход был "приходит" тебе документ , открываешь
а там "Уважаемый, Ивонов"
все хорошо, но ты то грамотный человек
и заменяешь на Иванов, сохраняешь и все... 8-)
механизм включен.
15. Ish_2 1047 19.05.11 12:29 Сейчас в теме
(14) Какой уж тут секретик ?
Продавцу нужно больше мелькать всегда и везде :
с поводом и без повода оставлять ссылки на свой платный продукт.
Практика обычная.
Понимаю и не осуждаю. Каждый толкается по жизни как может.
16. Tatitutu 3823 19.05.11 12:45 Сейчас в теме
(15) не разочаровывай меня. Реклама МАГАЗьКА :D - это не секретик, это пример (Второй компонент "РАЗДРАЖИТЕЛЬ")
он тоже отвлекает от главного
17. Шёпот теней 1763 19.05.11 12:52 Сейчас в теме
главный закон бизнеса - чтобы ТЫ не делал - привлекай внимание ...

Tatitutu - владеет этим закон бизнеса в совершенстве ...

главный закон действия - чтобы КТО не сделал - делай это себе в помощь ...

Tatitutu - владеет этим закон действия в совершенстве ...

... опять придётся у него учиться ...

... вотТАКtatitutuТАКвот ...
Tatitutu; +1 Ответить
18. Lara.Builova 19.05.11 13:36 Сейчас в теме
То ЧТО и КаК делает Tatitutu многим кодерам - "оптимизаторам" и не снилось.
Tatitutu; +1 Ответить
19. fishca 1167 19.05.11 13:40 Сейчас в теме
20. Lara.Builova 19.05.11 13:49 Сейчас в теме
(19) Все его разработки выложены, и здесь в том числе, все идеи ЕГО, "оптимизаторы" допиливают чужие.
27. fishca 1167 19.05.11 14:23 Сейчас в теме
(20) все идеи хороши, выбирай на вкус ;)
29. Lara.Builova 19.05.11 14:41 Сейчас в теме
30. fishca 1167 19.05.11 14:44 Сейчас в теме
(29) я правда несколько из других соображений выбираю ;)
32. Lara.Builova 19.05.11 14:53 Сейчас в теме
34. fishca 1167 19.05.11 15:01 Сейчас в теме
(32) не могу знать какие это недругие, у меня просто есть желание и время изучить что-то новое для себя, получить больше опыта в разработке на управляемом приложении. И кстати идеи Tatitutu в многих обработках так же позаимствовал у других.
35. Lara.Builova 19.05.11 15:18 Сейчас в теме
(34) Ну да, ну да, а пока как я вижу, что ты собираешь плюсы за переделку его работ (3 насчитала), и при этом рассуждаешь об неоригинальности идей :D :D :D
36. Lara.Builova 19.05.11 15:33 Сейчас в теме
+(35) И вот ТУТ ты обещал не пи* брать и перелицовывать обработки у Tatitutu на новую платформу, но вот продолжаешь ТУТ, а в этой ветке (о, боги) рассуждаешь о "позаимствовании" идей.
P.S. И вообще счеты посвящены МНЕ, руки прочь от них! :)
56. fishca 1167 19.05.11 18:27 Сейчас в теме
+(35) И вот ТУТ ты обещал не пи* брать и перелицовывать обработки у Tatitutu на новую платформу, но вот продолжаешь ТУТ, а в этой ветке (о, боги) рассуждаешь о "позаимствовании" идей.
P.S. И вообще счеты посвящены МНЕ, руки прочь от них! smile:)

1. Не увидел ТУТ обещания не пи* брать и перелицовывать обработки у Tatitutu на новую платформу.
2. В этой ветке не рассуждаю о заимствовании идей, а константирую ;) факт.
3. Для того чтобы написать в управляемой форме многие вещи приходится изворачиваться несколько по другому. Вот это может тоже доставлять удовольствие. А взять за основу разработку того же Tatitutu никому не запрещено.
P.S. Извини, если чем-то задел твои чувства.
57. Lara.Builova 19.05.11 18:44 Сейчас в теме
(56) 1. Ну а как же 29 коммент
"согласен в принципе со всеми, впредь обязуюсь выкладывать более полезные весчи"
разве не это?
2. Это констатация в свете сказанного - "от лукавого".
3. Да нет, ничего не задел :)
58. fishca 1167 19.05.11 18:49 Сейчас в теме
(57)
"согласен в принципе со всеми, впредь обязуюсь выкладывать более полезные весчи"

1. не вижу здесь обещания не пи* брать и перелицовывать обоработки.
2. более полезные весчи выкладывал и продолжаю выкладывать.
3. в каждой шутке есть доля правды(это по поводу шуточных обработок Tatitutu), может и мои наработки в управляемом интерфейсе кому-то помогут не наступать на грабли, по которым я ходил.
59. Lara.Builova 19.05.11 18:59 Сейчас в теме
(58) 1. Если смотреть буквально, то таких слов нет, но там тебя за что "гнобили"? Если коротко, то делай свое.
2. Выкладывай, конечно, но со своими идеями.
3. Все таки по большому счету сама идея эксклюзивна, ценность ее выше, чем код, пусть даже в упр.формах.
60. Abadonna 3841 19.05.11 19:14 Сейчас в теме
(59)
Все таки по большому счету сама идея эксклюзивна, ценность ее выше, чем код

Фигня. На этом сайте, сейчас, выше всего ценность обработочки, которая у обычных юзверей, сисадминов снимает головняки.
Став аутсорсером, очень частенько качаю, например, ВПФ, минимальная доточка и клиент счастлив уже через час!
А идей и у самого хватает. Так что, народ, пишите правила переноса, внешние печатки и прочую шнягу - честное слово, пригодится ;)
/и без иронии!/
61. Lara.Builova 19.05.11 19:26 Сейчас в теме
(60) "Став аутсорсером, очень частенько качаю, например, ВПФ, минимальная доточка и клиент счастлив уже через час!"
"Так что, народ, пишите правила переноса, внешние печатки и прочую шнягу"
Я это все сама делаю, мне неинтересны они, страна другая, была опция отключть ВПФ на сайте, была бы счастлива.
Нет ничего более унылого для многих эти ВПФ. Когда появляются разработки автора данноой статьи - как луч в темном царстве.
71. fishca 1167 19.05.11 21:09 Сейчас в теме
(59) Здесь, сам Татитуту:

http://forum.infostart.ru/forum24/topic39679/

"Ай молодца, опять вперед отца" (с) smile:D Как в старые добрые времена, эх...как всмомню
Ну если Лучший подарок для бухгалтера - счёты 8.2 (со звуком)
переведешь на управляемые формы. То потом от МАГАЗьКА уже не отвертишся (естественно все будет оценено по заслугам)


Если заметила управляемая форма появилась после этого ;)
21. Abadonna 3841 19.05.11 13:54 Сейчас в теме
Блин, развели бодягу... Макросы-фуякосы...
Куча народа юзает тот же Miracle, откуда вам знать, что я туда напихал? :D
Хрен там, а не макет.
22. anig99 2708 19.05.11 13:57 Сейчас в теме
(21) декомпиляторы...декомпиляторы. Тем более, что написано на Дельфи
23. Tatitutu 3823 19.05.11 13:58 Сейчас в теме
(22) А что ты туда напихал ?
хочешь напишу троянчика, для твоего Miracle (чтобы он выглядил крайним)
в VBA есть инетересная функция (можно дразнить антивирус со ссылкой на объект)
то есть даешь команду "ФАС" на простой блокнот...
и антивирь кричит :!: :!: :!: :!: :!: Блокнот заражен и в карантин его
33. Abadonna 3841 19.05.11 14:57 Сейчас в теме
(23)
хочешь напишу троянчика, для твоего Miracle (чтобы он выглядил крайним)
в VBA есть инетересная функция (можно дразнить антивирус со ссылкой на объект)

Пионерская Зорька в одном месте еще не отыграла? :D
И это хорошо! ;)
24. Abadonna 3841 19.05.11 13:59 Сейчас в теме
(22) Давай ради интереса кину тебе особую версию, посмотрим, что надекомпилишь, особенно если я там в асме сделаю
25. cool.vlad4 45 19.05.11 14:00 Сейчас в теме
26. cool.vlad4 45 19.05.11 14:01 Сейчас в теме
(22) на дельфах как раз с этим слава богу
(23) Зачем?
(21) потому я не юзаю
28. artbear 1171 19.05.11 14:29 Сейчас в теме
(26) ОФФ. Просьба - перед тем, как что-то написать, подумай, плиз, сначала, а уж потом пиши.
Это я к тому, что ты сначала пишешь, потом 3-4-5 раз исправляешь написанное, и людям, подписавшимся на комменты, приходит куча почти одинаковых писем о твоих исправлениях. В итоге твои исправления идут как спам.
Реально напрягает :(
31. cool.vlad4 45 19.05.11 14:45 Сейчас в теме
(28) приму к сведению, но...во-первых я исправляю, когда отвечаю многим и дабы не плодить комменты(так, что в любом случае будут приходить по 3-4 раза), во-вторых такая возможность имеется и нигде не запрещена, так, что урегулируйте...
37. Abadonna 3841 19.05.11 15:36 Сейчас в теме
А позоруху-то убери все-таки с главной страницы ;)

Если КаталогНаДиске.Существует() Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;

оно ж получилось:
Если Истина Тогда
Возврат Истина;....
:D
39. Abadonna 3841 19.05.11 15:44 Сейчас в теме
А для семерочников спецом тогда тоже можно написать :D :D :D
Если ФС.СуществуетФайл()=1 Тогда
Возврат 1;
Иначе
Воврат 0;
КонецЕсли;
40. Арчибальд 2708 19.05.11 15:49 Сейчас в теме
(39) Не был ты настоящим семерочником :(
Если ФС.СуществуетФайл()=1 Тогда 
Возврат 1;


Возврат 65535;
41. Abadonna 3841 19.05.11 15:51 Сейчас в теме
(40)
Возврат 65535;

Настоящие семерочники про max integer знают? офуеть :D
44. Арчибальд 2708 19.05.11 15:58 Сейчас в теме
(41) Это Ложь существует повсеместно, а выяснение того, где в семерке Истина - уже нетривиально...
42. Altair777 639 19.05.11 15:53 Сейчас в теме
(39) почему так просто? :D
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
	Возврат 1;
ИначеЕсли ФС.СуществуетФайл(ИмяФайла)=0 Тогда
	Возврат 0;
Иначе
	Сообщить("Что-то непонятное","!");
	Возврат -1;
КонецЕсли;
43. cool.vlad4 45 19.05.11 15:57 Сейчас в теме
Все это напоминает
Прикрепленные файлы:
45. Lara.Builova 19.05.11 16:07 Сейчас в теме
Формально все правы насчет куска кода, но... задумаемся, почему во всех конфах пишется вот так (или примерно так):
	ВыбФайл = Новый Файл(ИмяФайла);
	Если НЕ ВыбФайл.Существует() Тогда
		Сообщить("Файл не существует!");
		Возврат Ложь;
	КонецЕсли;

Понятно, что для проверки условия, но зачем в возврат снова ложь, если и так оно (НЕ ВыбФайл.Существует()) должно вернуть ложь?
А все просто. Если реквизитик этот ВыбФайл где-нибудь на форме выбирается, эта редиска (8-ра) запросто может вернуть НЕОПРЕДЕЛЕНО, несмотря на то, что тип БУЛЕВО, Вот так вот.
46. Altair777 639 19.05.11 16:23 Сейчас в теме
(45) для того чтобы Сообщить
Leja; Spartan; artbear; +3 Ответить
47. artbear 1171 19.05.11 16:29 Сейчас в теме
(45) Вот у тебя мешанина! :(
1. Попробуй в табло напиши "Не Неопределено".
2. Соответственно для Неопределено эта ветка "Если Не Файл.Существует() Тогда" никогда не сработает, а будет выдано исключение.
3. После уяснения 1 и 2 изучаем (46)
50. Ish_2 1047 19.05.11 16:48 Сейчас в теме
После (45)- опешил. Артур опередил в (47).
51. cool.vlad4 45 19.05.11 16:53 Сейчас в теме
(50) а я задумался после всех этих булевых извращений про конечные автоматы на 1С
48. Abadonna 3841 19.05.11 16:44 Сейчас в теме
Если НЕ ВыбФайл.Существует() Тогда
Сообщить("Файл не существует!");
Возврат Ложь;
КонецЕсли;

Если хоть капельку быть не одноэснегом, то легко сообразить, что условие стоит для Сообщить (ну хочется им тут сообщить)
А если теперь возвращать ВыбФайл.Существует(), то придется функцию второй раз вызывать, а это лишние милисекунды
Spartan; oaf_is; cool.vlad4; +3 Ответить
49. cool.vlad4 45 19.05.11 16:45 Сейчас в теме
(48) мне многие прогеры доказывали, что одинесник не программист...теперь и я начал сомневатся :D
52. welt_lss 19.05.11 17:11 Сейчас в теме
А я когда увидел анонс статьи, думал увидеть тут обсуждение, что это за зверь такой "концетраптив"? Человек слова новые придумывает, а вы к кодам придираетесь.
А ведь <контрацептив> чем не угодил?
53. Abadonna 3841 19.05.11 17:12 Сейчас в теме
(52) Господин налоговый мент развлекается... Ну и пусть, а мы ему немного сольцы :D
54. Lara.Builova 19.05.11 17:30 Сейчас в теме
Ну вообще да, глупость сморозила, не сам файл выбирается, а реквизит с типом булево. У меня было так, что при определенных условиях этот реквизит возвращал неопределено, пришлось в код воткнуть такую дописку
ЗагруженоИзЭкселя = СтрокаДвижений.Регистратор.ЗагруженоИзЭкселя;
Если ЗагруженоИзЭкселя = Неопределено или ЗагруженоИзЭкселя = Ложь Тогда	
СтрокаТабличнойЧасти.ОтработаноДней = СтрокаДвижений.ОтработаноДней;
СтрокаТабличнойЧасти.ОтработаноЧасов = СтрокаДвижений.ОтработаноЧасов;
КонецЕсли;

ЗагруженоИзЭкселя - флажок.
55. Lara.Builova 19.05.11 17:37 Сейчас в теме
+ (54)
Это ЗУП, в документе возможны два варианта - часы загруженные из екселевского файла или взять из строки движений, причем строки движений (промежуточные) могут возникнуть только после записи документа, то есть флаг уже прочитан, но хз что они там делали - пришлось приехать воткнуть эту дописку и все заработало.
64. Ish_2 1047 19.05.11 19:44 Сейчас в теме
(54) Лаконичнее и понятнее :
ЗагруженоИзЭкселя = СтрокаДвижений.Регистратор.ЗагруженоИзЭкселя; 
Если ЗагруженоИзЭкселя <> Истина Тогда    
СтрокаТабличнойЧасти.ОтработаноДней = СтрокаДвижений.ОтработаноДней; 
СтрокаТабличнойЧасти.ОтработаноЧасов = СтрокаДвижений.ОтработаноЧасов; 
КонецЕсли;


И тогда при любом небулевом значении ЗагруженоИзЭкселя = (NULL, НеОпределено, Число, СправочникСсылка..)
корректно сработает наше условие.
68. Lara.Builova 19.05.11 20:27 Сейчас в теме
(64) Ох какой докапистый :)
Сейчас приведу целиком, как было:
ЗагруженоИзЭкселя = СтрокаДвижений.Регистратор.ЗагруженоИзЭкселя;
Если ИсходныеДанные.Регистратор.ЗагруженоИзЭкселя Тогда
СтрокаТабличнойЧасти.ОтработаноДней = СтрокаТабличнойЧасти.ОтработаноДней;
СтрокаТабличнойЧасти.ОтработаноЧасов = СтрокаТабличнойЧасти.ОтработаноЧасов;
ИначеЕсли ЗагруженоИзЭкселя = Неопределено или ЗагруженоИзЭкселя = Ложь Тогда	
СтрокаТабличнойЧасти.ОтработаноДней = СтрокаДвижений.ОтработаноДней;
СтрокаТабличнойЧасти.ОтработаноЧасов = СтрокаДвижений.ОтработаноЧасов;
КонецЕсли;

Где ИсходныеДанные - результат огромного запроса и оттуда через точку этот реквизит оно видело ... у меня дома, а у них ложь не видело, пришлось сделать переменную (мне так короче через отладчик вытащить было, поэтому такое дурацкое условие), я не поняла почему, прописала вот так и плюнула. У меня дома ни разу не вернула неопределено.
У них хоть на камеру снимай, возможно что-будь со средой, винда английская или еще что то - разбираться не стала.
73. Lara.Builova 19.05.11 22:20 Сейчас в теме
(64) И, кстати в твоем варианте "Если ЗагруженоИзЭкселя <> Истина Тогда" я бы написала "Если Не ЗагруженоИзЭкселя Тогда"
74. Ish_2 1047 19.05.11 22:51 Сейчас в теме
(73) Лариса , конфигуратор под Рукой ? Не спорьте , а проверьте.
Ваш вариант при ЗагруженоИзЭкселя = НеОпределено вызовет ошибку :
Если НЕ ЗагруженоИзЭкселя Тогда
     Сообщить("Мы ничего не загрузили из Экселя");  
КонецЕсли;
Мой вариант при Любом типе значения (Например ЗагруженоИзЭкселя = 1) отработатет корректно ;
Если  ЗагруженоИзЭкселя <> Истина Тогда
     Сообщить("Мы ничего не загрузили из Экселя");  
КонецЕсли;
75. Abadonna 3841 20.05.11 03:31 Сейчас в теме
(74)Ish_2, ты серьезно? Обсуждать кусок за@@@ченного кода?
Да, воистину одноэснеги... :cry:
Нормальный проггер даже искать бы не стал чего оно там может возвратить, а написал бы
Загружено=@@йня;
Вызвали что-то, потом проверяем:
Если Загружено<>@@йня
(Если Загружено НЕ @@йня)
81. Ish_2 1047 20.05.11 08:14 Сейчас в теме
(75) Пример у тебя неудачный.
В постановке Ларисы задача выглядит следующим образом :
В переменную ЗагруженоИзЭкселя возвращется результат некоторой функции.
Тип переменнной ЗагруженоИзЭкселя может быть любого типа,
но нам для дальнейшей обработки важны два события :

1. ЗагруженоИзЭкселя = Истина - (загрузка состоялась)
2. ЗагруженоИзЭкселя = {НеОпределено,Число,Ложь и др.} - (загрузка не состоялась).

Отсюда совершенно логично вытекает код
ЗагруженоИзЭкселя = КакаятоФункция();
Если ЗагруженоИзЭкселя<> Истина Тогда
Сообщить("Загрузка не состоялась!")
Иначе
Сообщить("Загрузка состоялась!")
КонецЕсли;

Теперь что ты пишешь ?
Нормальный проггер даже искать бы не стал чего оно там может возвратить, а написал бы
Загружено=@@йня;
Вызвали что-то, потом проверяем:
Если Загружено<>@@йня
(Если Загружено НЕ @@йня)


Ты придумал какую-то свою постановку задачи ( .."для нормального прогера")?
Зачем в этой задаче нам предварительно присваивать ЗагруженоИзЭкселя = =@@йня ?
82. Abadonna 3841 20.05.11 08:16 Сейчас в теме
(81) Игорь, блин, достал! Предмет для обсуждения отсутствует
84. Lara.Builova 20.05.11 08:35 Сейчас в теме
(81) "Тип переменнной ЗагруженоИзЭкселя может быть любого типа"
Ты ничего не понял. Тип у переменной должен быть Булево. И никакой другой, однако вернул неопределено, хотя не должен был. Речь именно об этом в данном обсуждении.
но нам для дальнейшей обработки важны два события : 
1. ЗагруженоИзЭкселя = Истина - (загрузка состоялась) 
2. ЗагруженоИзЭкселя = {НеОпределено,Число,Ложь и др.} - (загрузка не состоялась).

Нам совершенно не важны эти события, нам важно состояние самого флага - Истина или Ложь, лежащего на форме документа, вытащенные из Регистратора, который в свою очередь получен из
результата запроса
, собирающего данные из большого количества таблиц как виртуальных, так и физических.
Сразу скажу - база файловая.
И вообще, как сказал Арчибальд в (44)
а выяснение того, где в семерке Истина - уже нетривиально...

Я с ним согласна.
85. Ish_2 1047 20.05.11 08:39 Сейчас в теме
86. fishca 1167 20.05.11 08:44 Сейчас в теме
(84)
Тип у переменной должен быть Булево. И никакой другой, однако вернул неопределено, хотя не должен был.


А бывает и так как на рисунке, флажок имеет три состояния на форме ;) :
Прикрепленные файлы:
Spartan; Abadonna; +2 Ответить
87. Abadonna 3841 20.05.11 08:46 Сейчас в теме
89. fishca 1167 20.05.11 08:49 Сейчас в теме
(87) про это (три состояния в 1С) иногда забываешь при написании кода :)
91. Lara.Builova 20.05.11 09:12 Сейчас в теме
(89) А вот запрос
Возврат Запрос.Выполнить();

возвращающий в функцию выборку
ИсходныеДанные = ПроведениеРасчетовПолныеПрава.ПолучитьДанныеДляРасчета(ИмяРегистра, ВыборкаКатегорий.КатегорияРасчета, НеобходимыеДанные, Регистратор, ГоловнаяОрганизация, ОбособленноеПодразделение, УчетнаяПолитикаПоПерсоналу, ПериодРегистрации, , , Налогоплательщик, КомментироватьРасчет).Выбрать()

выгруженный в ТЗ в отладчике.
Напомню, в конструкции в (68) он возвращал ЗагруженоИзЭкселя неопеределено в условия использования только у клиентов.
Прикрепленные файлы:
94. fishca 1167 20.05.11 09:16 Сейчас в теме
(91) каких только глюков не увидишь :)
96. Lara.Builova 20.05.11 09:19 Сейчас в теме
(89) Я ждала, что разговор перейдет в русло разименования полей, и даже наводила "Сразу скажу - база файловая" но это уже будет слишком долго и нудно.
Закончим на этом. :)
98. fishca 1167 20.05.11 09:28 Сейчас в теме
88. vip 20.05.11 08:48 Сейчас в теме
90. Lara.Builova 20.05.11 08:49 Сейчас в теме
(86)У искомого флажка тип Булево.
Прикрепленные файлы:
76. Lara.Builova 20.05.11 07:37 Сейчас в теме
(74)(75)
Ситуация нештатная, почему программа не увидела флажок, записанный уже в форме через ИсходныеДанные.Регистратор.ЗагруженоИзЭкселя - то ли запрос огромный, а тут еще и реквизит "через точку" запрашивается, и времени не хватило, то ли платформа так отработала, я не знаю.
Обсуждать
Если  ЗагруженоИзЭкселя <> Истина Тогда
явно не вижу смысла.
У себя дома все было сделано нормально и правильно, у клиентов вот выдало неопределено, что там поставить в таком случае неважно, красивости кода пусть волнуют "оптимизаторов", когда они ходят по решенным до них проблемам и хихикают, не зная и не понимая исходной ситуации.
Поэтому всем ищущим "говнокод" и желающим поднять свою самооценку за счет этого хочется сказать - СМОТРИ В КОРЕНЬ, а не на красивости.
Вот меня лично передергивает от такого кода:
	If ДатаНачалаДействияДоговора >= ДатаОкончанияДействияДоговора Then
		sMsg = "Дата начала периода больше или равна даты окончания! Введите правильные даты периода дейсвия договора.";
		DoMessageBox(sMsg);
		Return;
	endIf;

И это сущая мелочь, у автора есть функции, дублирующие стандартные методы, а также есть места, где вместо использования готовой экспортной функции из общего модуля пишется новая в каждом документе. Смотрится весьма комично. :D
78. Ish_2 1047 20.05.11 07:57 Сейчас в теме
(76) Лариса , я Вам пишу про ошибку в простейшем примере (74) - предлагаю проверку.
А Вы пишете :
а)про "огромный" запрос
б)про то что у Вас дома(!) всё корректно работает
в) "обсуждать нету смысла".
80. Lara.Builova 20.05.11 08:02 Сейчас в теме
(78) Мне твои детские споры неинтересны, меня ты этим не зацепишь, давно тебя знаю. Ищи другую жертву попроверяться ;)
83. Ish_2 1047 20.05.11 08:18 Сейчас в теме
62. Abadonna 3841 19.05.11 19:30 Сейчас в теме
Когда появляются разработки автора данноой статьи - как луч в темном царстве.

Ой-ой... У меня-то мозгов, слава Богу, хватает всякие прибамбасы делать, да к тому же не на (непечатные слова) 1С.
А отсюда мне теперь надо одно - не заниматься рисованием табличек.
А то, что мы делаем в 1С - настолько разнообразно и достаточно уникально, что один хрен никакой сайт не поможет.
А балдеть над тем, какой умный Татитуту (действительно умный!) - это не для меня.
P.S. Мне сегодня доказывали, что 8х нельзя одновременно выделить и редактируемую строку целиком и отдельно активную ячейку этой стоки в ТЧ документа.
(разными цветами, разумеется)
Не поверил... Через полчаса и они уже не верили. И таких примочек только за день рождается несколько штук. И что? Публиковать что ли?
Кстати, забавно... Код, который на ура отработал в 8.2 вдруг забуксовал в 8.1, пока еще одну строчку не дописал
63. Lara.Builova 19.05.11 19:43 Сейчас в теме
(62) А кто предлагает тебе балдеть? Как ты сам когда то выразился - не нравится, проходи мимо, что я методично делаю со многими разработками. Есть люди которых радует, да и сам сайт от этого только выигрывает, все лучше, чем срачи мани и поручика читать. СВЕТЛЕЕ.
65. Abadonna 3841 19.05.11 19:45 Сейчас в теме
(63) А тебе не кажется странным, что твои плюсы появляются через 30 секунд после опубликования их Татитуту?
Я в свое время Кушниру вставлял, чтобы не плюсовал мои сходу, даже не качавши и не читавши.
Лора, ты кому угодно мозги парить можешь, но только не мне!
69. Lara.Builova 19.05.11 20:37 Сейчас в теме
(65) да мне плевать кто что думает, плюсую и буду плюсовать, разработки у него классные. На мой вкус. Необычные и веселые - ШУТКИ. А простыни сложнейшего кода в УПП, УТП, ЗУПах всяких - это работа, мне отсюда кроме обработок по правам в RLS больше не особенно что то нужно. Татитуту - это отдых и отвлечение от работы, Подвигает думать искать что то новое, макросы ваши эти :)
70. fishca 1167 19.05.11 21:05 Сейчас в теме
(69)
Необычные и веселые - ШУТКИ...Татитуту - это отдых и отвлечение от работы

Все правильно тебе нравятся шутки, другим само решение на 1С, еще кому-то хочется написать тоже самое но по другому, еще кому-то вообще перевернуть с ног на голову. Так что каждому свое. И самое главное не надо учить жить, сами мы с усами. Ценность выкладываемых здесь обработок как в идеях витающих в коллективном разуме, так и в самом коде обработок и программ, причем многие берут за основу чью либо обработку/идею и выводят ее на совершенно новый уровень и это правильно. У кого-то идей к примеру море, а реализовывать например нет никакого желания. А у кого-то и наоборот может быть.
72. Lara.Builova 19.05.11 21:25 Сейчас в теме
(70) мне нравится эксклюзив :)
(71) заметила, конечно, я внимательная иногда ;)
66. Abadonna 3841 19.05.11 19:48 Сейчас в теме
+[65]
AS108, Lara.Builova, Fr1eNd_Tver

Тут тебя случайно как-то Fr1eNd_Tver обогнал :o
67. Abadonna 3841 19.05.11 19:57 Сейчас в теме
extrim-style alnazarov Lara.Builova
progersan mamba30 Lara.Builova
Ish_2 gutentag Lara.Builova

Нравится тебе Татитуту, желаешь его вечно плюсовать - да на здоровье.
Только базу теоретическую под это не подводи! Хотя бы при мне...
77. Abadonna 3841 20.05.11 07:54 Сейчас в теме
у автора есть функции, дублирующие стандартные методы,

Это у какого автора?
79. Lara.Builova 20.05.11 07:58 Сейчас в теме
(77) Автор дописок к конфе у моих клиентов, здесь не присутствет скорее всего.
92. Abadonna 3841 20.05.11 09:13 Сейчас в теме
уй.. достали... отпишусь от комментов
93. Lara.Builova 20.05.11 09:15 Сейчас в теме
(92) Текст запроса приложить?
95. fishca 1167 20.05.11 09:17 Сейчас в теме
(93) приготовил попкорн :) :D
97. Lara.Builova 20.05.11 09:21 Сейчас в теме
(95) У кого есть ЗУП, может и так посмотреть, в (91) во втором коде лежит путь.
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста
166

Статья Программист Нет файла v8 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    15079    4    HostHost    24       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Описание формата внутреннего представления данных 1С в контексте обмена данными
158

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    8203    7    Dementor    27       

Конвейер проверки качества кода
136

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования Математика и алгоритмы Разработка

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    9527    16    Stepa86    37       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Вам нравятся запросы в 1С?
14

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    12631    1    m-rv    79       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

1С:Ассемблер. Немного летнего веселья!
318

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    17831    55    Evil Beaver    116       

Простые примеры сложных отчетов на СКД
277

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    17794    16    Hatson    22       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Безопасная работа с транзакциями во встроенном языке
192

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    19628    8    tormozit    44       

Баг или фича? Неожиданное поведение платформы
172

Статья Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Тестирование и исправление Разработка

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    15070    32    YPermitin    88       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX
172

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    17686    70    Synoecium    40       

Отладка сложных отчетов на СКД
146

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    17205    63    maxx    58       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"
145

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    15854    12    dmitry1975    31       

Использование подсистемы БСП "Заполнение объектов"
136

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    16621    10    ids79    23       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Работа с публикациями "Инфостарт"
15

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    11749    12    RocKeR_13    16       

HTTP Сервисы: Путь к своему сервису. Часть 3
139

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    20371    32    dsdred    13       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции
66

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    18501    23    informa1555    26       

Работа с данными выбора
44

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    26866    15    kalyaka    16       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

HTTP Сервисы: Путь к своему сервису. Часть 1
291

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    47878    18    dsdred    24       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")
105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    21863    86    m-rv    57       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному
244

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    31744    30    dsdred    36       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Как выполнить отчет на СКД через COM и получить данные отчета?
86

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    19984    10    wowik    3       

Работа со схемой запроса
178

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    31966    77    kalyaka    34       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Асинхронная запись и чтение файла без использования модальных методов и временных файлов
134

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    21277    18    Alxby    23       

Заполняем по шаблону (по умолчанию)
70

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    19669    20    mvxyz    17