Паузы при исполнении кода (Sleep для 1С)

Программирование - Практика программирования

пауза sleep

72
Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

По результатам чтения форума http://forum.infostart.ru/forum9/topic42820/ и некоторых других форумов, остался вопрос: а какой вариант работает, какой лучше использовать. Для проверки была создана предлагаемая обработка. В ней можно протестировать найденные варианты. Для себя я нашел только 2 варианта: с использованием ping и winmgmts.

Более подробно про проверенные варианты:

1) ping и winmgmts. Оба варианта прекрасно работают, практически не нагружая процессор.

2) Пустой цикл. Вариант работающий, часто предлагаемый на форумах. Имеет большой минус - грузит процессор.

3) Вариант с использованием Sleep. Насколько я понимаю, требуют наличия программы sleep.exe. На моем компьютере такой нет, варианты проверить не удалось.

4) SleepJs и SleepVbs. Работают. Неплохой вариант. Варианты отличаются только алгоритмом запуска команды.

5) TimeoutWs и Timeout. Работают. Неплохой вариант. Варианты отличаются только алгоритмом запуска команды. Timeout показывает черное окно при каждом запуске паузы.

6) DynamicWrapper. Нужна dll. Этот вариант не проверял, так как искал вариант без внешних компонент.

В прилагаемой обработке все варианты можно протестировать в своей базе и выбрать наиболее подходящий.

Есть обычная и управляемая форма, поэтому запускать можно в любой базе. Код открыт.

Протестировано на версиях 8.2 и 8.3.11.

 
Процедура СделатьПаузу(ЗадержкаСекунд = 3, Вариант = "Ping")
	
    Если ЗадержкаСекунд = 0 Тогда
        Возврат
    КонецЕсли;
	
	Если ТранзакцияАктивна() Тогда
		ЗафиксироватьТранзакцию();
	КонецЕсли;
	
	Сообщить("начало: "+ТекущаяДата());
	
	Если Вариант = "Ping" Тогда
		
		СтрокаЗапроса = "ping -n 1 -w "+Формат(1000 * ЗадержкаСекунд, "ЧДЦ=0; ЧГ=") + " 127.255.255.255"; 
		WshShell = Новый COMОбъект("WScript.Shell"); 
		WshShell.Run(СтрокаЗапроса, 0, -1); 
		
	ИначеЕсли Вариант = "smaharbA" Тогда
		
		Для к = 1 По ЗадержкаСекунд Цикл
			ПолучитьCOMОбъект("winmgmts:").ExecNotificationQuery("Select * from __instancemodificationevent where TargetInstance isa 'Win32_UTCTime'").NextEvent();
		КонецЦикла;
		
	ИначеЕсли Вариант = "Пустой цикл" Тогда
		
		// грузит процессор
		ДатаВыхода = ТекущаяДата() + ЗадержкаСекунд;
		Пока ТекущаяДата() < ДатаВыхода Цикл
			ОбработкаПрерыванияПользователя();
		КонецЦикла;
		
	ИначеЕсли Вариант = "Sleep" Тогда
		
		// не работает
		
		scr = Новый ComОбъект("WScript.Shell"); 
		scr.Run("sleep "+Формат(ЗадержкаСекунд, "ЧДЦ=0; ЧГ="), 0, 1);
		
	ИначеЕсли Вариант = "SleepJs" Тогда
		
		// работает
		
		Скрипт = Новый ТекстовыйДокумент(); 
		Скрипт.УстановитьТекст 
		( 
		"if (WScript.Arguments.Count()==0) 
		| WScript.Quit(); 
		|else 
		| if (isNaN(parseInt(WScript.Arguments(0)))) 
		| WScript.Quit(); 
		|WScript.Sleep(WScript.Arguments(0));" 
		); 
		Скрипт.Записать(КаталогВременныхФайлов()+"sleep.js", КодировкаТекста.ANSI); 
		WshShell = Новый COMОбъект("wscript.shell"); 
		WshShell.Run("wscript.exe """+КаталогВременныхФайлов()+"sleep.js"" "+Формат(ЗадержкаСекунд*1000,"ЧГ=0"), 0, -1); 
		УдалитьФайлы(КаталогВременныхФайлов()+"sleep.js"); 
		
	ИначеЕсли Вариант = "SleepVbs" Тогда
		
		// работает
		
		Сигнатура = Формат(ТекущаяДата(), "ДФ=yyyyMMddhhmmss");
		ПутьСкрипта = КаталогВременныхФайлов()+"SleepScript"+Сигнатура+".vbs";
		СкриптФайл = Новый ТекстовыйДокумент;
		СкриптФайл.ДобавитьСтроку("WScript.Sleep("+Формат(ЗадержкаСекунд*1000, "ЧГ=0")+")");
		СкриптФайл.Записать(ПутьСкрипта, КодировкаТекста.OEM);
		WSHShell = Новый COMОбъект("WScript.Shell");
		WSHShell.Run("wscript.exe """+ПутьСкрипта+"""", 0, 1);
		УдалитьФайлы(ПутьСкрипта);
		
	ИначеЕсли Вариант = "TimeoutWS" Тогда
		
		// работает
		
		КомандаWindows = "Timeout /T " + Формат(ЗадержкаСекунд, "ЧГ=0") + " /NoBreak";
		
		WshShell = Новый COMОбъект("WScript.Shell"); 
		WshShell.Run(КомандаWindows, 0, -1);
		
	ИначеЕсли Вариант = "Timeout" Тогда
		
		// работает, показывает черное окно
		
		КомандаWindows = "Timeout /T " + Формат(ЗадержкаСекунд, "ЧГ=0") + " /NoBreak";
		ЗапуститьПриложение(КомандаWindows,,Истина);
		
	ИначеЕсли Вариант = "DynamicWrapper" Тогда
		
		// нужна библиотека
		
		Wrapper = Новый ComОбъект("DynamicWrapper"); 
		Wrapper.Register("KERNEL32.DLL", "Sleep", "i=l", "f=s"); 
		
		Wrapper.Sleep(ЗадержкаСекунд);
		
	КонецЕсли;
	
	Сообщить("^^^^^^: "+ТекущаяДата());
		
КонецПроцедуры

 

 

72

Скачать файлы

Наименование Файл Версия Размер
Паузы при исполнении кода (Sleep для 1с):
.epf 11,61Kb
24.11.17
5
.epf 11,61Kb 5 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. CyberCerber 237 28.11.17 17:45 Сейчас в теме
Странно, что не работает SleepVbs. Я обычно таким методом пользуюсь, на компах с Виндовс работает.
13. swimdog 587 29.11.17 13:04 Сейчас в теме
(1) Сравнил с (7). Работает, у меня пауза была не в секундах, а в миллисекундах, поэтому я решил, что не работает.
2. Infector 124 29.11.17 07:11 Сейчас в теме
Процедура Ожидание(Секунд)
	
	КомандаWindows = "Timeout /T " + Строка(Секунд) + " /NoBreak";
	ЗапуститьПриложение(КомандаWindows,,Истина);
	
КонецПроцедуры	
15. swimdog 587 29.11.17 13:20 Сейчас в теме
3. maikl007 79 29.11.17 08:04 Сейчас в теме
Все работает...

Процедура ПаузаWSH(Секунд) Экспорт
	
	ПолноеИмяФайла  = КаталогВременныхФайлов() + "sleep.vbs";
	Текст = Новый ТекстовыйДокумент;
	Текст.ДобавитьСтроку("wscript.sleep wscript.arguments(0)");
	Текст.Записать(ПолноеИмяФайла, КодировкаТекста.OEM);
	
	WshShell = Новый COMОбъект("Wscript.Shell");
	WshShell.Run("Wscript.exe """+ПолноеИмяФайла+""" "+Секунд*1000, 0, 1);
  
КонецПроцедуры
Показать
4. japopov 49 29.11.17 08:15 Сейчас в теме
Почему-то забыли для УФ асинхронный диалог вопроса? Он принимает параметр Таймаут (который нам и нужен), и заодно выводит юзеру сообщение - а обратная связь не помешает, ведь так? Я обычно вызываю что-то вроде

&НаКлиенте
Процедура ПриОткрытии(Отказ)

	СписокКнопок = Новый СписокЗначений;
	СписокКнопок.Добавить(КодВозвратаДиалога.Прервать,"Прервать");
	ЗадержкаВСекундах = 5;
	ПоказатьВопрос(Новый ОписаниеОповещения("ПриОткрытииЗавершение", ЭтаФорма), "Выполняется Супер-обработка. Подажуйста, подождите",СписокКнопок,ЗадержкаВСекундах,,"Длительная операция");

КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытииЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
	
	Если РезультатВопроса=КодВозвратаДиалога.Таймаут Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Вы дождались, ура!");
	Иначе
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Невтерпёж, да?");
	КонецЕсли;
	
КонецПроцедуры

Показать


Кроме очевидного - задержки, не нагружая системные ресурсы - этот метод даёт пользователю возможность прервать длительный процесс, а нам - корректно отработать это прерывание и сделать всё красиво.

Ах, да, и самое, наверное, важное: этот метод работает с любым клиентом в любой операционной системе. В отличие от.
DarkUser; y.dyachenko; TreeDogNight; necropunk; jif; Yakud3a; Gluk_1C; mickey.1cx; vano-ekt; forseil; NeviD; WizaXxX; +12 Ответить
5. zqzq 17 29.11.17 08:41 Сейчас в теме
(4) +1, какой-то набор вредных советов в статье :) Если только нужно именно на сервере пауза, в очень редких случаях.

Есть ещё
ПодключитьОбработчикОжидания()

работает и в обычных и в управляемых формах.
27. gigabyte_artur 26.12.18 12:31 Сейчас в теме
Найдено в недрах БСП:

Процедура Пауза(Секунд) Экспорт
	
	ТекущийСеансИнформационнойБазы = ПолучитьТекущийСеансИнформационнойБазы();
	ФоновоеЗадание = ТекущийСеансИнформационнойБазы.ПолучитьФоновоеЗадание();
	
	Если ФоновоеЗадание = Неопределено Тогда
		Параметры = Новый Массив;
		Параметры.Добавить(Секунд);
		ФоновоеЗадание = ФоновыеЗадания.Выполнить("ОбщегоНазначенияБТС.Пауза", Параметры);
	КонецЕсли;
		
	Попытка
		ФоновоеЗадание.ОжидатьЗавершения(Секунд);
	Исключение
		Возврат;
	КонецПопытки;
	
КонецПроцедуры
Показать


Платформо-независимо, работает на сервере, не нагружает процессор.
Вызов из БСП:

ОбщегоНазначенияБТС.Пауза(5);
28. gigabyte_artur 26.12.18 12:34 Сейчас в теме
Найдено в недрах БСП:

Процедура Пауза(Секунд) Экспорт
	
	ТекущийСеансИнформационнойБазы = ПолучитьТекущийСеансИнформационнойБазы();
	ФоновоеЗадание = ТекущийСеансИнформационнойБазы.ПолучитьФоновоеЗадание();
	
	Если ФоновоеЗадание = Неопределено Тогда
		Параметры = Новый Массив;
		Параметры.Добавить(Секунд);
		ФоновоеЗадание = ФоновыеЗадания.Выполнить("ОбщегоНазначенияБТС.Пауза", Параметры);
	КонецЕсли;
		
	Попытка
		ФоновоеЗадание.ОжидатьЗавершения(Секунд);
	Исключение
		Возврат;
	КонецПопытки;
	
КонецПроцедуры
Показать


Платформо-независимо, работает на сервере, не загружает процессор.
Вызов из БСП (пример):

ОбщегоНазначенияБТС.Пауза(5);
16. bulpi 138 29.11.17 13:53 Сейчас в теме
(4)
То, что Вы предлагаете, принципиально не годится, именно из-за асинхронности. Нужна ПАУЗА! А у Вас не будет никакой паузы. Висящий вопрос в асинхронном режиме - это не пауза, т.к. программа уже пошла вовсю дальше работать.
17. japopov 49 29.11.17 14:44 Сейчас в теме
(16)
То, что Вы предлагаете, принципиально не годится, именно из-за асинхронности. Нужна ПАУЗА! А у Вас не будет никакой паузы. Висящий вопрос в асинхронном режиме - это не пауза, т.к. программа уже пошла вовсю дальше работать.


То есть, как делать формы для работы в асинхронном режиме, Вы не умеете. Но это - недостаток Вас как специалиста, а не моего ответа как алгоритма.

Подскажу для тех, кто в танке: код в методе ПриОткрытииЗавершение() выполнится только после завершения ожидания.
Переносите в него всё, что должно было отработать после паузы, и всё!

А вообще, сайт its.1c.ru, и RTFM
21. bulpi 138 29.11.17 17:54 Сейчас в теме
(17)
То есть, смысл моего замечания Вы не поняли. Но это - недостаток Вас как специалиста, а не моего замечания :).
Уж конечно, я понимаю, что "код в методе ПриОткрытииЗавершение() выполнится только после завершения ожидания". Но вот то, что ПОСЛЕ ПоказатьВопрос - выполнится сразу. И вот этот "гениальный" подход : "Переносите в него всё, что должно было отработать после паузы, и всё" - применим не всегда. Или для этого нужно извратиться так, как рвать гланды через Ж. Статья вообще не об этом, а о паузе. А это не ПАУЗА ( впрочем, что-то я повторяюсь, а зачем ? )
6. d_protos 29.11.17 09:33 Сейчас в теме
Статья не настолько полезна, насколько вредна.
Если нужна пауза в клиентском коде, то есть ПодключитьОбработчикОжидания() и не нужно изобретать велосипед.
Если нужна пауза в серверном коде, то что-то не так с логикой приложения.
8. ediks 325 29.11.17 10:16 Сейчас в теме
(6)
Если нужна пауза в серверном коде, то что-то не так с логикой приложения.

Вы считаете, что обработкам, выполняющимся на сервере, совсем никогда не нужна задержка выполнения?
Реальный пример кода, где обработка ждет, когда все задания отправятся на принтер. Кстати, применен один из методов паузы, описанный автором статьи:
Пока пОбъектПринтер.cCountOfPrintjobs < пКоличествоЗадачПечати И ТекущаяДата() <= ПаузаОкончание Цикл
	//Wait until all print jobs have entered the print queue
	Если пКоличествоЗадачПечати = 0 Тогда Прервать КонецЕсли; 
КонецЦикла;
9. Yimaida 34 29.11.17 10:40 Сейчас в теме
(6) пример из жизни. нужна была пауза при отправке смс, т.к. оператор устанавливал лимит на количество сообщений в очереди в секунду.
P.S. Сделал через ПодключитьОбработчикОжидания()
echo77; sasha777666; +2 Ответить
7. ediks 325 29.11.17 09:53 Сейчас в теме
(0)
3) Варианты с использованием Sleep. Насколько я понимаю, требуют наличия программы sleep.exe.

Не соглашусь с автором - вариант SleepJs прекрасно работает.

СкриптФайл  = Новый ТекстовыйДокумент;
СкриптФайл.УстановитьТекст("WScript.Sleep(5000)");
СкриптФайл.Записать(КаталогВременныхФайлов() + "clean.vbs",КодировкаТекста.ANSI);
Сообщить(ТекущаяДата());
ЗапуститьПриложение("""" + КаталогВременныхФайлов() + "clean.vbs""",, Истина);
Сообщить(ТекущаяДата());
14. swimdog 587 29.11.17 13:04 Сейчас в теме
(7) Работает, у меня пауза была не в секундах, а в миллисекундах, поэтому я решил, что не работает.
10. МихаилМ 29.11.17 11:25 Сейчас в теме
все варианты работают в windows. укажите чисто 1с метод через HTTPСоединение или ожидания блокировки
19. Darklight 18 29.11.17 16:34 Сейчас в теме
(10) Через HTTPСоединение
функция ОжидатьЧерезHTTP(Знач Таймаут)
	хтп = новый HTTPСоединение("1C.ru",11111,,,,Таймаут);
	Попытка
		хтп.получить(новый HTTPЗапрос (""));
	исключение
		
	Конецпопытки;
КонецФункции
Показать


Будет платформенонезависимо, будет работать на клиенте. Но опять-таки, не работает в безопасном режиме (хотя на сервере профиль безопасности можно настроить, чтобы работало - для КОРП лицензии сервера).

И, главное, чтобы строка соединения в "HTTPСоединение" была указана корректная - чтобы доступ к HTTP ресурсу в принципе был!
11. SerebanSK 26 29.11.17 11:28 Сейчас в теме
Если очень хочется ждать на сервере, то на мой взгляд наименее костыльный способ - это ожидание фоновым заданием самого себя.

Процедура ЖдатьНаСервереВФоновомЗадании(Знач Таймаут) Экспорт
		
	Ключ = Строка(Новый УникальныйИдентификатор());
	Наименование = "Фоновое ожидание";
	
	МассивПараметров = Новый Массив;
	МассивПараметров.Добавить(Таймаут);
	МассивПараметров.Добавить(Ключ);
	МассивПараметров.Добавить(Наименование);
	
	ФЗ = ФоновыеЗадания.Выполнить("ОбщегоНазначения.ЖдатьЗавершенияФонового", МассивПараметров, Ключ, Наименование);
	ФЗ.ОжидатьЗавершения();
	
КонецПроцедуры


Процедура ЖдатьЗавершенияФонового(Таймаут,Ключ,Наименование) Экспорт
	
	Попытка
		ФоновыеЗадания.ПолучитьФоновыеЗадания(Новый Структура("Наименование,Ключ", Наименование, Ключ))[0].ОжидатьЗавершения(Таймаут);
	Исключение
	КонецПопытки;	
	
КонецПроцедуры
Показать
KEV_SZK; JohnyDeath; Evil Beaver; Krio2; Darklight; nixel; azubar; Labotamy; +8 Ответить
18. Darklight 18 29.11.17 15:48 Сейчас в теме
Ожидание на фоновом задании - самое интересное решение (сам только что хотел предложить такое же) - но, надо бы проверить как будет вести себя в файловой базе. Предложу ещё фичу - один раз запустить "бесконечное" регл. задание (аналогично ждущее завершения самого себя) - и всем остальным сеансам обращаться на ожидание завершения ФЗ этого регл. задания. Но будет одна пользовательская лицензия расходоваться на регл. задание. Но ФЗ доступны только на сервере или в толстом клиенте - но для длительного ожидания можно и в серверный контекст переходить - это не проблема.

Остальные все советы платформенозависимые (хотя некоторые подходы можно переработать так, чтобы они имели реализацию для разных платформ).
Использовать WshShell
WshShell = Новый COMОбъект("Wscript.Shell");
WshShell.Run("Wscript.exe...")

Всё же не рекомендую - 10-я версия платформы на это может ругаться, да ещё и в безопасном режиме работать не будет.
Но если надо так - то лучше "ЗапуститьПриложение(КомандаWindows,,Истина);" - по крайней мере будет работать в Windows, Linux и MacOS (c WEB-клиентом могут быть проблемы), где теперь тоже есть клиенты 1С.

Если нужно чисто на клиенте - то придётся извращаться с "ПодключитьОбработчикОжидания" - если нужно платформеннонезависимое решение, работающее в безопасном режиме, без модальности.

Но прямо среди кода остановиться так не получится - но, на мой взгляд, если такой код разбить на части через "ПодключитьОбработчикОжидания" не получится - значит там явно очень плохой дизайн.

Либо, нужно просто написать классический бесконечный цикл (думаю, что сюда попадут лишь короткие паузы - не более пары секунд- можно и покрутить проц клиента - коли уж очень нужно).

Или писать платформеннозависимый не безопасный код через вызов «ЗапуститьПриложение» или, ожидать на фоновом задании (регламентном или специально запускаемом), ждущим самого себя; с заходом в серверный контекст выполнения (если это не толстый клиент).

В общем всё ещё ждём, когда 1С встроит в платформу системную функцию паузы... давно ждём....
Krio2; SerebanSK; +2 Ответить
12. azubar 35 29.11.17 12:27 Сейчас в теме
Можно еще так фоновое задание+блокировки:

// Процедура - Ожидание
//
// Параметры:
// Длительность - Число - длительность ожидания в секундах.
//
Процедура Ожидание(Длительность) Экспорт
 
     Идентификатор = Новый УникальныйИдентификатор;
 
     НачатьТранзакцию();
 
     Блокировка = Новый БлокировкаДанных; 
     Элемент = Блокировка.Добавить("РегистрСведений.сшпБлокировкаОчереди");
     Элемент.Режим = РежимБлокировкиДанных.Исключительный;
     Элемент.УстановитьЗначение("Идентификатор", Идентификатор); 
     Блокировка.Заблокировать();
 
     мсвПараметров = Новый Массив;
     мсвПараметров.Добавить(Идентификатор);
     Задание = ФоновыеЗадания.Выполнить("сшпОбщегоНазначения.ВыполнитьПаузу", мсвПараметров,, "Выполнить паузу "+Длительность+" сек.");
 
     Попытка
          Задание.ОжидатьЗавершения(Длительность);
          Исключение
     КонецПопытки; 
 
     ОтменитьТранзакцию();
 
КонецПроцедуры
Показать


// Процедура - Выполнить паузу
//
// Параметры:
// Идентификатор - УникальныйИдентификатор - идентификатор сессии ожидания.
//
Процедура ВыполнитьПаузу(Идентификатор) Экспорт
 
     НачатьТранзакцию();
     Блокировка = Новый БлокировкаДанных;
 
     Элемент = Блокировка.Добавить("РегистрСведений.сшпБлокировкаОчереди");
     Элемент.Режим = РежимБлокировкиДанных.Исключительный;
     Элемент.УстановитьЗначение("Идентификатор", Идентификатор);
 
     Попытка
          Блокировка.Заблокировать();
     Исключение
     КонецПопытки;
     ОтменитьТранзакцию();
 
КонецПроцедуры
Показать
20. opx 548 29.11.17 16:40 Сейчас в теме
Я думаю, что это хороший пример того как писать не надо.
24. user966794 27.04.18 21:13 Сейчас в теме
(20)Павел, здравствуйте! Пишу не по теме, но хотелось бы проконсультироваться с Вами по поводу Вашего плагина для вордпресс opcity. Как с Вами можно связаться?
22. Infector 124 30.11.17 12:34 Сейчас в теме
Думаю, что многие уже сами догадались, но все-таки нужно поотделять мух от котлет хотя бы для новичков, которые могут это читать:

Вариант с пингами:
&НаКлиенте
Процедура Ping_01(Секунд)
	
	КомандаWindows = "ping -n 1 -w "+Формат(1000 * Секунд, "ЧДЦ=0; ЧГ=") + " 127.255.255.255"; 
	WshShell = Новый COMОбъект("WScript.Shell"); 
	WshShell.Run(КомандаWindows, 0, -1); 
	
КонецПроцедуры


Трансформируется в:
&НаКлиенте
Процедура Ping_02(Секунд)
	
	КомандаWindows =  "ping -n 1 -w "+Формат(1000 * Секунд, "ЧДЦ=0; ЧГ=") + " 127.255.255.255"; 
    ЗапуститьПриложение(КомандаWindows,,Истина);
	
КонецПроцедуры


Аналогично Timeout, который я выложил в комментариях
&НаКлиенте
Процедура Timeout_03(Секунд)
	
	КомандаWindows = "Timeout /T " + Строка(Секунд) + " /NoBreak";
    ЗапуститьПриложение(КомандаWindows,,Истина);
	
КонецПроцедуры


Трансформируется в:
&НаКлиенте
Процедура Timeout_04(Секунд)            
	
	КомандаWindows = "Timeout /T " + Строка(Секунд) + " /NoBreak";

	WshShell = Новый COMОбъект("WScript.Shell"); 
	WshShell.Run(КомандаWindows, 0, -1); // Вставить содержимое обработчика.
	
КонецПроцедуры
Показать


Соответственно все эти варианты обращаются к командам, которые можно вводить через консольку операционной системы, использовать в CMD-файлах, но следует различать:
Во-первых обратиться можно к разным командам ОС (Ping, Timeout)
Во-вторых способ, которым можно обратиться - (Оператор платформы "ЗапуститьПриложение" и COMОбъект("WScript.Shell"); )

Соответственно - на клиенте "ЗапуститьПриложение" выкидывает черное окно с консолью, на сервере его никто не видит
COMОбъект("WScript.Shell") - обходится без визуальных эффектов.

А что из этого использовать - дело другое Timeout команда для задержки собственно и предназначенная, но в старых операционных системах (Windows 2000 точно, Windows XP не помню точно) отсутствовала. Проблема с CMD в те времена решалась похишением Timiout.exe с серверной операционной системы аналогичной давности и помещением в System32 на целевой машине.

А вот найти машину не поддерживающую Ping и лишенную TCP/IP напрочь уже тогда было сложно. (Хотя мне это удалось)
leemuar; Yasasha; serg_infostart; Alligator84; swimdog; +5 Ответить
23. fish249 05.12.17 09:45 Сейчас в теме
Спасибо, очень полезная статья.
25. swimdog 587 06.06.18 11:16 Сейчас в теме
Кусок функционала из БСП:

Функция ПроверитьДоступностьСервера(АдресСервера)

СистемнаяИнформация = Новый СистемнаяИнформация();
ЭтоWindows = (СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86)
Или (СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64);

Если ЭтоWindows Тогда
ШаблонКоманды = "ping %1 -n 2 -w 500";
Иначе
ШаблонКоманды = "ping -c 2 -w 500 %1";
КонецЕсли;

СтрокаКоманды = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонКоманды, АдресСервера);

Результат = ЗапуститьПрограмму(СтрокаКоманды, ПараметрыЗапускаПрограммы);
26. nordcomp 05.12.18 09:43 Сейчас в теме
Ссылка на эту статью есть в публикации, которую использовали. Взяли на заметку
Оставьте свое сообщение