Внешняя обработка заполнения табличной части из Excel (с созданием Номенклатуры)

Публикация № 579188

Учет и отчетность - Оптовая торговля

обработка загрузка заполнение табличной части Excel

Внешняя обработка заполнения табличной части из Excel (с созданием Номенклатуры)

Обработка не претендует на уникальность. Скорее еще один вариант из многих. Суть работы с обработкой

- подключается как внешняя обработка заполнения табличной части (по умолчанию - подключается к документу "Счет на оплату поставщика")

- пользователь выбирает файл xls или xlsx

- в файле Excel не всегда удобно визуально определить номера колонок, в которых указаны реквизиты, необходимые для табличной части. В качестве помощи - кнопка "Прочитать файл (необязательно)". При нажатии на кнопку считывается файл в табличный документ. Определить колонки можно точно

- пользователь указывает номера колонок и номера строк, из которых будут считаны данные, нажимает кнопку "1 - Заполнить таблицу". Таблица заполняется информацией из файла

- теперь необходимо выполнить сопоставление с Номенклатурой, существующей в базе. Выбирается вариант поиска - "По наименования", "По артикулу", "По наименованию и артикулу", "По наименованию, затем по артикулу", "По артикулу, затем по наименованию". Поиск выполнен в виде запросов в цикле (по каждой строке). Понимаю, что в ущерб производительности.

"Наименование" - это Полное наименование Номенклатуры (из-за ограничения длины "Наименования")

- если Номенклатура не найдена, ячейка выделяется оранжевым фоном. Пользователь нажимает кнопку "2 - Создать номенклатуру". Номенклатура создается в указанной папке с указанным "Видом номенклатуры"

- затем нажимается кнопка "3 - Перенести в документ" и происходит окончательная обработка табличной части штатными средствами (по кнопке "Изменить" - устанавливается ставка НДС, например)

Проверено на конфигурации "Бухгалтерия предприятия, редакция 3.0 (3.0.44.188)"

 

Update 17.02.2019

Внесены изменения (проверено на релизе 3.0.67.74)

- Изменено - чтение файла Excel выполняется средствами платформы (режим совместимости, соответственно, должен быть не ниже 8.3.6), наличие установленного MS Office (Exel) на клиентском компьютере или сервере не требуется

- Исправлено - теперь обработка работает и в серверном режиме (ранее при открытии обработки на стороне сервера, если файл находился на компьютере клиента, и путь к файлу был указан не сетевой - возникало сообщение, что файл не найден)

Скачать файлы

Наименование Файл Версия Размер
Заполнение табличной части из Excel

.epf 19,18Kb
22.01.17
153
.epf 1.1.0 19,18Kb 153 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Blackie 23.01.17 10:40 Сейчас в теме
Спасибо за обработку. Вроде, удобно. А можете добавить способ загрузки xls-файла не только через com-соединение, но и без установленного на компьютере MS Excel? В 8.3, вроде, у табличного документа уже есть метод Прочитать().
lebedenko; +1 Ответить
2. Batman 154 23.01.17 11:20 Сейчас в теме
С предложением полностью согласен. Начиная с 8.3.6, если мне память не изменяет, появилась эта возможность. На дворе - 8.3.9, разумное пожелание. Будет время - придумаю, спасибо за предложение
3. lebedenko 25.01.17 07:49 Сейчас в теме
Очень существенное пожелание! При работе на сервере часто сталкиваюсь с такой проблемой com-соединений... из за чего приходится переходить на пользовательский компьютер с установленным Экселем.
4. ImHunter 195 25.01.17 07:55 Сейчас в теме
XLSX без Excel - легко. Ибо это зазипованный XML. Из какой-то обработки из состава БСП нужно использовать/скопировать 2-3-4 процедуры. Будет кому интересно - поищу.
5. Batman 154 25.01.17 09:45 Сейчас в теме
(4) ImHunter, информация пригодится, мне точно интересно :) Заранее - спасибо
34. shmax 4 12.11.19 14:00 Сейчас в теме
35. Batman 154 12.11.19 17:10 Сейчас в теме
(34) В почту пришло сообщение с текстом "БП 3.0.73.60 8.3.12.1685 при открытии сразу ошибка :-( {ВнешняяОбработка.изExcel.Форма.Форма.Форма(4)}: Поле объекта не обнаружено (ОбъектыНазначения) Если НЕ Параметры.ОбъектыНазначения...". Думаю, это был Ваш вопрос, хотя у меня видна только часть "БП 3.0.73.60 8.3.12.1685"

Проверьте, пожалуйста, для каких документов подключена эта обработка (картинку с примером прилагаю)
Прикрепленные файлы:
6. ImHunter 195 25.01.17 10:05 Сейчас в теме
// Передираем из БСП, обработка ЗагрузкаДанныхИзФайла
Функция ТаблицаИзФайлаExcel2007(ПутьКФайлу)
	
	ВременныйКаталог = КаталогВременныхФайлов() + ПолучитьРазделительПути() + "excel2007";
	УдалитьФайлы(ВременныйКаталог);
	
	РаспаковатьФайл(ПутьКФайлу, ВременныйКаталог);
	
	ФайлСтрок = ВременныйКаталог + ПолучитьРазделительПути() + "xl" + ПолучитьРазделительПути() +"sharedStrings.xml";
	СписокСтрок = ПрочитатьСписокСтрок(ФайлСтрок);
	
	ФайлФорматов = ВременныйКаталог + ПолучитьРазделительПути() + "xl" + ПолучитьРазделительПути() +"styles.xml";
	СписокФорматов = ПрочитатьСписокФорматов(ФайлФорматов);
	
	НомерЛиста = 1;
	ФайлЛиста = ВременныйКаталог + ПолучитьРазделительПути() + "xl" + ПолучитьРазделительПути() + "worksheets" + ПолучитьРазделительПути() + "sheet" + НомерЛиста + ".xml";
	Файл = Новый Файл(ФайлЛиста);
	Если НЕ Файл.Существует() Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	МассивБукв = ПолучитьМассивБукв();
	ДеревоДанных = ПолучитьДеревоДанных(ФайлЛиста);
	
	Таблица = Новый ТаблицаЗначений;
	
	// Создаем колонки
	Колонки = ДеревоДанных.Строки.Найти("dimension", "Объект", Истина);
	Счетчик = 0;
	Для Каждого Строка Из Колонки.Строки Цикл
		Если Строка.Объект = "ref" Тогда
			Диапазон = Строка.Значение; 
			// Поиск максимального значения колонки.
			Счетчик = МассивБукв.Количество();
			Пока Счетчик > 0 Цикл 
				Счетчик = Счетчик - 1;
				Если Найти(Диапазон, МассивБукв[Счетчик]) > 0 Тогда
					Для Индекс = 0 По Счетчик Цикл
						Таблица.Колонки.Добавить(МассивБукв[Индекс]);
					КонецЦикла;
					Счетчик = 0;
				КонецЕсли;
			КонецЦикла;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	// читаем строки
	СтрСтрок = ДеревоДанных.Строки.Найти("sheetData", "Объект", Истина);
	Для Каждого Строка Из СтрСтрок.Строки Цикл
		НоваяСтрока = Таблица.Добавить();
		
		Для Каждого Колонка Из Строка.Строки Цикл
			Если Колонка.Объект <> "c" Тогда
				Продолжить;
			КонецЕсли;
			
			ЗначениеЯчейки = Неопределено;
			
			СтрЗначение = Колонка.Строки.Найти("v", "Объект");
			Если СтрЗначение <> Неопределено Тогда
				ЗначениеЯчейки = СтрЗначение.Значение;
			КонецЕсли;
			
			ЯчейкаСодержитТекст = Ложь;
			СтрЗначение = Колонка.Строки.Найти("t", "Объект");
			Если СтрЗначение <> Неопределено И СтрЗначение.Значение = "s" И ЗначениеЯчейки <> Неопределено Тогда
				ЯчейкаСодержитТекст = Истина;
				Позиция = Число(ЗначениеЯчейки); 
				Если СписокСтрок.Количество() > Позиция Тогда
					ЗначениеЯчейки = СписокСтрок.Получить(Позиция).Значение;
				КонецЕсли;
			КонецЕсли;
			
			сОбъект = Колонка.Строки.Найти("s", "Объект");
			Если сОбъект <> Неопределено Тогда
				СтрЗначение = СтрокуВЧисло(Колонка.Строки.Найти("s", "Объект").Значение, -1);
				Если СтрЗначение >= 0 Тогда
					ИмяФормата = СписокФорматов.Получить(СтрЗначение);
					Если ИмяФормата = "Дата" ИЛИ ИмяФормата = "ДатаВремя" ИЛИ ИмяФормата = "Время" Тогда
						Если ЗначениеЗаполнено(ЗначениеЯчейки) И НЕ ЯчейкаСодержитТекст Тогда
							ПозицияРазделителя = Найти(ЗначениеЯчейки, ".");
							Если ПозицияРазделителя > 0 Тогда 
								КоличествоДней = СтрокуВЧисло(Лев(ЗначениеЯчейки, ПозицияРазделителя - 1)) * 86400 - 2 * 86400;
								КоличествоСекунд = СтрокуВЧисло(Сред(ЗначениеЯчейки, ПозицияРазделителя + 1)) - 2 * 60;
							Иначе
								КоличествоДней = СтрокуВЧисло(ЗначениеЯчейки) * 86400 - 2 * 86400;
								КоличествоСекунд = 0;
							КонецЕсли;
							ПолученнаяДата = Дата(1900, 1, 1, 0, 0, 0) + КоличествоДней + КоличествоСекунд;
							Если ИмяФормата = "Дата" Тогда 
								ЗначениеЯчейки = Формат(ПолученнаяДата, "ДЛФ=D");
							ИначеЕсли ИмяФормата = "ДатаВремя" Тогда 
								ЗначениеЯчейки = Формат(ПолученнаяДата, "ДЛФ=DT");
							ИначеЕсли ИмяФормата = "Время" Тогда 
								ЗначениеЯчейки = Формат(ПолученнаяДата, "ДЛФ=T");
							КонецЕсли;
						КонецЕсли;
					Иначе
						Если ИмяФормата = "Число" Тогда
							ЗначениеЯчейкиЧисло = Формат(СтрокуВЧисло(ЗначениеЯчейки), "ЧРГ=''; ЧГ=0");
							Если НЕ ЗначениеЗаполнено(ЗначениеЯчейкиЧисло) Тогда
								ЗначениеЯчейки = Формат(ЗначениеЯчейки, "ЧРГ=''; ЧГ=0");
							Иначе
								ЗначениеЯчейки = ЗначениеЯчейкиЧисло;
							КонецЕсли;
						КонецЕсли;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
			
			// поиск колонки
			СтрЗначение = Колонка.Строки.Найти("r", "Объект");
			Если СтрЗначение <> Неопределено Тогда
				ИмяКолонки = СтрЗначение.Значение;
			КонецЕсли;
			ИндексСтроки = Неопределено;
			Счетчик = МассивБукв.Количество();
			Пока Счетчик > 0 Цикл 
				Счетчик = Счетчик - 1;
				Если Найти(ИмяКолонки, МассивБукв[Счетчик])>0 Тогда
					ИндексСтроки = Счетчик;
					Счетчик = 0;
				КонецЕсли;   
			КонецЦикла;
			
			НоваяСтрока[МассивБукв[ИндексСтроки]] = ЗначениеЯчейки;
		КонецЦикла;
	КонецЦикла;
	Возврат Таблица;
	
КонецФункции

Функция ПолучитьДвоичныеДанныеДляЗагрузки(АдресХранилищаИлиДвоичныеДанные)
	// анализируем входной параметр	
	ТипВходногоПараметра = ТипЗнч(АдресХранилищаИлиДвоичныеДанные);
	Если ТипВходногоПараметра=Тип("Строка") Тогда 
		Если Не ЭтоАдресВременногоХранилища(АдресХранилищаИлиДвоичныеДанные) Тогда 
			ВызватьИсключение("Недопустимый адрес загружаемого реестра: " + АдресХранилищаИлиДвоичныеДанные);
		КонецЕсли;
		ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресХранилищаИлиДвоичныеДанные);
		ТипДанныхИзХранилища = ТипЗнч(ДвоичныеДанные);
		Если ТипДанныхИзХранилища<>Тип("ДвоичныеДанные") Тогда
			ВызватьИсключение("По переданному адресу " + АдресХранилищаИлиДвоичныеДанные + " содержатся НЕ двоичные данные. Тип: " + ТипДанныхИзХранилища);
		КонецЕсли;
	ИначеЕсли ТипВходногоПараметра=Тип("ДвоичныеДанные") Тогда 
		ДвоичныеДанные = АдресХранилищаИлиДвоичныеДанные;
	Иначе 
		ВызватьИсключение("Недопустимый вид данных загружаемого реестра: " + ТипВходногоПараметра);
	КонецЕсли;
	Возврат ДвоичныеДанные;
КонецФункции

// Локальная замена штатной функции из платформы 8.3
Функция ПолучитьРазделительПути()
	Возврат "\";
КонецФункции

Процедура РаспаковатьФайл(Файл, Каталог)
	Архив = Новый ЧтениеZipФайла;
	Архив.Открыть(Файл);
	Архив.ИзвлечьВсе(Каталог, РежимВосстановленияПутейФайловZIP.Восстанавливать);
КонецПроцедуры
Показать
bow; AlX0id; +2 Ответить
7. Batman 154 25.01.17 10:35 Сейчас в теме
8. rozer 268 26.01.17 20:55 Сейчас в теме
велосипед это конечно хорошо но в БСП есть же "загрузка из файлов" https://youtu.be/ovjumkjtn9I?list=PL8TlceaQF_l_CMirNFV1rgUfXUM_w_JMD .... enjoy ))
9. ir.iv 16.10.17 01:29 Сейчас в теме
Здравствуйте, Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.52.32)
При открытии возникла ошибка:
Поле объекта не обнаружено (ОбъектыНазначения)
Помогите, будьте добры.....
10. Batman 154 16.10.17 10:33 Сейчас в теме
(9) ir.iv, доброго времени суток, отвечаю Вам в личном сообщении
11. ir.iv 16.10.17 14:04 Сейчас в теме
(10) Спасибо огромное-все заработало! Обработку подключила в самой программе (администрирование-подключение внешних печатных форм и обработок). Давно искала такую "без заморочек". Так что +++++
20. llg_44 25 16.02.19 22:20 Сейчас в теме
(10) У меня аналогичная ошибка. Могу я расчитывать на помощь? время прошло, релиз уже 3.0. 67.67.
{ВнешняяОбработка.изExcel.Форма.Форма.Форма(4)}: Поле объекта не обнаружено (ОбъектыНазначения)
Если НЕ Параметры.ОбъектыНазначения = Неопределено Тогда
21. llg_44 25 16.02.19 22:22 Сейчас в теме
(10) У меня аналогичная ошибка. Могу я расчитывать на помощь? время прошло, релиз уже 3.0. 67.67.
{ВнешняяОбработка.изExcel.Форма.Форма.Форма(4)}: Поле объекта не обнаружено (ОбъектыНазначения)
Если НЕ Параметры.ОбъектыНазначения = Неопределено Тогда
(10)
Прикрепление обработки к базе ничего не дало. Я не нахожу следы обработки в базе(
22. Batman 154 16.02.19 23:16 Сейчас в теме
(21) Доброго времени суток. Давайте проверим, к каким типам документов Вы подключили обработку?
Прикрепленные файлы:
23. llg_44 25 17.02.19 14:54 Сейчас в теме
(22) К счету на оплату покупателю.
24. Batman 154 17.02.19 15:32 Сейчас в теме
(23) Проверил на демо-базе релиза 3.0.67.74, серверная, подключив обработку к документу "Счет на оплату покупателю", воспроизвести ситуацию не удалось, к сожалению. В чем еще может быть причина....
В одном из сообщений была фраза, что на версии КОРП не работает. Не проверял на этой версии конфигурации. У Вас, случайно, не КОРП?
25. llg_44 25 17.02.19 18:17 Сейчас в теме
26. Batman 154 18.02.19 09:05 Сейчас в теме
(25) Ответил личным сообщением
12. Batman 154 16.10.17 19:36 Сейчас в теме
13. user777072 22.01.18 12:59 Сейчас в теме
Добрый день,
Не работает в конфигурации КОРП
Ошибка - Поле объекта не обнаружено (объекты назначения)
Как можно исправить?
14. Batman 154 22.01.18 16:28 Сейчас в теме
Добрый день.
При подключении обработки - указали объекты назначения (документы), к которым должна подключиться эта обработка заполнения табличных частей?
15. nata_87 36 20.08.18 15:51 Сейчас в теме
При нажатии на кнопку прочитать файл, данные с файла читаются, а при нажатии на 1-Заполнить таблицу выходит сообщение, что Файл не существует!
16. Batman 154 20.08.18 21:04 Сейчас в теме
Что может быть.... Длина пути к файлу - не превышает ли 255 символов?
17. AlexB1 13.02.19 00:13 Сейчас в теме
не заполняет таблицу. файл видит. бп (3.0.67.43)
18. Batman 154 13.02.19 10:58 Сейчас в теме
(17) Доброго времени суток. Уточните - база файловая или серверная? Пришлите для примера файл, пожалуйста
19. AlexB1 13.02.19 17:08 Сейчас в теме
Доброго дня. Пробую на файловой.Но работать будет на серверной.
Прикрепленные файлы:
Поставка МТР 4 квартала для АБС для загрузки.xls
27. VKuser105103569 21.04.19 19:15 Сейчас в теме
двс!
аудит на фреше пройдет?
29. Batman 154 21.04.19 21:13 Сейчас в теме
(27) Затрудняюсь ответить. С фрешем еще не работал
30. tsk-ga2011 22.04.19 19:34 Сейчас в теме
Здравствуйте, Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.70.30)
При открытии возникла ошибка:
Поле объекта не обнаружено (Товары)
Помогите, пожалуйста.
31. Batman 154 23.04.19 08:35 Сейчас в теме
(30) Доброго времени суток. Проверьте, для какого документа подключена внешняя обработка. Судя по тексту - либо не подключена к документу, либо подключена к документу, у которого нет табличной части с названием "Товары". Чуть выше в переписке, в ответе с номером 22 показана картинка, проверьте на своей ситуации
32. tsk-ga2011 23.04.19 13:17 Сейчас в теме
Добрый день, высылаю скриншоты, посмотрите пожалуйста.
Прикрепленные файлы:
33. Batman 154 23.04.19 22:02 Сейчас в теме
(32) Верно, у этого документа нет табличных частей с названием "Товар" . Выслал в личном сообщении обработку
Оставьте свое сообщение

См. также

Загрузка табелей рабочего времени из файлов Excel Промо

Зарплата Обработка документов Учет рабочего времени Загрузка и выгрузка в Excel v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Обработка по загрузке в типовой документ «Табель» конфигурации ЗУП 3.1 данных из файлов MS Excel, согласно шаблону.

18.10.2019    7432    5    HostHost    0    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

10 стартмани

30.08.2019    15552    13    AleSSandre    25    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    39348    245    informa1555    200    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    30765    7    taurus__    22    

Загрузка файлов/картинок/изображений/фото номенклатуры PRO

Оптовая торговля Розничная торговля Управленческий учет (прочее) v8 v8::УФ Розница УНФ УТ11 Россия Абонемент ($m)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    20466    94    zannv    34    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    27033    61    m-rv    34    

Валовая прибыль в текущем месяце. Актуальная себестоимость (рассчитывается из последней цены закупки с учетом доп.расходов)

Управленческие Оптовая торговля Учет доходов и расходов Оптовая торговля Учет доходов и расходов v8 v8::ОУ УТ11 УУ Абонемент ($m)

Валовая прибыль "Вместо себестоимости - Закупочные цены + Доп. расходы". Дополнительный внешний отчет для конфигурации Управление торговлей 11. Отчет поможет предприятиям, если нет возможности: - закрывать месяц ежедневно; - считать себестоимость вообще по разным причинам. В отчет попадают закупочные цены на *конецпериода* формирования отчета + дополнительные расходы.

3 стартмани

16.03.2018    22680    74    zaika007    49    

Печатные формы для БП 3.0: УПД, ТОРГ-12, Акт, Счет-фактура, Доверенность, Счет Промо

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешние печатные формы УПД, ТОРГ-12, Акта об оказании услуг, Счет-фактуры, Доверенности и Счета на оплату покупателю, актуализированы на последний релиз 3.0.71, поддерживают типовые факсимиле (новую галочку "Подпись и печать"), не содержат ошибок с новой ставкой НДС. В публикации также представлены печатные формы для устаревших релизов.

1 стартмани

28.01.2016    71608    843    config    47    

Автоматизация отдела продаж - CRM конфигурация для небольшой компании

Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. A-CRM - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    23046    41    user718500    14    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    32584    41    KorotkovRV    16    

Анализ распределения заказов по предоплатам

Статистические Оптовая торговля Оптовая торговля v8 УПП1 УУ Абонемент ($m)

Отчет, в котором предоплаты разделены по интервалам (порогам) предоплат.

1 стартмани

21.02.2018    17869    0    wowik    0    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    36150    41    skyadmin    18    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    44362    31    mvv1975    7    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    45335    89    alexey.kutya    81    

Автозаказ для 1С:Управление торговлей 11

Управленческие Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 УУ Абонемент ($m)

Отчет выводит информацию, помогающую принять решение о пополнении товарного запаса.

3 стартмани

26.09.2017    26969    45    The Ded    26    

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    62806    183    ah7777777    487    

Счет-фактура+УПД+УКД с 01.10.2017 в редакции Постановления Правительства РФ от 19.08.2017 № 981. Для всех конфигураций на 1С 8

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 БП2.0 УТ10 УПП1 УНФ БП3.0 УТ11 БУ НУ Абонемент ($m)

Внешние печатные формы с автоматической регистрацией для документа "Счет-фактура выданный" в редакции Постановления Правительства РФ №981 от 19.08.2017 года. Новые счета-фактуры № 981 применяются с 01.10.2017 года. Так же для УТ 10 очень старых релизов применяется сч.фактура в файле.

2 стартмани

18.09.2017    81491    1337    Kontakt    90    

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С

Сканер штрих-кода Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    39164    24    kuld    45    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    36883    236    Windyhead    32    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    59876    351    Tatitutu    48    

Внешние печатные формы Счет-фактура, УПД, УКД образца 2017 г. (ПП от 19.08.2017 № 981) для УПП 1.3, КА 1.1, БП 2.0

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 КА1 БП2.0 УПП1 БУ Абонемент ($m)

Внешние печатные формы "Счет-фактура", "Универсальный передаточный документ", "Универсальный корректировочный документ" (в редакции постановления Правительства Российской Федерации от 19.08.2017 № 981) для типовых конфигураций УПП 1.3, КА 1.1, БП 2.0.

1 стартмани

30.06.2017    53532    725    Tavalik    63    

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3)

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Абонемент ($m)

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    45389    441    a.kapustin    43    

Отчет по продажам с себестоимостью, наценками, рентабельностью (по регистру бухгалтерии) для БП 3.0

Бухгалтерские Управленческие Оптовая торговля Оптовая торговля v8::БУ БП3.0 БУ Абонемент ($m)

С помощью этого отчета можно посмотреть продажи и их себестоимость с широкими возможностями настройки разрезов, вплоть до документа учета.

3 стартмани

26.05.2017    24812    130    kg2    20    

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол

Кассовые операции Оптовая торговля Розничная торговля ККМ Кассовые операции Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    51043    127    Atom74    69    

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен Ценообразование, прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    55409    121    myALKleon    40    

Групповая выгрузка - загрузка налоговых и приходных накладных в формате XML 1С 8.x (Украина) 2019 (Обновление 12.04.2019)

Обмен через XML Оптовая торговля Оптовая торговля v8::БУ 1cv8.cf Украина БУ НУ НДС Абонемент ($m)

Обновление и развитие функционала обработки "Групповая выгрузка налоговых накладных в формате XML 1С 8.x (Украина)"

3 стартмани

27.03.2017    26487    41    script    19    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы документов Пакетная печать Email Оптовая торговля Оптовая торговля v8 БП2.0 КА1 УПП1 УТ10 Россия БУ Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    49592    30    trendy    20    

Отчеты для логистов (а также презентация и пояснительная записка)

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Развитие розничных торговых сетей осуществляется благодаря применению логистики, призванной удовлетворять потребности покупателей в качественных товарах и услугах. Предлагаю Вашему вниманию ряд методических положений, связанных с совершенствованием функционирования логистических систем розничных торговых сетей.

1 стартмани

09.10.2016    30924    2    ksnik    4    

Легкий интернет-магазин из УТ 11.2

WEB Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v8 УТ10 УУ Абонемент ($m)

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    29573    23    hlopik    36    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    24742    10    Smaylukk    3    

Проверка заполнения штрихкодов для УТ 11.2/11.3 и Розница 2.2

Оптовая торговля Розничная торговля Рабочее место Анализ учета Оптовая торговля Розничная торговля v8 Розница УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Новое поступление товаров? Хотите быстро и просто проверить, на все ли товары заданы штрихкоды и быстро? Тогда эта обработка для вас!

2 стартмани

27.07.2016    32382    77    RocKeR_13    30    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    41450    4    milkers    2    

Рабочее место менеджера по продажам

Оптовая торговля Рабочее место Оптовая торговля v8 1cv8.cf Украина УУ Абонемент ($m)

Каждый день менеджеры создают кучу документов. Это и заказы покупателей и сопутствующие документы, которые создаются на основании. Менеджеру всегда необходимо иметь под рукой наиболее эффективный инструмент для формирования заявки от покупателя. Таковым я постарался сделать и эту обработку. Обработка "Рабочее место менеджера продаж" позволяет быстро узнать информацию о товарах на складах, цены товара в различных типах цен номенклатуры, узнать какие цены у поставщиков по выбранному товару и так далее. Много месяцев текущая обработка работает на благо сотрудников и приносит действительно большую пользу. Правда, она более внедрена в работу организации, но даже её модифицированная часть для общества должна принести не менее выгоды в работе с товарами и и заказами покупателей. Так что вот она.

5 стартмани

16.07.2016    31610    50    yarsort    9    

Исправление ошибок при закрытии месяца. Управление Торговлей 11.х для 1С Предприятие 8.3

Закрытие периода Закрытие периода Оптовая торговля Закрытие периода Оптовая торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

В при работе обработки: Закрытие месяца возникают ошибки расчета себестоимости. Постепенно ошибки накапливаются и при дальнейшей эксплуатации системы количество ошибок лавинообразно растет. Обработка помогает исправить ошибки расчета себестоимости. Полный доступ к коду обработки.

3 стартмани

21.06.2016    40757    101    Ликреонский    28    

Неликвиды на складе Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации Управление торговлей 11.2, 11.1 1С Предприятие 8.3

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С Управление Торговлей 11.2, 11.1. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    32320    47    Ликреонский    2    

Автопрайс: Конструктор прайс-листов с автоматической рассылкой по шаблонам

Ценообразование, прайсы Email Оптовая торговля Оптовая торговля v8 УТ10 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Гибкая и удобная система для формирования и автоматической рассылки прайс-листов. Быстрая рассылка - прайсы на 100+ тыс. строк уходят десяткам клиентов с индивидуальными настройками менее чем за 10 мин. Форматы:.XLS, .XLSX, .TXT /CSV(UTF-8/ANSI), .MXL, .HTML, .DOCX, .PDF, .ODS. Поддерживает картинки в прайсе. Создание макетов прайсов, рассылка по почте и FTP, архивация в ZIP, шаблоны, гибкая настройка и расписание, отчеты о рассылке.

10 стартмани

08.06.2016    21619    3    taurus__    0    

Анализ продаж по периодам + оборачиваемость по периодам + средняя стоимость по периодам для УТ10.3

Управленческие Оптовая торговля Оптовая торговля v8 КА1 УТ10 УПП1 Россия УУ Абонемент ($m)

Отчет позволяет сравнивать такие показатели, как валовая прибыль, рентабельность, эффективность, средняя стоимость товаров, оборачиваемость за разные периоды.

4 стартмани

25.05.2016    21263    15    alnovin    0    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена, FTP Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    16090    19    John_d    0    

Печатная форма Счет-Фактура от 01.10.2017, УПД 01.10.2017, Торг-12, Счет на оплату, ТТН (1-Т) БП 3.0 ОРИГИНАЛЬНЫЕ

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 БУ Абонемент ($m)

Набор внешних печатных форм: Счет-Фактура, УПД, Торг-12, ТТН, Счетна оплату для 1С: БП 3.0. Формы взяты из релиза 3.0.54.20 бухгалтерии предприятия. Печатные формы (УПД и счет-фактуры) приведены в соответствие постановления 625 от 25.05.2017 И В РЕДАКЦИИ ПОСТАНОВЛЕНИЯ 981 ОТ 19.08.2017 в формах выводится "Идентификатор госконтракта" и прочие изменения.

1 стартмани

04.05.2016    45661    352    A7758735    3    

ЕГАИС: код алкогольной продукции из штрихкода акцизной марки

Универсальные обработки Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Акцизы Абонемент ($m)

В последнее время мне пришлось потратить очень много времени на внедрение и реализацию функционала ЕГАИС. Очень часто, на форумах, я встречал вопрос: "Как из штрих-кода акцизной марки получить код алкогольной продукции ЕГАИС?". Несколько раз видел неверную реализацию этой задачи. Глядя на это, я набросал простую обработку пересчета кода акцизной марки (base36) в понятный нам уникальный ФСРАР ID алкогольной продукции (Base10).

1 стартмани

11.02.2016    54639    156    OrcaMax    29    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    21550    6    trendy    1