Бегство из Frontol в Далион или очередной день программиста

Публикация № 545406 22.09.16

Бухгалтерский учет - Розничная торговля

frontol Далион

Если к вам пришел маленький серый зайчик в виде сломанного жесткого диска, и вы забыли, что нужно быть нежными и пушистыми и делать копии, то эта статья для вас

Немножко предыстории.

Все началось с того, что сломался очередной жесткий диск и, как всегда, копий нет. Но есть рабочая касса под руководством программы FRONTOL 4 и нужно быстро реанимировать 1С хотя бы в части справочника номенклатуры, ну и цен соответственно.

Учет ведется в программе Далион:УНО (ПРО, Сеть)

Для того, чтобы все это осуществить, нам понадобится программа, которая умеет экспортировать из базы данных INTERBASE/FIRIBERD в Exсel или DBF,  я использовал вот такую:

IBExpert (http://www.ibexpert.net/ibe/index.php) (не спрашивайте, где брать не демо).

  1. Экспортируем следующие таблицы: SPRT -- SPRT.DBF, PRICEDATA -- PRICEDAT.DBF, BARCODE -- BARCODE.DBF, REMAIN -- REMAIN.DBF (для тех, кто использует сложные разрезы цен, думайте сами)
  2. Восстанавливаем чистую базу из шаблона или другим способом
  3. Запускаем обработку указываем ей каталог (жестко прописан, выбор не работает).
  4. После всего этого работать будет все, кроме выгрузки  в кассу.

Чтобы заработала выгрузка в кассу, нужно или заново перезаписать каждую группу, или написать обработку, которая заполнит регистр сведений "АссортиментСкладов"

Для всех, кто будет просить скачать ему обработку у друзей, привожу ее полный код. Не ленитесь, господа.

Функция ОткрытьТаблицуDBF(ИмяТаблицы)
    xbase = Новый xBase; xBase.ОткрытьФайл(ИмяТаблицы);
    Если xBase.Открыта() Тогда    Возврат xBase; иначе Возврат Неопределено; КонецЕсли;
КонецФункции

Процедура СкопироватьxBaseВТЗ(xBase,ТЗн)
    xBase.Первая();
    Пока НЕ xBase.вКонце() Цикл
        НоваяСтрока = ТЗн.Добавить();ЗаполнитьЗначенияСвойств(НоваяСтрока,xBase); xBase.Следующая();    
    КонецЦикла;
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
    xBaseТовары         = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"SPRT.DBF");
    xBaseШтрихКоды         = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"BARCODE.DBF");
    xBaseЦены             = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"PRICEDAT.DBF");
    xBaseЦеныОстатка     = ОткрытьТаблицуDBF(СокрЛП(КаталогТаблиц)+"REMAIN.DBF");
    Если xBaseТовары=Неопределено или xBaseШтрихКоды =Неопределено или
        xBaseЦены =Неопределено или xBaseЦеныОстатка =Неопределено Тогда
        Сообщить("не могу открыть таблицы SPRT.DBF BARCODE.DBF PRICEDAT.DBF REMAIN.DBF");
        Возврат;
    КонецЕсли;
    
    ТзнШтрихКоды = Новый таблицаЗначений;
    ТзнШтрихКоды.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнШтрихКоды.Колонки.Добавить("WareID",Новый ОписаниеТипов("Число"));
    ТзнШтрихКоды.Колонки.Добавить("Barcode",Новый ОписаниеТипов("Строка"));
    ТзнШтрихКоды.Колонки.Добавить("Factor",Новый ОписаниеТипов("Число"));
    
    ТзнЦены = Новый таблицаЗначений;
    ТзнЦены.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнЦены.Колонки.Добавить("Price",Новый ОписаниеТипов("Число"));
    ТзнЦены.Колонки.Добавить("RemainID",Новый ОписаниеТипов("Число"));    //брать из таблице remain поле ID
    
    ТзнЦеныОстатка = Новый таблицаЗначений;
    ТзнЦеныОстатка.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнЦеныОстатка.Колонки.Добавить("WareID",Новый ОписаниеТипов("Число"));
    
    ТзнТовары = Новый ТаблицаЗначений;
    ТзнТовары.Колонки.Добавить("ID",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("PARENTID",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("Code",Новый ОписаниеТипов("Число"));
    ТзнТовары.Колонки.Добавить("Name",Новый ОписаниеТипов("Строка"));
    ТзнТовары.Колонки.Добавить("Text",Новый ОписаниеТипов("Строка"));
    ТзнТовары.Колонки.Добавить("Flags",Новый ОписаниеТипов("Число"));    //Flags = //9727 весовой товар
                                                                        //9726 - обычный товар  254 - группа
    ТзнТовары.Колонки.Добавить("IsWare",Новый ОписаниеТипов("Число"));    // 1- Товар
    ТзнТовары.Колонки.Добавить("Номенклатура",Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));
    
    СкопироватьxBaseВТЗ(xBaseШтрихКоды,ТзнШтрихКоды);
    СкопироватьxBaseВТЗ(xBaseЦены,ТзнЦены);
    СкопироватьxBaseВТЗ(xBaseЦеныОстатка,ТзнЦеныОстатка);
    
    Начатьтранзакцию();
    
    ДокАкт = Документы.АктПереоценки.СоздатьДокумент();
    ДокАкт.Дата = Рабочаядата;
    ЗаполнитьШапкуДокумента(ДокАкт, ПараметрыСеанса.ТекущийПользователь);
    ДокАкт.ВидОперации = Перечисления.ВидыОперацийАктПереоценки.Переоценка;
    ДокАкт.ТОСоздания = ПараметрыСеанса.ТекущийТО;
    УстановитьНомерДокумента(ДокАкт.ЭтотОбъект);
    ДокАкт.ЗаписыватьРасценку = УправлениеРИБ.ТребуетсяПодтверждениеПереоценки(ДокАкт);
    
    xBaseТовары.Первая();
    Пока НЕ xBaseТовары.вКонце() Цикл
        НоваяСтрока = ТзнТОвары.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрока,xBaseТовары);
        
        Если xBaseТовары.IsWare<>1 Тогда    
            НовЭлем = Справочники.Номенклатура.СоздатьГруппу();
            НовЭлем.Код = xBaseТовары.Code;
            НовЭлем.Наименование = xBaseТовары.Name;
            НовЭлем.Записать();
            
            НоваяСтрока.Номенклатура = НовЭлем.Ссылка;    // для идетификации групп
            
            Если  xBaseТовары.PARENTID <> 0  Тогда
                НайденаяГруппа = ТзнТовары.Найти(xBaseТовары.PARENTID,"ID" );
                Если НЕ НайденаяГруппа=неопределено Тогда
                    НовЭлем.Родитель =НайденаяГруппа.Номенклатура;
                    НовЭлем.Записать();
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        xBaseТовары.Следующая();
    КонецЦикла;
    
    Для каждого СтрокаТзн Из ТзнТОвары Цикл
        Если СтрокаТзн.IsWare <> 1 Тогда
            Продолжить;
        КонецЕсли;
        НовЭлем = Справочники.Номенклатура.СоздатьЭлемент();
        НовЭлем.Код             = СтрокаТзн.Code;
        НовЭлем.Наименование     = СтрокаТзн.Name;
        НовЭлем.НаименованиеПолное = СтрокаТзн.Text;
        
        НовЭлем.КатегорияТовара    = Справочники.КатегорииТоваров.УчетПоХарактеристикамНеВедется;
        Если Константы.УстанавливатьПроизводителяПоШК.Получить() Тогда
            НовЭлем.Производитель = Справочники.КлассификаторСтранМира.ПустаяСсылка();
        ИначеЕсли Не ЗначениеЗаполнено(НовЭлем.Производитель) Тогда
            НовЭлем.Производитель =  Константы.ОсновнойПроизводитель.Получить();
        КонецЕсли;
        НовЭлем.СтавкаНДС          = Константы.ОсновнаяСтавкаНДС.Получить();
        НовЭлем.ФирмаФР            = Константы.УправленческаяФирма.Получить();
        НовЭлем.ГруппаТоваровДляПривязкиКФР = Справочники.ГруппыТоваровДляПривязкиКФР.ОсновнаяГруппаТоваров;
        НовЭлем.ОсновноеИзображение = Справочники.ХранилищеДополнительнойИнформации.ПустаяСсылка();
            
        Если СтрокаТзн.Flags=9726 Тогда
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИ.Получить();
        ИначеЕсли СтрокаТзн.Flags=9727 Тогда  
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИВес.Получить();
            НовЭлем.ВыгружатьВВесы                 = истина;
            НовЭлем.РазрешеноДробноеКоличество     = истина;
            НовЭлем.ШтрихКодВключаетКоличество     = истина;
        Иначе
            БазоваяЕдиницаОКЕИ = Константы.ОсновнаяЕдиницаОКЕИ.Получить();
        КонецЕсли;
        НовЭлем.ОбменДанными.Загрузка = Истина;    //чтоб дал записать единицы измерения
        НовЭлем.Записать();
        
        НовЕдиница = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
        НовЕдиница.Владелец                 = НовЭлем.Ссылка;
        НовЕдиница.ЕдиницаПоКлассификатору     = БазоваяЕдиницаОКЕИ;
        НовЕдиница.Наименование             = БазоваяЕдиницаОКЕИ;
        НовЕдиница.Коэффициент                 = 1;
        НовЕдиница.Записать();
        
        НовЭлем.БазоваяЕдиницаИзмерения = НовЕдиница.Ссылка;
        НовЭлем.ЕдиницаИзмеренияОтчетов = НовЕдиница.Ссылка;
        НовЭлем.ЕдиницаИзмеренияЗаказов = НовЕдиница.Ссылка;
        НовЭлем.Записать();
        
        СтрокаТзн.Номенклатура = НовЭлем.Ссылка;
        
        Если  СтрокаТзн.PARENTID <> 0  Тогда
            НайденаяГруппа = ТзнТовары.Найти(СтрокаТзн.PARENTID,"ID" );
            Если НЕ НайденаяГруппа=неопределено Тогда
                НовЭлем.Родитель =НайденаяГруппа.Номенклатура;
                НовЭлем.Записать();
            КонецЕсли;
        КонецЕсли;
        
        НайденныеШтрихКоды = ТзнШтрихКоды.НайтиСтроки(Новый Структура("WareID",СтрокаТзн.ID));
        Для каждого СтрокаШтрихКод Из НайденныеШтрихКоды Цикл
            
            НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.ШтрихКод.Установить(СокрЛП(СтрокаШтрихКод.Barcode));
            НаборЗаписей.Отбор.Номенклатура.Установить(НовЭлем.Ссылка);
            НаборЗаписей.Записать();
            
            НоваяЗапись = НаборЗаписей.Добавить();
            НоваяЗапись.Номенклатура     = НовЭлем.Ссылка;
            НоваяЗапись.Штрихкод         = СокрЛП(СтрокаШтрихКод.Barcode);
             НоваяЗапись.ТипШтрихкода     = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
            Новаязапись.ЕдиницаИзмерения= НовЭлем.БазоваяЕдиницаИзмерения;
            НаборЗаписей.Записать();
            
        КонецЦикла;
        //самое трудное
        найденыйостатокЦены = ТзнЦеныОстатка.Найти(СтрокаТзн.ID,"WareID");
        Если НЕ найденыйостатокЦены = Неопределено Тогда
            НайденнаяЦена             = ТзнЦены.найти(найденыйостатокЦены.ID,"RemainID");
            НоваяЦена                 = ДокАкт.Товары.Добавить();
            НоваяЦена.Номенклатура     = НовЭлем.Ссылка;
            НоваяЦена.Цена             = НайденнаяЦена.Price;
            //Сообщить("найденая цена "+СтрокаТзн.Code+" "+СтрокаТзн.Name+" "+НайденнаяЦена.Price);
        КонецЕсли;
    КонецЦикла;
    ДокАкт.Записать(РежимЗаписиДокумента.Запись);
    ЗафиксироватьТранзакцию();
КонецПроцедуры

Процедура КаталогТаблицНачалоВыбора(Элемент, СтандартнаяОбработка)
КонецПроцедуры

КаталогТаблиц = "D:\Supermarket\";

ВОТ ТАК И ЗАКОНЧИЛИСЬ ОЧЕРЕДНЫЕ БЕССОННЫЕ ВЫХОДНЫЕ.

Доработок не будет.

Скачать файлы

Наименование Файл Версия Размер
ЗагрузитьИзFrontolDBF

.epf 8,64Kb
11
.epf 8,64Kb 11 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. maljaev 799 20.01.17 11:54 Сейчас в теме
Спасибо, помогло раскрутить связку tranzt-sprt-remain-pricedata при построении запроса.
P.S. Кстати да, а чего ADODB и запросы не юзаешь-то? Зачем этот изврат с DBF?
2. sodrk 08.09.21 23:41 Сейчас в теме
Спасибо за обработку, круто выручила. Правда, что-то с кодировкой и при загрузке номенклатуры вместо русских букв загрузились кракозябры, потом исправил загрузкой из табличного документа с перезаписью наименований. 3 минуты работы
Оставьте свое сообщение

См. также

Групповое штрихкодирование номенклатуры (ERP 2.4, ERP 2.5, КА 2.4, УТ 11.4)

Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Внешняя обработка "Групповое штрихкодирование номенклатуры" для ERP 2.4, 2.5, КА 2.4, УТ 11.4 для быстроты присвоения штрихкодов номенклатуры.

2 стартмани

08.06.2021    6285    6    SergAl    10    

Отправка счетов в PayKeeper

Розничная торговля Оптовая торговля WEB v8 v8::БУ БП3.0 Бытовые услуги, сервис Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Расширение предназначено для отправки счетов в платежный сервис PayKeeper из типовой Бухгалтерии предприятия 3.0 (создавалось и тестировалось на релизе 3.0.88.32)

4 стартмани

20.04.2021    6157    5    Krasnyj    0    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2) Промо

Обмен через XML Перенос данных из 1C8 в 1C8 Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Розница УУ Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    58363    6    SEOAngels    65    

Декларации по формам 7 и 8 алкогольной продукции, перенос данных из Декларант-Алко, импорт данных из файлов XML форм 11,12,7,8

Розничная торговля Регламентированная отчетность Обмен через XML v8 v8::УФ Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия БУ Акцизы Абонемент ($m)

Конфигурация на управляемых формах, платформа 1С 8.3.10.2667 и выше, с помощью которой можно сформировать Декларации по формам 7 и 8 алкогольной продукции, выполнить перенос данных из ПО Декларант-Алко версии 4.31.05 и выше, импорт и загрузку из файлов XML форм 11,12,7,8. Есть возможность автоматического подписания и шифрации файла выгрузки.

1 стартмани

15.04.2021    8465    43    independ    39    

[Расширение] Временное отключение онлайн-эквайринга в РМК (УТ 11.4, Розница 2.3)

Розничная торговля Рабочее место Эквайринг v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение предназначено для исправления исключительных ситуаций, когда оплата по эквайринговому терминалу с подключением оборудования прошла успешно, но чек на ККТ не был фискализирован. Расширение позволит временно отключить онлайн-эквайринг непосредственно из формы РМК.

1 стартмани

14.12.2020    10808    47    RocKeR_13    13    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    10344    15    quazare    20    

Загрузка весового товара в весы Масса-К ВПМ-Ф (1С Предприятие, УТ 11.2-11.4 управляемые формы) Промо

Весы Розничная торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Данная обработка загружает весовой товар из базы в весы. Данная обработка тестировалась только на версии УТ 11.2-11.4 (1С Предприятие 8.3) и весах ВПМ-Ф.

2 стартмани

21.07.2016    25109    55    user594264_e.sitnik    5    

Продажи со склада поставщика WildBerries. Взаимодействие с АПИ из 1С

WEB Розничная торговля v8 УТ11 УУ Абонемент ($m)

Взялся я тут делать интеграцию с АПИ нового проекта Диких Ягод - Продажи со склада поставщика (ПССП). Это было нелегко. Никто же не читает инструкцию (уже аж 7 версии!), а зря! Для начала сделал получение списка товаров и обмен остатками.

5 стартмани

06.11.2020    30901    195    kiv1c    138    

Клиент API ГИС МТ (ИС МП) "Честный знак". Чтение данных и отправка документов. Работа на стороне сервера.

Розничная торговля WEB v8 1cv8.cf Россия Абонемент ($m)

Обращаемся в личный кабинет системы "Честный знак", ГИС МТ (ИС МП) за информацией о маркировке, товарах, документах и т.д. используя предоставляемый API. Отправляем собственный исходящий документ. Разбираемся с электронной подписью на клиенте и на сервере.

1 стартмани

26.10.2020    10626    77    elian    28    

Маркировка обуви. Получение информации о документах и товаре в Честном знаке

Розничная торговля WEB v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Обработка позволяет подключаться к Честному знаку, и получать оттуда информацию по документам или кодам идентификации.

2 стартмани

21.09.2020    6381    46    SpiRUS    0    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение Промо

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    31743    65    AleSSandre    34    

Комплексный контроль остатков. Для одного или сразу нескольких логически связанных регистров накопления. Универсальное решение уровня данных для контроля не только складских остатков

Комиссионная торговля Оптовая торговля Розничная торговля v8 v8::ОУ 1cv8.cf УУ Абонемент ($m)

Разработка для контроля остатков регистров накопления. Может быть использована в качестве дополнения или замены типовых механизмов любых конфигураций (ERP 2, УТ 11, КА 2 или "устаревших" УТ 10, УПП и многих других). Контролироваться может как отдельный ресурс одного регистра, так и комплексно – в виде комбинации логически связанных ресурсов разных регистров накопления. Контроль может осуществляться при оперативном, неоперативном ("задним" числом) проведении документов и при отмене проведения. Разработка доступна в виде подсистемы или в виде расширения.

1 стартмани

25.06.2020    6443    7    Алексей Воробьев    7    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    28496    302    independ    130    

Примеры работы с API в Честный знак (обувь)

WEB Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

К сожалению, документация API честного знака полна пробелов и неточностей. В данной статье описан мой опыт отгрузки маркированных товаров с одного юр. лица на другое.

1 стартмани

15.05.2020    27874    41    stas8359    65    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    48990    25    skyadmin    22    

Кассовая программа "АрсКасса" на C# - без ограничений

Розничная торговля Кассовые операции Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кассовая программа "АрсКасса" предназначена для автоматизации рабочего места кассира, без дополнительных затрат на покупку лицензий ПО.

1 стартмани

03.05.2020    11428    21    coolseo    9    

Отображение цен и остатков в списке номенклатуры и подборах "как в УТ 10.3" в УТ 11, КА 2, ERP 2 (расширение, платформа 8.3.12+)

Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

(©Топчий Д.Ю.) Посвящается Всем, кто привык к удобному отображению цен и остатков в конфигурации "Управление торговлей 10.3" в списке номенклатуры! Не требует модификации конфигурации, устанавливается как расширение! Выбранные виды цен сохраняются в рамках пользователя. Отображение идет в виде дерева по характеристикам. Работа проверена на конфигурациях УТ 11.4, КА 2, ERP2. (Обновление от 17.04.2020)

3 стартмани

31.03.2020    12341    87    hakerxp    19    

Маркировка в УТ 10.3.59.2: ошибки в релизе

Кассовые операции Розничная торговля v8 УТ10 Россия Абонемент ($m)

Вышел релиз УТ 10.3.59.2, в котором реализована поддержка маркировки обуви. Релиз содержит некоторое количество ошибок, не позволяющих использовать его при продаже обуви.

1 стартмани

28.02.2020    32938    4    Sholl    75    

Готовые решения для инвентаризации товаров и основных средств на мобильных устройствах для КА, УТ, ERP и БП 3.0 на базе Simple UI

Оптовая торговля Розничная торговля Учет ОС и НМА Мобильная разработка Учет ТМЦ v8 ERP2 БП3.0 УТ11 КА2 БУ УУ Абонемент ($m)

В расширениях для Бухгалтерия 3.0 и КА2.4/УТ11.4/ERP2.4 представлены готовые рабочие места для онлайн и оффлайн инвентаризации товаров (для БП 3.0 также инвентаризации основных средств) на базе бесплатного конструктора мобильного фронта Simple UI. При этом используется расширенная работа с идентификацией товаров и ОС с помощью различных подходов – сканирование штрих кода, распознавание артикулов и инвентарных номеров и различные поиски. Также используются различные возможности платформы Simple UI. Данная разработка может быть полезна как конечным пользователям, так и разработчикам в качестве заготовки, так как на базе этих блоков можно сделать ввод любого документа конфигурации , связанного с товаром или с ОС. Тестировалось на 1С 8.3.13.1865, КА 2.4.8.63 и БП 3.0.74.69

5 стартмани

28.02.2020    15842    74    informa1555    76    

Эмулятор ККТ с передачей данных (вер. 1.05 ОФД)

ККМ v8 v8::УФ УТ10 Розница УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Эмулятор ККТ с передачей данных для обычных и управляемых форм ( 32/64-битное расширение).

1 стартмани

15.01.2020    40062    702    Consultant_1C    61    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    25371    125    etmarket    53    

Расширение "Интерфейс Плюс" Промо

Розничная торговля Рабочее место Розничная торговля v8 v8::ОУ Розница УТ11 Россия УУ Абонемент ($m)

Расширение для 1С:Розница 2.2/2.3 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

1 стартмани

22.09.2018    36816    178    RocKeR_13    138    

Печать, создание XML и сохранение в базу 1С кодов маркировки

Пакетная печать Розничная торговля v8 1cv8.cf Абонемент ($m)

Внешняя обработка для печати кодов марок, полученных из системы "Честный знак".

1 стартмани

14.01.2020    39300    423    user635667    334    

Маркировка. Формирование и печать марок с CSV-файла "Честный Знак" и подготовка файла ввода в оборот

Розничная торговля v8 Розница УНФ УТ11 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Внешняя обработка для формирования и печати марок с кодом DataMatrix, на основании полученных CSV-файлов с кодами из системы "Честный знак". Формирование файла о вводе марок в оборот для загрузке на сайт системы "Честный знак"

3 стартмани

09.01.2020    47955    301    Turbokey    176    

Очень быстрый поиск номенклатуры в РМК

Розничная торговля Работа с интерфейсом Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Расширение для конфигурации Розница 2.2, ну очень быстрый поиск товара в РМК.

1 стартмани

19.11.2019    9188    46    Vyacheslide    60    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    63143    271    informa1555    239    

Слипы вышли, а чек - нет!

Розничная торговля Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Флаг устанавливающий Эквайринговый терминал как эмулятор для пробития чеков по карте.

1 стартмани

14.11.2019    33075    84    obmanOZ    47    

Несколько касс ККМ в РМК Розница 2.3 с выбором кассы для каждой строки

Розничная торговля ККМ Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Расширение позволяет подключить несколько касс ККМ к одному рабочему месту, по одной организации. Выбор кассы осуществляется на каждую строку товара. При добавлении позиции товара, автоматически выбирается касса по умолчанию. Определение кассы по умолчанию осуществляется в настройках пользователя. Расширение можно подключить в Рознице 2.3 версии ПРОФ.

3 стартмани

13.11.2019    19658    74    SerGray    121    

Выгрузка - загрузка на WildBerries из УНФ 1.6, УТ 11.4, УТ 10.3

Розничная торговля WEB Обмен через XML v8 УНФ БУ УУ Абонемент ($m)

Обработка выгружает накладную ЭДО для отправки на wildberries.ru в формате xml и загружает данные, выгруженные с сайта в формате xlsx. + печатные формы "Заказ для wildberries" и "Спецификация для wildberries"

1 стартмани

27.09.2019    21422    227    KVIKS    85    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 Промо

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    47082    20    biz-intel    6    

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4

Оптовая торговля Розничная торговля Математика и алгоритмы Практика программирования v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    17772    15    informa1555    24    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    24212    61    kaliuzhnyi    48    

1С REST API клиент. Обмен из 1С с сайтом/магазином WordPress/WooCommerce с помощью REST API

Универсальные обработки WEB Универсальные функции Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Обмен 1С с сайтом на WordPress и магазином Woocommerce. Внешняя обработка сделана как REST API клиент сайта WordPress, позволяет разработчику публиковать/изменять/удалять/просматривать посты/страницы/товары/фотографии (в связке с товаром/страницей) на сайте/магазине WordPress/Woocommerce. Обработки сделаны с использованием обычных форм, демо-формы использования в комплекте.

10 стартмани

29.07.2019    14926    15    osivv    15    

ЕГАИС 3 Контролёр для 1С:Розница Промо

Терминал сбора данных Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    27297    17    kuld    30    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    36502    24    sapervodichka    14    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. UPD Устарело (см. Simple UI)

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    20581    45    informa1555    39    

Иерархический список быстрых товаров в рабочем месте кассира (УНФ 1.6.26)

Рабочее место Розничная торговля Розничная торговля v8 УНФ Россия УУ Абонемент ($m)

Модификация рабочего места кассира (РМК) в 1С "Управление нашей фирмой" (УНФ): произвольно настраиваемое меню быстрых товаров. Реализовано в виде расширения конфигурации.

1 стартмани

08.04.2019    9679    32    asorozhkin    6    

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера Промо

Кассовые операции ККМ Кассовые операции v8 Розница Абонемент ($m)

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    24196    16    valerasv    7    

Расширение для 1С: Розница 2.2 - 2.3. В подборе и списке товаров - колонки Остаток, Цены розничная и закупочная, Сальдо. В документах команда Остатки и цены - для просмотра по списку товаров из документа

Обработка справочников Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение для 1С Розница 2.2 / Розница 2.3. В Подборе товаров и списке товаров добавлен вывод колонок Остаток на складах, Цена розничная, Цена Закупочная, Сальдо цен. В документе Отчет о розничных продажах, Оприходование, Списание, Установка цен - добавлена команда "Остатки и цены". Служит для анализа остатков и цен товаров, указанных в документе.

1 стартмани

09.03.2019    13496    127    cmax    65    

Обработки для 1С: Розница по работе с ЕГАИС

Розничная торговля Обработка документов Обработка справочников Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

1 стартмани

25.02.2019    26677    57    independ    15    

Выполнение проверки поступившей алкопродукции в ТТН ЕГАИС одним нажатием. 1С: Розница

Розничная торговля Обработка документов Розничная торговля v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Расширение и код для 1С: Розница 2.2.9/2.2.10/2.2.11 для быстрой проверки поступившего алкоголя ЕГАИС.

1 стартмани

05.02.2019    18558    12    independ    8    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    35116    227    independ    140    

Эмулятор ККМ по стандарту ФФД 1.1

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v8 Розница УТ11 Россия Абонемент ($m)

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    30302    162    Matveymc    31    

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 УТ10 УПП1 Абонемент ($m)

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    88682    89    Johny_v    51