Формы для 1script

Публикация № 540284

Разработка - Инструментарий разработчика

onescript gui

134
В последнее время для задач, связанных с администрированием 1С или расширением возможностей конфигуратора, стал использовать 1script (onescript). Движок оказался очень удобным и приятным, но чего-то не хватало, а именно работы с формами. В ряде скриптов использовать GUI было бы предпочтительней параметров командной строки, тем более если с этим работать конечному пользователю.

Имея некоторый опыт работы с C#, решил написать внешнюю компоненту для 1script, благо базовый пример был. После нескольких часов работы появилась компонента, позволяющая работать с формами и обрабатывать события. API старался сделать максимально приближенным к 1С.

Во время разработки очень порадовала обратная связь с разработчиками onescript, ответы на вопросы получал очень быстро. Библиотечные методы написаны просто и понятно, ряд вопросов решился просмотром исходных кодов и копипастом (перебор элементов формы в цикле ДляКаждого Элемент Из Коллекции Цикл).

Проект выложен на github, там же лежит бинарник, для более быстрого начала использования. Методы компоненты покрыты тестами, которые так же являются и примерами работы с объектами компоненты. За тесты отдельное спасибо artbear, всегда знает в каком направлении правильно пнуть :D

Основная задача компоненты - простая работа с формами. Позволяет создать большое количество разных элементов форм. Поддерживается обработка событий элементов. Управление свойствами видимости, доступности и другими. Создан единый интерфейс для работы со значениями элементов (через свойство Значение).

Доступны основные элементы формы и события:

Установка

opm install gui 

либо скачать с github https://github.com/ret-Phoenix/oscript-simple-gui

Виды полей

  • ПолеВвода - Однострочное текстовое поле;
  • ПолеИндикатора - Прогрессбар.
  • ПолеКалендаря - Поле для ввода даты
  • ПолеНадписи - Надпись (декорация в терминалогии 1С)
  • ПолеФлажка - Флажок, имеет статусы: Включен/Выключен
  • ПолеТекстовогоДокумента - Многострочный текст
  • ПолеСоСписком - Поле со списком (ComboBox)
  • ПолеСписка - Поле списка (ListBox)
  • ОбычнаяГруппа - Контейнер для группы элементов
  • Страница - Страницы
  • Кнопка
  • ТаблицаФормы - Компонент для отображения объекта ТаблицаЗначений
  • ПредставлениеСписка - ListView для отображения объекта ТаблицаЗначений
  • ДеревоФормы - Компонент для отображения объекта ДеревоЗначений

 

Обрабатываемые события

  • Форма: ПриОткрытии
  • Кнопка: ПриНажатии
  • ПолеФормы: ПриИзменении, ПриВыборе (нажат Enter), ПриНажатииНаКнопку (KeyDown)
  • ПолеСписка: ПриДвойномКлике

Диалоги, уведомления

  • Вопрос
  • Предупреждение
  • Диалог выбора файла
  • Уведомление в трее

Примеры работы с компонентой

Перейдем к работе с компонентой...

Создание формы и вывод надписи

#Использовать gui
Перем Форма;

Процедура ПриСозданииОбъекта()

    УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
    Форма = УправляемыйИнтерфейс.СоздатьФорму();

    //# Устанавливаем обработку события ПриОткрытии
    Форма.УстановитьДействие(ЭтотОбъект, "ПриОткрытии", "ПриОткрытииФормы");
    Форма.Показать();

КонецПроцедуры

//# Обработка события первого открытия формы
Процедура ПриОткрытииФормы() Экспорт
    
    Декорация1 = Форма.Элементы.Добавить("Декорация1", "ПолеФормы", Неопределено);
    Декорация1.Вид = Форма.ВидПоляФормы.ПолеНадписи;
    Декорация1.Заголовок = "Это действительно работает!";
    
    Форма.Высота = 100;

КонецПроцедуры

Создание формы с кнопкой и обработка события нажатия на кнопку

#Использовать gui

Перем Форма;

Процедура ПриСозданииОбъекта()

    УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
    Форма = УправляемыйИнтерфейс.СоздатьФорму();

    //# Устанавливаем обработку события ПриОткрытии
    Форма.УстановитьДействие(ЭтотОбъект, "ПриОткрытии", "ПриОткрытииФормы");
    Форма.Показать();

КонецПроцедуры

//# Обработка события первого открытия формы
Процедура ПриОткрытииФормы() Экспорт
    
    ПолеВвода1 = Форма.Элементы.Добавить("ПолеВвода1", "ПолеФормы", Неопределено);
    ПолеВвода1.Вид = Форма.ВидПоляФормы.ПолеВвода;
    ПолеВвода1.Заголовок = "Поле ввода";
    ПолеВвода1.Значение = "Значение задано из скрипта";

    Кнопка1 = Форма.Элементы.Добавить("Кнопка1", "КнопкаФормы", Неопределено);
    Кнопка1.Заголовок = "Нажми меня";
    Кнопка1.УстановитьДействие(ЭтотОбъект, "Нажатие", "ПриНажатииНаКнопку1");

КонецПроцедуры

Процедура ПриНажатииНаКнопку1() Экспорт
    Форма.Элементы.Найти("ПолеВвода1").Значение = "Значение после нажатия на кнопку";
КонецПроцедуры

Перейдем к более сложному примеру, создадим форму с кнопкой, полем ввода.

Пример работы с выпадающим списком
#Использовать gui

Перем Форма;

Процедура ПриСозданииОбъекта()

    УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
    Форма = УправляемыйИнтерфейс.СоздатьФорму();

    //# Устанавливаем обработку события ПриОткрытии
    Форма.УстановитьДействие(ЭтотОбъект, "ПриОткрытии", "ПриОткрытииФормы");
    Форма.Показать();

КонецПроцедуры

//# Обработка события первого открытия формы
Процедура ПриОткрытииФормы() Экспорт
    
    Данные = Новый Соответствие;
    Данные.Вставить("Один", "1");
    Данные.Вставить("Два", "2");
    Данные.Вставить("Три", "3");

    ПолеСоСписком1 = Форма.Элементы.Добавить("ПолеСоСписком1", "ПолеФормы", Неопределено);
    ПолеСоСписком1.Заголовок = "Поле со списком";
    ПолеСоСписком1.Вид = Форма.ВидПоляФормы.ПолеСоСписком;
    ПолеСоСписком1.СписокВыбора = Данные;
    ПолеСоСписком1.Значение = "3";
    ПолеСоСписком1.УстановитьДействие(ЭтотОбъект, "ПриИзменении", "ПриИзменииЗначения");

    Форма.Высота = 80;

КонецПроцедуры

Процедура ПриИзменииЗначения() Экспорт
    Сообщить("Новое значение: " +  Форма.Элементы.Найти("ПолеСоСписком1").Значение);
КонецПроцедуры

 

ТаблицаФормы

Функция ПолучитьТЗ()
	
	ТЗ = Новый ТаблицаЗначений;
	ТЗ.Колонки.Добавить("Код");
	ТЗ.Колонки.Добавить("Наименование");
	ТЗ.Колонки.Добавить("ДатаРождения");
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 1;
	СтрокаТЗ.Наименование = "Вася";
	СтрокаТЗ.ДатаРождения = Дата(2000,2,1);
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 2;
	СтрокаТЗ.Наименование = "Коля";
	СтрокаТЗ.ДатаРождения = Дата(2010,5,2);
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 3;
	СтрокаТЗ.Наименование = "Саша";
	
	Возврат ТЗ;	
КонецФункции // ПолучитьТЗ()


ПровайдерТЗ = Новый Провайдер;
ПровайдерТЗ.Источник = ПолучитьТЗ();

Поле1 = Форма.Элементы.Добавить("ТаблицаФормы1", "ТаблицаФормы", Неопределено);
Поле1.ПутьКДанным = ПровайдерТЗ;
Поле1.Заголовок = "Провайдер - ТЗ";
Поле1.ПоложениеЗаголовка = УправляемыйИнтерфейс.ПоложениеЗаголовка.Верх;
Поле1.Закрепление = 5;

 

ДеревоФормы

Функция ПолучитьТЗ()

	Дерево = Новый ДеревоЗначений();

    Дерево = Новый ДеревоЗначений();
    Дерево.Колонки.Добавить("Год");
    Дерево.Колонки.Добавить("Месяц");
    Дерево.Колонки.Добавить("День");
    
    СтрокаДереваГод = Дерево.Строки.Добавить();
    СтрокаДереваГод.Год = 2016;

    СтрокаДереваМесяц = СтрокаДереваГод.Строки.Добавить();
    СтрокаДереваМесяц.Месяц = "Jan";
    СтрокаДереваМесяц.Год = СтрокаДереваГод.Год;

    СтрокаДереваМесяц = СтрокаДереваГод.Строки.Добавить();
    СтрокаДереваМесяц.Месяц = "Dec";
    СтрокаДереваМесяц.Год = СтрокаДереваГод.Год;

    СтрокаДереваГод = Дерево.Строки.Добавить();
    СтрокаДереваГод.Год = 2017;

    СтрокаДереваМесяц = СтрокаДереваГод.Строки.Добавить();
    СтрокаДереваМесяц.Месяц = "Feb";
    СтрокаДереваМесяц.Год = СтрокаДереваГод.Год;

    СтрокаДереваМесяц = СтрокаДереваГод.Строки.Добавить();
    СтрокаДереваМесяц.Месяц = "Mar";
    СтрокаДереваМесяц.Год = СтрокаДереваГод.Год;

    СтрокаДереваДень = СтрокаДереваМесяц.Строки.Добавить();
    СтрокаДереваДень.День = "1";
    СтрокаДереваДень.Месяц = "Mar";
    СтрокаДереваДень.Год = СтрокаДереваГод.Год;


	Возврат Дерево;

КонецФункции

ПровайдерТЗ = Новый Провайдер;
ПровайдерТЗ.ИсточникДерево = Данные;

Поле1 = Форма.Элементы.Добавить("ДеревоФормы1", "ДеревоФормы", Неопределено);
Поле1.ПутьКДанным = ПровайдерТЗ;
Поле1.Заголовок = "Провайдер - Дерево значений";
Поле1.ПоложениеЗаголовка = УправляемыйИнтерфейс.ПоложениеЗаголовка.Верх;
Поле1.Закрепление = 5;
Поле1.ТекущаяСтрока = 1;

Процедуры и функции интерактивной работы

УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
Диалоги = УправляемыйИнтерфейс.СтандартныеДиалоги;

Ответ = Диалоги.Вопрос("Тест", РежимДиалогаВопрос.ДаНет, 1, КодВозвратаДиалога.Нет , "Заголовок", КодВозвратаДиалога.Нет);

ТекстПредупреждения = "Текст предупреждения";
Таймаут = 10;
Заголовок = "Заголовок окна";
Диалоги.Предупреждение(ТекстПредупреждения, Таймаут, Заголовок);

Трей = Новый УведомлениеВТрее();
Трей.Заголовок = "Стандартная иконка";
Трей.Текст = "Иконка из ресурсов библиотеки";
Трей.Таймаут = 15;
Трей.Показать();

 

Возможности компоненты

На самом деле возможностей компоненты значильно больше нежели приведено в примерах, ознакомиться с ними можно на странице github.

Классы

УправляемыйИнтерфейс/ManagedInterface

Свойства

  • Версия/Version - Строка - Только чтение - Номер версии;
  • СтильЗакрепления/DockStyle
  • ВидПоляФормы/FormFieldType
  • ВидГруппыФормы/FormGroupType
  • ПоложениеЗаголовка/TitleLocation

Методы

  • СоздатьФорму/CreateForm - Форма - Создать форму (близка к Управляемой форме)

Форма/Form

Свойства

  • ВидПоляФормы/FormFieldType - ВидПоляФормы
  • ВидГруппыФормы/FormGroupType
  • ПоложениеЗаголовка/TitleLocation
  • Заголовок/Caption

Методы

  • Показать/Show
  • ПоказатьНеМодально/ПоказатьНеМодально
  • Элементы/Items
    • Возвращаемое значение
      • Коллекция с ПолеФормы, ГруппаФормы, КнопкаФормы

Элементы/Items

Свойства

Методы

  • Количество/Count - Число - Количество элементов
  • Найти/Find - Найти элемент по имени элемента
    • Параметры
      • ИмяЭлемента - Строка
    • Возвращаемое значение
      • ПолеФормы, ГруппаФормы, КнопкаФормы, Неопределено
  • Удалить - Удалить элемент
    • Параметры
      • ПолеФормы, ГруппаФормы, КнопкаФормы
  • Переместить/Move - Переместить элемент
    • Параметры
      • Элемент - ПолеФормы, ГруппаФормы, КнопкаФормы
      • Родитель - ГруппаФормы, УправляемаяФорма - Новый родитель элемента. Может совпадать со старым.
      • МестоРасположения - ПолеФормы, ГруппаФормы, КнопкаФормы - Элемент, перед которым нужно разместить перемещаемый элемент. Если не задан, то перемещается в конец коллекции.
  • Добавить/Add - Добавить элемент на форму
    • Параметры
      • ИмяЭлемента - Строка - Уникальное имя элемента
      • ТипЭлемента - Строка - Тип элемента (ПолеФормы, ГруппаФормы, КнопкаФормы)
      • Родитель - ГруппаФормы, Неопределено - Родитель для добавляемого элемента. Если не указан, то добавляется на верхний уровень.

КнопкаФормы/FormButton

Свойства

  • Родитель/Parent - ГруппаФормы, УправляемаяФорма - Только чтение - Содержит ссылку на родительский элемент.
  • Имя/Name - Строка - Имя кнопки
  • Видимость/Visible - Булево - Видимость кнопки
  • Доступность/Enabled - Булево - Доступность кнопки
  • Заголовок/Title - Строка - Надпись на кнопке

Методы

  • КнопкаНажатие/ButtonClick - deprecated - Обработчик нажатия на кнопку

    • Параметры

      • Скрипт - Объект - ссылка на скрипт с обработиком события
      • ИмяМетода - Строка - Имя метода обработчика события
      Кнопка1 = ЭлементыФормы.Добавить("Кнопка1", "КнопкаФормы", Неопределено);
      Кнопка1.Заголовок = "Нажми меня";
      Кнопка1.КнопкаНажатие(ЭтотОбъект,"ПриНажатииКнопка1");
      
  • УстановитьДействие/SetAction - Устанавливает обработчик события.

    • Параметры
      • Скрипт - Объект - Ссылка на скрипт с обработчиком события
      • ИмяСобытия - Строка - Имя события. Для кнопки только "Нажатие"
      • ИмяМетода - Строка - Имя метода для обработчика
  • ПолучитьДействие/GetAction - Получает имя установленного обработчика события.
    • Параметры
      • ИмяСобытия - Строка - Имя события. Для кнопки только "Нажатие"

ПолеФормы/FormField

Свойства

  • Значение/Value - Установка и получение значения.
  • Вид/Type - ВидПоляФормы
  • Имя/Name - Строка
  • Видимость/Visible - Булево
  • Доступность/Enabled - Булево
  • Заголовок/Title - Строка
  • ПоложениеЗаголовка/TitleLocation - ПоложениеЗаголовка
  • СписокВыбора/ChoiceList - Соответствие
  • Родитель/Parent - ГруппаФормы, УправляемаяФорма - Только чтение
  • ТолькоПросмотр/ReadOnly - Булево
  • Закрепление/Dock
  • АвтоматическийРазмер/AutoSize
  • Ширина/Width
  • Высота/Height

Методы

  • УстановитьДействие/SetAction - Устанавливает обработчик события.
    • Параметры
      • Скрипт - Объект - Ссылка на скрипт с обработчиком события
      • ИмяСобытия - Строка - Имя события. Для кнопки только "Нажатие"
      • ИмяМетода - Строка - Имя метода для обработчика
  • ПолучитьДействие/GetAction - Получает имя установленного обработчика события.
    • Параметры
      • ИмяСобытия - Строка - Имя события. Для кнопки только "Нажатие"

Обрабатываемые события

  • Форма: ПриОткрытии
  • Кнопка: ПриНажатии
  • ПолеФормы: ПриИзменении, ПриВыборе (нажат Enter)
    • ПолеСписка: ПриДвойномКлике

ВидПоляФормы/FormFieldType

  • ПолеВвода/InputField
  • ПолеИндикатора/ProgressBarField
  • ПолеКалендаря/CalendarField
  • ПолеНадписи/LabelField
  • ПолеФлажка/CheckBoxField
  • ПолеТекстовогоДокумента/TextDocumentField
  • ПолеСоСписком/ComboBox
  • ПолеСписка/ListBox
  • ТаблицаФормы / FormTable
  • ПредставлениеСписка / ListView
  • ДеревоФормы / FormTree

ВидГруппыФормы/FormGroupType

  • ОбычнаяГруппа/UsualGroup
  • Страница/Page
  • Страницы/Pages

ПоложениеЗаголовка

  • Авто/Auto
  • Верх/Top
  • Лево/Left
  • Нет/None
  • Низ/Bottom
  • Право/Right

СтильЗакрепления

  • Нет/None
  • Верх/Top
  • Низ/Bottom
  • Лево/Left
  • Право/Right
  • Заполнение/Fill
134

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. Fragster 928 01.08.16 17:38 Сейчас в теме
ждем кроссплатформенного исполнения
3. ret-Phoenix 461 01.08.16 17:43 Сейчас в теме
(2) Решение уже кроссплатформенно, работу под Linux проверяли. У меня примеры под Windows, т.к. ничего больше не стоит
AntoShiK86; Fragster; +2 Ответить
11. KAV2 09.09.16 17:21 Сейчас в теме
(3) Подскажите пожалуйста, а что необходимо сделать для того, чтобы можно было использовать под Linux? Файл oscript-simple-gui.dll ведь не кросс-платформенный.
12. ret-Phoenix 461 09.09.16 20:26 Сейчас в теме
(11) в gitter ответил на вопрос. Для общественности:
под Linux будет работать под Mono.
Моя либа нормально работает под Linux (проверял @dmpas )
т.е. с точки зрения скриптописателя - разницы нет Windows or Linux
4. gubanoff 46 02.08.16 11:59 Сейчас в теме
Прекрасная работа! На самом деле, это первое, что приходит в голову, после начала работы с onescript - добавить интерактив в виде форм.
5. Alien_job 163 02.08.16 12:07 Сейчас в теме
Что вы подразумеваете под расширением возможностей конфигуратора?
upd: Ой,пропустил http://infostart.ru/public/339035/.
6. brr 176 02.08.16 15:34 Сейчас в теме
7. ret-Phoenix 461 02.08.16 15:37 Сейчас в теме
(6) А если без шуток, в ближайшее время планирую изменить название этого этого класса. Будут доступны оба варианта, ПростойГУЙ будет deprecated
8. artbear 1156 03.08.16 11:08 Сейчас в теме
ПростойГуй звучит, да :)
KEV8383; 1cWin; DmitrySinichnikov; +3 Ответить
9. HDRX 22 03.08.16 11:39 Сейчас в теме
Что за шрифт используете в редакторе?
10. ret-Phoenix 461 03.08.16 12:26 Сейчас в теме
(9) Стандартный в VSCode: "editor.fontFamily": "Consolas, 'Courier New', monospace",
13. Darklight 19 25.09.17 13:52 Сейчас в теме
Очень здорово. Но есть предложение по оформлению. Хотелось бы, чтобы стиль отображения формы и элементов управления соответствовал стилю 1С (в идеале чтобы можно было настроить перед открытием формы, например указав нужную редакцию платформы 1С или АВТО - последння, включённая в библиотеку, версия стиля платформы 1С). Неплохо бы и загружать параметры стиля оформления формы из файла и/или из строки.

Ещё одно важное предложение - сделайте загрузку настройки элементов формы из файла и/или строки. В идеале - в формате 1С (причём можно загрузить как формат неуправляемых форм - но это не очень просто, но возможно; так и xml формат управляемых форм - и создать "похожу" расстановку поддерживаемых элементов формы) - вот это действительно круто будет!

И, ещё одно предложение - сделайте несколько встроенных форм - например для диалогов вопроса, предупреждения, ввода/выбора из списка единичного значения, редактирования списка/таблицы/дерева значений. Быстрой регенерации формы, позволяющей ввести набор значений с представлением вида дерева (с иерархие в виде дерева и/или закладок - а на листьях - просто список полей ввода - отображаемых вертикально на форме, с надписями).
14. ret-Phoenix 461 25.09.17 21:04 Сейчас в теме
1. По оформлению - маловероятно что буду делать, но если кто сделает - PR проверю и приму.
2. Загрузка настройки элементов - была идея, но пока не доходят руки.
3. формы диалогов есть, в тестах примеры обращения. Выбор из ТЗ - дело нескольких строк, пример есть. Дерево есть - формируете обычное дерево и указываете как источник.
Автогенерация - 1 функция которая будет принимать тип, имя и еще ряд свойств - можно самим один раз написать и использовать.
Сейчас первоочередная задача - довести список компонентов до уровня 1С, переработать расположение.
15. DmitrySinichnikov 178 20.10.17 15:16 Сейчас в теме
Интересно а почему после компиляции в *.exe форма не открывается? Или открывается на долю секунды и закрывается сразу. Проверял и на ваших примерах и на своем коде.
Хотел небольшую утилиту написать, видимо облом, печалька((
16. ret-Phoenix 461 20.10.17 19:15 Сейчас в теме
(15) Пока движок oscript не умеет корректно работать с ВК. поэтому поставлять пока можно в виде *.os
17. pvlunegov 142 26.10.17 21:34 Сейчас в теме
Прекрасно, все работает, замечательное расширение мегаразработки OneScript.
Меня страстно интересуют следующие вопросы:
1. Есть ли возможность выводить картинки в поля элементов формы
Например, картинки в ТабличноеПоле.

Я пока тестирую вашу работу, не нашел реализации вывода картинок.
Есть ли вообще такая возможность?
18. ret-Phoenix 461 27.10.17 10:48 Сейчас в теме
(17) картинки можно использовать в "ПредставлениеСписка" (иконка в строке), больше ничего с картинками нет, не было необходимости
19. ret-Phoenix 461 27.10.17 10:52 Сейчас в теме
Процедура Тест_Должен_УстановитьВидТаблица() экспорт
	ПолучитьФорму();
	
	ПровайдерТЗ = Новый Провайдер;
	ПровайдерТЗ.Источник = ПолучитьТЗ();
	
	Поле1 = Форма.Элементы.Добавить("ТаблицаФормы1", "ПредставлениеСписка", Неопределено);
	Поле1.Представление = Поле1.ВидыПредставлений.Таблица;
	Поле1.ПутьКДанным = ПровайдерТЗ;
	Поле1.Заголовок = "Провайдер - ТЗ";
	Поле1.ПоложениеЗаголовка = УправляемыйИнтерфейс.ПоложениеЗаголовка.Верх;
	Поле1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Заполнение;
	
	Поле1.ОтображатьСетку = Истина;

	Поле1.КолонкаСИндексомИзображения = 0;

	Изображения = Поле1.МаленькиеИзображения;
	Изображения.Добавить("c:\Users\ushakov\Downloads\gconfeditor.ico");
	Изображения.Добавить("c:\Users\ushakov\Downloads\gconfeditor.ico");
	//Изображения.Добавить("c:\Users\ushakov\Documents\СтрелкаВлево.png");

	Изображения = Поле1.БольшиеИзображения;
	Изображения.Добавить("c:\Users\ushakov\Documents\32.ico");
	Изображения.Добавить("c:\Users\ushakov\Documents\32.ico");
	//Изображения.Добавить("c:\Users\ushakov\Documents\СтрелкаВлево.png");
	
	//
	Строки = Поле1.ВыделенныеСтроки;
	Для каждого Стр Из Строки Цикл
		Сообщить(Стр);
	КонецЦикла;
	
	Ожидаем.Что(Форма.Элементы.Найти("ТаблицаФормы1")).Существует();
	
	Форма.Показать();	
КонецПроцедуры
Показать
20. pvlunegov 142 27.10.17 14:56 Сейчас в теме
Подскажите, картинки нужны для формирования отчетов и вывод в форму.
Как это дело можно организовать?
Формирование отчета в поле табличного документа или таблицу управляемой формы и показ оной
21. ret-Phoenix 461 27.10.17 15:35 Сейчас в теме
(20) Аналога Табличного документа нет, есть только ТабличноеПоле. Как вариант, можно дописать ПолеHTML, пока оно не реализовано.
22. pvlunegov 142 27.10.17 15:43 Сейчас в теме
Я почему заинтересовался вашей разработкой - потому что хотел применить ее для:
1. Создания Win-приложения с формами, минимальной графикой
2. Код в приложении делать на 1с.
3. Минимальная графика должна быть хотя бы в виде отчетов (статических таблиц с картинками или графиками или ....)

Без 3 шага реализовать мало-мальски годное приложение шансов = 0

Согласитесь, что если ваше решение чуток доработать, можно делать полноценные приложения с БД с графикой = конкурент 1с на локальной машине без лицензий.

Я думаю в свободное время засесть за C# покопаться в вашем решении и придумать плагин для использования графики.
Например, вывод картинок в поле HTML - думаю самое простое и быстрое решение.
24. ret-Phoenix 461 27.10.17 15:46 Сейчас в теме
(22) Да, работа с ПолеHTML самое простое, но тоже требует времени, пока у меня его нет, переносить возможности поля совсем по минимуму не особо хочется, а на полноценное время выделить пока не могу.
Диаграммы - тоже хочется. даже знаю какую задачу буду ими решать, опять же - вопрос времени.
Сейчас gui развивается в первую очередь чтобы решать задачи SmartConfigurator.
26. pvlunegov 142 27.10.17 15:53 Сейчас в теме
(24) жалько что столько времени уделяете конкуренту Снегопата.
Не взлетит, по моему мнению.
Снегопат хоть и весь оброс бородой, глючный и некрасивый, но народ к нему привык.

Советую задуматься над моим предложением по доработки графических фишек к OneScript.

К сожалению, сейчас, у меня дикое желание использовать вашу разработку для например игр на 1с.
Но придется привинчивать сторонние плагины C# для реализации графики в формах.

Покопаюсь, поделаю, если получится, отпишусь вам.

Возможно, получится сделать обычный плагин в виде давно известного решения.
29. ret-Phoenix 461 27.10.17 16:08 Сейчас в теме
(26) Вообще-то, мои скрипты появились за много лет до появления снегопата, фактически с них и начались разработки примочек к конфигуратору. Раньше проект не так сильно развивал как сейчас.

Я даже не помню, когда в последний раз использовал снегопат, т.к. мне приходится работать на последних версиях платформы, нужна стабильность и доступность всегда и везде.
pvlunegov; +1 Ответить
30. ret-Phoenix 461 27.10.17 16:11 Сейчас в теме
(26) Нашел когда впервые выложил: http://www.1cpp.ru/forum/YaBB.pl?num=1227553473 (24. Ноября 2008)
pvlunegov; +1 Ответить
23. pvlunegov 142 27.10.17 15:45 Сейчас в теме
После шага 3 можно делать даже развлекательные приложения в виде простых игр (табличных, статичная 2d графика)
С применением управляемых форм можно даже сделать браузерные игры.
Преимущества - внутренний код на 1с - огромное (для меня).

Поэтому шаг 3 нужно ОБЯЗАТЕЛЬНО сделать, это АРХИВАЖНО!
25. pvlunegov 142 27.10.17 15:49 Сейчас в теме
Многие люди не понимают ГИГАНТСКИЙ шаг OneScript в направлении:
1. БЕСПЛАТНОГО приложения для создания полноценных Win-приложений с БД, с графикой и внутренним кодом на русском языке.

Если привинтить графику к тому что есть, то то, что я выше обозначил - свершится.

Уже все готово, кроме графики:
1. Внутренний код на 1с работает, хотя глючит и есть ошибки
2. Вся изюминка C# и ООП в наличии (расширяемость, свои классы и функции, библиотеки)
3. Есть формы, есть подключение к БД, есть работа с сетью, файлами и много чего...

Осталось САМОЕ ГЛАВНОЕ - минимальная графика в формах.

Тогда данный проект превратится в полноценный редактор бизнес-решений
27. pvlunegov 142 27.10.17 15:59 Сейчас в теме
Подскажите, в OneScript есть возможность выполнять C# код из 1с кода?
Что то наподобие
Выполнить("С# код...") ?
НАпример, берем руководство Микрософт по рисованию фигур и всякой мелочи https://msdn.microsoft.com/ru-ru/library/x5wshyk0(v=vs.90).aspx
Создаем библиотеку в виде функций на 1с для рисования фигур, подключаем ее к решению
и начинаем использовать графику в 1с.
Взлетит такое?
28. ret-Phoenix 461 27.10.17 16:04 Сейчас в теме
OneScript не позволяет выполнить код c#, но есть возможность работать с .net сборками. Примеры были на github.
31. iolko 233 25.01.18 12:53 Сейчас в теме
Добрый день!
А можно добавить примеров с предупреждением и диалогом выбора файла.
Не могу найти
33. iolko 233 05.02.18 06:32 Сейчас в теме
(32) Не могу победить ДиалогВыбораФайла... Вот где-то туплю, и не пойму где. Можно тоже пример, для "ОсосбоОдаренных"
34. ret-Phoenix 461 05.02.18 21:55 Сейчас в теме
(33)
#Использовать gui

Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
ДиалогВыбораФайла = Новый ДиалогВыбораФайла(Режим);
	
ДиалогВыбораФайла.Каталог = "c:\";
Если ДиалогВыбораФайла.Выбрать() Тогда
	Сообщить(ДиалогВыбораФайла.Каталог);
КонецЕсли;
Показать


https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/oscript-component/FileDialog.cs
https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/oscript-component/FileDialogMode.cs
35. bulpi 156 24.02.18 20:43 Сейчас в теме
Автор, Вы бы для новичков добавили буквально абзац с пошаговой инструкцией, что и как делать :
1)Что именно качать и откуда
2)Что делать со скачанным

Потому как примеры Ваши из статьи уже не рабочие, и ничего интуитивно понятного я не увидел в процессе подключения. Пока что-то получилось, 2 часа прошло на ровном месте.
Я, конечно, понимаю, что Вы нам ничем не обязаны. Но досадно, от такой хорошей публикации появляется раздражение из-за мелочей.
user1107052; user1140658; meckszp; +3 Ответить
37. ret-Phoenix 461 22.07.18 17:29 Сейчас в теме
(35) Приведенные примеры вообще-то работающие. OneScript позволяет по разному работать с плагинами. Насчет обновления материала - согласен, пора бы обновить. На следующей неделе обновлю.
Проблемные мелочи, как правило, связаны с неумением читать документацию ;)
36. meckszp 22.07.18 01:12 Сейчас в теме
Также пробовал подключать библиотеку через opm и через ПодключитьВнешнююКомпоненту, но результата 0.
Скрипты запускаются, но не одна форма так не открылась. Перепробовал все примеры.
Очень жаль, что нет актуального материала по подключению этой компоненты. Версия 1CScript 1.0.20.108, ОС Windows 7 x64 запуск через Notepad++ v7.5.7 с плагином NppExec. Кто сталкивался с данной проблемой, прошу помочь. Заранее спасибо!
38. ret-Phoenix 461 22.07.18 17:34 Сейчас в теме
(36) для помощи/решения проблемы принято выкладывать проблемный код, по Вашему посту понять что не так невозможно.
Сейчас компонент активно используется как раз на вашем окружении. А скрипты вообще нужно запускать отдельно, я не знаю как себя ведет Notepad++.

материал актуален, т.к. описанные методы работали и будут работать. даже при использовании библиотеки gui (#использовать gui) происходит загрузка библиотеки как описано в статье https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/oslib/package-loader.os


Процедура ПриЗагрузкеБиблиотеки(Путь, СтандартнаяОбработка, Отказ)
	
	СтандартнаяОбработка = Ложь;
	ПодключитьВнешнююКомпоненту(ОбъединитьПути(Путь, "bin\oscript-gui.dll"));
	
КонецПроцедуры
39. meckszp 27.07.18 22:19 Сейчас в теме
(38) Спасибо! Проблема решилась после запуска отдельно.
40. ret-Phoenix 461 29.07.18 15:53 Сейчас в теме
(39) для разработки на OneScript смотрите в сторону MS VisualStudio Code, редактор бесплатен и хорошо развивается, много плагинов для разных языков, основное сообщество OneScript сидит именно на нем и развивает только его.
NotePad++ как бы не казался живым, но все же умирает.
41. ildary 05.10.18 15:41 Сейчас в теме
(39) Опишите пожалуйста подробнее, как Вам удалось запустить скрипты с формами из Notepad++?
42. ret-Phoenix 461 05.10.18 20:05 Сейчас в теме
Написали ведь, запуск отдельно, не из мертвого notepad++
Переходите на нормальный редактор - visual studio code
43. ildary 07.10.18 20:05 Сейчас в теме
(42) похоже вы не работали в организациях, где на компьютерах программистов нет администраторских прав.
44. ret-Phoenix 461 08.10.18 21:18 Сейчас в теме
Как раз в такой работаю. Код на c# пишу в блокноте, сборка через батник.
vscode не требует админских прав. Жду свой комп и будет стоять vscode
45. ildary 09.10.18 08:31 Сейчас в теме
(44) спасибо, я был неправ, когда думал что VSCode - это что-то вроде VS (тяжелое, требующее install и кучу прав). У меня всё получилось.
46. ret-Phoenix 461 10.10.18 09:56 Сейчас в теме
(45) а плагин bsl поставили? Рекомендую.
47. ildary 10.10.18 10:36 Сейчас в теме
(46) Спасибо за совет, поставил, стало очень хорошо, правда не хватает цветовой схемы конфигуратора.

Можно пару вопросов по Вашей библиотеке: Каким образом правильно работать с выводимой таблицей значений? В частности я пробовал задать заголовок у объекта ТЗ (который провайдер данных) вот так:

ТЗ.Колонки.Добавить("Блокировка", Новый ОписаниеТипов("Булево"), "Блок");

но у ТЗ на форме выводится заголовок "Блокировка" - я правильно понимаю, что надо как-то обращаться к Элементы.Найти() и потом с ним работать?

Также хотелось бы узнать, будет ли у ТЗ на форме работать отображение флажка и что для этого надо сделать?
48. ret-Phoenix 461 10.10.18 13:52 Сейчас в теме
Заголовок - тянет имя колонки, почему так было сделано не помню.
Если нужен флажок - "представление списка" позволяет выводить флажки.
49. ildary 11.10.18 06:39 Сейчас в теме
(48) спасибо за ответ, а есть ли событие ПриНажатииНаСтроку() с функцией ПолучитьТекущуюКолонку()? И есть ли поддержка свойства ВыделенныеСтроки? Извините, что так много спрашиваю, пытаюсь написать приложение в котором ТЗ на форме - важнейшая часть.
51. ret-Phoenix 461 11.10.18 13:54 Сейчас в теме
(49) Документацию к библиотеке читали? она входит в поставку + на github лежат исходники с документацией.
Дока по Табличному полю здесь
Примеры здесь:
https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/tests/test-FormTable.os
https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/tests/test-FormListView.os

а можно и так глянуть: https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/oscript-component/ListViewVT/FormListView.cs
50. ildary 11.10.18 12:28 Сейчас в теме
Ещё вопрос вдогонку - а каким образом работает горизонтальное выравнивание в группе? Ваш пример работает правильно, но как только я пытаюсь создать свою группу с двумя кнопками - высота группы сразу становится сокращенной.
52. ret-Phoenix 461 11.10.18 13:54 Сейчас в теме
(50) Код покажите. можете здесь, можете в гиттер, мы там уже пересекались.
53. ildary 11.10.18 14:29 Сейчас в теме
(52) Прошу прощения, закрыл VSCode, заново открыл - и все работает (прямо как чистка кеша в 1С).
54. ret-Phoenix 461 11.10.18 14:44 Сейчас в теме
(53) Горизонтальное размещение вышло только в прошлом релизе, могут быть косяки.
55. ildary 11.10.18 16:40 Сейчас в теме
(54) извините, доку не читал, теперь постараюсь. Нашел интересный момент - два флажка рядом - выводятся один под другим (скриншот прилагаю).

Также заметил интересный момент (так задумано?):

создаю группу, в ней - кнопку, вот так:

ГруппаКнопки = Форма.Элементы.Добавить("ГруппаКнопки", "ГруппаФормы", Неопределено);
	ГруппаКнопки.Вид = ВидГруппыФормы.ОбычнаяГруппа;
	
	Кнопка1 = Форма.Элементы.Добавить("КнопкаОбновить", "КнопкаФормы", ГруппаКнопки);
	Кнопка1.Заголовок = "Обновить";
	Кнопка1.УстановитьДействие(ЭтотОбъект, "Нажатие", "ПриНажатииКнопкаОбновить");
	Кнопка1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;

Показать

и кнопка не становится элементом формы.

То есть вот так кнопка не находится:

ТекЭлем = Форма.Элементы.Найти("КнопкаОбновить");

А вот так - находится:

ГруппаКнопки = Форма.Элементы.Найти("ГруппаКнопки");
ТекЭлем = ГруппаКнопки.Элементы.Найти("КнопкаОбновить");
Прикрепленные файлы:
56. ret-Phoenix 461 11.10.18 16:50 Сейчас в теме
Элементы.Найти - ищет только в текущем подчинении, без обработки вложенности, если не ошибаюсь, это родное поведение 1С.
Если у контрола не указать Закрепление - используется вариант TOP
57. ildary 12.10.18 08:38 Сейчас в теме
(56) извините, вы не правы - в УФ ЭтаФорма.Элементы.Найти(ИмяЭлемента) - вернет любой элемент, неважно в какой вложенности в группе и странице он расположен.

По поводу закрепления - я пытаюсь вывести на форму ТЗ и под ней - многострочный текст. ТЗ должна занимать всё свободное место, а лог - прямо под ней. Скажите пожалуйста - как это сделать? Делаю вот так:

Поле1 = ЭлементыФормы.Добавить("Базы", "ТаблицаФормы", Неопределено);
	Поле1.ПутьКДанным = ПровайдерТЗ;
	Поле1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Заполнение;

	ПолеЛог = ЭлементыФормы.Добавить("Лог", "ПолеФормы", Неопределено);
	ПолеЛог.Заголовок		   = "Лог";
	ПолеЛог.Вид				   = ВидыПоляФормы.ПолеТекстовогоДокумента;
	ПолеЛог.ПоложениеЗаголовка = ПоложениеЗаголовка.Низ;
Показать

Получается см. скриншот
Прикрепленные файлы:
58. ildary 12.10.18 09:16 Сейчас в теме
Прошу помощи ещё в одном вопросе - вывел на форму ТЗ (тип - "ТаблицаФормы") - всё прекрасно работает. Пытаюсь изменить тип на "ПредставлениеСписка" - получаю ошибку для ТЗ с одной колонкой (данные - строки) "Input string was not in a correct format". Ошибка выходит в строке ТЗНаФорме.ПутьКДанным = ПровайдерТЗ;
59. ret-Phoenix 461 12.10.18 09:34 Сейчас в теме
(58) как-то так. Это все копипасты из примеров, прилагаемых к либе

#Использовать gui

Функция ПолучитьТЗ()
	
	ТЗ = Новый ТаблицаЗначений;
	ТЗ.Колонки.Добавить("Код");
	ТЗ.Колонки.Добавить("Наименование");
	ТЗ.Колонки.Добавить("ДатаРождения");
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 1;
	СтрокаТЗ.Наименование = "Вася";
	СтрокаТЗ.ДатаРождения = Дата(2000,2,1);
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 2;
	СтрокаТЗ.Наименование = "Коля";
	СтрокаТЗ.ДатаРождения = Дата(2010,5,2);
	
	СтрокаТЗ = ТЗ.Добавить();
	СтрокаТЗ.Код = 3;
	СтрокаТЗ.Наименование = "Саша";
	
	Возврат ТЗ;	
КонецФункции // ПолучитьТЗ()

УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
Форма = УправляемыйИнтерфейс.СоздатьФорму();
ЭлементыФормы = Форма.Элементы;
ВидыПоляФормы = Форма.ВидПоляФормы;
ПоложениеЗаголовка = Форма.ПоложениеЗаголовка;
ВидГруппыФормы = Форма.ВидГруппыФормы;

Группа1 = ЭлементыФормы.Добавить("ОбычнаяГруппа1", "ГруппаФормы", Неопределено);
Группа1.Вид = ВидГруппыФормы.ОбычнаяГруппа;
Группа1.Заголовок = "Группа1";
Группа1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Заполнение; 


ПровайдерТЗ = Новый Провайдер;
ПровайдерТЗ.Источник = ПолучитьТЗ();

Поле1 = ЭлементыФормы.Добавить("Базы", "ТаблицаФормы", Группа1); 
Поле1.ПутьКДанным = ПровайдерТЗ; 
Поле1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Заполнение; 
Поле1.ПоложениеЗаголовка = ПоложениеЗаголовка.Нет;

Группа2 = ЭлементыФормы.Добавить("ОбычнаяГруппа2", "ГруппаФормы", Неопределено);
Группа2.Вид = ВидГруппыФормы.ОбычнаяГруппа;
Группа2.Заголовок = "Группа2";
Группа2.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Низ; 

ПолеЛог = ЭлементыФормы.Добавить("ПолеЛог", "ПолеФормы", Группа2);
ПолеЛог.Заголовок = "ПолеТекстовогоДокумента";
ПолеЛог.Вид = ВидыПоляФормы.ПолеТекстовогоДокумента;
ПолеЛог.ПоложениеЗаголовка = ПоложениеЗаголовка.Нет;

Группа3 = ЭлементыФормы.Добавить("ОбычнаяГруппа3", "ГруппаФормы", Неопределено);
Группа3.Вид = ВидГруппыФормы.ОбычнаяГруппа;
Группа3.Заголовок = "Группа1";
Группа3.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Низ; 


ПредставлениеСписка = Форма.Элементы.Добавить("ПредставлениеСписка", "ПредставлениеСписка", Группа3);
ПредставлениеСписка.ПутьКДанным = ПровайдерТЗ;
ПредставлениеСписка.Заголовок = "Провайдер - ТЗ";
ПредставлениеСписка.ПоложениеЗаголовка = УправляемыйИнтерфейс.ПоложениеЗаголовка.Верх;
ПредставлениеСписка.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Заполнение;
ПредставлениеСписка.ВыделятьВсюСтроку = Истина;
ПредставлениеСписка.МножественноеВыделение = Истина;

Форма.Показать();

Показать
60. ildary 12.10.18 11:33 Сейчас в теме
Большое спасибо за пример, я разобрался - надо помещать всё в группы и группы разберутся, кто в каком порядке выводится.
61. ret-Phoenix 461 12.10.18 12:01 Сейчас в теме
(60) Да. если смотреть глубже: создается Panel, на нее кладется Label + <НужныйВидЭлементаФормы>. Когда управляешь Закреплением - происходит работа с Panel. И когда их много и они не разбиты на группы - бывает тяжело подобрать нужное состояние.

Для лучшего понимания работы форм - запустите студию, создайте форму и попробуйте руками, через свойство закрепление (Dock) получить нужный результат.
Понимаю, что в 1С это сделано проще, я старался сделать как можно ближе к 1С, но очень сильно бороться с .net поведением, если оно не сходится с 1С не стал.
62. ildary 12.10.18 12:21 Сейчас в теме
По поводу ПредставлениеСписка - вопрос остался. Есть Ваш простой демо пример который работает. Но если создать свою ТЗ и в первую колонку положить строку или булево - Input string was not in a correct format. Также непонятно, как можно управлять пометками (они выводятся, но не изменяются мышкой или программно).
63. ret-Phoenix 461 12.10.18 13:39 Сейчас в теме
(62) Проблему вижу, буду разбираться.
64. ret-Phoenix 461 12.10.18 14:15 Сейчас в теме
(62) по ПС и первой колонке не числу - там все ясно, и видно из документации:
 /// <summary>
/// Номер колонки с индексом изображения. Если ничего не задано - 0
/// </summary>
[ContextProperty("КолонкаСИндексомИзображения")]


Поэтому 1 колонкой должно быть число, если получится выделить время на выходных - исправлю.
65. ildary 12.10.18 14:24 Сейчас в теме
Если я ещё не надоел - очередной вопрос: вот демо пример поля со списком

Данные = Новый Соответствие;
Данные.Вставить("Один", "1");
	Данные.Вставить("Два", "2");
	Данные.Вставить("Три", "3");
	
	ПолеСоСписком1 = ЭлементыФормы.Добавить("ПолеСоСписком1 ", "ПолеФормы", Неопределено);
	ПолеСоСписком1.Заголовок = "Кластер:";
	ПолеСоСписком1.Вид = ВидыПоляФормы.ПолеСоСписком;
	ПолеСоСписком1.СписокВыбора = Данные;
	ПолеСоСписком1.Значение = "3";
Показать


Установленное значение ( "3" ) - не отображается на форме и если позже обратиться к полю формы и попытаться получить его значение: получим ошибку "Object reference not set to an instance of an object" - ПолеСоСписком1.Значение


p.s. Также не работает установка свойства Ширина у ПолеФормы если тип - ПолеВвода или ПолеСоСписком
66. ret-Phoenix 461 12.10.18 14:48 Сейчас в теме
по блоку соответствия, с 1 версии шла ошибка, попутал местами Ключ/Значение. сейчас правильно будет так
Данные = Новый Соответствие; 
Данные.Вставить(1, "Один"); 
Данные.Вставить(2, "Два"); 
Данные.Вставить(3. "Три"); 


Насчет Ширины, повторюсь, по умолчанию стоит закрепление вверх, в таком случае указание ширины - не имеет смысла, закрепление перебивает его.
68. ildary 15.10.18 07:54 Сейчас в теме
(66) к сожалению установка ширины не работает, если включено не только закрепление вверх, но и влево.

Также не совсем работает логика расположения в группе:

Форма.Ширина	= 1024;
	Форма.Высота	= 500;
	Форма.Заголовок = "Управление базами";
	
	ВидыПоляФормы	   = Форма.ВидПоляФормы;
	ПоложениеЗаголовка = Форма.ПоложениеЗаголовка;
	ВидГруппыФормы	   = Форма.ВидГруппыФормы;
	ЭлементыФормы	   = Форма.Элементы;

    УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();


	ГруппаКнопки = ЭлементыФормы.Добавить("ГруппаКнопки", "ГруппаФормы", Неопределено);
	ГруппаКнопки.Вид = ВидГруппыФормы.ОбычнаяГруппа;
	
	Кнопка1 = ЭлементыФормы.Добавить("КнопкаОбновить", "КнопкаФормы", ГруппаКнопки);
	Кнопка1.Заголовок	= "Обновить";
	Кнопка1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;
	Кнопка1.УстановитьДействие(ЭтотОбъект, "Нажатие", "ПриНажатииКнопкаОбновить");
	
	ТекстовоеПоле1 = ЭлементыФормы.Добавить("КолвоБаз", "ПолеФормы", ГруппаКнопки);
	ТекстовоеПоле1.Заголовок   = "Кол-во:";
	ТекстовоеПоле1.Вид		   = ВидыПоляФормы.ПолеВвода;
	ТекстовоеПоле1.Доступность = Ложь;
	ТекстовоеПоле1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;
	
	ПолеФлажок = ЭлементыФормы.Добавить("ОтборТолькоБлок", "ПолеФормы", ГруппаКнопки);
	ПолеФлажок.Вид		   = ВидыПоляФормы.ПолеФлажка;
	ПолеФлажок.Заголовок   = "Блокировка";
	ПолеФлажок.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;

	ПолеФлажок = ЭлементыФормы.Добавить("ОтборТолькоБлокРегЗад", "ПолеФормы", ГруппаКнопки);
	ПолеФлажок.Вид		 = ВидыПоляФормы.ПолеФлажка;
	ПолеФлажок.Заголовок = "Блокировка рег.зад";
	ПолеФлажок.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;
	
	Данные = Новый Соответствие;
	Данные.Вставить(""			   , "Вручную");
	Данные.Вставить("test-srv-1c"  , "test-srv-1c" );
	Данные.Вставить("srv-1c"	   , "srv-1c" );
	Данные.Вставить("srv-1c-supera", "srv-1c-supera" );
	Данные.Вставить("blade-1"	   , "blade-1" );
	
	ПолеСоСписком1 = ЭлементыФормы.Добавить("Кластер", "ПолеФормы", ГруппаКнопки);
	ПолеСоСписком1.Заголовок = "Кластер:";
	ПолеСоСписком1.Вид = ВидыПоляФормы.ПолеСоСписком;
	// СТОИТ ВКЛЮЧИТЬ СЛЕД.СТРОКУ, КАК ПОЛЕ СКРОЕТСЯ ПОД СЛЕДУЮЩИМ ПРОГРЕССБАРОМ
	//ПолеСоСписком1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево; 
	ПолеСоСписком1.СписокВыбора = Данные;
	ПолеСоСписком1.Значение = "test-srv-1c";

        // ЭТО ТЕКСТОВОЕ ПОЛЕ НЕ ВЫВОДИТСЯ СПРАВА ОТ СПИСКА, А ЕСЛИ ПОД НИМ - ФЛАЖКИ СЛЕВА СБИВАЮТСЯ ПО ВЫСОТЕ
	//ТекстовоеПоле1 = ЭлементыФормы.Добавить("КластерВручную", "ПолеФормы", ГруппаКнопки);
	//ТекстовоеПоле1.Заголовок   = "Вручную:";
	//ТекстовоеПоле1.Вид		   = ВидыПоляФормы.ПолеВвода;
	//ТекстовоеПоле1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево;

	ПрогрессБар = ЭлементыФормы.Добавить("ИндикаторОбновленияСпискаБаз", "ПолеФормы", Неопределено);
	ПрогрессБар.Вид = ВидыПоляФормы.ПолеИндикатора;
	ПрогрессБар.ПоложениеЗаголовка = ПоложениеЗаголовка.Нет;
Показать
69. ret-Phoenix 461 15.10.18 09:57 Сейчас в теме
(68) Продолжаем изучение документации и убираем магию ) (я не злобно, настроение такое)
ГруппаКнопки = ЭлементыФормы.Добавить("ГруппаКнопки", "ГруппаФормы", Неопределено); 
ГруппаКнопки.Вид = ВидГруппыФормы.ОбычнаяГруппа; 
// добавим 2 строки, уберем комментарии там где не работало и получим счастье
ГруппаКнопки.АвтоматическийРазмер  = Ложь;
ГруппаКнопки.Высота = 50;
70. ildary 15.10.18 14:06 Сейчас в теме
(69) Спасибо, помогло!

Новый вопрос: Создал поле со списком, всё прекрасно работает, но если в него ввести своё (произвольное) значение, начинает ругаться на:
ScriptEngine.Machine.ExternalSystemException: {Модуль C:\OneScript\lib\BaseManagement\УправлениеБазами.os / Ошибка в строке: 31 / Внешнее исключение (System.NullReferenceException): Object reference not set to an instance of an object.}
Возврат Сервер.Значение;

Сам объект Сервер при этом сохраняет тип значения ПолеФормы.
98. petrov_2015 23.05.19 16:30 Сейчас в теме
(66) Никак не пойму в чем дело? ПолеСоСписком не устанавливается Значение если Данные СпискаВыбора сформированы в цикле:
Процедура ПриОткрытииФормы() Экспорт
    
    Данные = Новый Соответствие;
    Данные.Вставить(0, "0");
    Данные.Вставить(1, "1");
    Данные.Вставить(2, "2");
    
    Данные1 = Новый Соответствие;
    Для Сч=0 По 2 Цикл
		Данные1.Вставить(Сч, Строка(Сч));
    КонецЦикла;
    
    ПолеСоСписком1 = Форма.Элементы.Добавить("ПолеСоСписком1", "ПолеФормы", Неопределено);
    ПолеСоСписком1.Заголовок = "Поле со списком";
    ПолеСоСписком1.Вид = Форма.ВидПоляФормы.ПолеСоСписком;
    //ПолеСоСписком1.СписокВыбора = Данные; // так Работает
    ПолеСоСписком1.СписокВыбора = Данные1;  // а так НЕ работает (значение в списке Не устанавливается)
    ПолеСоСписком1.Значение = 2;            // ! причем значения 0 и 1 работают, а 2 и далее - нет?!
    ПолеСоСписком1.УстановитьДействие(ЭтотОбъект, "ПриИзменении", "ПриИзменииЗначения");

    Форма.Высота = 80;

КонецПроцедуры
Показать


И далее при интерактивной установке Значения=2 вылетает ошибка "Ссылка на объект не указывает на экземпляр объекта" при обращении
Форма.Элементы.Найти("ПолеСоСписком1").Значение
67. ret-Phoenix 461 12.10.18 15:03 Сейчас в теме
Можно попробовать сделать через группы.
71. ildary 16.10.18 07:41 Сейчас в теме
Простите мою настойчивость, а есть ли (или будет ли) возможность выводить в ТЗ на форме не одну, а несколько колонок с типом булево и видом Флажок? Или хотя бы в "Представление списка" получить работу с одной колонкой флажка?
73. ret-Phoenix 461 16.10.18 10:37 Сейчас в теме
(71) в ТЗ вообще-то можно сколько угодно булево, или я ошибаюсь? Ограничение не накладывал. Вид флажок - идея хорошая, в issue можно закинуть.
В представлении списка флажок - это 0 колонка, в понимании .net, пока не смотрел что там не так.
76. ildary 16.10.18 12:33 Сейчас в теме
(73) Речь не о том, что в ТЗ нельзя хранить Булево, а в том, чтобы любая колонка с Булево выводилась бы в виде флажка (не только первая).
72. ildary 16.10.18 10:36 Сейчас в теме
Скажите пожалуйста, а возможно ли получить имя текущей колонки в ТЗ?
Получаю текущую колонку через ТЗ.ТекущийЭлемент, а далее не вижу у колонки свойство Имя (искал вот тут: https://github.com/ret-Phoenix/oscript-simple-gui/blob/master/oscript-component/FormTableColumn.cs).
74. ret-Phoenix 461 16.10.18 11:02 Сейчас в теме
75. ildary 16.10.18 12:29 Сейчас в теме
(74) спасибо, я вспомнил, что Заголовок = Имя.
77. ildary 17.10.18 15:46 Сейчас в теме
Очередной вопрос - а умеет ли форма (прошу прощения если я не не нашёл в документации) обработчик ожидания? Сценарий такой - запускаем на выполнение некую команду (например 1С с приказом выполнить обмен и каждые 10 секунд проверяем - завершился ли обмен, с возможностью у пользователя на форме отменить выполнение?
80. ret-Phoenix 461 18.10.18 15:39 Сейчас в теме
(77) Обработчик ожидания - как вариант метод Sleep, может что-то уже добавилось в самом OneScript, на какое-то время выпадал из развития проекта.
78. ildary 17.10.18 16:35 Сейчас в теме
почему-то в коде ниже установка Ширина у поля формы не работает:

ГруппаУпр = ЭлементыФормы.Добавить("ГруппаУпр", "ГруппаФормы", Неопределено);
ГруппаУпр.Вид = ВидГруппыФормы.ОбычнаяГруппа;
ГруппаУпр.АвтоматическийРазмер = Ложь;
ГруппаУпр.Высота = 42;

Декорация1 = Форма.Элементы.Добавить("ПодписьГруппДейств", "ПолеФормы", ГруппаУпр);
Декорация1.Вид = Форма.ВидПоляФормы.ПолеНадписи;
Декорация1.Закрепление = УправляемыйИнтерфейс.СтильЗакрепления.Лево; //это не помогло
Декорация1.АвтоматическийРазмер = Ложь; //и это не помогло
Декорация1.Ширина = 10;
Декорация1.Заголовок = "Действия с выделенными базами:";
81. ret-Phoenix 461 18.10.18 15:45 Сейчас в теме
(78) Киньше issue, как будет время гляну. Добиться желаемого результата не смог. А если я не смог такое за пару минут - скорее всего баг.
79. ildary 17.10.18 16:51 Сейчас в теме
И последний вопрос на сегодня - у объекта есть свойство ВыделенныеСтроки. Оно только для чтения, а можно его сделать записываемым? На форме есть ТЗ, я перебираю выделенные строки, меняю их, обновляю ТЗ на форме через ТЗНаФорме.ПутьКДанным = ПровайдерТЗ;

после чего ВыделенныеСтроки слетают...
82. ret-Phoenix 461 18.10.18 15:47 Сейчас в теме
(79) конечно можно, жду PR )
Сам пока не знаю когда смогу посмотреть. В первую очередь буду исправлять баги. В свободное время в приоритете SmartConfigurator2.
83. ildary 19.10.18 08:04 Сейчас в теме
(82) Извините, а что за PR?

И еще я заметил что если на форме запустить длительное выполнение, то в случае переключения на другую программу и назад - окно замерзает (freeze) и
перестает себя перерисовывать, а в заголовке формы появляется Not Responding.

P.S. А будет ли у поля формы работать ToolTip?
84. ret-Phoenix 461 19.10.18 11:13 Сейчас в теме
(83) PR - Pull Request, доработка кода.
freeze - это уже операционка +.net
ToolTip - планировалось, даже набросок был сделан, пока не включено в релиз, надо проверять.
85. ildary 19.10.18 12:26 Сейчас в теме
(84) Pull Request - извините, дотнетом не владею, буду подождать.
86. SkyLink2012 251 06.11.18 15:02 Сейчас в теме
Очень интересно, что скриты 1script можно запускать и из PowerShell Прочитал документацию. Не нашел способа ручного измения окна мышью.

Подскажите пжлст, запускаю форму, как обычно. Мне надо вручную, мышкой ширину менять . Как это сделать?

Или, при запуске устанавливаю ширину 600. Эта ширина - фиксированная Как сделать "резиновую", растягивающуюся форму? Какое свойство, как установить?



		//ЭтаФорма.СостояниеОкна = "Обычное";
		//ЭтаФорма.СтартоваяПозиция = "ЦентрЭкрана";
		ЭтаФорма.Ширина = 600;

		//  Какое свойство устанавливает ВОЗМОЖНОСТЬ РУЧНОГО ИЗМЕНЕНИЯ окна МЫШЬЮ  ??
87. leobrn 191 07.11.18 10:28 Сейчас в теме
Подскажите почему, при выборе конкретной базы не отрабатывает ВыбраннаяБаза = Форма.Элементы.Найти("ПолеСписокБаз").Значение;
#Использовать gui 
#Использовать ParserFileV8i

Перем Парсер;
Перем Форма;

Процедура Инициализация()
	
	УправляемыйИнтерфейс = Новый УправляемыйИнтерфейс();
	Форма = УправляемыйИнтерфейс.СоздатьФорму();
	
	//# Устанавливаем обработку события ПриОткрытии
	Форма.УстановитьДействие(ЭтотОбъект, "ПриОткрытии", "ПриОткрытииФормы");
	Форма.Показать();
	
КонецПроцедуры

//# Обработка события первого открытия формы
Процедура ПриОткрытииФормы() Экспорт
	
	ЭлементыФормы = Форма.Элементы;
	ВидГруппыФормы = Форма.ВидГруппыФормы;
	ВидПоляФормы = Форма.ВидПоляФормы;
	//Группа страниц
	ГруппаСтраницы = ЭлементыФормы.Добавить("ГруппаСтраницы","ГруппаФормы", Неопределено);
	ГруппаСтраницы.Вид = ВидГруппыФормы.Страницы;
	
	//Страница полная очистка
	СтраницаПолнаяОчистка = ЭлементыФормы.Добавить("СтраницаПолнаяОчистка","ГруппаФормы",ГруппаСтраницы);
	СтраницаПолнаяОчистка.Вид = ВидГруппыФормы.Страница;
	СтраницаПолнаяОчистка.Заголовок = "Очистить весь кеш";
	//Кнопка полной очистики
	КнопкаПолнаяОчистка = ЭлементыФормы.Добавить("КнопкаПолнаяОчистка", "КнопкаФормы", СтраницаПолнаяОчистка);
	КнопкаПолнаяОчистка.Заголовок = "Очистить кеш";
	КнопкаПолнаяОчистка.УстановитьДействие(ЭтотОбъект, "Нажатие", "ОчиститьВесьКеш");
	
	//Страница выборочная очистка
	СтраницаВыборочнаяОчистка = ЭлементыФормы.Добавить("СтраницаВыборочнаяОчистка","ГруппаФормы",ГруппаСтраницы);
	СтраницаВыборочнаяОчистка.Вид = ВидГруппыФормы.Страница;
	СтраницаВыборочнаяОчистка.Заголовок = "Очистить кеш выбранной базы";
	
	//ПолеВыбораБазы
	Данные = Новый Соответствие();
	Парсер = Новый ПарсерСпискаБаз;
	Парсер.УстановитьФайл();
	СписокБаз = Парсер.ПолучитьСписокБаз();
	Для Каждого База из СписокБаз Цикл
		СтруктураАдреса = База.Значение;
		Данные.Вставить(СтруктураАдреса.Name,СтруктураАдреса.Name);
	КонецЦикла;
	ПолеСписокБаз = ЭлементыФормы.Добавить("ПолеСписокБаз","ПолеФормы",СтраницаВыборочнаяОчистка);
	ПолеСписокБаз.Вид = ВидПоляФормы.ПолеСоСписком;
	ПолеСписокБаз.Заголовок = "Базы:";
	ПолеСписокБаз.СписокВыбора = Данные;
	ПолеСписокБаз.УстановитьДействие(ЭтотОбъект, "ПриИзменении", "ПриИзменииЗначения");
	//Кнопка выборочной очистики
	КнопкаВыборочнаяОчистка = ЭлементыФормы.Добавить("КнопкаВыборочнаяОчистка", "КнопкаФормы", СтраницаВыборочнаяОчистка);
	КнопкаВыборочнаяОчистка.Заголовок = "Очистить кеш выбранной базы";
	КнопкаВыборочнаяОчистка.УстановитьДействие(ЭтотОбъект, "Нажатие", "ВыборочнаяОчисткаКеша");
	
	Форма.Высота = 130;
	
КонецПроцедуры

Процедура ОчиститьВесьКеш() Экспорт
	Чистильщик = Новый ОчисткаКеша();
	Чистильщик.УстановитьПарсер(Парсер);
	Чистильщик.ОчиститьВесьКеш();
КонецПроцедуры

Процедура ВыборочнаяОчисткаКеша() Экспорт
	ВыбраннаяБаза = Форма.Элементы.Найти("ПолеСписокБаз").Значение;
	Результат = Парсер.НайтиПоИмени(ВыбраннаяБаза);
	Если Результат = Неопределено Тогда
		Сообщить("Не найдена база с именем: " + ВыбраннаяБаза);
	Иначе
		Сообщить("Кеш для базы очищен. " + ВыбраннаяБаза);
		Чистильщик = Новый ОчисткаКеша();
		Чистильщик.УстановитьПарсер(Парсер);
		Чистильщик.ОчиститьКеш(Результат);
	КонецЕсли;
КонецПроцедуры

Процедура ПриИзменииЗначения() Экспорт
	//Сообщить("Новое значение: " +  Форма.Элементы.Найти("ПолеСписокБаз").Значение);
КонецПроцедуры

Инициализация();
Показать
88. ildary 07.11.18 14:05 Сейчас в теме
(87) Потому что у Вас ВыбраннаяБаза принадлежит группе СтраницаВыборочнаяОчистка. Надо сначала найти в элементах формы СтраницаВыборочнаяОчистка и уже в ней искать ВыбраннаяБаза. Если Вы с таким поведением не согласны - переубеждайте автора компоненты или дописывайте её сами.
89. leobrn 191 08.11.18 08:01 Сейчас в теме
(88) пробу так Форма.Элементы.Найти("ГруппаСтраницы").ПодчиненныеЭлементы.Найти("СтраницаВыборочнаяОчистка").ПодчиненныеЭлементы.Найти("ПолеСписокБаз").Значение выдает недоступно
90. ildary 08.11.18 12:08 Сейчас в теме
(89) Вот как это делаю я:

ТЗНаФорме = Форма.Элементы.Найти("ГруппаТЗ").Элементы.Найти("Базы");
91. ret-Phoenix 461 08.11.18 15:16 Сейчас в теме
На текущий момент, элемент формы ищет только в пределах выбранного родителя. без просмотра подчиненных элементов. Поведение надо менять, сейчас руки не доходят.
Если не хочется заморачиваться с поиском - можете определить элемент как переменную модуля, так вы всегда получите к нему доступ.
92. leobrn 191 09.11.18 06:20 Сейчас в теме
(91) возможность работы после компиляции в *.exe не поддерживается? видел, что в (15) уже интересовались, но это было год назад. Изменилось ли что-то?
93. ret-Phoenix 461 09.11.18 11:54 Сейчас в теме
(92) Нет, никто пока не допилил такую возможность в движке. Обходной вариант есть от Khoreva (создать как ресурс, который потом распаковывается).
94. Viktor_Ermakov 17.12.18 09:10 Сейчас в теме
(93)
Нет, никто пока не допилил такую возможность в движке. Обходной вариант есть от Khoreva (создать как ресурс, который потом распаковывается)

А где описан этот вариант? Хочется воспользоваться.
96. user1140658 15.02.19 16:20 Сейчас в теме
(95) случайно наткнулся на onescript... Вопрос: позволяет ли текущее состояние сделать распространяемое приложение(без установки) с функциями: получить информацию от пользователя(текстовая строка), обработать по алгоритму и вывести информацию в виде таблицы или в виде файла(ворд или пдф)?
97. ret-Phoenix 461 16.02.19 11:26 Сейчас в теме
(96) Позволяет, рекомендую ознакомиться с документацией.
99. alex_bob 221 08.07.19 12:39 Сейчас в теме
Пробую oscript + gui (новичок). Ubuntu 16.04, Mono 5.2, oscript 1.1.1, gui 1.1.1.2.
При запуске примера example-all-component.os из examples выдает ошибку:
{Модуль /usr/share/oscript/lib/gui/examples/example-all-components.os / Ошибка в строке: 107 / Внешнее исключение (System.NotSupportedException): Specified method is not supported.}
Строка:
ПолеСоСписком1.СписокВыбора = Данные; 


После комментирования этой строки и такой же для ПолеСписка1 пример запускается и отрабатывает.
100. ret-Phoenix 461 25.07.19 13:06 Сейчас в теме
(99) Попробуйте на новом релизе. Указанная Вами сборка очень старая. Сегодня выпустил релиз: 1.1.2.3
Оставьте свое сообщение

См. также

Фреймворк для создания бизнес web-приложений 5

Статья Программист Нет файла Бесплатно (free) Прочие инструменты разработчика

Для создания систем, решающих узкие бизнес задачи, использовать 1С бывает нецелесообразно. Хочу представить альтернативу - web фреймворк katejs. Будет интересно также тем, кто интересуется web разработкой на современном javascript.

сегодня в 15:37    288    nep_i    5       

FastCode - сервис поиска кода 1С 48

Инструменты и обработки Программист Архив с данными v8 Бесплатно (free) Инструментарий разработчика

Добавляйте свои шаблоны кода или ищите готовые шаблоны других разработчиков. Оставляйте отзывы и лайки, добавляйте понравившиеся фрагменты в свою библиотеку. Ищите по БСП или по общим модулям своей конфигурации.

10.09.2019    4736    m.bolsun    21       

Как мы разрабатываем в EDT 63

Статья Программист Нет файла v8 Бесплатно (free) EDT

EDT – это новая среда разработки, на которую сейчас перешли разработчики фирмы «1С». Однако до сих пор существует ряд «белых пятен», касающихся как теоретической, так и практической части применения этого инструмента. Про опыт перехода на разработку в EDT на конференции INFOSTART EVENT 2018 EDUCATION рассказал начальник сектора разработки в компании «Группа Полипластик» Владимир Крючков.

23.08.2019    5018    ivanov660    21       

1С:EDT. Первые шаги… или есть ли альтернатива конфигуратору? 81

Статья Программист Нет файла v8 Windows Бесплатно (free) EDT

Заменить конфигуратор сложно, а в некоторых случаях невозможно, если, например, нужно оперативно подправить код непосредственно в рабочей конфигурации…

15.08.2019    7537    ellavs    76       

Отказ от использования хранилищ 1С, переход на Git. 70

Статья Программист Нет файла Бесплатно (free) Инструментарий разработчика Разработка

Валерий Максимов в своем докладе на конференции INFOSTART EVENT 2018 EDUCATION делится опытом перехода нескольких команд (более 100 разработчиков) от использования хранилищ 1С на системы контроля версий Git.

25.07.2019    5880    theshadowco    31       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8359    ids79    24       

Групповая обработка (Управляемая консоль отчетов) 26

Статья Программист Нет файла v8 v8::УФ v8::Запросы 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Бесплатно (free) Обработка документов Инструментарий разработчика Обработка справочников

Статья предназначена тем, кто понимает, зачем нужна групповая обработка в консоли запросов. Рассматривается групповая обработка в консоли Управляемая консоль отчетов.

13.05.2019    3431    Evg-Lylyk    6       

Быстрый ввод неудобных символов 65

Статья no Нет файла Бесплатно (free) Пользователю системы Инструментарий разработчика

Использование Alt-кодов для ввода “[”, “]”, “”, “&”, “#”, “|”

15.04.2019    5089    pparshin    24       

Перенос и резервное копирование настроек конфигуратора 55

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика

Удобный перенос между рабочими местами и резервное копирование настроек конфигуратора через подсистему "Инструменты разработчика".

14.04.2019    4919    tormozit    18       

Как добавить типовую форму для СКД (для начинающих) (1С 8.3, управляемые формы) 9

Статья Программист Стажер Нет файла v8 v8::УФ v8::СКД Бесплатно (free) Инструментарий разработчика Работа с интерфейсом

Кастомизация СКД, нестандартная расшифровка, загрузка параметров и другие действия требуют наличия формы отчета. При создании СКД отчета по умолчанию форма не создается, в большинстве случаев это и не требуется. Однако при ситуациях, перечисленных выше, форму все же нужно создать. Это простая инструкция по созданию такой типовой формы.

25.03.2019    5254    ellavs    9       

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS 20

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8::УФ УУ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Бесплатно (free) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    5775    informa1555    0       

Git + 1С. Часть 2. Реализация Git workflow в 1С-разработке по шагам 128

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

В этой части мы рассмотрим наиболее распространённую схему workflow при групповой разработке с использованием Git. Как приступить к доработке по поставленной задаче; исправить ошибку, обнаруженную на этапе тестирования; отправить свой код на слияние в предстоящий релиз; и т.д. Постараемся охватить большинство задач, составляющих основной цикл разработки

28.01.2019    9677    stas_ganiev    18       

Автоматизация тестирования с помощью WinAutomationUI 28

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Рассматривается использование инструмента WinAutomationUI для создания автоматизированных сценарных тестов на примере 1 + 1 = 2.

11.12.2018    3855    AlexKo    30       

[8.3] Анализ планов запросов (Управляемая консоль отчетов) 131

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Консоль запросов

Новый инструмент! Позволяет удобно работать с планами запросов, анализ планов в файловой базе.

19.11.2018    13891    Evg-Lylyk    6       

Метрики, графики, статистика = Prometheus + Grafana 108

Статья Программист Нет файла v8 v8::ОУ Россия Бесплатно (free) Инструментарий разработчика

Снятие метрик из базы данных 1С с хранением в Phrometheus и красивое оформление на основе Grafana. Или как мы создавали комфортные условия административному персоналу на отдельно взятом складе.

23.10.2018    9451    197    freewms    64       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 266

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    33197    stas_ganiev    72       

Взгляд на практику разработки в EDT из зазеркалья 115

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) EDT

В данной статье расскажем о практическом опыте использования разработки в EDT: немного про интерфейс, командную разработку и GIT.

26.07.2018    17235    ivanov660    104       

Практика применения инструментов продвинутого разработчика 1С 155

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Статья адресована разработчикам. Будет чуть-чуть теории, будут воспоминания, и потом пойдет практика.

23.07.2018    19472    artbear    22       

Лайфхак: исходники внешних обработок и отчетов 1С - это просто. 33

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Важно: статья далеко на любителя всяких таких git'ов, gitlab'ов и oscript'ов.

22.06.2018    7574    new_user    11       

Создание поставки конфигурации 97

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Инструментарий разработчика

Пошаговая демонстрация создания поставки конфигурации, файлов обновления и настройка для обновления через FTP.

27.02.2018    13358    Vladimir_412    6       

Легкий способ обновления измененной конфигурации 41

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Легкий способ обновления измененной конфигурации. Сервис подготовки расширения конфигурации

25.10.2017    18480    avk72    63       

Metadata.js для построения дешевых высоконагруженных сервисов 199

Статья Программист Нет файла Бесплатно (free) Инструментарий разработчика WEB Мобильная разработка

В маркетинге есть понятие "голубой океан". Стратегия опирается на создание не существовавшего ранее спроса на новом рынке, где практически отсутствуют конкуренты. Вместо того, чтобы конкурировать со множеством игроков на малоприбыльных рынках ("красный океан"). В статье я расскажу об одном из инструментов, помогающем создавать и осваивать новый рынок Интернет-сервисов для бизнеса.

08.08.2016    32466    unpete    100       

Консоль запросов для УФ с возможностью передачи готовой ТЗ в качестве параметра 15

Статья Программист Нет файла v8 v8::УФ Россия Windows Бесплатно (free) Консоль запросов

Небольшая статья о том, как передать готовую таблицу значений в качестве параметра запроса в консоли запросов.

11.07.2016    12436    vadim1011985    7       

Wiki движки для публикации пользовательской документации 32

Статья Программист Нет файла Бесплатно (free) Инструментарий разработчика

В июне 2016 года я провел вебинар по созданию пользовательской документации для конфигураций, разрабатываемых на платформе 1С:Предприятие. Одна из тем, вызвавших интерес: онлайн документация.

09.07.2016    17694    kuld    4       

Поиск несериализуемых значений при помещении в хранилище 12

Статья Программист Нет файла v8 Windows Бесплатно (free) Инструментарий разработчика Практика программирования Универсальные функции

В статье разобран пример, как найти несериализуемые значения в случае помещения в хранилище коллекций, содержащих вложенные элементы. В качестве хранилищ рассмотрены временное хранилище значений и переменные типа ХранилищеЗначения.

02.03.2016    19991    balanton    2       

Подсветка синтаксиса 1С в текстовых редакторах Atom, Sublime Text, VS Code 101

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Разработка внешних компонент

Пакеты, добавляющие поддержку синтаксиса языка 1С:Предприятие 8 в текстовые редакторы Atom, Sublime Text и VS Code. И не только.

02.02.2016    22652    nixel    38       

Дай дернуть! О веб-сервисах, Linux'ах и добрых поисковых сайтах 60

Статья Программист Нет файла v8 1cv8.cf Linux Бесплатно (free) Инструментарий разработчика Администрирование данных 1С WEB

О веб-сервисах, апачах и *nix'ах. - установим на новенький убунту старенький апач с php. - дернем сервис из php-скрипта. - создадим приложение, позволяющее дергать произвольный сервис с произвольными данными. - ну и что там получится по пути в лес...

30.12.2015    22426    starik-2005    4       

xUnitFor1C - набор инструментов для выполнения тестирования (модульного/юнит, приемочного, сценарного для 1С 8.3, интеграционного) в 1С:Предприятии 8 177

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика

xUnitFor1C - простой и мощный фреймворк для тестирования в 1С. Позволяет тестировать в разных режимах обычное приложение, тонкий и толстый клиент управляемого приложения. Поддерживаются любые платформы 1С - от 8.2.17 до 8.3.5 и выше. Любые наборы тестов могут прогоняться в полностью автоматическом режиме. Автозапуск используется в различных build-серверах в системах Continuous Integration. Также возможно очень простое создание тестовых данных на основании табличных макетов. Эти макеты можно генерировать из реальных боевых данных. Полученные данные в тестах загружаются одной строкой кода. В статье я кратко описал историю продукта + вставил небольшое описание различных возможностей нашего фреймворка + список полезных статей/примеров/видео, обучающих/рассказывающих о практическом применении инструмента

13.11.2015    37134    artbear    45       

Сервис обмена кодом 28

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика

Бывало так, что вам нужно быстро показать кому-то свой код, но опубликовать его негде, так как популярные сервисы просто не поддерживают раскраску кода 1С? Теперь решение есть!

26.06.2015    17740    Infactum    23       

Многопоточность в 1С, клиент-серверный вариант 59

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Математика и алгоритмы

Многопоточность - это свойство системы выполнять одновременно более одной операции (в пределе - более одной программы), позволяя в ряде случаев добиться существенного роста производительности программного продукта...

21.06.2015    30111    starik-2005    50       

Универсальная функция для программного выполнения СКД 110

Статья Программист Нет файла v8::СКД 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика Универсальные функции

Часто встречаются вопросы на форумах о программном формировании СКД. Вроде и информации много по этому поводу, но... Все как всегда :) Собственно, в описании без лишних слов выложен текст общей функции, в которую, для выполнения отчета, нужно передать (минимум 2 параметра): СКД и ТабличныйДокумент.

20.05.2015    26562    dj_serega    18       

1C:Enterprise Development tools (EDT) или кодим в Eclipse 254

Статья Программист Нет файла v8 Windows Бесплатно (free) EDT

Как и выход мобильной платформы был для оооочень большого числа разработчиком открытием, так и я уверен, что и о новом конфигураторе - тоже мало кто слышал. Поэтому давайте попробуем пробежаться по новому конфигуратору. (Много больших картинок)

11.04.2015    70707    DitriX    297       

Bugs must die! или Как повысить качество внедрений инструментами тестирования 48

Статья Программист Нет файла Windows Бесплатно (free) Инструментарий разработчика

Речь в статье пойдет про тестирование, про качество программ и про то, как можно процесс тестирования автоматизировать. Статья написана по итогам доклада, прочитанного автором на Конференции IE 2013 Еvolution 23-24 мая 2013 года. Также она напечатана в Журнале Инфостарта №2.

03.03.2015    17699    eu_genij    17       

Перевод интерфейса конфигурации с использованием программы 1С:Переводчик 33

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Перевод текстов интерфейсов конфигураций без использования технологии памяти переводов приводит к рассогласованности терминологии, когда один и тот же объект в конфигурации в разных меню может называться по-разному. Решить эту проблему можно используя программу 1С:Переводчик.

09.02.2015    28174    boogie    21       

Генерация кода управляемой формы (декомпиляция элементов) 510

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика Практика программирования Работа с интерфейсом

Изменение форм типовых конфигураций лучше выполнять программно. Эта обработка упрощает добавление элементов на форму, генерируя код создания элементов, реквизитов и команд формы.

29.09.2014    92311    8926    ekaruk    123       

Типовой механизм упрощенного изменения конфигурации в ERP 2.0 и УТ 11 212

Статья Системный администратор Программист Нет файла v8 УТ10 ERP2 Windows Бесплатно (free) Инструментарий разработчика Практика программирования Работа с интерфейсом

В ERP 2.0 (и соответственно в УТ 11) появился функционал для упрощенной возможности модификации конфигурации разработчиками. Он касается в частности изменения форм объектов и размещения подписок на элементы, теперь задача изменения конфигурации на поддержке упростилась. Также появились дополнительные возможности в новой версии платформы 8.3.5, которые также упростят задчу.

22.09.2014    49451    ivanov660    49       

Просмотр SQL-таблиц из 1С. Возможность очистки таблиц 26

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика

Обработка позволяет соединиться с SQL-сервером (SQL-авторизация), получить список баз на сервере, после выбора базы - получить список таблиц. Позволяет вывести таблицу на просмотр, при необходимости очистить таблицу средствами SQL (delete from), просмотреть соответствие имен таблиц объектам конфигурации, в которой запущена база

29.08.2014    18560    377    Abadonna    4       

TurboConf:Шаблоны - сервис для поиска и хранения фрагментов кода 43

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика

Сервис добавляет в Конфигуратор возможность поиска и хранения фрагментов кода. Делитесь своими шаблонами с другими разработчиками или используйте уже готовые!

13.08.2014    19795    m.bolsun    68       

Консоль запросов. Очередная гайка. 18

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Консоль запросов

Небольшое дополнение к консоли запросов. Позволяет создавать функцию вместе с текстом запроса.

23.07.2014    6387    mdmdvd    3       

Анализ запросов с помощью SQL Profiler 219

Статья Системный администратор Программист Нет файла Windows Бесплатно (free) Производительность и оптимизация (HighLoad) Инструментарий разработчика Администрирование данных 1С

В своей работе мы довольно часто мы сталкиваемся с ситуацией, когда определенный запрос работает медленно, причем по тексту запроса невидно никаких очевидных проблем. Обычно в этом случае необходимо расследовать проблему на более глубоком уровне. Как правило, возникает необходимость посмотреть текст SQL-запроса и его план, и вот в этом нам как раз помогает SQL Profiler.

22.07.2014    67245    Andreynikus    20       

Конвертер юникода в кириллицу 8

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика

Как преобразовать строку на юникоде в строку на кириллице, например, вот это: "/u042E/u043D/u0438/u043A/u043E/u0434" в это: "Юникод"

25.04.2014    9806    Mart    1       

Сохранение в Excel из WEB-клиента 13

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Инструментарий разработчика

Не всегда корректно отрабатывает сохранение в Excel из 1C при работе в WEB-клиенте. Мне попалась ситуация, когда не отрабатывал код "ТабличныйДокумент.Записать(...)" и выдавалась ошибка "неизвестная ошибка.: object doesn't support this property or method" Ниже предложена процедура сохранения в Excel, корректно работающая во всех типах подключения.

24.04.2014    18293    Tavalik    1       

Подсистема "COMExchange": консоль запросов в режиме «Консоль кода». 8

Статья Системный администратор Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Консоль запросов

Описана возможность использования обработки «Консоль запросов 1С+ADO» в качестве «консоли кода». При этом имеется возможность помещения результатов вычислений в «табло формул». Кроме результатов вычислений в это «табло» можно также вывести время выполнения и описание обработанных ошибок времени исполнения.

03.04.2014    23328    yuraos    2       

Автоматизированное тестирование в 8.3 163

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика

В данной статье будет рассмотрен новый механизм системы "1С:Предприятие 8" поддерживаемый начиная с платформы версии 8.3. Механизм позволяет легко и быстро создавать различные сценарии тестирования, без необходимости написания сложных процедур и функций для имитации действий пользователя.

06.03.2014    54225    M.Shalimov    45       

Изменение данных среды выполнения «на лету» в процессе отладки с помощью внешней обработки 9

Статья Программист Нет файла v8 Windows Бесплатно (free) Инструментарий разработчика

Иногда бывают такие моменты, что при остановке во время отладки необходимо «на лету» поменять какое-то значение реквизита или переменной. Или даже выполнить какой-то совершенно посторонний кусок кода в то время пока программа стоит на точке.

13.02.2014    7757    Рэйв    7       

Перенос таблицы значений между клиентом и сервером 50

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Инструментарий разработчика Практика программирования

Всем привет. Бывают такие моменты, когда необходимо таблицу значений передать с сервера на клиент, увы, Мутабельные значения и т.д. В тоже время есть возможность перекидывать все это добро через Хранилище, чем собственно разработчики часто пользуются. Но сегодня я бы хотел вынести на Вашу критику вот такой пример переноса. Сильно не пинайте.

10.12.2013    76233    Draconus    35       

Коллективная разработка на 1С версии 7.7 и Git 21

Статья Программист Нет файла v7.7 Россия Windows Бесплатно (free) Инструментарий разработчика Разработка внешних компонент

В данной статье я не буду рассматривать работу с системой контроля версий Git, для этого есть специальные ресурсы, например http://git-scm.com/book/ru. Я только расскажу тем, кто привык и любит Git, подружить старую добрую 7-ку и систему контроля версий Git.

17.09.2013    15165    s.nek    12