Хранение файлов в томах на диске (для УПП 1.3)

Публикация № 529067

Разработка - Практика программирования

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

Часто возникает необходимость хранить присоединенные файлы где-нибудь на сетевом диске, чтобы как-то сократить рост размера базы.
К большому сожалению, приходится изобретать велосипед, т.к. в УПП 1.3 (заметьте, версия продается и поддерживается) НЕТ! хранения файлов вне базы.
Да, эта возможность уже реализована в УПП 1.3 для электронных документов, а все остальное по-прежнему хранится в базе.

"Допилок" этой функциональности много, есть и платные. Предлагаю свой варинат велосипеда. Версия рабочая, проверялась на УПП 1.3.72.3.

 

Побежали!

Включим хранение файлов в томах на диске

 

Добавим в справочник "ХранилищеДополнительнойИнформации" два реквизита:

ИмяФайлаВТоме (тип "Строка(50)")

НомерВерсии (тип "Число(10)")

 

 

 

В модуле объекта справочника "ХранилищеДополнительнойИнформации" пишем код (реквизит "Хранилище" очистим, а данные сохраним на диск). Использована типовая процедура "ФайловыеФункции.ДобавитьНаДиск", которая позволит также контролировать размер файла и запишет в имя файла на диске версию:

Процедура ПередЗаписью(Отказ)
	
	//+wowik
	Если ФайловыеФункции.ПолучитьТипХраненияФайлов() <> Перечисления.ТипыХраненияФайлов.ВИнформационнойБазе Тогда
		Если Хранилище.Получить() <> Неопределено Тогда // когда помечается элемент на удаление, то хранилище пустое
			Если не ЗначениеЗаполнено(ИмяФайлаВТоме) Тогда
				ИмяФайлаВТоме = Строка(Новый УникальныйИдентификатор);
				НомерВерсии = 1;
			Иначе			
				НомерВерсии = НомерВерсии + 1; //будем сохранять версии файлов на всякий случай
			КонецЕсли;
			
			Если Этотобъект.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Файл Тогда
				РасширениеФайла = СтрЗаменить(Прав(ИмяФайла,4),".","");
				ДвоичныеДанныеФайла = Хранилище.Получить();
			Иначе			
				РасширениеФайла = "bmp";
				ВременныйФайл = ПолучитьИмяВременногоФайла(РасширениеФайла);
				Картинка = Хранилище.Получить();
				Картинка.Записать(ВременныйФайл); 
				ДвоичныеДанныеФайла = Новый ДвоичныеДанные(ВременныйФайл);
			КонецЕсли;
			
			ПутьКФайлуВТоме = ИмяФайлаВТоме+"."+РасширениеФайла;
			
			РазмерФайла = ДвоичныеДанныеФайла.Размер(); 
			
			ФайловыеФункции.ДобавитьНаДиск(
			ДвоичныеДанныеФайла,
			ПутьКФайлуВТоме,
			"", //ссылка на том, все равно она обнуляется в процедуре ДобавитьНаДиск
			1,
			НомерВерсии,
			ИмяФайлаВТоме,
			РасширениеФайла,
			РазмерФайла,
			Ложь,
			ТекущаяДата()
			);
			
			//хранилище элемента очищаем 
			Хранилище = Неопределено;  
		КонецЕсли;
	КонецЕсли;
	//-wowik
	
КонецПроцедуры

Далее в каком-либо общем модуле (в моем случае общий модуль "wowikОбщийМодуль") добавляем функцию:

Функция ПолучитьДвоичныеДанныеФайлаВХранилище(ХранилищеДополнительнойИнформацииСсылка, ВернутьХранилищеЗначения = Ложь) Экспорт
	
	Если ФайловыеФункции.ПолучитьТипХраненияФайлов() = Перечисления.ТипыХраненияФайлов.ВИнформационнойБазе Тогда
		Если ВернутьХранилищеЗначения Тогда
			Возврат ХранилищеДополнительнойИнформацииСсылка.Хранилище;
		Иначе
			Возврат ХранилищеДополнительнойИнформацииСсылка.Хранилище.Получить();
		КонецЕсли;
	Иначе
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТомаХраненияФайлов.Ссылка
		|ИЗ
		|	Справочник.ТомаХраненияФайлов КАК ТомаХраненияФайлов
		|ГДЕ
		|	ТомаХраненияФайлов.ПометкаУдаления = &ПометкаУдаления
		|
		|УПОРЯДОЧИТЬ ПО
		|	ТомаХраненияФайлов.ПорядокЗаполнения";
		
		Запрос.УстановитьПараметр("ПометкаУдаления", Ложь);
		Выборка = Запрос.Выполнить().Выбрать();
		
		Если Выборка.Количество() = 0 Тогда
			ВызватьИсключение(НСтр("ru = 'Нет ни одного тома для размещения файла.'"));
		КонецЕсли;
		
		Пока Выборка.Следующий() Цикл 			
			СсылкаНаТом = Выборка.Ссылка;			
			ПутьКТому = ФайловыеФункции.ПолныйПутьТома(СсылкаНаТом);
			ИмяФайлаВТоме = ХранилищеДополнительнойИнформацииСсылка.ИмяФайлаВТоме;
			Если ЗначениеЗаполнено(ИмяФайлаВТоме) Тогда
				НайденныеФайлы = НайтиФайлы(ПутьКТому,"*"+ИмяФайлаВТоме+"*",Истина);
				Если НайденныеФайлы.Количество() > 0 Тогда
					//получить последнюю версию файла. Предполагается что файлы беспорядочно отсортированы
					ПолучитьФайлСНомером = 1;
					ИндексНайденногоФайла = 0;
					Для Каждого НайденныйФайл из НайденныеФайлы Цикл
						 НомерВерсии = Число(СтрЗаменить(Прав(НайденныйФайл.ИмяБезРасширения,2),".",""));						 
						 Если НомерВерсии >= ПолучитьФайлСНомером Тогда
							 ПолучитьФайлСНомером = НомерВерсии;
							 ФайлВТоме = НайденныйФайл;
						 КонецЕсли; 						 
					КонецЦикла;
					     
					ПутьКФайлуЛокальный = ПолучитьИмяВременногоФайла(ФайлВТоме.Расширение);
					КопироватьФайл(ФайлВТоме.ПолноеИмя, ПутьКФайлуЛокальный); //открыть картинку из локального диска быстрее получится, чем по сети открыть				
					Если ВернутьХранилищеЗначения Тогда
						Возврат Новый ХранилищеЗначения(Новый ДвоичныеДанные(ПутьКФайлуЛокальный));
					Иначе
						Возврат Новый Картинка(ПутьКФайлуЛокальный);
					КонецЕсли;
				КонецЕсли;
			Иначе
				Если ВернутьХранилищеЗначения Тогда
					Возврат Новый ХранилищеЗначения(Неопределено);
				Иначе
					Возврат Новый Картинка;
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;		
	КонецЕсли;
	
КонецФункции

Далее ищем глобальным поиском выражение "Хранилище.Получить()":

в большинстве случаев замена проста:

...

                //мТекущееОсновноеИзображение = ОсновноеИзображение.Хранилище.Получить(); //wowik
                мТекущееОсновноеИзображение = wowikОбщийМодуль.ПолучитьДвоичныеДанныеФайлаВХранилище(ОсновноеИзображение); //wowik

...

            //ЭлементКартинки.Картинка = ОсновноеИзображение.Хранилище.Получить(); //wowik
            ЭлементКартинки.Картинка = wowikОбщийМодуль.ПолучитьДвоичныеДанныеФайлаВХранилище(ОсновноеИзображение); //wowik

...

Но в некоторых случаях сложнее, например в процедуре "ОтображениеИзображения()" формы "ФормаИзображения" справочника "ХранилищеДополнительнойИнформации":

Процедура ОтображениеИзображения()

	//+wowik
	Если Хранилище.Получить() = Неопределено Тогда
 		Если ФайловыеФункции.ПолучитьТипХраненияФайлов() = Перечисления.ТипыХраненияФайлов.ВИнформационнойБазе Тогда
			ЭлементыФормы.ПолеИзображения.Картинка = Новый Картинка();
		Иначе
			Если НЕ ЗначениеЗаполнено(ИмяФайлаВТоме) Тогда 
				ЭлементыФормы.ПолеИзображения.Картинка = Новый Картинка();
			Иначе
				КартинкаВТоме = wowikОбщийМодуль.ПолучитьДвоичныеДанныеФайлаВХранилище(Ссылка);
				ЭлементыФормы.ПолеИзображения.Картинка = КартинкаВТоме;
				Хранилище = Новый ХранилищеЗначения(КартинкаВТоме);
			КонецЕсли;
		КонецЕсли;
		Возврат;
	КонецЕсли;

	Если ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение Тогда
		ЭлементыФормы.ПолеИзображения.Картинка = Хранилище.Получить();
	Иначе
		ЭлементыФормы.ПолеИзображения.Картинка = Новый Картинка();
	КонецЕсли; 
	 //-wowik
	 
КонецПроцедуры

 

Отображение картинок поправили, теперь переходим к сохранению и открытию внешних файлов:

 

в общем модуле "РаботаСФайлами" исправляем:

...

//СохранитьФайл(СтруктураПараметров, СсылкаФайл.ИмяФайла, СсылкаФайл.Хранилище, СпособПерезаписи); //wowik            
СохранитьФайл(СтруктураПараметров, СсылкаФайл.ИмяФайла, wowikОбщийМодуль.ПолучитьДвоичныеДанныеФайлаВХранилище(СсылкаФайл,Истина), СпособПерезаписи); //wowik
...

//ДанныеФайла = СсылкаФайл.Хранилище; //wowik
ДанныеФайла = wowikОбщийМодуль.ПолучитьДвоичныеДанныеФайлаВХранилище(СсылкаФайл,Истина);//wowik

...

в общем модуле "ФайловыеФункции" ставим "попытку":  

Попытка //wowik
 // Установим время изменения файла таким, как оно стоит в текущей версии
ФайлНаДиске = Новый Файл(ПолноеИмяФайлаСПутем);
ФайлНаДиске.УстановитьВремяИзменения(ВремяИзменения);
ФайлНаДиске.УстановитьТолькоЧтение(Истина);
Исключение
КонецПопытки;

Возможно, еще где-то придется что-то закомментировать. Далее все решается отладкой уже в конфигурации.

И все.  Спасибо. Удачного внедрения!

Скачать файлы

Наименование Файл Версия Размер
Все обработки от wowik на infostart.ru до 01.10.2018
.zip 59,98Kb
03.10.18
6
.zip 59,98Kb 6 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. cool.vlad4 44 05.06.16 15:33 Сейчас в теме
а в вашей версии УПП есть модули ПрисоединенныеФайлы, ПрисоединенныеФайлыКлиент?(скорее всего есть) Имхо через него все проще можно было сделать. там уже готовые функции все есть.(т.е. через БСП это сделать)
2. wowik 740 05.06.16 22:05 Сейчас в теме
(1) cool.vlad4, сделайте, опубликуйте свой вариант, чё пальцы гнуть)
user1320061; 1Cynep4eJIoBek; Trancer64; +3 1 Ответить
3. cool.vlad4 44 05.06.16 22:10 Сейчас в теме
(2) а я где-то пальцы гнул?
Irwin; pss1985; kadild; AlexKoso; CSiER; Рамзес; waol; sulfur17; +8 1 Ответить
4. Ivon 640 08.06.16 12:26 Сейчас в теме
Механизм интересен, но хранение в файловых шарах имеет свои минусы, порой очень существенные. Я бы делал хранение в отдельной БД - и бекапить проще и безопасность данных выше.
5. thelans 28 08.06.16 14:05 Сейчас в теме
На сколько я знаю в MS SQL есть возможность хранить файлы, сохранённые в поле BLOB, на диске. В 1С дорабатывать при этом ничего не надо, а выставить соответствующие настройки СУБД.
6. Xershi 920 08.06.16 19:49 Сейчас в теме
(5) thelans, что то новенькое. Где про это почитать подробнее?
13. CSiER 29 14.06.16 07:21 Сейчас в теме
(6) Xershi, рискну предположить, что речь идет про filestream - но структурой бд "рулит" 1С (как в этом случае быть при реструктуризациях, триггерах и прочих мелочах с данными - тоже интересно).
14. cool.vlad4 44 15.06.16 01:06 Сейчас в теме
(6) Xershi, c 2008 sql server filestream как верно выше заметили и с 2012 filetables появились, котороые позволяют делать таблицы, связывать их с папкой, где можно будет работь уже с файлами привычными операциями. технология крутая, но как ее связать с 1С (какой профит от этого получить) , я не знаю. в принципе хранения в томах из БСП имхо достаточно для 1С, может ошибаюсь, поправьте.
7. webester 31 09.06.16 06:00 Сейчас в теме
(5)(6)Угу очень интересно, как это работает.
9. SuhoffGV 09.06.16 17:06 Сейчас в теме
(5) thelans, Только выгрузка в DT и бэкап средствами СУБД быстрее от этого не станут. А если хранить файлы в ФС то выгрузка в dt будет намного быстрее.
romankoav; +1 Ответить
8. kosmo0 96 09.06.16 08:58 Сейчас в теме
В подобных случаях у меня зачастую возникает вопрос - неужели люди не создают тестовые базы для всяких безобразий? (причем чтобы и пользователи могли изменения и/или новинки потестить).

К чему весь разговор. Тестовые базы зачастую это загруженная сохраненка рабочей БД. И в этом случае тестовая база может легко и непринужденно что-нибудь сотворить с сохраненными файлами рабочей БД. Так что не помешало бы сделать маленький механизм контроля какой БД с файлами можно работать, а какой - нет (либо только смотреть, но не менять).
KAV2; Krio2; ph33l; NazarovV; +4 Ответить
10. SuhoffGV 09.06.16 17:11 Сейчас в теме
(8) kosmo0, Создают. У меня в базе есть константа "СтрокаСоединенияСРабочейБазой". И процедура общего модуля "ЭтоРабочаяБаза()" которая проверяет совпадает ли строка соединения текущей базы с значением константы. Если совпадает, то база считается рабочей и критичный функционал работает нормально.

Но к сожалению хранение файлов во внешних каталогах пока не написали, но уже назрело. Бэкап средствами СУБД идет 80 минут. Только из-за файлов в базе.
11. Xershi 920 09.06.16 17:14 Сейчас в теме
(10) SuhoffGV, а каков их объем? У нас 40 гигов на ссд за 130 сек бекапит.
15. SuhoffGV 21.06.16 17:13 Сейчас в теме
(11) Xershi, 40Гб только дамп сжатый а gzip занимает. База в postgresql на 300Gb SAS дисках. Размер самой базы по данным pg_admin - 65Gb. Из них чуть более 32,2Гб в виде файлов в базе.
12. vshish 123 10.06.16 03:12 Сейчас в теме
Все хорошо и вроде бы правильно, но. Как писал в [1] да есть Присоединенные файлы, и есть еще некоторые подводные камни.
Я о них знаю потому, что сам делал такую доработку. Вот она http://infostart.ru/public/411416/
и вообще этот метод работает и на КА 1.1 и на УТ 10.3 и на УПП 1.3 правда с релиза как появился механизм электронного обмена документами.
16. qapex 59 23.06.16 09:45 Сейчас в теме
добрый день, сервер 1с на linux, с правами на linux настроили, файлы записывает на шару, а при открытии выдает ошибку. По коду получилось, что ПолучитьФайлы() возвращает пустой массив и дальше код не отрабатывает. Получается, что ПолучитьФайлы() работает от клиента (и пути, и права), а запись файлов через сервер (и пути, и права под которыми сервер 1с запущен). А путь предполагается использовать один и тот же?
17. wowik 740 23.06.16 21:29 Сейчас в теме
(16) qapex, ПолучитьФайлы() - что за процедура?
22. alen-s 12.12.16 08:49 Сейчас в теме
(16)
У Вас получилось решить эту проблему?
18. qapex 59 24.06.16 06:58 Сейчас в теме
19. wowik 740 24.06.16 20:34 Сейчас в теме
(18) qapex, ну вообще должно работать, если папка открыта для сети и обращаетесь через "\\". Не знаю в чем дело.
20. Himikuda 22.07.16 07:56 Сейчас в теме
Всё работает класс) Огромное спасибо! хоть база пухнуть не будет. Только есть нюанс, имена файлов не корректно отображаются (набор символов) зато читаются., может кто то подскажет как это возможно поправить?
21. vovan_matveev 5 15.09.16 01:53 Сейчас в теме
Спасибо, wowik!
Статья очень помогла.

Я ограничился только тем что храню только присоединенные файлы (которые добавляются и отображаются через формы справочника Хранилище дополнительной информации)
таким образом я ограничился только первой частью статьи (доработка справочника Хранилище дополнительной информации и общий модуль), последней чстью (сохранение и открытие внешних файлов).

А вместо объемной средней части (где подмена функций во всех ссылках на "Хранилище.Получить()" я ограничился изменением одной функции модуля формы в справочнике Хранилище дополнительной информации.

В моем случае в базе уже были картинки хранящиеся внутри базы. поэтому мне было важно отображать и старый файлы и новые файлы из тома.

// Процедура показывает картинку текущей строки таблицы Изображения
//
// Параметры: 
//  Элемент - элемент формы, Изображения
//
// Возвращаемое значение:
//  Нет.
//
Процедура ПоказатьКартинкуТекущейСтроки(Элемент)

	Если Элемент.ТекущиеДанные = Неопределено Тогда
		ЭлементыФормы.ПолеИзображения.Картинка = Новый Картинка();
		Возврат;
	КонецЕсли;

	//Проверка на новую строку, если новая то не обновляем изображение.
	Если НЕ Элемент.ТекущаяСтрока.Пустая() Тогда
		//Изменения на основе wowik
		ТекущаяКартинка = Элемент.ТекущиеДанные.Ссылка.Хранилище.Получить();
		Если  ТекущаяКартинка = Неопределено Тогда
			ТекущаяКартинка = ОбщийМодульРМ.ПолучитьДвоичныеДанныеФайлаВХранилище(Элемент.ТекущиеДанные.Ссылка);
		КонецЕсли;
		//--Изменения на основе wowik
		ЭлементыФормы.ПолеИзображения.Картинка = ?(ТекущаяКартинка <> Неопределено, ТекущаяКартинка, Новый Картинка());
	КонецЕсли;
	
	ОбновитьКнопкиОсновногоИзображения(ЭлементыФормы.Изображения.ТекущаяСтрока);

КонецПроцедуры
Показать
23. alen-s 29.12.16 12:59 Сейчас в теме
24. n0ther 09.02.17 13:45 Сейчас в теме
Почему в справочник не добавлен реквизит Том с типом ТомаХраненияФайлов? Так же быстрее и проще, чем перебирать все тома.
25. wowik 740 03.04.17 11:40 Сейчас в теме +10 $m
(24)
ее и проще, чем перебирать все тома.

это уже бантики)
26. albertik88 7 04.05.17 07:00 Сейчас в теме
Добрый день, у меня упп версии 1.3.5.1 - она полностью доработана и абсолютно не обновляется...у меня вообще отсутствует вкладка электронные документы в настройках программы...а сейчас возникла необходимость хранение файлов вне базы...если есть возможность скинь мне базу cf, или выложи в облако...буду очень признателен и благодарен! zakievar@mail.ru
27. pss1985 3 03.05.18 05:20 Сейчас в теме
я у себя такое как-то реализовывал, но еще добавил права на открытие файла. Создал таб часть "Пользователи" с реквизитами Пользователь и право записи, право чтения. Если в ней есть пользователь, то дается право на осуществление действий с этим файлом. Бывают случаи, когда надо некоторым пользователям запретить открытие и изменение файла.
user1320061; 1Cynep4eJIoBek; alen-s; +3 Ответить
28. KOVRUS 21 20.02.20 12:30 Сейчас в теме
Очень помогла статься, сделал в сильно измененной Ут 10.3
Оставьте свое сообщение

См. также

Краткое руководство по внесению изменений в конфигурацию

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Практика программирования

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    10085    18    sapervodichka    41       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Полезные процедуры и функции для программиста

Статья Программист Нет файла v8 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    19100    9    HostHost    27       

Описание формата внутреннего представления данных 1С в контексте обмена данными

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    12332    10    Dementor    29       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Конвейер проверки качества кода

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования Математика и алгоритмы

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    14409    19    Stepa86    44       

Время учиться: до 3 апреля скидки на курсы до 40%! Промо

Для тех, кто решил провести самоизоляцию с пользой, Инфостарт запускает акцию «Время учиться». С 30 марта до 3 апреля 2020 года наши курсы и видеозаписи докладов INFOSTART EVENT 2019 INCEPTION продаются со скидкой!

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    14718    4    m-rv    86       

1С:Ассемблер. Немного летнего веселья!

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    21042    67    Evil Beaver    117       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Простые примеры сложных отчетов на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    21524    19    Hatson    22       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    24100    9    tormozit    44       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    21211    77    Synoecium    40       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Отладка сложных отчетов на СКД

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    20203    74    maxx    58       

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    17909    13    dmitry1975    31       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Использование подсистемы БСП "Заполнение объектов"

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    19516    10    ids79    23       

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    14051    12    RocKeR_13    16       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    24599    44    dsdred    13       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    21384    25    informa1555    26       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    32390    17    kalyaka    16       

HTTP Сервисы: Путь к своему сервису. Часть 1

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    58601    24    dsdred    24       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    23922    86    m-rv    57       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    36091    31    dsdred    36       

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    21907    11    wowik    3       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    36236    81    kalyaka    34       

Асинхронная запись и чтение файла без использования модальных методов и временных файлов

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    23400    19    Alxby    23