Использование ТСД на WM 6 как беспроводной сканер с получением данных из 1С

Публикация № 525806

Администрирование - Торговое оборудование - Терминал сбора данных

.Net Compact Framework C#

Как вариант печати этикеток на мобильный принтер, получение информации по ШК.
Можно легко расширить до более сложных задач. В том числе на Xamarin под Android и IOS.

Сейчас много старых ТСД,  которые можно использовать в этом варианте. В отличие от беспроводных сканеров мы можем получить информацию о товаре. Подтвердить действия и т.д.

Основное в разработке - это модуль обмена по TCP/IP.

Применен протокол со сжатием данных, так как это актуально в медленных сетях Wi-Fi, особенно вдали от точки.

Конечно можно использовать и Вэб сервисы, но часто нужно настраивать мобильный принтер на машире оператора, или делать авбор данных в ручную с локального компьютера.

Применение в 1С такое.

&НаКлиенте
Процедура Запустить(Команда)
	// Вставить содержимое обработчика.
	Если TCPСервер=неопределено Тогда
		TCPСервер= СоздатьСерверTCP();
		
	КонецЕсли; 
	
	Событие=Врап.ПолучитьОбъектДляСобытийСПараметром(TCPСервер,"ПришлоСообщениеПоTCP");
	
	ДобавитьОбработчик Событие.СобытиеСПараметром, ПолучениеДанныхПоTCP;
	TCPСервер.ОткрытьАйПиПортСНомеромПорта(Отчет.Порт);
	
	Элементы.ЗапуститьСерверTCPIP.Доступность=Ложь;
КонецПроцедуры


&НаКлиенте
Процедура ПолучениеДанныхПоTCP(Данные)
	
	// Получаем данные в виде объекта у которого 2 свойства
	// Команда Имя запроса строка
	// Данные Строковое представление данных
	Сообщить("Команда="+Данные.Команда);
	Сообщить("Данные="+Данные.Данные);
	Сообщить("ЕстьОтвет="+Данные.ЕстьОтвет);	
	
	// ТСД Посылает команду "СканированШК" и отсканированный ШК 
	Если Данные.Команда="СканированШК" Тогда
		Шк=Данные.Данные;
		// Получим данные по Номенклатуре и отправит данные ТСД
		Ответ=ПолучениеДанныхПоШК(ШК);
		TCPСервер.Ответить(Ответ);
		
		возврат
	КонецЕсли; 
	
	// Для других команд просто отправим текущее время и дату 
	Если Данные.ЕстьОтвет Тогда
		Ответ="Ответ на команду "+Данные.Команда+"
		|Данные "+Данные.Данные+"
		|ВремяНаСервере="+XmlСтрока(ТекущаяДата());
		TCPСервер.Ответить(Ответ);
		
		
	КонецЕсли; 
	
КонецПроцедуры
 

Вот исходники модуля передачи и приема данных по сети

 

Тестировал на эмуляторе.

Также удобно передавать данные сразу в сериализованном DataTable для универсальной обработки на TCL с фильтрами поиском и тд

 

Функция ПолучитьТипКолонкиДляДТ(Колонка) Экспорт
Тип=Колонка.ТипЗначения;
Если Тип=Неопределено Тогда
возврат "System.Object"
КонецЕсли; 

Если тип.Типы().Количество()>1 Тогда
	возврат "System.Object"
КонецЕсли; 

Тип1=тип.Типы()[0];

Если Тип1=Тип("Число") Тогда
	Квалификатор=Тип.КвалификаторыЧисла;
	Если Квалификатор.РазрядностьДробнойЧасти>0 Тогда
		возврат "System.Decimal"
	КонецЕсли; 
	
	Разрядность=Квалификатор.Разрядность;
	Если Разрядность<10 Тогда
		возврат "System.Int32"
	ИначеЕсли Разрядность<19 Тогда	
		возврат "System.Int64"
	Иначе
		возврат "System.Decimal"
	КонецЕсли; 
	
КонецЕсли; 

Если Тип1=Тип("Строка") Тогда
 возврат "System.String"
ИначеЕсли Тип1=Тип("Дата") Тогда
 возврат "System.DateTime"
КонецЕсли;

return "System.Object"
КонецФункции	

Функция СоздатьДТ(врап,Тз,ИмяТаблицы) Экспорт

	 Колонки=Тз.Колонки;

	 myTable=Врап.СоздатьОбъект("System.Data.DataTable, System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",ИмяТаблицы);
	 DataColumn=Врап.ПолучитьТип("System.Data.DataColumn");
	 Columns= myTable.Columns;
	 КоличествоКолонок=Колонки.Количество();
	 Для каждого Колонка Из Колонки Цикл
	 
	 	 colItem =Врап.СоздатьОбъект(DataColumn,Колонка.Имя, Врап.ПолучитьТип(ПолучитьТипКолонкиДляДТ(Колонка)));
         Columns.Add(colItem);
	 
	 КонецЦикла; 
	 
//	rowArray =новый COMSafeArray("VT_VARIANT",КоличествоКолонок);//Врап.СоздатьМассив("System.Object",КоличествоКолонок);
    Rows=myTable.Rows;
	Для каждого стр Из Тз Цикл
		  Row = myTable.NewRow();
		Для сч=0 По КоличествоКолонок-1 Цикл
			сообщить(стр[сч]);
		Row.set_Item(сч,стр[сч]);
		  
	  КонецЦикла;
	  
Сообщить(Row.ToString());
//Rows.Add(Row);
врап.ВыполнитьМетод(Rows,"Add",Row);


	КонецЦикла; 
	
	возврат myTable
КонецФункции 

 

В Папке Для1С лежат файлы NetObjetToIDispatch45.dll и RegAsm.bat и внешняя обработка ТестТСД.erf 
 
Скопируйте в общедоступную папку и зарегистрируйте, запустив от администратора RegAsm.bat
 
В Папке ТСДкакСканер лежат файлы ТСДкакСканер.exe и ТСДкакСканер.exe.config, их нужно скопировать на КПК, например, в Programm Files
 
Но перед тем. как копировать, измените ТСДкакСканер.exe.config
<add key="ServerName"  value="10.250.0.1" /> 
<add key="ServerPort" value="6891" /> 
 
ServerName на IpAddress компьютера, на котором будет загружаться обработка. Порт должен быть таким, как в обработке.
 
Запускаете обработку, нажимаете на кнопку Запустить, и можно обмениваться данными с ТСД, сканировать как эмулятор  клавиатуры, набирать ШК вручную.
 
Ссылки на подключение эмулятора к сети
 
Ссылка на SDK

Скачать файлы

Наименование Файл Версия Размер
ТестТСД
.zip 141,74Kb
25.05.16
7
.zip 141,74Kb 7 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Операция1Ы 53 18.05.16 20:36 Сейчас в теме
Снимаю шляпу, определенно плюс за концепцию.
2. Serginio 817 18.05.16 20:42 Сейчас в теме
3. avz_1C 10 19.05.16 13:47 Сейчас в теме
Актуально.
Плюс.
Спасибо.
4. Serginio 817 19.05.16 14:02 Сейчас в теме
5. igor_nat 07.08.16 10:33 Сейчас в теме
Очень интересная и полезная тема. Автору спасибо большое. Искал по интернету а тут есть Может есть примеры включения,отключения сканера
получение данных со сканера тсд.
различных моделей тоже будет интересно
6. Serginio 817 07.08.16 11:57 Сейчас в теме
В данном примере сканер как клавиатура. Есть модели, где есть специальное апи с событием.
В настройках для каждой модели можно настраивать, что куда и когда
7. wmonref1 15.08.17 09:46 Сейчас в теме
Сергей Смирнов, как думаете, ТСД на Windows 10 будет работать?
Спасибо!
8. Serginio 817 15.08.17 10:29 Сейчас в теме
Работает. Там внутри ТСД на WM 6 можно и к вэб сервисам подключаться и обмен по Tcp/ip.
Единственно это то, что нужно использовать для WM 6 VS 2008 и при этом нельзя пользоваться эмулятором, так как Win 10 не поддерживает Virtual PC 2007
9. wmonref1 15.08.17 16:16 Сейчас в теме
(8) А что, использование эмулятора обязательна?
10. Serginio 817 15.08.17 17:42 Сейчас в теме
Нет конечно. Ты через шнурок и мобильный центр подключаешься для отладки
Эмуляторы нужны когда девайса нет.
11. wmonref1 17.08.17 12:13 Сейчас в теме
(10) Сергей, я хочу подключиться с ТСД к серверу через РДП и сканировать ШК товаров прямо в 1С, в форме документа. Возможно ли это сделать с помощью вашей обработки?
12. Serginio 817 17.08.17 13:30 Сейчас в теме
Моя обработка нужна для работы в полу ОнЛайн.
Для РДП ничего не нужно, так как ты работаешь с удаленным экраном.
Минусы РДП, что нужен постоянный Онлайн и нужны формы учитывающие размер и с разрешение ТСД
Ну и язык C# значительно мощнее 1С
13. Xershi 958 24.12.17 18:36 Сейчас в теме
Для справки для обмена сообщениями по сети в конфигурацию придется встроить 2 компоненты?
14. Serginio 817 25.12.17 11:18 Сейчас в теме
Ну нужна только одна https://infostart.ru/public/238584/
А она уже использует любые .Net классы
Оставьте свое сообщение

См. также

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    36778    238    informa1555    200    

Работа с журналом регистрации. Выходим за границы платформы

Журнал регистрации Бесплатно (free)

Работа с журналом регистрации нестандартными средствами. А также немного про использование платформы .NET в экосистеме 1С.

12.05.2020    2944    0    YPermitin    24    

Выгрузка на терминал сбора данных по документу инвентаризации

Терминал сбора данных v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Выгрузка товаров на терминал сбора данных по конкретному документу инвентаризации товаров.

1 стартмани

09.04.2020    842    0    SpartakM    0    

Пример работы с ТСД в БП 3.0

Терминал сбора данных v8 v8::БУ БП3.0 БУ УУ Абонемент ($m)

Доработка выполнена в виде расширения конфигурации. Для работы с оборудованием использована стандартная подсистема БПО (библиотека подключаемого оборудования), существующая в конфигурации. Доработанные документы - "Отчет производства за смену" и "Реализация товаров и услуг". Отдельно в публикацию добавлена внешняя печатная форма для печати этикетки со штрихкодом

1 стартмани

11.11.2019    3792    16    maxim_kuleev    6    

ЕГАИС 3 Контролёр для 1С:Розница Промо

Терминал сбора данных Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    16997    17    kuld    30    

Расширение для обмена БГУ 2.0 и ТСД DataMobile

Терминал сбора данных v8 БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Предлагаемое расширение реализует off-line обмен между конфигурацией "Бухгалтерия государственного учреждения, ред 2.0" и терминалом сбора данных с ПО Data Mobile для проведения инвентаризации основных средств

2 стартмани

21.10.2019    3235    2    Sedaiko    7    

AllegroClient - Android - конструктор складских операций для терминалов сбора данных и смартфонов (нативное приложение на Java)

Терминал сбора данных v8 1cv8.cf Россия УУ Абонемент ($m)

AllegroСlient-android– универсальное программное обеспечение для мобильных устройств, позволяющее организовать учет на складах, в торговых залах, в магазинах с применением штрих-кодирования. Решение превращает мобильный телефон в полноценный терминал сбора данных, а так же может использоваться на любой модели терминала сбора данных с ОС Android. Программный продукт позволяет адаптировать всевозможные бизнес процессы под любые конфигурации 1С версий 8.2 и выше. Преимущественное отличие от других систем – вся разработка логики работы клиента на мобильном устройстве осуществляется на стороне 1С и не требует от программиста 1С отдельных знаний. Программа позволяет быстро настроить операции на мобильном устройстве в связке с 1С. Конструирование форм и программирование обработчиков событий осуществляется во внешней обработке, что в свою очередь не требует изменений в конфигурации 1С.

1 стартмани

01.10.2019    4662    23    allegrosoft    6    

Простой терминал сбора данных на мобильной платформе Андроид с функцией сканирования акцизных марок алкоголя

Розничная торговля Терминал сбора данных v8::Mobile Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Простая конфигурация мобильного приложения 1С: терминал сбора данных + сканирование акцизных алкомарок.

1 стартмани

18.09.2019    5244    24    independ    13    

Мобильный терминал - универсальное мобильное решение для автоматизации учета на складских предприятиях, в торговых залах и складах при магазинах с применением технологии Штрих-кодирования

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 1cv8.cf Россия УУ Абонемент ($m)

Мобильное приложение предназначено для проведения инвентаризаций, сбора заказов, проверки накладных, проверки ценников, просмотра информации об остатках и ценах на смартфоне или терминале сбора данных под управлением Android.

1 стартмани

09.09.2019    1252    3    @lexandr    7    

ERP 2.4 "Рабочее место работника склада" на ТСД + Android 7

Терминал сбора данных Рабочее место Мобильная разработка Учет ТМЦ Учет ТМЦ v8 ERP2 УУ Абонемент ($m)

Решение задачи использования терминала сбора данных в режиме онлайн при помощи типовой обработки ERP 2.4 "Рабочее место работника склада", запуском ERP на мобильном клиенте 1С. Для настройки использовался ТСД Urovo V5100 на ОС Андроид 7.

1 стартмани

07.08.2019    8330    8    chemezov    8    

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции

Терминал сбора данных Мобильная разработка Розничная торговля Розничная торговля v8::Mobile Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции на ТСД под Android. Получение данных марок (штрихкодов), используя БПО для мобильного приложения. Разработка на платформе 8.3.13.1809. Мобильная платформа 8.3.13.64. Версия сборщика 2.0.8.19.

1 стартмани

18.07.2019    5735    16    savostin.alex    5    

Складские операции на ТСД Промо

Терминал сбора данных Учет ТМЦ Учет ТМЦ v8 УУ Абонемент ($m)

Складская мобильная программа для терминалов сбора данных.

1 стартмани

15.11.2015    24213    4    JetBrain    8    

Сканирование товара в машине по заданию на перевозку

Терминал сбора данных Оптовая торговля Оптовая торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Обработка для ТСД в режиме RDP. Ищет задание по номеру машины. Сканирует штрих-кода и заполняет таблицу для контроля товара в машине.

1 стартмани

04.07.2019    3311    1    6en9er    3    

Расширение для УНФ: загрузка в документ данных взвешивания из весов

Терминал сбора данных Весы Учет ТМЦ Учет ТМЦ v8 УНФ УУ Абонемент ($m)

Универсальный драйвер к весам, который встроен в типовые конфигурации на базе БСП позволяет читать регистрации как записи терминала сбора данных, однако функционал, который позволит этот делать из формы документа в конфигурации Управление нашей фирмой отсутствует.

3 стартмани

20.06.2019    4210    1    al_zzz    0    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. Для автоматизации склада нужен только телефон

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    9930    31    informa1555    22    

AllegroClient - универсальное ПО для ТСД Промо

Терминал сбора данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

AllegroСlient – бесплатная универсальная программа для интеграции терминалов сбора данных (ТСД) Motorola, Casio и мобильных устройств на ОС Android с системой 1С. Программный продукт позволяет адаптировать всевозможные бизнес процессы под любые конфигурации 1С версий 8.2 и выше. Преимущественное отличие от других систем – вся разработка логики работы клиента на ТСД осуществляется на стороне 1С и не требует от программиста 1С отдельных знаний.Так же, программа может быть интересна, если у Вас уже есть готовое решение. Данный программный продукт можно использовать как дополнение к имеющему решению.

1 стартмани

24.02.2014    37160    70    allegrosoft    61    

Заполнение инвентаризации товаров на складе из терминала сбора данных cipherlab 8001 c с прошивкой скан сити

Обработка документов Учет ТМЦ Терминал сбора данных Учет ТМЦ v8 УПП1 УУ Абонемент ($m)

Обработка заполнения табличной части написана для конфигурации УПП 1.3 так же подойдет и для конфигурации УТ 10.1 разрабатывалась и тестировалась на платформе 1С версии 8.3.13.1644. В обработке и задаче для ТСД(терминала сбора данных) реализована возможность загрузки остатков и наименований склада который выбран в документе инвентаризация товаров.

1 стартмани

24.05.2019    4303    3    returnigor    2    

EGAIS Scan - приложение для ТСД

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 УПП1 УТ11 КА2 Россия УУ Абонемент ($m)

Каждый, кто занимается торговлей алкогольной продукцией, сталкивался с проблемами сканирования акцизных марок и трудностями при взаимодействии с учетной системой 1С. Приложение EGAIS Scan - простое и оптимальное решение для выполнения быстрой приемки и отгрузки алкогольной продукции.

1 стартмани

17.04.2019    4795    4    MrChe    2    

Обработка нажатия аппаратных кнопок на ТСД в мобильной платформе

Разработка внешних компонент Терминал сбора данных Розничная торговля Розничная торговля v8::Mobile Абонемент ($m)

Обработка и передача события нажатия аппаратных клавиш на Android в мобильную платформу 1С.

1 стартмани

11.04.2019    7476    33    dewersia    31    

Report generator 1.0 Промо

Терминал сбора данных v8 1cv8.cf УУ Абонемент ($m)

Генератор произвольных отчетов на терминале сбора данных (ТСД) на основе данных системы 1С. Отчеты формируются на основе запросов 1С. Программа работает с любыми конфигурациями 1С версии 8.2 и выше.

1 стартмани

23.04.2013    21451    1    allegrosoft    6    

Исходный код Native драйвера сканера штрихкода и терминала сбора данных через TCP VS C++ 2017

Практика программирования Сканер штрих-кода Терминал сбора данных Разработка v8 1cv8.cf Россия Абонемент ($m)

Исходный код Native драйвера 1с 8.3. Сканер штрихкода и терминала сбора данных через интернет или локальную сеть VS С++ 2017. 1с 8.3 все версии, протестирован на БП 3.0,  УТ 10.3, УТ 11, УНФ 1.6.

5 стартмани

14.03.2019    5074    10    Grigoriy251    6    

Подключение ТСД через MobileLogistics 8.Х на примере Opticon SMART и создание простого расширения для выгрузки остатков

Розничная торговля Терминал сбора данных Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

В статье рассмотрен процесс подключения терминала сбора данных в конфигурацию 1С:Розница редакции 2.2 при помощи драйвера "АТОЛ:Терминалы сбора данных MobileLogistics 8.Х" на примере ТСД Opticon SMART (CLK-3000) и написание расширения для корректной выгрузки остатков. Типовая обработка от 1С остатки не выгружает. Материал ориентирован на новичков в сфере подключения торгового оборудования / написании расширений.

1 стартмани

07.03.2019    12541    5    1c.pro.fun    14    

Мобильное приложение: Терминал сбора данных (Автоматизация работы склада в режиме он-лайн)

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ v8::Mobile ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Мобильное приложение предназначено для автоматизации работы склада в режиме он-лайн. Программа работает на ТСД (или на смартфоне) под управлением Android. Для работы необходим постоянный доступ к веб-публикации центральной базы данных через интернет.

1 стартмани

10.12.2018    13290    63    prof-it60    21    

Подключаем ТСД на android к УТ 10 по rdp

Терминал сбора данных Учет ТМЦ Учет ТМЦ v8 УТ10 Россия УУ Абонемент ($m)

Обработка для УТ 10.3 с удобным интерфейсом на ТСД honeywell eda60k. Запуск по rdp. Решаемые задачи - Информация о товаре, инвентаризация, перемещение, поступление товара.

1 стартмани

27.11.2018    11707    46    kida1    35    

Алкосфера: Транспорт штрихкодов

Терминал сбора данных v8 v8::Mobile Беларусь Латвия Россия Абонемент ($m)

Передача сканированных штрихкодов с ТСД Android на удаленный TCP сервер.

1 стартмани

02.11.2018    5347    0    Hadgehogs    2    

Терминал сбора данных (ТСД) Opticon Smart: интеграция с самописной системой 1С

Учет ТМЦ Терминал сбора данных Учет ТМЦ v8 v8::ОУ 1cv8.cf Россия УУ Абонемент ($m)

Терминал сбора данных (ТСД) Opticon Smart, интеграция с самописной конфигурацией 1С. Обработка писалась для конфигурации ТСД  "Инвентаризация с вводом данных.ctf"  (Base)

1 стартмани

10.10.2018    6312    1    Cv17    1    

1C + Arduino + сканер отпечатков пальцев + RFID считыватель

Терминал сбора данных Сервисные утилиты Учет рабочего времени Учет рабочего времени v8 1cv8.cf Абонемент ($m)

Связываем 1C, Arduino, сканер отпечатков пальцев и RFID считыватель для системы учёта рабочего времени или пропускной системы.

1 стартмани

21.08.2018    20698    14    DGorgoN    39    

Про новую Розницу и старое торговое оборудование

Сканер штрих-кода Терминал сбора данных Розничная торговля Розничная торговля v8 v8::УФ Розница Россия Абонемент ($m)

Как я подключал старенькое торговое оборудование с драйвером Атол версии 6.Х в Розницу 2.2. Может помочь при добавлении подключаемого оборудования с ДТО старых версий, снятых с поддержки производителем, и при условии того, что они есть в списке драйверов оборудования в программе.

1 стартмани

13.07.2018    6807    6    dofsh2    3    

Конфигурация-основа для мобильного приложения - сканер штрихкода (фото сканер и ТСД) + фото

Учет ТМЦ Мобильная разработка Сканер штрих-кода Терминал сбора данных Учет ТМЦ v8::Mobile 1cv8.cf УУ Абонемент ($m)

Конфигурация-основа для мобильной платформы. Работа с фотосканером (через приложение Barcode Scanner) и сервис для перехвата Broadcast со сканера штрих-кодов ТСД Теперь любой смартфон превратить в почти полноценный ТСД в вашем приложении. + По публикации https://infostart.ru/public/587908/: Service перехвата сообщений Broadcast со сканера штрих-кодов в мобильную платформу 1С (эмуляция внешнего события). Позволяет получать и обрабатывать штрих-коды не в разрыв клавиатуры (определенное активное окно), а "под капотом". Поддержка запуска/остановки из программного кода 1С.

7 стартмани

23.11.2017    33450    197    Vladimir45    145    

Обработка заполнения табличной части Материалы документа Требование-Накладная из терминала сбора данных

Учет ТМЦ Терминал сбора данных Обработка документов Учет ТМЦ v8 КА1 УТ10 УПП1 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Данная возможность не реализована в типовых 1С-конфигурациях. Предлагается лаконичное решение, с использованием возможностей другого документа (РТУ). Форма которого открывается из обработки, а затем копируется ТЧ в целевой документ ТН.

1 стартмани

05.09.2017    8345    0    ИНТЕГРА    0    

Терминал сбора данных штрихкодов на планшете Windows

Розничная торговля Терминал сбора данных Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Терминал сбора данных штрихкодов с использованием планшета WIndows и беспроводного сканера - простое решение

1 стартмани

18.08.2017    18459    24    independ    16    

Настройка торгового оборудования в разрезе пользователей 1С (ОФ)

ККМ Ридер магнитных карт Сканер штрих-кода Терминал сбора данных Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v8 КА1 БП2.0 УТ10 Розница Россия Абонемент ($m)

На моей практике появилась задача настройки ТО в разрезе пользователей 1С на сервере. Доработка позволит настроить любое оборудование из списка.

1 стартмани

11.08.2017    12994    11    sanymust    2    

Мобильное приложение для контрольно-пропускного пункта + схема работы КПП

Терминал сбора данных Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Решение позволяет на посту выезда из оптовой базы (магазина) контролировать идентичность данных товарного чека (накладной) и данных соответствующей накладной в ИБ организации. Для исключения подделок чеков и контроля ассортимента и количества вывозимого товара. Мобильная часть решения написана под терминалы сбора данных на Android. Транспорт данных - POST - запрос на HTTP сервис. Серверная часть - сервис на базе 1с сервера.

2 стартмани

19.05.2017    12631    3    Prometeus2011    11    

Управление лазерным сканером ТСД Lanchang на Android

Разработка внешних компонент Мобильная разработка Терминал сбора данных v8::Mobile Абонемент ($m)

"Дорожная карта" для желающих расширить свой опыт в сторону программирования под Android NDK&SDK с целью создания внешних компонент для мобильных приложений 1С. Представлена внешняя компонента автора для управления лазерным сканером фирмы Lanchang - U8000S.

10 стартмани

10.03.2017    16900    8    IgorKissil    7    

Android cервис для передачи штрихкода в мобильное приложение 1С

Сканер штрих-кода Терминал сбора данных Розничная торговля Розничная торговля v8::Mobile 1cv8.cf Россия УУ Абонемент ($m)

Приложение android (сервис), реализованное для перехвата события считывания штрихкода и передачи события в мобильное приложение 1С.

1 стартмани

23.01.2017    25960    70    Meteorage    35    

Инсталлятор обработок 1С 8.3, 8.2, 8.1, 7.7 для загрузки документов 1С с весовых терминалов сбора данных (весов) МАССА-К серии R

Терминал сбора данных Весы Розничная торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md УУ Абонемент ($m)

Набор внешних обработок 1С 8.3, 8.2, 8.1, 7.7. для загрузки новых документов 1С сразу из весов МАССА-К от 6 кг до 6 тонн. Из весов можно выгрузить 7 типов документов: поступление, перемещение, реализация, списание, инвентаризация, продажа и возврат. Гибкие настройки обработок под любую конфигурацию. Встроенный редактор для этикеток любого дизайна с ШК 7 форматов: ЕАN13, ЕАN13+5, Interleaved 2of5, ITF-14, Code39, Code128, ЕАN128.

1 стартмани

27.12.2016    14946    5    Boorkov    0    

Выгрузка весового товара в терминал сбора данных (ТСД) для УТ 11.2.3.195 и выше

Терминал сбора данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Россия УУ Абонемент ($m)

С версии УТ 11.2.3.195 перестал работать отбор весового товара для выгрузки в ТСД. Данная внешняя обработка исправляет этот недочёт типовой конфигурации.

1 стартмани

08.11.2016    11889    3    user618695_ka    2    

Обмен данными ТСД: Далион Мобильное рабочее место и УТ 10.3

Терминал сбора данных Внешние источники данных Оптовая торговля Оптовая торговля v8 УТ10 Абонемент ($m)

Обработка по обмену данными между Конфигурацией УТ 10.3 и ТСД Далион: Мобильное рабочее место. Создана на основе обработки от Атол.

1 стартмани

06.09.2016    13677    3    olegmedvedev    1    

Подключение Opticon smart clk-3001 к УТ 10.3

Терминал сбора данных Розничная торговля Розничная торговля v8 УТ10 Россия Абонемент ($m)

Изменена стандартная обработка обслуживания ТСД opticon smart clk-3001, которая неправильно загружала подсчитанный товар.

1 стартмани

29.06.2016    33927    48    Timur001    8    

Обработка обслуживания ТО ТСД с ПО Goods

Терминал сбора данных Розничная торговля Розничная торговля v8 УТ10 Розница Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Данная обработка служит для работы с терминалами сбора данных, с установленных на них ПО "Goods". В частности, это обработка обслуживания ТО для терминала Casio DT-900 с прошивкой от ГЕКСАГОН

1 стартмани

04.05.2016    15199    13    ПерваяСистема    4    

Работа с ТСД Opticon 1005

Терминал сбора данных Розничная торговля Розничная торговля v8 Розница Казахстан Абонемент ($m)

Самописная прошивка и обработка для работы с ТСД Opticon 1005. Сделал для "Розница 1.0" В принципе, возможна доработка и использование в других конфигурациях

2 стартмани

24.03.2016    13747    6    talych    5    

CipherLab 8000/8100/8200/8300 для Розница 2.1

Терминал сбора данных v8 УТ10 Розница Абонемент ($m)

Универсальный механизм для загрузки и выгрузке данных с ТСД CipherLab 8000/8100/8200/8300 для Розница 2.1. Штатный механизм для ТСД CipherLab - не работает вплоть до новой версии 1С Розницы.

1 стартмани

21.11.2015    37268    56    maksa2005    40    

Загрузка данных из терминала сбора данных с ПО Goods любой версии

Обработка документов Терминал сбора данных Розничная торговля Розничная торговля v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Внешняя обработка для загрузки данных из терминала сбора данных с предустановленным программным обеспечением Goods любой версии.

1 стартмани

12.09.2015    14546    12    seva1405    1    

Терминал сбора данных, на основе андроид смартфона и сканера штрих-кода

Терминал сбора данных Розничная торговля Розничная торговля v8 УТ10 Абонемент ($m)

SAM-TSD Это Терминал сбора данных, на основе андроид смартфона и сканера штрих-кода, это самое бюджетное устройство для проведения складских операций. В ТСД загружается информация о товаре из товароучетных программ "1с Управление торговлей" и "Штрих-м Торговое предприятие 4.х".

1 стартмани

12.09.2015    23086    14    vitnaut    33