Скрипт автообновления типовых конфигураций

Публикация № 519499

Разработка - Практика программирования

Автообновление OneScript

Батник на "языке 1С" для клиент серверных баз, скачивает с сайта ИТС нужное обновление, бекапит базу и обновляет. На что-то новое не претендует, как рабочая заготовка для собственных "обновляторов" подойдет. В текущем виде все работает. Надо только занести свои переменные.

Химера из двух работ

Скрипт для автоматического обновления баз 1С (загрузка с сайта, применение и др)

//catalog.mista.ru/public/241253/

И

Как решать повседневные задачи с помощью OneScript

//catalog.mista.ru/public/327581/


----
В итоге Батник на "языке 1С" для клиент серверных баз, скачивает с сайта ИТС нужное обновление, бекапит базу и обновляет. Подойдет как рабочая заготовка для собственных "обновляторов". В текущем виде все работает. Надо только занести свои переменные.
 

// 	Путь к обновлениям
Перем мРасположениеОбновлений;

//Параметры для подключения к серверу обновления 1С
Перем мИтсЛогин;
Перем мИтсПароль;

//****
Перем home;
Перем DumpIB;

Перем ФайлСписокОбновленийZIP;
Перем ФайлСписокОбновленийXML;

Перем КодВозврата;

// Проверка существования файла или каталога.
//
// Параметр:
//  ПутьКФайлу   - Строка - путь к файлу или каталогу, существование которого
//                 нужно проверить.
//
// Возвращаемое значение:
//  Булево - признак существования файла или каталога.
//
Функция ФайлСуществует(Знач ПутьКФайлу) Экспорт
	
	Файл = Новый Файл(ПутьКФайлу);
	Возврат Файл.Существует();
	
КонецФункции 

Процедура УстановитьКонстанты()
	каталог_tmplts = "D:\tmplts";
 	мИтсЛогин = "---";
	мИтсПароль = "---";
	
	//**Ниже можно не менять.
	мРасположениеОбновлений = каталог_tmplts + "\1c";
	home = каталог_tmplts + "\1Cupdate";
	DumpIB = home + "\DumpIB\";
	ФайлСписокОбновленийXML = home + "\v8cscdsc.xml";
	ФайлСписокОбновленийZIP = home + "\v8upd11.zip";
	
	Если НЕ ФайлСуществует(home) Тогда
		СоздатьКаталог(home); 
	КонецЕсли;
	
	Если НЕ ФайлСуществует(DumpIB) Тогда
		СоздатьКаталог(DumpIB); 
	КонецЕсли;
	
	Если НЕ ФайлСуществует(мРасположениеОбновлений) Тогда
		СоздатьКаталог(мРасположениеОбновлений); 
	КонецЕсли;

КонецПроцедуры

Функция ВернутьРелизИПлатформу(мИмяСервера,мИмяБазы,мВерсияПлатформы,мБазаЛогин,мБазаПароль)

   ПараметрыБазы = Неопределено;
 
   Попытка
        //Создаем COM-объект с идентификатором V82.COMConnector
        COMОбъект = Новый COMОбъект("V"+мВерсияПлатформы+".COMConnector");   //выйдет V82.COMConnector
   Исключение
        Сообщить("Не удалось создать COM-объект!");    
        Возврат ПараметрыБазы;
   КонецПопытки; 

    ПутьКБазе = "srvr="""+ СокрЛП(мИмяСервера) +""";" + "ref=""" + СокрЛП(мИмяБазы)  +""";";    

	СтрокаСоединения = ПутьКБазе + "Usr="""+ СокрЛП(мБазаЛогин) +""";" + "Pwd="""+ СокрЛП(мБазаПароль) + """;";    
 
	 Попытка
        //Устанавливаем внешнее соединение с информационной базой через COM-соединение
        V82 = COMОбъект.Connect(СтрокаСоединения);
    Исключение
    	Сообщить(СтрокаСоединения);
        Сообщить("Внешнее соединение не установлено!");    
        Возврат ПараметрыБазы;
    КонецПопытки;

	 ПараметрыБазы = Новый Структура;
	 ПараметрыБазы.Вставить("ТекущаяВерсия", v82.Метаданные.Версия);
	 ПараметрыБазы.Вставить("ПутьКПлатформе",v82.КаталогПрограммы() + "1cv8.exe");

	 Возврат ПараметрыБазы;
КонецФункции

Процедура УстановитьCOMСоединение(мИмяСервера,мИмяБазы,мВерсияПлатформы,мБазаЛогин,мБазаПароль) 
   Попытка
        //Создаем COM-объект с идентификатором V82.COMConnector
        COMОбъект = Новый COMОбъект("V"+мВерсияПлатформы+".COMConnector");   //выйдет V82.COMConnector
   Исключение
        Сообщить("Не удалось создать COM-объект!");    
        Возврат;
   КонецПопытки; 

    //Инициализируем строку подключения к информационной базе:    
 //   Если ФайловаяИБ Тогда
        //Файловый вариант 
   //     ПутьКБазе = "File="""+ СокрЛП(КаталогИБ) +""";";
//    Иначе
        //Серверных вариант    
        ПутьКБазе = "srvr="""+ СокрЛП(мИмяСервера) +""";"+
               "ref=""" + СокрЛП(мИмяБазы)  +""";";    
//    КонецЕсли;
                
    СтрокаСоединения = ПутьКБазе +
            "Usr="""+ СокрЛП(мБазаЛогин) +""";"+
            "Pwd="""+ СокрЛП(мБазаПароль) +""";";    
        Сообщить(СтрокаСоединения);         
    Попытка
        //Устанавливаем внешнее соединение с информационной базой через COM-соединение
        V82 = COMОбъект.Connect(СтрокаСоединения);
    Исключение
    	Сообщить(СтрокаСоединения);
        Сообщить("Внешнее соединение не установлено!");    
        Возврат;
    КонецПопытки;
             
КонецПроцедуры

		
		
		
// Загрузка списка обновлений из файла XML
// Достаем из XML файла, наибольший номер возможного обновления
Функция ВыполнитьЗагрузкуСпискаОбновлений(ИмяФайлаЗагрузки,ТекущаяВерсияКонфигурации)
	
	СообщениеОбОшибке = "Ошибка при чтении файла списка обновлений.";
	
	Если НЕ ФайлСуществует(ИмяФайлаЗагрузки) Тогда
		Сообщить("Нету XML файла (списка обновлений)");
		Возврат Неопределено;
	КонецЕсли;
	
	ВерсияДляОбновления = Неопределено;
	Попытка
//		ТаблицаЗначений = Новый ТаблицаЗначений;		
//		ТаблицаЗначений.Колонки.Добавить("Конфигурация",          Тип("Строка"));
//		ТаблицаЗначений.Колонки.Добавить("Поставщик",             Тип("Строка"));
//		ТаблицаЗначений.Колонки.Добавить("Версия",                Тип("Строка"));
//		ТаблицаЗначений.Колонки.Добавить("ВерсияДляОбновления",   Тип("Строка"));
//		ТаблицаЗначений.Колонки.Добавить("ПутьКФайлуОбновления",  Тип("Строка"));
//		ТаблицаЗначений.Колонки.Добавить("РазмерФайлаОбновления", Тип("Число"));
		
		ЧтениеXML = Новый ЧтениеXML;
		ЧтениеXML.ОткрытьФайл(ИмяФайлаЗагрузки);
		ЧтениеXML.Прочитать(); // <?xml version="1.0" encoding="UTF-8" ?> 
		
		// Дата формирования файла.
		ЧтениеXML.Прочитать();
		ЧтениеXML.Прочитать();
		ДатаФормирования = ЧтениеXML.Значение;
		ЧтениеXML.Прочитать();
		// Читаем начало элемента Update или конец элемента UpdateList.
		Пока ЧтениеXML.Прочитать() Цикл
			
			Если ЧтениеXML.Имя = "v8u:updateList" Тогда
				Прервать;					
			Иначе		
				
				Конфигурация = ЧтениеXML.ПолучитьАтрибут("configuration");
				
				Пока ЧтениеXML.Прочитать() Цикл
					
					Если ЧтениеXML.Имя = "v8u:update" Тогда
						Прервать;					
					Иначе		
						
						Если ЧтениеXML.Имя = "v8u:vendor" Тогда
							ЧтениеXML.Прочитать();
							Поставщик = ЧтениеXML.Значение;							
						ИначеЕсли ЧтениеXML.Имя = "v8u:version" Тогда
							ЧтениеXML.Прочитать();
							Версия = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:file" Тогда
							ЧтениеXML.Прочитать();
							ПутьКФайлуОбновления = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:size" Тогда
							ЧтениеXML.Прочитать();
							РазмерФайлаОбновления = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:target" Тогда
							ЧтениеXML.Прочитать();
						//	НоваяСтрока = ТаблицаЗначений.Добавить();
						//	НоваяСтрока.Конфигурация          = Конфигурация;
						//	НоваяСтрока.Поставщик             = Поставщик;
						//	НоваяСтрока.Версия                = Версия;
						//	НоваяСтрока.ВерсияДляОбновления	  = ЧтениеXML.Значение;
						//	НоваяСтрока.ПутьКФайлуОбновления  = ПутьКФайлуОбновления;
						//	НоваяСтрока.РазмерФайлаОбновления = РазмерФайлаОбновления;
							Если ЧтениеXML.Значение = ТекущаяВерсияКонфигурации Тогда   //279 Новые в конце. на последнюю полученную и будем обновяться
								ВерсияДляОбновления = Версия;
							КонецЕсли;
						КонецЕсли;
						
						ЧтениеXML.Прочитать();
						
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		КонецЦикла;
		
	Исключение
		Сообщить(СообщениеОбОшибке);
		ЧтениеXML.Закрыть();
		Возврат Неопределено;
		
	КонецПопытки;
	//Возврат ТаблицаЗначений;	
	ЧтениеXML.Закрыть();
	Возврат ВерсияДляОбновления;
	
КонецФункции // ВыполнитьЗагрузкуСпискаОбновлений()


//Входящие Сервер - База - ТипКонфигурации - ВерсияРелиза - ВерсияПлатформы-ИТС логин и пароль необязательно
Процедура ПроверитьОбновлениеКонфигурации(мИмяСервера,мИмяБазы,мТипКонфигурации,мВерсияРелиза,мВерсияПлатформы,мБазаЛогин,мБазаПароль)	
	Сообщить("----------------------------------------------------------------------");
	//удалить старые файлы
	УдалитьФайлы(ФайлСписокОбновленийXML);
	УдалитьФайлы(ФайлСписокОбновленийZIP);	

	// Качаем v8cscdsc.xml в виде v8upd11.zip	
	// Создание HTTP-соединения с сервером обновлений
	СерверОбновлений = Новый HTTPСоединение("downloads.1c.ru",,мИтсЛогин,мИтсПароль,);
	ЗапросКСерверуОбновлений = Новый HTTPЗапрос("/ipp/ITSREPV/V8Update/Configs/"+мТипКонфигурации+"/"+мВерсияРелиза+"/"+мВерсияПлатформы+"/v8upd11.zip");
	СерверОбновлений.Получить(ЗапросКСерверуОбновлений,ФайлСписокОбновленийZIP);

	// Распаковываем v8cscdsc.xml
	ФайлZip = Новый ЧтениеZipФайла(ФайлСписокОбновленийZIP); 
	ФайлZip.ИзвлечьВсе(home);
	ФайлZip.Закрыть();
	УдалитьФайлы(ФайлСписокОбновленийZIP);
	
	//+++++ Запрос версии конфигурации базы...
		ПараметрыComБазы = ВернутьРелизИПлатформу(мИмяСервера,мИмяБазы,мВерсияПлатформы,мБазаЛогин,мБазаПароль);
		
		Если ПараметрыComБазы = Неопределено Тогда 
			Возврат; 
		КонецЕсли;
		ВерсияДляОбновления = ВыполнитьЗагрузкуСпискаОбновлений(ФайлСписокОбновленийXML,ПараметрыComБазы.ТекущаяВерсия);
		ТребуетсяОбновление = Ложь;
		Если ВерсияДляОбновления = Неопределено Тогда 
			Сообщить(мИмяБазы + " ver: " +ПараметрыComБазы.ТекущаяВерсия+ " ОБНОВЛЕНИЕ НЕ ТРЕБУЕТСЯ");
			Возврат;
		КонецЕсли;
		Сообщить(мИмяБазы + " ver: " +ПараметрыComБазы.ТекущаяВерсия+ " update: " + ВерсияДляОбновления);
	//----- Запрос версии конфигурации базы...
	
	КомандаПакетногоАрхивирования = """" + ПараметрыComБазы.ПутьКПлатформе +""""+" CONFIG /S"+мИмяСервера+"\"+мИмяБазы+" /N"""+мБазаЛогин+""" /P"""+мБазаПароль+""" /DumpIB "+DumpIB + мИмяБазы + ".dt /OUT """+home+"\"+мИмяБазы+".log"" -NoTruncate";
	//NoTruncate - не очищать логи 
	//Сообщить(КомандаПакетногоАрхивирования);
	ЗапуститьПриложение(КомандаПакетногоАрхивирования,,Истина,КодВозврата);
	Если КодВозврата = 0  Тогда
		Сообщить("Резервная копия успешно создана.");
	Иначе
		Сообщить("Ошибка при создании резервной копии");
		Возврат;
	КонецЕсли;
	
	Версия_Для_Обновления = СтрЗаменить(ВерсияДляОбновления, ".", "_"); //в каталоге шаблонов через подчеркивание храняться

	//качаем новую версию, если уже не скачено
	Если НЕ ФайлСуществует(мРасположениеОбновлений +"\"+мТипКонфигурации+"\"+Версия_Для_Обновления+"\") Тогда
		//качаем новую
		// Создание HTTP-соединения с сервером обновлений
	    Заголовки = Новый Соответствие();
	    Заголовки.Вставить("User-Agent", "1C+Enterprise/8.2");     //без заголовка сайт не даст скачать.
		СерверОбновлений = Новый HTTPСоединение("downloads.v8.1c.ru",,мИтсЛогин,мИтсПароль,);
		СтрокаЗапросHTTP = "/tmplts/1c/"+мТипКонфигурации+"/"+ Версия_Для_Обновления +"/1cv8.zip";
		Сообщить(СтрокаЗапросHTTP);
		ЗапросКСерверуОбновлений = Новый HTTPЗапрос(СтрокаЗапросHTTP,Заголовки);
		СерверОбновлений.Получить(ЗапросКСерверуОбновлений, мРасположениеОбновлений+"\1cv8.zip");
		
		ФайлZip = Новый ЧтениеZipФайла(мРасположениеОбновлений+"\1cv8.zip"); 
		ФайлZip.ИзвлечьВсе(мРасположениеОбновлений+"\"+мТипКонфигурации+"\"+Версия_Для_Обновления);
		ФайлZip.Закрыть();
		
		УдалитьФайлы(мРасположениеОбновлений+"\1cv8.zip");
	КонецЕсли;
	//запускаем обновление                                                                                                                                                              
	КомандаПакетногоОбновления = """" + ПараметрыComБазы.ПутьКПлатформе +""""+" CONFIG /S"+мИмяСервера+"\"+мИмяБазы+" /N"""+мБазаЛогин+""" /P"""+мБазаПароль+""" /UpdateCfg "+мРасположениеОбновлений+"\"+мТипКонфигурации+"\"+Версия_Для_Обновления + "\1cv8.cfu /UpdateDBCfg /OUT """+home+"\"+мИмяБазы+".log"" -NoTruncate";
	//Сообщить(КомандаПакетногоОбновления);
	ЗапуститьПриложение(КомандаПакетногоОбновления,,Истина,КодВозврата);
	Если КодВозврата = 0 Тогда
		Сообщить("База Успешно обновлена");
	Иначе
		Сообщить("ОШИБКА ПРИ ОБНОВЛЕНИИ");
		Возврат;
	КонецЕсли;
	
	//Еще разок запрос версии
	//+++++ Запрос версии конфигурации базы...
		ПараметрыComБазы = ВернутьРелизИПлатформу(мИмяСервера,мИмяБазы,мВерсияПлатформы,мБазаЛогин,мБазаПароль);
		
		Если ПараметрыComБазы = Неопределено Тогда 
			Возврат; 
		КонецЕсли;
		ВерсияДляОбновления = ВыполнитьЗагрузкуСпискаОбновлений(ФайлСписокОбновленийXML,ПараметрыComБазы.ТекущаяВерсия);
		ТребуетсяОбновление = Ложь;
		Если ВерсияДляОбновления = Неопределено Тогда 
			Сообщить(мИмяБазы + " ver: " +ПараметрыComБазы.ТекущаяВерсия+ " ОБНОВЛЕНИЕ НЕ ТРЕБУЕТСЯ");
			Возврат;
		КонецЕсли;
		Сообщить(мИмяБазы + " ver: " +ПараметрыComБазы.ТекущаяВерсия+ " update: " + ВерсияДляОбновления);
	//----- Запрос версии конфигурации базы...

КонецПроцедуры
		
УстановитьКонстанты();
//ОСНОВНЫЕ

//ЗУП 2.5
ПроверитьОбновлениеКонфигурации("ka1sql1:1641","up_el","HRM","25","82","Администратор","Администратор");
ПроверитьОбновлениеКонфигурации("ka1sql1:1641","up_spb","HRM","25","82","Администратор","Администратор");


//БП 3.0
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_domx","Accounting","30","83","Администратор","Администратор");
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_el","Accounting","30","83","Администратор","Администратор");

//СВЕТЛАНЫ
//БП 3.0
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_ip","Accounting","30","83","Администратор","Администратор");
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_guild","Accounting","30","83","Администратор","Администратор");
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_lebedeva","Accounting","30","83","Администратор","Администратор");
//ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_service","AccountingBase","30","83","Администратор","Администратор");
ПроверитьОбновлениеКонфигурации("ka1sql1:1741","bp_porsche","Accounting","30","83","Администратор","Администратор");

//ЗУП 2.5
ПроверитьОбновлениеКонфигурации("ka1sql1:1641","up_service","HRM","25","82","Администратор","Администратор");

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Vovan1975 13 07.07.16 10:35 Сейчас в теме
2. sergey279 79 07.07.16 10:57 Сейчас в теме
(1) Vovan1975, "самозанятый" бухгалтер, повышенной производительности =)
3. Seregio22 07.07.16 13:54 Сейчас в теме
{Форма.Форма.Форма(261)}: Ошибка при вызове конструктора (ЧтениеZipФайла)
ФайлZip = Новый ЧтениеZipФайла(ФайлСписокОбновленийZIP);
по причине:
Некорректный формат файла: ...\1Cupdate\v8upd11.zip

Скаченный файл (1 кб) имеет следующий текст:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /tmplts/ipp/ITSREPV/V8Update/Configs/HRM/25/82/v8upd11.zip was not found on this server.</p>
</body></html>
4. sergey279 79 07.07.16 16:45 Сейчас в теме
(3) Seregio22, щас попробую потестить без паролей и с заблоченым сервером обновлений.
так то пишет что zip распокавать не выходит т.к. не скачался.
5. Seregio22 07.07.16 16:55 Сейчас в теме
(4)
дописал строки ниже так:
//НЕ СКАЧИВАЕТСЯ. ЭТО АЛЬТЕРНАТИВА
СерверОбновлений = Новый HTTPСоединение("downloads.1c.ru");
ЗапросКСерверуОбновлений = Новый HTTPЗапрос("ipp/ITSREPV/V8Update/Configs/"+мТипКонфигурации+"/"+мВерсия­Релиза+"/"+мВерсияПлатформы+"/v8upd11.zip");
СерверОбновлений.Получить(ЗапросКСерверуОбновлений,ФайлСписокОбновленийZIP);

вроде есть контакт :)
8. sergey279 79 07.07.16 17:37 Сейчас в теме
(5) Seregio22, спс, тоже отловил . в OneScript и с "/tmplts" работает, видать просто игнорирует.
а в 1с хоть в отладчике и игнорирует (видно сервер соединения только "downloads.1c.ru") ,а отрабатывает как будто с этим излишком.

СерверОбновлений = Новый HTTPСоединение("downloads.1c.ru",,мИтсЛогин,мИтсПароль,);
//было СерверОбновлений = Новый HTTPСоединение("downloads.1c.ru/tmplts",,мИтсЛогин,мИтсПароль,);

в тексте сейчас исправлю, благодарю.
6. sergey279 79 07.07.16 16:57 Сейчас в теме
(4) без всяких паролей наличие номера новых релизов должно скачивать.
щас проверю засунув в форму 1с . сам текст под OneScript использую.
7. LavinVadik 128 07.07.16 17:33 Сейчас в теме
идея хороша.но имхо утопия.
9. Drak0n 170 08.07.16 10:29 Сейчас в теме
Объединил текст из данной публикации со своим. Из основных отличий:
1. Загрузка списка обновлений 1 раз для семейства
2. Обновление через несколько релизов
3. Преимущественное обновление на уже скачанные релизы
4. Ну и по мелочи
Получилось вот что:

PS Если автор не против могу выложить отдельной темой

Перем КаталогВременныхФайлов;

Перем НастройкаСоединения;
Перем ПараметрыОбновления;
Перем ПараметрыПротоколирования;

Перем КодВозврата;

// Устанавливает значение констант.
//
// Возвращаемое значение:
//  Булево - признак успешной установки.
//
Функция УстановитьКонстанты()
    
    НастройкаСоединения = Новый Структура();
    НастройкаСоединения.Вставить("Пользователь", "---");
    НастройкаСоединения.Вставить("Пароль",       "---");
    
    Каталог_tmplts = "\\server\H\Дистрибутивы\Конфигурация";
    
    КаталогВременныхФайлов = Каталог_tmplts + "\1Cv8Update"; 
    Если НЕ ПроверитьСоздатьКаталог(КаталогВременныхФайлов) Тогда Возврат Ложь; КонецЕсли;
    
    ПараметрыПротоколирования = Новый Структура();
    ПараметрыПротоколирования.Вставить("КаталогФайловЛогов", КаталогВременныхФайлов + "\Logs");
    Если НЕ ПроверитьСоздатьКаталог(ПараметрыПротоколирования.КаталогФайловЛогов) Тогда Возврат Ложь; КонецЕсли;
    ПараметрыПротоколирования.Вставить("КаталогФайловДампа", КаталогВременныхФайлов + "\DumpIB");
    Если НЕ ПроверитьСоздатьКаталог(ПараметрыПротоколирования.КаталогФайловДампа) Тогда Возврат Ложь; КонецЕсли;
    
    ПараметрыОбновления = Новый Структура();
    ПараметрыОбновления.Вставить("ИмяZipФайлаСпискаШаблонов", "v8upd11.zip");
    ПараметрыОбновления.Вставить("ИмяZipФайлаОбновления"   , "1cv8.zip");
    ПараметрыОбновления.Вставить("КаталогФайловОбновления"    , каталог_tmplts + "\1C"); 
    Если НЕ ПроверитьСоздатьКаталог(ПараметрыОбновления.КаталогФайловОбновления) Тогда Возврат Ложь; КонецЕсли;
    
    Возврат Истина;
    
КонецФункции

// Скачивает из Интернета списки обновлений.
//
// Параметры:
//  ТипКонфигурации - Строка - Краткое наименование конфигурации;
//  ВерсияРелиза    - Строка - Версия релиза;
//  ВерсияПлатформы - Строка - Версия платформы: 82; 83.
//
// Возвращаемое значение:
//  Булево - признак успешного получения.
//
Функция ПолучитьСпискиОбновлений(ТипКонфигурации, ВерсияРелиза, ВерсияПлатформы = "83") 
    
    Сообщить("----------------------------------------------------------------------");
    Сообщить(СтрШаблон(НСтр("ru = 'Конфигурация %1, релиз %2, платформа %3.'"), 
        ТипКонфигурации, ВерсияРелиза, ВерсияПлатформы));     
    
    СообщитьПользователю(НСтр("ru = 'Получение списков обновления.'"));   
    
    // Очищаем устаревшие файлы
    ZipФайлСпискаШаблонов = КаталогВременныхФайлов + ПараметрыОбновления.ИмяZipФайлаСпискаШаблонов; 
    Попытка
        УдалитьФайлы(ZipФайлСпискаШаблонов);    
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось удалить временный файл %1:
            |%2'"), ZipФайлСпискаШаблонов, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    ФайлСпискаШаблонов = КаталогВременныхФайлов + "\v8cscdsc.xml"; 
    Попытка
        УдалитьФайлы(ФайлСпискаШаблонов);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось удалить временный файл %1:
            |%2'"), ФайлСпискаШаблонов, ИнформацияОбОшибке()));
    КонецПопытки;
    
    // Получаем сам файл из Интернета.
    Попытка
        Соединение = Новый HTTPСоединение("downloads.1c.ru", , НастройкаСоединения.Пользователь, НастройкаСоединения.Пароль,);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось установить HTTP-соединение с сервером downloads.1c.ru:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    Попытка
        HTTPЗапрос = Новый HTTPЗапрос(СтрШаблон("/ipp/ITSREPV/V8Update/Configs/%1/%2/%3/v8upd11.zip", ТипКонфигурации, ВерсияРелиза, ВерсияПлатформы));
        Соединение.Получить(HTTPЗапрос, ZipФайлСпискаШаблонов);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось получить файл с сервера downloads.1c.ru:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    // Распаковываем файл
    Попытка
        ФайлZip = Новый ЧтениеZipФайла(ZipФайлСпискаШаблонов); 
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось прочесть архив %1:
            |%2'"), ZipФайлСпискаШаблонов, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    ФайлZip.ИзвлечьВсе(КаталогВременныхФайлов);
    ФайлZip.Закрыть();
    
    Попытка
        УдалитьФайлы(ZipФайлСпискаШаблонов);    
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось удалить временный файл %1:
            |%2'"), ZipФайлСпискаШаблонов, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    ФайлСпискаШаблоновОбъект = Новый Файл(ФайлСпискаШаблонов);
    Если НЕ ФайлСпискаШаблоновОбъект.Существует() Тогда    
        СообщитьПользователю(НСтр("ru = 'XML файл списка шаблонов не найден в каталоге.'"));
        Возврат Ложь;
    КонецЕсли;
    
    СообщитьПользователю(НСтр("ru = 'Списки обновления успешно получены.'"));
    
    Возврат Истина;
    
КонецФункции

// Обновляет информационную базу.
// 
// Параметры:
//  ТипКонфигурации                          - Строка - Краткое наименование конфигурации
//  ВариантРаботыИнформационнойБазы             - Число  - Вариант работы информационной базы: 0 - файловый; 1 -
//                                                             клиент-серверный;
//  КаталогИнформационнойБазы                   - Строка - Каталог информационной базы для файлового режима работы;
//  ИмяСервера1СПредприятия                     - Строка - Имя сервера1С:Предприятия;
//  ИмяИнформационнойБазыНаСервере1СПредприятия - Строка - Имя информационной базы на сервере1С:Предприятия;
//  АутентификацияОперационнойСистемы           - Булево - Признак аутентификации операционной системы при создании
//                                                             внешнего подключения к информационной базе;
//  ИмяПользователя                             - Строка - Имя пользователя информационной базы;
//  ПарольПользователя                          - Строка - Пароль пользователя информационной базы.
//  ВерсияПлатформы                              - Строка - Версия платформы: 82; 83;
// 
Процедура ПроверитьОбновлениеКонфигурации(ТипКонфигурации,
                                        ВариантРаботыИнформационнойБазы = 0,
                                        КаталогИнформационнойБазы = "",
                                        ИмяСервера1СПредприятия = "",
                                        ИмяИнформационнойБазыНаСервере1СПредприятия = "",
                                        АутентификацияОперационнойСистемы = Ложь,
                                        ИмяПользователя = "",
                                        ПарольПользователя = "",
                                        ВерсияПлатформы = "83")
    
    Сообщить("----------------------------------------------------------------------");
    Сообщить(СтрШаблон(НСтр("ru = 'Информационная база %1.'"), 
        ?(ВариантРаботыИнформационнойБазы = 0, КаталогИнформационнойБазы, ИмяИнформационнойБазыНаСервере1СПредприятия)));
    
    ПараметрыПодключения = Новый Структура;
    ПараметрыПодключения.Вставить("ВерсияПлатформы", ВерсияПлатформы);
    ПараметрыПодключения.Вставить("ВариантРаботыИнформационнойБазы", ВариантРаботыИнформационнойБазы);
    ПараметрыПодключения.Вставить("КаталогИнформационнойБазы", КаталогИнформационнойБазы);
    ПараметрыПодключения.Вставить("ИмяСервера1СПредприятия", ИмяСервера1СПредприятия);
    ПараметрыПодключения.Вставить("ИмяИнформационнойБазыНаСервере1СПредприятия", ИмяИнформационнойБазыНаСервере1СПредприятия);
    ПараметрыПодключения.Вставить("АутентификацияОперационнойСистемы", АутентификацияОперационнойСистемы);
    ПараметрыПодключения.Вставить("ИмяПользователя", ИмяПользователя);
    ПараметрыПодключения.Вставить("ПарольПользователя", ПарольПользователя);
    
    СтрокаСоединения = ПолучитьСтрокуСоединения(ПараметрыПодключения);
    
    Пока Истина Цикл
        ИмяВременногоФайла = "Base" + Формат(ТекущаяДата(), "ДФ=ггММддЧЧммсс");        
        СтрокаДампа = """" + ПараметрыПротоколирования.КаталогФайловДампа + "\" + ИмяВременногоФайла + ".dt""";
        СтрокаЛогов = """" + ПараметрыПротоколирования.КаталогФайловЛогов + "\" + ИмяВременногоФайла + ".log""";
        
        // Получение параметров информационной базы
        Соединение = УстановитьВнешнееСоединениеСБазой(ПараметрыПодключения);   
        Если Соединение = Неопределено Тогда
            Возврат;
        КонецЕсли;     
        ПараметрыComБазы = Новый Структура;
        ПараметрыComБазы.Вставить("ТекущаяВерсия", Соединение.Метаданные.Версия);
        ПараметрыComБазы.Вставить("ПутьКПлатформе",Соединение.КаталогПрограммы() + "1cv8.exe");
        Соединение = Неопределено;
        
        // Прверка наличия обновлений
        МассивОбновлений = ВыполнитьЗагрузкуСпискаОбновлений(ПараметрыComБазы.ТекущаяВерсия);
        Если МассивОбновлений = Неопределено Тогда 
            Возврат;
        КонецЕсли;     
        
        КоличествоДоступныхОбновлений = МассивОбновлений.Количество(); 
        Если КоличествоДоступныхОбновлений = 0 Тогда
            СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Обновление не требуется.'"), ПараметрыComБазы.ТекущаяВерсия));
            Прервать;
        КонецЕсли;
        
        ЗагруженноеОбновлениеНайдено = Ложь;
        Для Сч = 1 По КоличествоДоступныхОбновлений Цикл
            ВерсияДляОбновления = МассивОбновлений[КоличествоДоступныхОбновлений - Сч]; 
            ФайлОбновленияВерсии = СтрШаблон("%1\%2\%3\1cv8.cfu", ПараметрыОбновления.КаталогФайловОбновления, ТипКонфигурации, ВерсияДляОбновления.Версия);
            ФайлОбновленияВерсииОбъект = Новый Файл(ФайлОбновленияВерсии);
            Если ФайлОбновленияВерсииОбъект.Существует() Тогда
                ЗагруженноеОбновлениеНайдено = Истина;
                СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Доступна для обновления версия: %2.'"), 
                    ПараметрыComБазы.ТекущаяВерсия, ВерсияДляОбновления.Версия));
                Прервать;
            КонецЕсли;
        КонецЦикла;
        
        // Загрузка файлов обновления
        Если Не ЗагруженноеОбновлениеНайдено Тогда
            ВерсияДляОбновления = МассивОбновлений[КоличествоДоступныхОбновлений - 1]; 
            ФайлОбновленияВерсии = СтрШаблон("%1\%2\%3\1cv8.cfu", ПараметрыОбновления.КаталогФайловОбновления, ТипКонфигурации, ВерсияДляОбновления.Версия);
            СообщитьПользователю(СтрШаблон(НСтр("ru = 'Текущая версия: %1. Доступна для загрузки версия: %2 (Поставщик %3, размер %4).'"), 
            ПараметрыComБазы.ТекущаяВерсия, ВерсияДляОбновления.Версия, ВерсияДляОбновления.Поставщик, ВерсияДляОбновления.РазмерФайлаОбновления));
            Если НЕ ПолучитьФайлыОбновлений(ТипКонфигурации, ВерсияДляОбновления) Тогда
                Возврат;
            КонецЕсли;
        КонецЕсли;
        
        // Создание резервной копии
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Создание резервной копии информационной базы (%1).'"), ИмяВременногоФайла));
        КомандаПакетногоАрхивирования = СтрШаблон("""%1"" CONFIG %2 /DumpIB %3 /OUT %4 -NoTruncate",
        ПараметрыComБазы.ПутьКПлатформе, СтрокаСоединения, СтрокаДампа, СтрокаЛогов);
        ЗапуститьПриложение(КомандаПакетногоАрхивирования, , Истина, КодВозврата);
        Если КодВозврата = 0  Тогда
            СообщитьПользователю(НСтр("ru = 'Резервная копия информационной базы успешно создана.'"));
        Иначе
            СообщитьПользователю(НСтр("ru = 'Ошибка при создании резервной копии информационной базы.'"));
            Возврат;
        КонецЕсли;
        
        // Обновление информационной базы                                                                                                                                                              
        СообщитьПользователю(НСтр("ru = 'Обновление информационной базы.'"));
        КомандаПакетногоОбновления = СтрШаблон("""%1"" CONFIG %2 /UpdateCfg ""%3"" /UpdateDBCfg /OUT %4 -NoTruncate",
        ПараметрыComБазы.ПутьКПлатформе, СтрокаСоединения, ФайлОбновленияВерсии, СтрокаЛогов);
        ЗапуститьПриложение(КомандаПакетногоОбновления, , Истина, КодВозврата);
        Если КодВозврата = 0 Тогда
            СообщитьПользователю(НСтр("ru = 'Информационная база успешно обновлена.'"));
        Иначе
            СообщитьПользователю(НСтр("ru = 'Ошибка при обновлении информационной базы.'"));
            Возврат;
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

// Проверяет наличия каталога и в случае его отсутствия пытается создать новый.
//
// Параметры:
//  КаталогФайла - Строка - Путь к каталогу, существование которого нужно проверить.
//
// Возвращаемое значение:
//  Булево - признак существования каталога.
//
Функция ПроверитьСоздатьКаталог(КаталогФайла)
    
    КаталогФайлаОбъект = Новый Файл(КаталогФайла);
    Если НЕ КаталогФайлаОбъект.Существует() Тогда
        Попытка 
            СоздатьКаталог(КаталогФайла);
        Исключение
            СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось создать каталог %1.
                |%2'"), КаталогФайла, ИнформацияОбОшибке()));
            Возврат Ложь;
        КонецПопытки;
    КонецЕсли;
    
    Возврат Истина;
    
КонецФункции

// Добавляет дату и время перед сообщением и выводит сообщение пользователю.
//
// Параметры:
//  ТекстСообщенияПользователю - Строка - Текст сообщения.
//
Процедура СообщитьПользователю(ТекстСообщенияПользователю)
    
    ТекстСообщенияПользователю = СтрШаблон("%1 %2", ТекущаяДата(), ТекстСообщенияПользователю);
    Сообщить(ТекстСообщенияПользователю);
    
КонецПроцедуры

// Устанавливает внешнее соединение с информационной базой по переданным параметрам подключения и возвращает указатель
// на это соединение.
// 
// Параметры:
//  ПараметрыПодключения - Структура - параметры для установки внешнего соединения с информационной базой.
//
//    * ВерсияПлатформы                              - Строка - Версия платформы: 82; 83;
//    * ВариантРаботыИнформационнойБазы             - Число  - Вариант работы информационной базы: 0 - файловый; 1 -
//                                                             клиент-серверный;
//    * КаталогИнформационнойБазы                   - Строка - Каталог информационной базы для файлового режима работы;
//    * ИмяСервера1СПредприятия                     - Строка - Имя сервера1С:Предприятия;
//    * ИмяИнформационнойБазыНаСервере1СПредприятия - Строка - Имя информационной базы на сервере1С:Предприятия;
//    * АутентификацияОперационнойСистемы           - Булево - Признак аутентификации операционной системы при создании
//                                                             внешнего подключения к информационной базе;
//    * ИмяПользователя                             - Строка - Имя пользователя информационной базы;
//    * ПарольПользователя                          - Строка - Пароль пользователя информационной базы.
// 
// Возвращаемое значение:
//  COMОбъект, Неопределено - указатель на COM-объект соединения или Неопределено в случае ошибки;
//
Функция УстановитьВнешнееСоединениеСБазой(знач ПараметрыПодключения) 
    
    ИмяCOMСоединителя = "V" + ПараметрыПодключения.ВерсияПлатформы + ".COMConnector";
    Попытка
        COMОбъект = Новый COMОбъект(ИмяCOMСоединителя);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось подключится к другой программе:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Неопределено;
    КонецПопытки; 
    
    ФайловыйВариантРаботы = ПараметрыПодключения.ВариантРаботыИнформационнойБазы = 0;
    
    // Проверка корректности указания параметров.
    ОшибкаПроверкиЗаполнения = Ложь;
    Если ФайловыйВариантРаботы Тогда
        Если ПустаяСтрока(ПараметрыПодключения.КаталогИнформационнойБазы) Тогда
            ТекстСообщения = НСтр("ru = 'Не задано месторасположение каталога информационной базы.'");
            ОшибкаПроверкиЗаполнения = Истина;
        КонецЕсли;
    Иначе
        Если ПустаяСтрока(ПараметрыПодключения.ИмяСервера1СПредприятия) Или ПустаяСтрока(ПараметрыПодключения.ИмяИнформационнойБазыНаСервере1СПредприятия) Тогда
            ТекстСообщения = НСтр("ru = 'Не заданы обязательные параметры подключения: ""Имя сервера""; ""Имя информационной базы на сервере"".'");
            ОшибкаПроверкиЗаполнения = Истина;
        КонецЕсли;
    КонецЕсли;
    
    Если ОшибкаПроверкиЗаполнения Тогда
        СообщитьПользователю(ТекстСообщения);
        Возврат Неопределено;
    КонецЕсли;
    
    // Формирование строки соединения.
    ШаблонСтрокиСоединения = "[СтрокаБазы][СтрокаАутентификации]";
    
    Если ФайловыйВариантРаботы Тогда
        СтрокаБазы = "File = ""&КаталогИнформационнойБазы""";
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&КаталогИнформационнойБазы", ПараметрыПодключения.КаталогИнформационнойБазы);
    Иначе
        СтрокаБазы = "Srvr = ""&ИмяСервера1СПредприятия""; Ref = ""&ИмяИнформационнойБазыНаСервере1СПредприятия""";
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&ИмяСервера1СПредприятия",                     ПараметрыПодключения.ИмяСервера1СПредприятия);
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&ИмяИнформационнойБазыНаСервере1СПредприятия", ПараметрыПодключения.ИмяИнформационнойБазыНаСервере1СПредприятия);
    КонецЕсли;
    
    Если ПараметрыПодключения.АутентификацияОперационнойСистемы Тогда
        СтрокаАутентификации = "";
    Иначе
        
        Если СтрНайти(ПараметрыПодключения.ИмяПользователя, """") Тогда
            ПараметрыПодключения.ИмяПользователя = СтрЗаменить(ПараметрыПодключения.ИмяПользователя, """", """""");
        КонецЕсли;
        
        Если СтрНайти(ПараметрыПодключения.ПарольПользователя, """") Тогда
            ПараметрыПодключения.ПарольПользователя = СтрЗаменить(ПараметрыПодключения.ПарольПользователя, """", """""");
        КонецЕсли;
        
        СтрокаАутентификации = "; Usr = ""&ИмяПользователя""; Pwd = ""&ПарольПользователя""";
        СтрокаАутентификации = СтрЗаменить(СтрокаАутентификации, "&ИмяПользователя",    ПараметрыПодключения.ИмяПользователя);
        СтрокаАутентификации = СтрЗаменить(СтрокаАутентификации, "&ПарольПользователя", ПараметрыПодключения.ПарольПользователя);
    КонецЕсли;
    
    СтрокаСоединения = СтрЗаменить(ШаблонСтрокиСоединения, "[СтрокаБазы]", СтрокаБазы);
    СтрокаСоединения = СтрЗаменить(СтрокаСоединения, "[СтрокаАутентификации]", СтрокаАутентификации);
    
    Попытка
        Соединение = COMОбъект.Connect(СтрокаСоединения);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось подключится к другой программе:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Неопределено;
    КонецПопытки;
    
    Возврат Соединение;
    
КонецФункции

// Возвращает строку для подключения к внешней базе по переданным параметрам подключения.
// 
// Параметры:
//  ПараметрыПодключения - Структура - параметры для установки внешнего соединения с информационной базой.
//
//    * ВерсияПлатформы                              - Строка - Версия платформы: 82; 83;
//    * ВариантРаботыИнформационнойБазы             - Число  - Вариант работы информационной базы: 0 - файловый; 1 -
//                                                             клиент-серверный;
//    * КаталогИнформационнойБазы                   - Строка - Каталог информационной базы для файлового режима работы;
//    * ИмяСервера1СПредприятия                     - Строка - Имя сервера1С:Предприятия;
//    * ИмяИнформационнойБазыНаСервере1СПредприятия - Строка - Имя информационной базы на сервере1С:Предприятия;
//    * АутентификацияОперационнойСистемы           - Булево - Признак аутентификации операционной системы при создании
//                                                             внешнего подключения к информационной базе;
//    * ИмяПользователя                             - Строка - Имя пользователя информационной базы;
//    * ПарольПользователя                          - Строка - Пароль пользователя информационной базы.
// 
// Возвращаемое значение:
//  Строка, Неопределено - строка подключения или Неопределено в случае ошибки;
//
Функция ПолучитьСтрокуСоединения(знач ПараметрыПодключения)  
    
    ФайловыйВариантРаботы = ПараметрыПодключения.ВариантРаботыИнформационнойБазы = 0;
    
    // Формирование строки соединения.
    СтрокаСоединения = "[СтрокаБазы][СтрокаАутентификации]";
    
    Если ФайловыйВариантРаботы Тогда
        СтрокаБазы = " /F""&КаталогИнформационнойБазы""";
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&КаталогИнформационнойБазы", ПараметрыПодключения.КаталогИнформационнойБазы);
    Иначе
        СтрокаБазы = " /S""&ИмяСервера1СПредприятия/&ИмяИнформационнойБазыНаСервере­1СПредприятия""";
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&ИмяСервера1СПредприятия",                     ПараметрыПодключения.ИмяСервера1СПредприятия);
        СтрокаБазы = СтрЗаменить(СтрокаБазы, "&ИмяИнформационнойБазыНаСервере1СПредприятия", ПараметрыПодключения.ИмяИнформационнойБазыНаСервере1СПредприятия);
    КонецЕсли;
    
    Если ПараметрыПодключения.АутентификацияОперационнойСистемы Тогда
        СтрокаАутентификации = "";
    Иначе
        
        Если СтрНайти(ПараметрыПодключения.ИмяПользователя, """") Тогда
            ПараметрыПодключения.ИмяПользователя = СтрЗаменить(ПараметрыПодключения.ИмяПользователя, """", """""");
        КонецЕсли;
        
        Если СтрНайти(ПараметрыПодключения.ПарольПользователя, """") Тогда
            ПараметрыПодключения.ПарольПользователя = СтрЗаменить(ПараметрыПодключения.ПарольПользователя, """", """""");
        КонецЕсли;
        
        СтрокаАутентификации = " /N""&ИмяПользователя"" /P""&ПарольПользователя""";
        СтрокаАутентификации = СтрЗаменить(СтрокаАутентификации, "&ИмяПользователя",    ПараметрыПодключения.ИмяПользователя);
        СтрокаАутентификации = СтрЗаменить(СтрокаАутентификации, "&ПарольПользователя", ПараметрыПодключения.ПарольПользователя);
    КонецЕсли;
    
    СтрокаСоединения = СтрЗаменить(СтрокаСоединения, "[СтрокаБазы]", СтрокаБазы);
    СтрокаСоединения = СтрЗаменить(СтрокаСоединения, "[СтрокаАутентификации]", СтрокаАутентификации);
    
    Возврат СтрокаСоединения;
    
КонецФункции

// Загрузка списка обновлений из файла XML
// 
// Параметры:
//  ТекущаяВерсияКонфигурации - Строка - Текущая версия конфигурации.
//
// Возвращаемое значение:
//  Массив, Неопределено - массив с параметрами версий для обновления или Неопределено в случае ошибки;
//
Функция ВыполнитьЗагрузкуСпискаОбновлений(ТекущаяВерсияКонфигурации)
    
    ФайлСпискаШаблонов = КаталогВременныхФайлов + "\v8cscdsc.xml"; 
    МассивОбновлений = Новый Массив;
    
    Попытка
        
        ЧтениеXML = Новый ЧтениеXML;
        ЧтениеXML.ОткрытьФайл(ФайлСпискаШаблонов);
        ЧтениеXML.Прочитать(); // <?xml version="1.0" encoding="UTF-8" ?> 
        ЧтениеXML.Прочитать();
        ЧтениеXML.Прочитать();
        ЧтениеXML.Прочитать();
        
        // Читаем начало элемента Update или конец элемента UpdateList.
        Пока ЧтениеXML.Прочитать() Цикл
            Если ЧтениеXML.Имя = "v8u:updateList" Тогда
                Прервать;                    
            Иначе        
                Пока ЧтениеXML.Прочитать() Цикл
                    Если ЧтениеXML.Имя = "v8u:update" Тогда
                        Прервать;                    
                    Иначе        
                        Если ЧтениеXML.Имя = "v8u:vendor" Тогда
                            ЧтениеXML.Прочитать();
                            Поставщик = ЧтениеXML.Значение;                            
                        ИначеЕсли ЧтениеXML.Имя = "v8u:version" Тогда
                            ЧтениеXML.Прочитать();
                            Версия = ЧтениеXML.Значение;
                        ИначеЕсли ЧтениеXML.Имя = "v8u:file" Тогда
                            ЧтениеXML.Прочитать();
                            ПутьКФайлуОбновления = ЧтениеXML.Значение;
                        ИначеЕсли ЧтениеXML.Имя = "v8u:size" Тогда
                            ЧтениеXML.Прочитать();
                            РазмерФайлаОбновления = ЧтениеXML.Значение;
                        ИначеЕсли ЧтениеXML.Имя = "v8u:target" Тогда
                            ЧтениеXML.Прочитать();
                            Если ЧтениеXML.Значение = ТекущаяВерсияКонфигурации Тогда
                                ВерсияДляОбновления = Новый Структура();
                                ВерсияДляОбновления.Вставить("Поставщик",             Поставщик);
                                ВерсияДляОбновления.Вставить("Версия",                   СтрЗаменить(Версия, ".", "_"));
                                ВерсияДляОбновления.Вставить("ПутьКФайлуОбновления",  ПутьКФайлуОбновления);
                                ВерсияДляОбновления.Вставить("РазмерФайлаОбновления", РазмерФайлаОбновления);
                                МассивОбновлений.Добавить(ВерсияДляОбновления);
                            КонецЕсли;
                        КонецЕсли;
                        ЧтениеXML.Прочитать();
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
    Исключение
        
        СообщитьПользователю(НСтр("ru = 'Ошибка при чтении файла списка обновлений.'"));
        ЧтениеXML.Закрыть();
        
        Возврат Неопределено;
        
    КонецПопытки;
    
    ЧтениеXML.Закрыть();
    
    Возврат МассивОбновлений;
    
КонецФункции

// Скачивает из Интернета файлы обновлений.
//
// Параметры:
//  ТипКонфигурации  - Строка  - Краткое наименование конфигурации;
//  ВерсияДляОбновления - Структура - Структура с параметрами версии для обновления.
//    * Поставщик             - Строка - Поставщик;
//    * Версия                - Строка - Версия;
//    * ПутьКФайлуОбновления  - Строка - Путь к файлу обновления;
//    * РазмерФайлаОбновления - Строка - Размер файла обновления в байтах.
//
// Возвращаемое значение:
//  Булево - признак успешного получения.
//
Функция ПолучитьФайлыОбновлений(ТипКонфигурации, ВерсияДляОбновления) 
    
    СообщитьПользователю(СтрШаблон(НСтр("ru = 'Получение файлов обновления версии %1.'"), 
    ВерсияДляОбновления.Версия));
    
    КаталогФайлаОбновленияВерсии = СтрШаблон("%1\%2\%3", ПараметрыОбновления.КаталогФайловОбновления, ТипКонфигурации, ВерсияДляОбновления.Версия);
    Если НЕ ПроверитьСоздатьКаталог(КаталогФайлаОбновленияВерсии) Тогда Возврат Ложь; КонецЕсли;
    
    // Очищаем устаревшие файлы
    ZipФайлОбновления = КаталогВременныхФайлов + "\" + ПараметрыОбновления.ИмяZipФайлаОбновления; 
    Попытка
        УдалитьФайлы(ZipФайлОбновления);    
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось удалить временный файл %1:
            |%2'"), ZipФайлОбновления, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    // Получаем сам файл из Интернета.
    Попытка
        Соединение = Новый HTTPСоединение("downloads.v8.1c.ru", , НастройкаСоединения.Пользователь, НастройкаСоединения.Пароль,);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось установить HTTP-соединение с сервером downloads.v8.1c.ru:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    Попытка
        Заголовки = Новый Соответствие();
        Заголовки.Вставить("User-Agent", "1C+Enterprise/8.3");
        HTTPЗапрос = Новый HTTPЗапрос("/tmplts/" + ВерсияДляОбновления.ПутьКФайлуОбновления, Заголовки);
        Соединение.Получить(HTTPЗапрос, ZipФайлОбновления);
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось получить файл с сервера downloads.v8.1c.ru:
            |%1'"), ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    // Распаковываем файл
    Попытка
        ФайлZip = Новый ЧтениеZipФайла(ZipФайлОбновления); 
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось прочесть архив %1:
            |%2'"), ZipФайлОбновления, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    ФайлZip.ИзвлечьВсе(КаталогФайлаОбновленияВерсии);
    ФайлZip.Закрыть();
    
    Попытка
        УдалитьФайлы(ZipФайлОбновления);    
    Исключение
        СообщитьПользователю(СтрШаблон(НСтр("ru = 'Не удалось удалить временный файл %1:
            |%2'"), ZipФайлОбновления, ИнформацияОбОшибке()));
        Возврат Ложь;
    КонецПопытки;
    
    СообщитьПользователю(НСтр("ru = 'Файлы обновления успешно получены.'"));
    
    Возврат Истина;
    
КонецФункции 

Если УстановитьКонстанты() Тогда
    
    // Бухгалтерия предприятия 3.0
    Если ПолучитьСпискиОбновлений("Accounting", "30") Тогда
        ПроверитьОбновлениеКонфигурации("Accounting", , "\\server\---\---\---",,,, "Администратор", "---");
    КонецЕсли;
    
    // Бухгалтерия предприятия 2.0
    Если ПолучитьСпискиОбновлений("Accounting", "20") Тогда
        ПроверитьОбновлениеКонфигурации("Accounting", , "\\server\---\---\---",,,, "Администратор", "---");
    КонецЕсли;
    
КонецЕсли;
Показать
10. sergey279 79 11.07.16 10:18 Сейчас в теме
(9) Drak0n,
Объединил текст из данной публикации со своим. Из основных отличий:
1. Загрузка списка обновлений 1 раз для семейства
2. Обновление через несколько релизов
3. Преимущественное обновление на уже скачанные релизы
4. Ну и по мелочи
Получилось вот что:

PS Если автор не против могу выложить отдельной темой


1. гуд. но думаю пару кбайт погоды не сделают.
2. обновление идет на максимально возможный релиз в пределах одного скачка.
далее еще не посмотрел как у вас реализовано. следущей накаткой обновлений до "победного" или все таки с запуском обработчиков в режиме "предприятия"?
3. Аналогично "//качаем новую версию, если уже не скачено"

PS ни когда не против, т.к.
а) эта публикация и так копия батника, только на другом языке.
б) если бы был против, ничего бы не смог с этим поделать. "Мне остается только стонать от бессилия или отравиться газами через выхлопную трубу!" © Лжец Лжец.
11. Drak0n 170 11.07.16 14:17 Сейчас в теме
Обновление идет на максимально возможный уже скачанный релиз, если такового не найдено - на максимально возможный в пределах скачка (загружается с сайта). Такая необходимость возникла в связи с тем что была куча баз с различными релизами и вместо того чтобы качать цепочку "максимальных" релизов для каждой все релизы обновлялись на уже скачанный и далее по одной цепочке до финального.
Обработчики в режиме Предприятия не запускаются. Тут принципиальная позиция - соглашение на клиентском компьютере принимает пользователь. Через чур старых ИБ не обновляется - поэтому проблем нет).
12. TimoniArtjom 07.08.16 19:26 Сейчас в теме
А он все базы обновляет или только одну?
13. Drak0n 170 30.08.16 15:05 Сейчас в теме
(12) TimoniArtjom, скрипт по очереди проходит по списку заданных информационных баз. Все базы обновляются последовательно.
14. simonov_2015 2 28.11.17 09:36 Сейчас в теме
Подскажите, есть ли возможность при открытии конфигуратора открыть произвести сравнение с конфигурацией из .cf и открыть окно сравнения/объединения?
15. sergey279 79 28.11.17 17:32 Сейчас в теме
(14)
Подскажите, есть ли возможность при открытии конфигуратора открыть произвести сравнение с конфигурацией из .cf и открыть окно сравнения/объединения?


Не встречал ничего похожего, в ключах такого нету. В голову лезет всякие извращения с автокликерами для мышей/клавиатур.
Так что не подскажу.
16. ilyav 10.05.18 15:25 Сейчас в теме
Добрый день, почему то запускаю скрипт и ошибка подключения COM к базе возникает {Модуль C:\Users\vorobyevie\Desktop\OneScript\script.os / Ошибка в строке: 371 / Внешнее исключение (System.Runtime.InteropServices.COMException): Ошибка при загрузке библиотеки. (Исключение из HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))}
Не подскажите как решить?
17. sergey279 79 12.05.18 13:27 Сейчас в теме
(16)
крипт и ошибка подключения COM к базе возникает {Модуль C:\Users\vorobyevie\Desktop\OneScript\script.os / Ошибка в строке: 371 / Внешнее исключение (System.Runtime.InteropServices.COMException): Ошибка при загрузке библиотеки. (Исключение из HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))}


не знаю, но по гуглу то виндовая , с правами админа попробовать запустить.
18. ilyav 13.05.18 23:05 Сейчас в теме
(17)
крипт и ошибка подключения COM к базе возникает {Модуль C:\Users\vorobyevie\Desktop\OneScript\script.os / Ошибка в строке: 371 / Внешнее исключение (System.Runtime.InteropServices.COMException): Ошибка при загрузке библиотеки. (Исключение из HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))}

Пробовал, все безуспешно, запустил на компьютере коллеги, тоже самое.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    9009    ids79    26       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    10364    John_d    22       

Последовательности событий. Шпаргалка

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    6796    kuzyara    33       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    10742    YPermitin    72       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    30476    ids79    50       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    18887    YPermitin    80       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    21572    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    42339    ids79    36       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    21625    avalakh    21       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    33288    ids79    11       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    23122    ids79    27       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    17560    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    14240    SeiOkami    49       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    36017    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Производительность и оптимизация (HighLoad)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    18820    dmurk    144       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    30969    YPermitin    30       

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    20177    Eret1k    23       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    11462    m-rv    2       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    14791    m-rv    16       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    25908    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    20645    ellavs    83