Шифрование и расшифровка строковых полей справочников методом Виженера (с улучшениями)

Публикация № 518576

Разработка - Защита и шифрование

Шифрование метод Виженера

52
Обработка по шифрованию и расшифровке строковых полей справочников модифицированным методом Виженера - реализация без внешних компонент, без com-объектов, чистый 1С.

Хочу поделиться примером реализации обработки по шифрованию/расшифровке произвольных текстовых полей справочников. Требования перед разработкой я поставил следующие:

  1. Должен быть реализован функционал шифрования и расшифровки по паролю;
  2. Зашифрованные данные должны храниться в полях исходных данных, т.е. длина зашифрованного текста должна быть равной длине исходного текста, дополнительных таблиц быть не должно;
  3. Список полей для шифрования/расшифровки должен быть настраиваемым и не зависеть от конфигурации;
  4. Шифрование должно выполняться средствами платформы 1С без внешних компонент, com-объектов и т.д., чтобы исключить зависимость от ОС;

Решений на Инфостарте по шифрованию/расшифровки строк огромное множество (Защита и шифрование) - практически на любой вкус. Приведу наиболее интересные (на мой субъективный взгляд):

  1. Подсистема шифрования данных + пример реализации: решение Keystore для хранения паролей;
  2. Симметричное шифрование в 1С;
  3. Шифрование текста, хеш сумма;
  4. Хеширование данных с ключом по алгоритму SHA-1 штатными средствами 1С;
  5.  Шифратор и дешифратор текста и файлов для 1С

Однако, найти публикацию, отвечающую всем моим требованиям, так и не удалось. Из-за наличия требования №2 (о не превышении длиной зашифрованного текста длины исходного текста), в качестве метода шифрования был выбран шифр Виженера.
Да, по современным стандартам данный шифр является ненадежным и поддается взлому. Поэтому, чтобы повысить время на дешифровку текста, в базовый алгоритм были внесены следующие улучшения:

  1. Ключ для шифрования формируется на основании пароля, длина ключа шифрования равна длине шифруемого текста;
  2. Код каждого символа ключа шифрования равен коду соответсвующего символа пароля, смещенного на псевдо случайную величину А;
  3. Псевдо случайная величина А зависит от максимального кода среди символов пароля и длины кодируемой строки;
  4. Код каждого символа зашифрованной строки равен сумме кода соответствующего символа исходной строки, кода соответствующего символа ключа шифрования и псевдо-случайной величины В;
  5. Псевдо случайная величина В зависит от максимального кода среди символов ключа шифрования и длины кодируемой строки;

 Для генерации псевдо случайных величин использовался встроенный объект платформы "ГенераторСлучайныхЧисел". Ниже приведны основные функции обработки:

  1. Функция ПолучитьМаксимальныйКодСимволаСтроки - получает максимальный код символа в переданной строке : 
    Функция ПолучитьМаксимальныйКодСимволаСтроки(СтрокаАнализа)
    	
    	ДлинаСтрокиАнализа = СтрДлина(СтрокаАнализа);
    	
    	МаксимальныйКодСимвола = 0;
    	
    	Для Счетчик = 1 По ДлинаСтрокиАнализа Цикл
    				
    		КодТекущегоСимвола = КодСимвола(СтрокаАнализа, Счетчик);
    		
    		Если КодТекущегоСимвола > МаксимальныйКодСимвола Тогда
    			
    			МаксимальныйКодСимвола = КодТекущегоСимвола;
    			
    		КонецЕсли;
    		
    	КонецЦикла;
    	
    	Возврат МаксимальныйКодСимвола;
    	
    КонецФункции

  2. Функция ПолучитьКлючШифрования - получает по паролю ключ шифрования с учетом псевдо случайного смещения:
    Функция ПолучитьКлючШифрования(лПароль, ДлинаКодируемойСтроки)
    	
    	лПароль_Длина 	= СтрДлина(лПароль);
    	КлючШифрования	= "";
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(лПароль_Длина);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	СчетчикПоПаролю = Неопределено;
    	
    	Для Счетчик = 1 По ДлинаКодируемойСтроки Цикл
    		
    		Если (СчетчикПоПаролю = Неопределено) ИЛИ (СчетчикПоПаролю > лПароль_Длина) Тогда
    			
    			СчетчикПоПаролю = 1;
    				
    		КонецЕсли;
    		
    		СлучайноеСмещение = ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    				
    		СимволПароля = Сред(лПароль, СчетчикПоПаролю, 1);
    		
    		КлючШифрования = КлючШифрования + Символ(КодСимвола(СимволПароля) + СлучайноеСмещение);
    		
    		СчетчикПоПаролю = СчетчикПоПаролю + 1;
    		
    	КонецЦикла;
    	
    	Возврат КлючШифрования;
    	
    КонецФункции

  3. Функция ЗашифроватьСтроку - шифрует строку шифром Виженера по ключу шифрования с учетом псевдо случайного смещения:
    Функция ЗашифроватьСтроку(КодируемаяСтрока, КлючШифрования)
    	
    	ДлинаКодируемойСтроки = СтрДлина(КодируемаяСтрока);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(КлючШифрования);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	ЗакодированнаяСтрока = "";
    	
    	Для Счетчик = 1 ПО ДлинаКодируемойСтроки Цикл
    		
    		КодСимволаИсходнойСтроки 	= КодСимвола(КодируемаяСтрока, Счетчик);
    		КодСимволаКлючаШифрования 	= КодСимвола(КлючШифрования, Счетчик);		
    		СлучайнаяСоставляющая 		= ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    		
    		КодЗакодированныгоСимвола = КодСимволаИсходнойСтроки + КодСимволаКлючаШифрования + СлучайнаяСоставляющая;
    		
    		ЗакодированнаяСтрока = ЗакодированнаяСтрока + Символ(КодЗакодированныгоСимвола);
    		
    	КонецЦикла;
    	
    	Возврат ЗакодированнаяСтрока;
    	
    КонецФункции

  4. Функция РасшифроватьСтроку - расшифровывает строку по ключу шифрования с учетом псевдо случайного смещения:
    Функция РасшифроватьСтроку(КодируемаяСтрока, КлючШифрования)
    	
    	ДлинаКодируемойСтроки = СтрДлина(КодируемаяСтрока);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ПолучитьМаксимальныйКодСимволаСтроки(КлючШифрования);
    	
    	ЧислоДляИнциализацииГенератораСлучаныхЧисел = ЧислоДляИнциализацииГенератораСлучаныхЧисел + ДлинаКодируемойСтроки;
    	
    	ГенераторСлучаныхЧисел = Новый ГенераторСлучайныхЧисел(ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    	
    	ЗакодированнаяСтрока = "";
    	
    	Для Счетчик = 1 ПО ДлинаКодируемойСтроки Цикл
    		
    		КодСимволаКлючаШифрования 	= КодСимвола(КлючШифрования, Счетчик);			
    		КодЗакодированныгоСимвола 	= КодСимвола(КодируемаяСтрока, Счетчик);
    		СлучайнаяСоставляющая 		= ГенераторСлучаныхЧисел.СлучайноеЧисло(1, ЧислоДляИнциализацииГенератораСлучаныхЧисел);
    		
    		КодСимволаИсходнойСтроки = КодЗакодированныгоСимвола - КодСимволаКлючаШифрования - СлучайнаяСоставляющая;
    		
    		ЗакодированнаяСтрока = ЗакодированнаяСтрока + Символ(КодСимволаИсходнойСтроки);
    		
    	КонецЦикла;
    	
    	Возврат ЗакодированнаяСтрока;
    	
    КонецФункции

  5. Функция ЗашифроватьРасшифроватьПолеОбъекта - получает ключ шифрования по паролю и шифрует или расшифровывает строку в зависимости от входных параметров:
    Процедура ЗашифроватьРасшифроватьПолеОбъекта(ЗначениеРеквизита, Пароль, ЗаписатьЭлемент, ЭтоШифрование)
    	
    	Если НЕ ПустаяСтрока(ЗначениеРеквизита) Тогда
    		
    		КлючШифрования = ПолучитьКлючШифрования(Пароль, СтрДлина(ЗначениеРеквизита));
    		
    		Если ЭтоШифрование Тогда
    			
    			ЗначениеРеквизита = ЗашифроватьСтроку(ЗначениеРеквизита, КлючШифрования);
    			
    		Иначе
    			
    			ЗначениеРеквизита = РасшифроватьСтроку(ЗначениеРеквизита, КлючШифрования);
    			
    		КонецЕсли;
    			
    		Если НЕ ЗаписатьЭлемент Тогда
    			
    			ЗаписатьЭлемент = ИСТИНА;
    			
    		КонецЕсли;
    		
    	КонецЕсли;
    	
    КонецПроцедуры

Фактическая реализация алгоритма в виде обработки в приложенном файле. Интерфейс обработки интуитивно понятен. Для выполнения шифрования (или расшифровки) необходимо выполнить несколько простых шагов: 

  1. Выбрать поля данных в базе для обработки (при нажатии на гиперссылку с надписью "Обработать:" открывается отдельная форма с деревом справочников конфигурации со всеми текстовыми реквизитами и табличными частями с текстовыми реквизитами;
  2. Ввести пароль;
  3. Ввести подтверждение пароля;
  4. Нажать кнопку "Зашифровать" или "Расшифровать" в зависимости от требуемого действия. 

В качестве примера работы алгоритма приложены скриншоты со справочником "Страны" до шифрования и после шифрования.  На этом все, спасибо за внимание, надеюсь, кому-нибудь пригодится.

Конструктивная критика приветствуется! 

52

Скачать файлы

Наименование Файл Версия Размер
ШифрованиеСтроковыхПолейСправочников.epf
.epf 18,61Kb
03.01.17
24
.epf 1.02 18,61Kb 24 Скачать
ШифрованиеСтроковыхПолейСправочников.epf
.epf 18,58Kb
03.01.17
8
.epf 1.01 18,58Kb 8 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Поручик 4330 27.04.16 07:57 Сейчас в теме
Интересно. Где бы это приспособить?
2. NikitaXa 53 27.04.16 08:23 Сейчас в теме
(1) Поручик, например, временное скрытие конфиденциальной информации в базе.
9. spectre1978 50 05.06.16 16:30 Сейчас в теме
(1) Ну наиболее типичное на мой взгляд применение - это если в объектах конфы хранятся имена-пароли (скажем от неких сторонних веб-сервисов, с которыми работает программа) и есть желание это дело немного прикрыть от посторонних глаз.
3. oleg_km 27.04.16 09:54 Сейчас в теме
У меня в базе хранятся зашифрованные пароли от всякий банк-клиентов так, чтобы их не мог прочитать ни администратор, ни программист. Но я использую для всякий шифрований .NET
4. altu71 27.04.16 10:24 Сейчас в теме
А не подскажите, сколько времени занимает шифрование/расшифровка этим методом на значительном объеме данных? Т.е. запись 10 000 элементов справочника без шифрования столько то, а этих же данных, но с шифрованием - столько то. Т.е. хочется узнать накладные расходы времени на шифрование.
5. NikitaXa 53 27.04.16 21:38 Сейчас в теме
(4) altu71, накладные расходы на шифрование будут напрямую зависеть от оборудования. Я делал замеры (5 циклов шифрования/расшифровки) на справочнике объемом около 6.000. Общее время записи элементов справочника плюс/минус равно (точность до секунды) общему времени записи элементов этих же элементов с шифрованием двух полей (номер телефона и электронная почта). Т..е .время шифрования незначительно по сравнению с временем записи элемента справочника в БД. Если скорость шифрования справочника неудовлетворительна из-за длительной записи элементов справочника, то всегда можно распараллелить этот процесс через фоновые задания.
6. bubus 26.05.16 02:30 Сейчас в теме
И какова стойкость такого метода интересно? Брутфорс пальцами конечно не вариант, а если из 1С обработки пробутфорсить, сколько времени займет интересно на строку из 10 символов (зашифрованный пароль)?
7. NikitaXa 53 26.05.16 23:07 Сейчас в теме
(6) bubus, вот здесь есть описание продолжительности перебора пароля в общем случае. Т.е. для 10 символов пароля получается 1162 года. Однако существуют различные методы расшифровки шифра Виженера, которые позволяют ускорить время расшифровки.
8. bubus 27.05.16 08:31 Сейчас в теме
(7) я уже глянул, да есть. И очень эффективный - частотный криптоанализ. https://habrahabr.ru/post/221485/ Жаль там ссылка на программу мертвая. Но, программа та работает с "обычным" Виженером, а у вас я так понял изменения некоторые с ключом, плюс не "алфавитный квадрат" а символьный. Но, было бы очень интересно посмотреть за сколько бы та программа справилась, если бы справилась вообще. Но, в любом случае ваша разработка мне кажется очень и очень полезной. Для мобильных приложений к примеру, где у нас нет возможности юзать .NET Framework для шифрования.
10. spectre1978 50 05.06.16 16:34 Сейчас в теме
(6) bubus, если нужна стойкость от реального взлома - Вижинер вряд ли подойдет. Это один из самых известных и простых методов шифрования.
Т.е. "защита от дурака". Для серьезных применений нужно использовать CryptoAPI и алгоритмы из него.
11. soulsteps 73 21.06.16 16:32 Сейчас в теме
Автор, сделай сортировку в списке выбора объектов. А так обработка супер. Как раз понадобилось шифрануть данные.
12. NikitaXa 53 22.06.16 11:30 Сейчас в теме
(11) soulsteps, приложена новая версия обработки с сортировкой дерева справочников по синониму.
soulsteps; +1 Ответить
13. dobrynin.i.s 93 03.01.17 19:13 Сейчас в теме
Уважаемый, попробовал на ут 11

{ВнешняяОбработка.ШифрованиеСтроковыхПолейСправочников.Форма.Форма.Форма(780)}: Ошибка при вызове метода контекста (Выполнить)
РезультатЗапроса = Запрос.Выполнить();
по причине:
{(16, 30)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
ИЛИ Таблица.ТекстоваяСтрока <<?>><> "")

убрал условие на непустую строку - обработка пишет зашифровано все, но результата не видно в справочнике
14. dobrynin.i.s 93 03.01.17 19:37 Сейчас в теме
(13) ф-я ЗашифроватьСтроку выдает пустой результат в любом случае цифры, кириллица. латиница
15. NikitaXa 53 03.01.17 22:40 Сейчас в теме
(14) Действительно, имела место ошибка в шифровании строковых реквизитов неограниченной длины. Исправленная версия обработки уже приложена к публикации. Для исправления ошибки в модуле формы необходимо заменить строку №734 замените с:
"| ИЛИ Таблица." + ИмяПоля + " <> """"";"
на:
"| ИЛИ ПОДСТРОКА(Таблица." + ИмяПоля + ", 1, 255) <> """"";".
dobrynin.i.s; +1 Ответить
17. ogidni 152 01.07.19 10:34 Сейчас в теме
КодЗакодированныгоСимвола = КодСимволаИсходнойСтроки + КодСимволаКлючаШифрования + СлучайнаяСоставляющая;

Я что то не понял у вас в сумме шифра случайное число. Получается текст зашифровать можно, а вот обратно нет. или только путем перебора случайной строки?
Оставьте свое сообщение

См. также

Запутывание кода 1С 39

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Защита и шифрование

Обработка запутывания (обфускации) исходного кода 1С с помощью регулярных выражений.

2 стартмани

02.09.2019    3243    12    leoxz    62       

Цифровая подпись Cades-BES для XML средствами 1С с помощью КриптоПро 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Защита и шифрование

Обработка иллюстрирует возможность подписания XML SOAP-конверта по стандарту Cades-BES средствами 1С с помощью внешней компоненты КриптоПРО "CAdESCOM" с учетом ГОСТ 2001 и ГОСТ 2012. Стандарт используется в различных механизмах государственных сайтов России, в том числе в СМЭВ и ГИС ЖКХ. Код не привязан к прикладному решению может быть встроен куда угодно, но только на платформе Windows.

1 стартмани

13.05.2019    3077    12    PythonJ    25       

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+) 45

Инструменты и обработки Программист Архив с данными v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    7140    84    hakerxp    8       

Встраиваемая подсистема "Универсальные шаблоны объектов" 47

Инструменты и обработки Программист Бухгалтер Конфигурация (md, cf) v8 v8::СПР v8::УФ ЗУП3.x Абонемент ($m) Обработка документов Обработка справочников

Очень часто бывает так, что пользователь каждый месяц делает какие-либо "одинаковые" операции, например, заводит одни и те же документы, каждый раз меняя в них только значения нескольких реквизитов. Также во многих системах набирают популярность так называемые многофункциональные документы, т.е. документы, отвечающие за несколько разных участков автоматизации и в зависимости от вида операции, заполняющихся по разному. Для автоматизации подобных процессов была реализована данная подсистема.

1 стартмани

17.05.2018    10075    29    Skin123    13       

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    8004    14    notserioussam    1       

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 17

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    14531    45    charivnick    3       

Расширение для 1С Розница - форма справочника номенклатуры с ценами, остатками, штрихкодами 32

Отчеты и формы Пользователь Расширение (cfe) v8 Розница УУ Розничная торговля Абонемент ($m) Обработка справочников

Форма справочника номенклатуры с расширенными возможностями для 1С Розница версии 2.2.6.ХХХ и выше, платформа не ниже 8.3.10.

1 стартмани

17.03.2018    6992    47    independ    14       

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту 38

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 ЗУП3.x Россия БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников WEB

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника "Физические лица". Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

1 стартмани

27.02.2018    11521    124    VladimirElohov    33       

[РАСШИРЕНИЕ] Заполнение данных контрагента по ИНН в 1С: Бухгалтерия и 1С: УНФ 38

Инструменты и обработки Бухгалтер Расширение (cfe) v8 УНФ БП3.0 Абонемент ($m) Обработка справочников

Бесплатное заполнение реквизитов контрагентов в 1С: Бухгалтерия, 1С: УНФ на базе сервиса dadata.ru. Добавляет кнопку заполнения по ИНН в карточку нового контрагента, не требует подписки на ИТС.

1 стартмани

09.01.2018    22159    189    Anton64    64       

Автоматическое заполнение реквизитов контрагентов по ИНН для ERP 2.2, УТ 11.4, УТ 11.3, УТ 11.2, КА 2.2 и БП 3.0 (расширение конфигурации) 32

Инструменты и обработки Бухгалтер Пользователь Архив с данными v8 v8::БУ v8::ОУ v8::УФ УПП1 ERP2 БП3.0 УТ11 КА2 Россия Абонемент ($m) Обработка справочников Внешние источники данных

Универсальное расширение конфигурации для автоматической загрузки реквизитов контрагентов (партнеров) из ОГРН для 1С:ERP Управление предприятием 2 (ERP Управление предприятием 2.2), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.4), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.3), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.2), 1С:Комплексная автоматизация 8 (Комплексная автоматизация, редакция 2.2) и 1С:Бухгалтерия 8 (Бухгалтерия предприятия редакция 3.0)

3 стартмани

08.11.2017    21269    182    AlexeyT1978    146       

Обфускация кода 1С 94

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Защита и шифрование

Обфускация кода 1С как вариант защиты кода.

10 стартмани

09.10.2017    25043    61    VsHome    5       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    39939    49    myALKleon    37       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 128

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36813    218    BlizD    179       

Удаление неиспользуемых элементов справочника (простые и управляемые формы) 29

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка справочников Чистка базы

Обработка предназначена для удаления неиспользуемых элементов выбранного Вами справочника. Обработка конфигурационно-независима. UPD. Расширены возможности обработки

3 стартмани

02.08.2016    9454    78    roma_semenov79    6       

Защита разработок от копирования (Обычная и Управляемая форма) 202

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Защита и шифрование

Вы разработчик, и разработали чудесный алгоритм, но не хотите ни с кем с ним делиться - используйте данную разработку, и тогда предполагаемый злоумышленник, глядя на такой код, просто плюнет и начнет писать свой.

1 стартмани

28.03.2016    33280    320    karpik666    123       

Номенклатура (Расширенная форма списка) и Корзина [Расширение] 80

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8 БП3.0 Windows Учет ТМЦ Абонемент ($m) Обработка справочников Рабочее место

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    26459    118    mrXoxot    45       

Двухфакторная аутентификация в 1С 83

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Защита и шифрование

Двухфакторная аутентификация (2FA) — это механизм, который позволяет защитить ваш аккаунт надежнее, чем традиционный пароль. Пароль должен быть сложным, при этом его нужно всегда помнить, хранить от посторонних глаз и достаточно часто менять. Но даже если вы принимаете все меры, пароль все равно остается уязвимым — например, для вирусов, которые могут перехватить то, что вы набираете на клавиатуре.

1 стартмани

16.02.2016    28490    112    Юрий-К    17       

Договоры (Расширенная форма списка) [Расширение] 27

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 БУ Windows Дебиторская и кредиторская задолженность Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка справочников

Красивая и удобная форма списка для справочника "Договоры". Задолженность по договору, быстрое создание документов, переход к общему журналу документов по договору.

5 стартмани

02.02.2016    15740    35    mrXoxot    7       

Генератор сертификатов 32

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Защита и шифрование

Недавно пришлось организовывать обмен шифрованными сообщениями в 1С, при этом кучу времени заняла процедура создания сертификатов для работы с "Менеджером криптографии". Как итог сделал небольшую обработку для генерации разных типов сертификатов.

3 стартмани

27.01.2016    16006    28    eskor    4       

Контрагенты (расширенная форма списка) [Расширение] 62

Инструменты и обработки Бухгалтер Расширение (cfe) v8 БП3.0 Windows Абонемент ($m) Обработка справочников

Красивая и удобная форма списка контрагентов. Добавлено быстрое создание документов из списка и оперативная информация по контрагенту.

5 стартмани

22.12.2015    21044    100    mrXoxot    22       

Обфускация кода 1С (приведение в нечитаемый вид) для платформы 1С:Предприятие 8.3.7 97

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Защита и шифрование

Обработка для обфуксации (приведения в нечитаемый вид) кода 1С, это может использоваться как один из способов защиты программных модулей.

1 стартмани

20.12.2015    34754    306    masterkio    106       

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) 184

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов Обработка справочников Загрузка и выгрузка в Excel

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    49839    373    Tatitutu    49       

Автоматическая загрузка классификатора адресов КЛАДР 9

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    17809    42    kolos    1       

Подсистема автоматического удаления дублей в справочниках (управляемые формы, любая конфигурация) 17

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Чистка базы Обработка справочников

Подсистема позволяет проводить автоматическое удаление дублей справочников в соответствии с заданными настройками. Возможно встраивание в любую конфигурацию на управляемых формах. Позволяет задать настройки справочников, в которых ищутся дубли и также поля поиска совпадений. Есть регламентное задание для запуска проверки с заданным периодом. Если в базе найдены ссылки на тот элемент, который будет удален, то они заменяются на тот элемент, который остается. Дублем считается элемент справочника, у которого больше значение кода.

1 стартмани

31.07.2015    28773    94    primat    9       

Конфигурация ФИАС для 1С 8.1 и 8.2 41

Инструменты и обработки Бухгалтер Конфигурация (md, cf) v8 1cv8.cf Россия Windows Абонемент ($m) Обработка справочников

Конфигурации, которые позволяют интегрировать ФИАС (Федеральная информационная адресная система) в любую конфигурацию 1С 8.1 и 1С 8.2, работающую на НЕ управляемых формах.

1 стартмани

30.07.2015    46686    702    dgonson    53       

Ключ защиты из USB накопителя для 8.3 59

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Информационная безопасность Защита и шифрование

Ключ защиты конфигурации из обычной USB-флешки для платформы 8.3. Можно внедрить на любой конфигурации, и ключик не привязывается к определенному рабочему месту. Реализовано в Такси.

5 стартмани

31.05.2015    31232    40    Naposaram    57       

Дубли контрагентов. Жесткий запрет на запись дублей [Расширение] 63

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 Windows Абонемент ($m) Обработка справочников

В типовой конфигурации БП3 можно записывать одинаковых контрагентов, достаточно только нажать "ОК". Исправим эту несправедливость. Запретим бухгалтерам плодить дубли контрагентов. Для этого используем возможность платформы 8.3.6 - Расширения.

1 стартмани

15.05.2015    33930    139    mrXoxot    55       

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы) 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Обработка справочников

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    13995    54    Foxes82    12       

Загрузка товаров с Яндекс.Маркет 22

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для загрузки товаров (их описаний, свойств, изображений) с торговой площадки Яндекс.Маркет в базу Управление Торговлей 11. В отличие от других подобных обработок Вам самим не придется парсить страницы Яндекс.Маркет и решать сопутствующие этому процессу проблемы (бан, капча, поиск прокси-серверов, длительное ожидание результатов при больших объемах данных), так как все данные уже загружены на наш сервер и готовы для использования. Обновление данных осуществляется раз в месяц. Таким образом, все что Вам нужно - подключиться раз в месяц к нашему сервису и получить обновленный ассортимент товаров.

1 стартмани

12.01.2015    29875    182    Sirruf    81       

Проверка контрагентов по ИНН и КПП через веб-сервис ФНС (внешняя) 22

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка проверяет контрагентов по ИНН и КПП через веб-сервис ФНС на наличие регистрации в ЕГРН. Может выполняться в любых типовых конфигурациях, при наличии справочника "Контрагенты" и реквизитов "ИНН" и "КПП"

1 стартмани

25.12.2014    31998    297    Willforre    12       

Реестр договоров для 1С:Бухгалтерии 14

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Обработка справочников

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    33613    110    RespectSoft    23       

Загрузка курсов валют 4

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка справочников WEB

Загрузка актуальных курсов валют с web - сервиса Сбербанка. На обычных и управляемых формах.

1 стартмани

15.10.2014    10564    27    miller-adm    3       

Быстрое создание характеристик номенклатуры по дополнительным реквизитам в УТ11 + ВИДЕО 7

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 УУ Windows Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка справочников

Обработка позволяет создавать характеристики по всевозможным сочетаниям "дополнительных реквизитов характеристик". На форму выводится дерево дополнительных реквизитов характеристик и их возможных значений. Таблицу можно редактировать. Обработка полным перебором значений этих реквизитов создаст всевозможные характеристики.

1 стартмани

06.09.2014    20820    38    GATTUSO    27       

Проверка данных 179

Инструменты и обработки no Архив с данными v8 1cv8.cf БУ НУ УУ Абонемент ($m) Обработка документов Обработка справочников

Простой и удобный инструмент для проверки данных (справочников, документов) сразу в момент записи. Позволяет значительно повысить качество информации, вводимой в любую систему на платформе 1С:Предприятие 8.2-8.3. Прост в освоении и использовании, оптимизирован по быстродействию.

1 стартмани

01.07.2014    36480    329    1c-intelligence    145       

Загрузка картинок для номенклатуры (google image API) 6

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для поиска и загрузки картинок номенклатуры.

1 стартмани

04.06.2014    11005    92    OVladius    4       

Смена валют учета в базе 6

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Обработка справочников

Крымчане столкнулись с проблемой смены валют с гривны на рубль. Эта обработка поможет решить данный вопрос.

1 стартмани

26.05.2014    21776    32    dmbal    4