Данные строки в обработке расшифровки СКД

Публикация № 383839

Разработка - Практика программирования

Расшифровка СКД

52
Скорее заметка на память, чем статья. Прошелся по форумам и не нашел решения данной проблемы. Везде предлагается получить значения только группировок, в которые входит эта ячейка. Был еще способ создать свой макет и там в параметрах ячейки указать параметры расшифровки, но мне показалось такое решение слишком сложным. Предлагаю другой путь - обойти ячейки строки, для каждой ячейки получить реквизит "Расшифровка" и данные расшифровки.

Код должен располагаться в модуле формы отчета. У поля табличного документа событие "ОбработкаРасшифровки" должно ссылаться на процедуру РезультатОбработкаРасшифровки

Решение, которое предлагают на форумах для получения значений группировок:

Функция ПолучитьРекурсивноСтруктуруОтбора(ТекущееПоле, СтруктураОтбора = Неопределено)
    Если СтруктураОтбора = Неопределено Тогда
        СтруктураОтбора = Новый Структура;
    КонецЕсли; 
    
    Если ТипЗнч(ТекущееПоле) = Тип("ЭлементРасшифровкиКомпоновкиДанныхПоля") Тогда
        Для Каждого ТекЭл Из ТекущееПоле.ПолучитьПоля() Цикл
            СтруктураОтбора.Вставить(ТекЭл.Поле, ТекЭл.Значение);
        КонецЦикла;
    КонецЕсли;
    
    Для Каждого ТекЭл Из ТекущееПоле.ПолучитьРодителей() Цикл
        ПолучитьРекурсивноСтруктуруОтбора(ТекЭл, СтруктураОтбора);
    КонецЦикла; 
    
    Возврат СтруктураОтбора;
КонецФункции 

Функции для передвижения по строке: разбирается имя ячейки и увеличивается или уменьшается номер колонки:

Функция РаспарситьИмяПоля(ИмяПоля)
	
	ИндексСи = Найти(ИмяПоля, "C");
	БазаИмени = Лев(ИмяПоля, ИндексСи);
	НомерКолонкиСтрокой = СтрЗаменить(ИмяПоля, БазаИмени, "");
	НомерКолонки = Число(НомерКолонкиСтрокой);
	
	Возврат Новый Структура (
		"БазаИмени, НомерКолонки",
		БазаИмени,
		НомерКолонки
		);
		
	
КонецФункции
 
Функция ИмяПредыдущегоПоляВСтроке(ИмяПоля)

	Данные = РаспарситьИмяПоля(ИмяПоля);
	
	Если Данные.НомерКолонки = 1 Тогда
		Возврат "";
	КонецЕсли;
	
	Результат = Данные.БазаИмени + (Данные.НомерКолонки - 1);
	
	Возврат Результат;
	
КонецФункции
 
Функция ИмяСледующегоПоляВСтроке(ИмяПоля, МаксНомерКолонки = 100)

	Данные = РаспарситьИмяПоля(ИмяПоля);
	
	Если Данные.НомерКолонки = МаксНомерКолонки Тогда
		Возврат "";
	КонецЕсли;
	
	Результат = Данные.БазаИмени + (Данные.НомерКолонки + 1);
	
	Возврат Результат;
	
КонецФункции

Собственно функции, которые собирают значения ячеек строки и добавляют их к переданной структуре

Функция ПолучитьДанныеРасшифровкиПоИмени(Элемент, ИмяПоля, СтруктураОтбора = Неопределено)
	
	Если СтруктураОтбора = Неопределено Тогда
		СтруктураОтбора = Новый Структура;
	КонецЕсли; 

	Расшифровка = Элемент.ПолучитьОбласть(ИмяПоля).ТекущаяОбласть.Расшифровка;
	Если Расшифровка = Неопределено тогда
		Возврат СтруктураОтбора;
	КонецЕсли;
	
	Поле = ДанныеРасшифровки.Элементы[Расшифровка];
	
	СтруктураОтбора = ПолучитьРекурсивноСтруктуруОтбора(Поле, СтруктураОтбора);
	
	Возврат СтруктураОтбора;
	
КонецФункции
 

Функция ПолучитьДанныеРасшифровкиЯчеекСтроки(Элемент, СтруктураОтбора = Неопределено)
	
	Если СтруктураОтбора = Неопределено Тогда
		СтруктураОтбора = Новый Структура;
	КонецЕсли; 

	Если ТипЗнч(Элемент) = Тип("ПолеТабличногоДокумента") Тогда
		
		ТекущееИмя = Элемент.ТекущаяОбласть.Имя;
		
		ИмяСчетчик = ИмяПредыдущегоПоляВСтроке(ТекущееИмя);
		Пока ИмяСчетчик <> "" Цикл
			
			СтруктураОтбора = ПолучитьДанныеРасшифровкиПоИмени(Элемент, ИмяСчетчик, СтруктураОтбора);
			ИмяСчетчик = ИмяПредыдущегоПоляВСтроке(ИмяСчетчик);
			
		КонецЦикла; 
	    
		ИмяСчетчик = ИмяСледующегоПоляВСтроке(ТекущееИмя);
		Пока ИмяСчетчик <> "" Цикл
			
			СтруктураОтбора = ПолучитьДанныеРасшифровкиПоИмени(Элемент, ИмяСчетчик, СтруктураОтбора);
			ИмяСчетчик = ИмяСледующегоПоляВСтроке(ИмяСчетчик);
			
		КонецЦикла; 
		
	КонецЕсли;
	
	Возврат СтруктураОтбора;
	
	
КонецФункции

Теперь в обработке расшифровки мы можем получить структуру со значениями группировок и ячеек нашей строки

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	
	Поле = ДанныеРасшифровки.Элементы[Расшифровка];
	СтруктураОтбора = ПолучитьРекурсивноСтруктуруОтбора(Поле);
	СтруктураОтбора = ПолучитьДанныеРасшифровкиЯчеекСтроки(Элемент, СтруктураОтбора);
	
КонецПроцедуры

 

52

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Aleksey81 959 28.07.15 21:19 Сейчас в теме
Спасибо, что нашел время изложить этот метод в инфостарте. Идея великолепна!!!! Респект!!!
2. 7OH 32 29.07.15 09:44 Сейчас в теме
Если в группировке есть поле через точку - вылетает.
Например "Контрагент.ИНН".
3. Alien_job 165 29.07.15 09:53 Сейчас в теме
(2) 7OH, Спасибо за репорт, к вечеру посмотрю, поправлю.
5. Alien_job 165 29.07.15 13:04 Сейчас в теме
(2) 7OH, Очень неожиданное поведение 1с - в структуру вообще нельзя вставить ключ, содержащий точку.
Решение - использовать вместо структуры соответствие.
4. Новиков 291 29.07.15 10:47 Сейчас в теме
За статью спасибо. Самого интересовал вопрос, как получить данные строки, без группировок и без макета. На курсах сказали - никак :)

Был еще способ создать свой макет и там в параметрах ячейки указать параметры расшифровки, но мне показалось такое решение слишком сложным

На самом деле этот способ гораздо проще и понятнее, чем вот такой спагетти-образный код. Я уже года два как только таким способом и пользуюсь, оглядываясь на разработчиков типовых. И Вам рекомендую разобраться с этим способом. Когда разберетесь, улыбнетесь насколько он элегантен и прост.
9. Alien_job 165 26.10.15 11:08 Сейчас в теме
(4) Новиков, не получается разобраться с этим элегантным и простым методом. Не нашел примеров работы с "ПараметрРасшифровки" в контексте СКД. Помоему этот подход работает только при самостоятельном выводе отчета (через ТабДок.Вывести(Область))
6. Жолтокнижниг 249 30.07.15 10:46 Сейчас в теме
Улыбнуло
Очень неожиданное поведение 1с
7. ikar-nikolay 75 28.08.15 15:12 Сейчас в теме
Ха! Решал такой вопрос, тоже столкнулся с отсутствием описания данного метода.
Я заметил, что коды расшифровки идут по порядку, поэтому обычной пробежкой по значениям вперед и назад, пока не встретим отсутствие значения группировки, находим данные строки
Вот мой код:
&НаСервере
Функция ПолучитьСписокПолейВСтрокеСКД(КодРасшифровки, ДанныеРасшифровки) Экспорт
	
 	// Получаем поля группировки
	ЭлементРасшифровки = ПолучитьИзВременногоХранилища(ДанныеРасшифровки).Элементы[КодРасшифровки];
	ПоляГруппировки = автРаботаСФормами.ПолучитьСтруктуруПолейРасшифровки(ЭлементРасшифровки);

	// Делаем проверку Влево и Вправо от значения, которое хотят расшифровать
	// и проверяем - есль поля из ТЗПолейРасшифровки (в ней остались только поля с данными и без текущего расшифровываемого поля)
	КодРасшифровкиВлево 	= КодРасшифровки;
	КодРасшифровкиВправо 	= КодРасшифровки;
	
	ПоляВСтроке	= Новый Структура; 
	Пока Истина Цикл
		КодРасшифровкиВлево 	= КодРасшифровкиВлево - 1;
		Если Не КодРасшифровкиВлево < 0 Тогда // если вылезли за диапазон возможных расшифровок
			ИДЭлементаРасшифровки 	= ПолучитьИзВременногоХранилища(ДанныеРасшифровки).Элементы[КодРасшифровкиВлево];
		Иначе
			Прервать;
		КонецЕсли;
		
		ЗначениеГруппировки = автРаботаСФормами.ПолучитьИмяРасшифровываемогоПоля(ИДЭлементаРасшифровки);
		Если ЗначениеГруппировки = Неопределено Тогда
			Прервать;
		КонецЕсли;
		
		Если  ПоляГруппировки.Свойство(ЗначениеГруппировки) Тогда 
			Прервать;
		КонецЕсли;
		
		ПоляГруппировкиТекущие = автРаботаСФормами.ПолучитьСтруктуруПолейРасшифровки(ИДЭлементаРасшифровки);
		РезультатСравненияГруппировок = СравнитьСоответствияГруппировок(ПоляГруппировкиТекущие, ПоляГруппировки);
		Если РезультатСравненияГруппировок Тогда
			 ПоляВСтроке.Вставить(автРаботаСФормами.ПолучитьИмяРасшифровываемогоПоля(ИДЭлементаРасшифровки), автРаботаСФормами.ПолучитьЗначениеРасшифровки(ИДЭлементаРасшифровки));
		Иначе
			 Продолжить;
		КонецЕсли;
		
	КонецЦикла;
	
	Пока Истина Цикл
		КодРасшифровкиВправо 	= КодРасшифровкиВправо + 1;
		
		Если ПолучитьИзВременногоХранилища(ДанныеРасшифровки).Элементы.Количество() < КодРасшифровкиВправо Тогда // если вылезли за диапазон возможных расшифровок
			ИДЭлементаРасшифровки 	= ПолучитьИзВременногоХранилища(ДанныеРасшифровки).Элементы[КодРасшифровкиВправо];
		Иначе
			Прервать;
		КонецЕсли;
			
		ЗначениеГруппировки = автРаботаСФормами.ПолучитьИмяРасшифровываемогоПоля(ИДЭлементаРасшифровки);
		Если ЗначениеГруппировки = Неопределено Тогда
			Прервать;
		КонецЕсли;
		
		Если  ПоляГруппировки.Свойство(ЗначениеГруппировки) Тогда 
			Прервать;
		КонецЕсли;
		
		ПоляГруппировкиТекущие = автРаботаСФормами.ПолучитьСтруктуруПолейРасшифровки(ИДЭлементаРасшифровки);
		РезультатСравненияГруппировок = СравнитьСоответствияГруппировок(ПоляГруппировкиТекущие, ПоляГруппировки);
		Если РезультатСравненияГруппировок Тогда
			 ПоляВСтроке.Вставить(автРаботаСФормами.ПолучитьИмяРасшифровываемогоПоля(ИДЭлементаРасшифровки), автРаботаСФормами.ПолучитьЗначениеРасшифровки(ИДЭлементаРасшифровки));
		Иначе
			 Продолжить;
		КонецЕсли;

	КонецЦикла;

	Возврат ПоляВСтроке;
	
КонецФункции
Показать


Оцените! )))
8. Alien_job 165 28.08.15 15:48 Сейчас в теме
13. Poopkeen 08.02.16 15:14 Сейчас в теме
(7) ikar-nikolay,

Камрад, а можно текст соответствующих функций из модуля автРаботаСФормами ?
10. megatrend 120 21.12.15 00:01 Сейчас в теме
Это только для неуправляемых форм? В управляемой форме возникает ошибка на первой же строке :

Значение не является значением объектного типа (Элементы)
Поле = ДанныеРасшифровки.Элементы[Расшифровка];
11. Alien_job 165 21.12.15 06:09 Сейчас в теме
(10) megatrend, На управляемых формах не проверял
15. HEKPOH 70 16.05.17 12:24 Сейчас в теме
(10)
Для УФ нужно использовать конструкцию:

ДанныеРасшифровкиКомпоновки = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
ПоляРасшифровки = ДанныеРасшифровкиКомпоновки.Элементы.Получить(Расшифровка).ПолучитьПоля();
AngV; Alien_job; +2 Ответить
12. it-tk-sibir 14.01.16 15:19 Сейчас в теме
14. moli_i_n 07.04.16 08:03 Сейчас в теме
Спасибо, интересное решение проблемы.
16. mrm1212 26 05.04.18 14:57 Сейчас в теме
Спасибо за код, только пришлось структуру на соответствие заменить и все заработало!
Оставьте свое сообщение

См. также

Альтернативный способ задания расшифровки СКД-отчета 9

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Задание расшифровки у отчета, выведенного с помощью СКД, как будто он был выведен традиционным способом. Изменения конфигурации при этом минимальны, создание формы у отчета не требуется, не нужно писать "простыни" кода.

11.11.2019    702    Serge R    4       

Лайфхак работы с СКД. Собираем отчет. 59

Статья Программист Бизнес-аналитик Пользователь Стажер Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

В этой статье я опишу небольшой "лайфхак" по сборке отчетов в СКД. Думаю, этот подход будет интересен тем, кто хочет быстро оформить отчет.

25.10.2019    5450    aximo    22       

Немного про СКД. Характеристики и проверка пустого отчета 75

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пример использования характеристик в СКД и программная работа с ними. А также описание проверки результата отчета на заполненность.

10.10.2019    3590    YPermitin    7       

Полезняшки по СКД и построителям. Просто код 45

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Универсальные функции

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    4011    Yashazz    45       

Две схемы СКД в одном отчете с пользовательскими параметрами 17

Статья Программист Нет файла v8::СКД Россия Бесплатно (free) Практика программирования

Простая реализация разных по типу отчетов в одном. Применение нескольких схем компоновки с корректной передачей пользовательских параметров.

10.10.2019    2336    evgeni-red    6       

Три способа создания одного отчета на СКД 80

Статья Программист Нет файла v8 v8::СКД ERP2 УТ11 КА2 Бесплатно (free) Практика программирования

СКД имеет столько возможностей, что часто приходится выбирать, каким образом строить отчет. Причем выбор не всегда очевидный. В статье рассмотрен пример построения отчета «Отрицательные остатки по товарам на момент проведения расходных документов» тремя разными способами. Приведены «За» и «Против» каждого варианта решения задачи.

08.10.2019    5144    ids79    23       

СКД. Отчеты с картинками 184

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Решение популярных кейсов с картинками в отчетах на СКД.

25.09.2019    5777    YPermitin    24       

СКД не только для отчетов 140

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

СКД позволяет получать данные из информационной базы не только для вывода в отчеты, но и для других целей. Пример такого использования рассматривается в настоящей статье.

18.09.2019    8093    YPermitin    31       

Агрегатные функции СКД, о которых мало кто знает 341

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    12928    ids79    44       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 252

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    13949    ids79    30       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 130

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    12578    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 144

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    11094    ids79    27       

Пользовательские настройки системы компоновки данных 88

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Работа с отчетами в пользовательском режиме, формы отчетов. Понятие пользовательских настроек в отчетах на СКД. Определение состава пользовательских настроек для разделов в целом и для отдельных элементов, для всего отчета и для отдельных группировок. Видимость функциональных опций в отчетах на СКД.

09.07.2019    7730    ids79    0       

"Меньше копипаста!", или как Вася универсальную процедуру писал 183

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    7776    SeiOkami    49       

Работа с настройками системы компоновки данных 107

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    12500    ids79    8       

Создание отчетов с помощью СКД - основные понятия и элементы 208

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    20868    ids79    17       

Не провоцируйте СКД, или пример "как не надо" 52

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Пример того, что не нужно использовать в запросах, чтобы не провоцировать СКД.

10.06.2019    7845    SeiOkami    91       

Еще один способ нестандартной расшифровки отчета. Без использования обработчиков формы. Для ленивых 92

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Лень+ СКД. Еще один нестандартный способ расшифровки отчета. Без использования обработчиков формы. Только макет компоновки и модуль отчета. Весь исходный текст в статье.

16.05.2019    5980    tusv    55       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 92

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    8370    Viktor_Ermakov    6       

Разворачивание таблицы свойств и значений по колонкам через СКД 18

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

СКД! Юниоры 1С начинают паниковать, когда слышат эту аббревиатуру. Хороший пример, упрощающий жизнь начинающему разработчику, представлен ниже.

12.05.2019    3985    Eret1k    0       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    5935    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    8577    m-rv    16       

"Склеивание" отчетов на СКД 23

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования Разработка

Методика программного объединения данных нескольких отчетов в итоговый сводный. По ссылке опубликован пример на реальных данных и код отчета: https://infostart.ru/public/1017891/

10.03.2019    4911    bivmail    2       

Добавление отчетов в типовые конфигурации 1С 206

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    26023    ids79    33       

Программная обработка данных отчета, полученных с помощью запроса, с выводом измененных данных в СКД 29

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Разработка

В данной публикации рассмотрена возможность программной обработки данных, полученных запросом в отчете, с последующим выводом обработанных данных пользователю с помощью штатных средств СКД.

17.02.2019    4569    srub    10       

Информирование пользователя. Работа с объектом «СообщениеПользователю» 252

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    19022    ids79    34       

Вывод результата компоновки в таблицу и дерево значений 29

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Загрузка данных из ТабличногоДокумента в ТаблицуЗначений с использованием внешних наборов данных СКД, для последующей обработки в запросе.

14.02.2019    4442    kasper076    5       

Ещё раз о суммировании группировок в СКД 60

Статья Программист Нет файла v8 v8::СКД 1cv8.cf УУ Производство готовой продукции (работ, услуг) Бесплатно (free) Практика программирования Разработка

Начинающие специалисты, создающие отчеты в СКД, часто сталкиваются с вопросом о суммировании результатов группировок. Столкнувшись с такой задачей, я понял, что часто проблемы возникают от неправильного понимания самой задачи, а также недопонимания действия механизмов платформы. В приведенной ниже статье попробуем с этим разобраться.

11.02.2019    7231    Dioneo    17       

Еще раз о расшифровке для СКД 23

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Программное управление расшифровкой для отчета, сформированного с помощью Системы Компоновки Данных.

27.12.2018    5353    scientes    2       

Заголовок с параметром в отчете СКД 30

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования

Статья, как сделать заголовок с параметром в отчете СКД.

19.12.2018    5880    user913680    16       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    23066    ids79    72       

Установка собственных значений полей при программном выводе отчета СКД по имени поля (по принципу "как в макете") 16

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования

При программном выводе отчета на СКД возникает задача заполнить поля своими значениями. Но при поэлементном выводе отчета параметры "обезличены" как П1, П2, П3, ... Как узнать в какое "П" содержит нужное поле и куда устанавливать значение? Статья поможет программистам начинающим освоение СКД и перешедшим на СКД с "макета" ответить на эти вопросы на примере готового решения.

23.11.2018    5394    lmnlmn    0       

Дополнительные реквизиты в типовом отчете и их отсутствие 18

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пара Лайфхаков, случайно найденных, когда было лень запускать конфигуратор. Отбор при отсутствии дополнительного реквизита.

18.11.2018    5297    dyuha    0       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    22079    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22202    ids79    40       

Перевод конфигурации на 8.3.13 17

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования

Опыт решения проблем. 1. Проблема с СКД преобразованием запроса при отключении режима совместимости:

06.11.2018    5898    serferian    26       

Вспомогательные инструкции в коде 1С 105

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21491    tormozit    100       

Приемы работы с СКД: делаем за 5 минут то, на что у других уйдет час 379

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования

Сергей Наумов делится опытом нестандартного использования системы компоновки данных. Он рассказывает о построении сложных отчетов с помощью функций СКД, описывает преимущества использования компоновки в коде для значительного сокращения строк кода и времени на решение задач, а также рассказывает про отладку компоновки и возможности оптимизации ее работы.

03.09.2018    32614    SergeyN    26       

Как легко в СКД сделать переключатель: рубли, тыс. руб., млн. руб. 73

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Достаточно часто пользователи просят добавить в отчеты функцию округления показателей отчетов до тысяч или миллионов. Работая в франчайзи, я встречал различные варианты реализации, например, разные варианты отчетов или округление значения показателей сразу в запросе и т.д. и т.п. Хочу предложить вариант решения данной задачи в отчетах, построенных в СКД.

07.08.2018    8800    SayDimas    15       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    20137    olegtymko    47       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    22083    m-rv    21