Скрываем неиспользуемые виды расчета

Публикация № 381692

Разработка - Практика программирования

Архив виды расчетов лкс скрыть виды расчета правильное изменение конфигурации Архив справочника сотрудники не помещать сотрудника в архив Актуальность скрыть показатели схем мотивации убрать из списка элемент справочника скрыть элементы справочника ненужные элементы скрыть неиспользуемое

Копятся ненужные виды расчета в ЗУП? Есть решение с минимальными затратами при последующих обновлениях!

Мне очень понравилось, как реализован механизм «Архив» в справочнике «Сотрудники». Сделаем так же и для видов расчета, но максимально сохранив конфигурацию на поддержке:

Сокращения: ПВР – план видов расчета

  1. Для этого, конечно же, необходимо включить возможность редактирования конфигурации, но замочек необходимо снять только c Корневого элемента конфигурации (чтобы добавлять новые объекты), с ПВР и его формы списка и выбора.
  2. В ПВР добавляем реквизит «Актуальность» - тип «Булево»
  3. Добавляем глобальный модуль «КА_ГлобальныйМодуль» (ИЛИ «ЛКС_ГлобальныйМодуль) код вставляем как указано в публикации TormozIT //catalog.mista.ru/public/16980/, делаем его глобальным и для обычного приложения. У себя в конфигурации я немного изменил префикс не «ЛКС», а «КА», прошу заранее извинить.
  4. Добавляем модуль «КА_ПодпискиНаСобытия» - директивы исполнения «Сервер» и «Клиент (обычное приложение)»
  5. Добавляем модуль «КА_ГенерацияЭлементовФормы» - «Клиент (обычное приложение)».
  6. Добавляем подписку на событие «УстановитьАктуальностьПВР» для события «ПередЗаписью» ПВР, указываем модуль исполнения КА_ПодпискиНаСобытия. В процедуре пишем:  
Если Источник.ЭтоНовый() Тогда
	Источник.Актуальность = Истина;
КонецЕсли; 
  1. Затем добавляем нужные кнопки и командную панель в форму списка и форму выбора ПВР как в форме списка справочники Сотрудники – это кнопки «Поместить расчет в архив» и «Показывать архив показателей», а также кнопку в контекстной панели «Поместить расчет в архив».
  2. Используя обработку из //catalog.mista.ru/public/99363/, любезно предоставленную нам Istur – декомпилируем необходимые нам кнопки (кстати я немного переделал его обработку, чтобы действия стандартных командных панелей представлялись в виде текстовой строки с помощью ЗначениеИзстрокиВнутр, так как по-другому их фиг получишь, и также чтобы автоматически добавлялись стандартные картинки). И затем удаляем все, что мы добавили (делаем формы типовыми).
  3. Добавляем полученный декомпилированный код в модуль «Ка_ГенерацияЭлементовФормы» в процедуру  ПланВидовРасчета_ФормаСписка_ПередОткрытием(Форма, Отказ, Подменю, СтандартнаяОбработка = Ложь) Экспорт
  4. Для универсальности основной исполняемый код перенесем в общий модуль "КА_АктуальностьПВР" - ("клиент (обычное приложение)"): 
    Процедура УточнитьНаименованиеИДоступностьКомандыИзменитьАктуальность(лТекСтрока, ЭлементыФормы, Подменю) Экспорт
    	
    	// Если выделенных строк нет - команды недоступны
    	Если лТекСтрока = Неопределено Тогда
    		ТекстЗаголовкаКоманды = "";
    	Иначе	
    	// Если выделенная строка одна - обратимся к текущим данным строки
    		Если лТекСтрока.Актуальность Тогда
    			ТекстЗаголовкаКоманды = "Поместить расчет в архив";
    		Иначе
    			ТекстЗаголовкаКоманды = "Извлечь расчет из архива";
    		КонецЕсли;
    	КонецЕсли;	
    			
    	
    	Если ПустаяСтрока(ТекстЗаголовкаКоманды) Тогда
    		ЭлементыФормы.КоманднаяПанельСписокВидовРасчета.Кнопки.ИзменитьАктуальность.Доступность	= Ложь;
    		Подменю.Кнопки.ИзменитьАктуальность.Доступность		= Ложь;
    	Иначе
    		ЭлементыФормы.КоманднаяПанельСписокВидовРасчета.Кнопки.ИзменитьАктуальность.Доступность	= Истина;
    		ЭлементыФормы.КоманднаяПанельСписокВидовРасчета.Кнопки.ИзменитьАктуальность.Текст		= ТекстЗаголовкаКоманды;
    		Подменю.Кнопки.ИзменитьАктуальность.Доступность		= Истина;
    		Подменю.Кнопки.ИзменитьАктуальность.Текст			= ТекстЗаголовкаКоманды;
    	КонецЕсли;
    	
    КонецПроцедуры
    
    Процедура Кнопка_ИзменитьАктуальность(ЭлементыФормы, Подменю) Экспорт
    	 // команда изменения актуальности доступна только при наличии
    	// выделенных строк и только если у всех выделенных сотрудников одинаковая актуальность
    	
    	лТекСтрока			= ЭлементыФормы.ПланВидовРасчетаСписок.ТекущаяСтрока;
    	Если лТекСтрока = Неопределено Тогда
    		Возврат;		
    	КонецЕсли; 
    	ТекущаяАктуальность	= лТекСтрока.Актуальность;
    	Наименование		= лТекСтрока.Наименование;
    	
    	Форма = ПолучитьОбщуюФорму("ДиалогВопрос");
    	
    	Если ТекущаяАктуальность Тогда
    		Форма.Заголовок	= "Перемещение показателей в архив";
    		Форма.ЭлементыФормы.НадписьТекстВопроса.Заголовок =
    		"Поместить выделенный расчет в архив.
    		|
    		|Показатели, помещенные в архив, не будут показаны в списке.";
    		Форма.ЭлементыФормы.КнопкаДействие1.Заголовок = "Поместить в архив";
    	Иначе
    		Форма.Заголовок	= "Извлечение показателя из архива";
    		Форма.ЭлементыФормы.НадписьТекстВопроса.Заголовок =
    		"Извлечь выделенный расчет из архива. 
    		|
    		|После извлечения из архива показатели будут показываться в списке.";
    		Форма.ЭлементыФормы.КнопкаДействие1.Заголовок = "Извлечь из архива";
    	КонецЕсли;
    	
    	Форма.ЭлементыФормы.КнопкаДействие2.Заголовок = "Отмена";
    	Результат = Форма.ОткрытьМодально();
    	
    	Если ПустаяСтрока(Результат) или Результат = "2" Тогда
    		// отказались от смены актуальности
    		Возврат;
    	Иначе
    		НачатьТранзакцию();
    		лПоказатель = лТекСтрока.ПолучитьОбъект();
    		лПоказатель.Актуальность = Не ТекущаяАктуальность;
    		лПоказатель.Записать();
    		ЗафиксироватьТранзакцию();
    		
    		// после смены актуальности уточним заголовок команды
    		УточнитьНаименованиеИДоступностьКомандыИзменитьАктуальность(лТекСтрока, ЭлементыФормы, Подменю);
    		
    	КонецЕсли;
    
    КонецПроцедуры
    
    Процедура ПВР_ПриПолученииДанных(ОформленияСтрок) Экспорт
    	Для Каждого Оформление Из ОформленияСтрок Цикл
    		ДанныеСтроки = Оформление.ДанныеСтроки.Ссылка;		
    		Если НЕ ДанныеСтроки.Актуальность Тогда
    			Оформление.ЦветТекста = ЦветаСтиля.ЦветРамки;
    		КонецЕсли;
    	КонецЦикла;
    КонецПроцедуры
    
    Процедура ПоказатьАрхив(Форма, Подменю, ПоказыватьАрхив) Экспорт
    	Форма.ПланВидовРасчетаСписок.Отбор.Актуальность.Использование	= Не ПоказыватьАрхив;
    	Форма.ПланВидовРасчетаСписок.Отбор.Актуальность.Значение		= Не ПоказыватьАрхив;
    	Подменю.Кнопки.ПоказыватьАрхив.Пометка							= ПоказыватьАрхив;	
    КонецПроцедуры

    Обратите внимание на передаваемую переменную "Подменю" - в форме списка и форме выбора ПВР кнопки находятся в разных подменю, поэтому для универсальности его нужно передавать.

  5. В форму списка в конец модуля вставляем следующий код:
    Процедура ДействияФормыИзменитьАктуальность(Кнопка)
    	лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю2;
    	КА_АктуальностьПВР.Кнопка_ИзменитьАктуальность(ЭлементыФормы, лПодменю);	
    КонецПроцедуры
    
    Процедура ДействияФормыПоказыватьАрхив(Кнопка)
    	лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю2;	
    	КА_АктуальностьПВР.ПоказатьАрхив(ЭтаФорма, лПодменю, НЕ лПодменю.Кнопки.ПоказыватьАрхив.Пометка);	
    КонецПроцедуры
    
    Процедура КаПередЗакрытием(Отказ, СтандартнаяОбработка)
    	Выполнить(КаПолучитьСтароеДействиеФормы(ЭтаФорма, "ПередЗакрытием"));
    	лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю2;
    	СохранитьЗначение("ПланВидовРасчетаОсновныеНачисления_ФормаСписка_ПоказыватьАрхив",	лПодменю.Кнопки.ПоказыватьАрхив.Пометка);	
    КонецПроцедуры
    
    // Процедура - обработчик события "ПередОткрытием" элемента формы "". 
    // 
    Процедура КаПередОткрытием(Отказ, СтандартнаяОбработка)
    	лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю2;	
    	
    	КА_ГенерацияЭлементовФормы.ПланВидовРасчета_ФормаСписка_ПередОткрытием(ЭтаФорма, Отказ, лПодменю, СтандартнаяОбработка);
    	
    	Выполнить(КаПолучитьСтароеДействиеФормы(ЭтаФорма, "ПередОткрытием"));		
    	ПоказыватьАрхив = ВосстановитьЗначение("ПланВидовРасчетаОсновныеНачисления_ФормаСписка_ПоказыватьАрхив");
    	Если ПоказыватьАрхив = Неопределено Тогда
    		ПоказыватьАрхив = Ложь;
    	КонецЕсли;
    	
    	КА_АктуальностьПВР.ПоказатьАрхив(ЭтаФорма, лПодменю, ПоказыватьАрхив);
    	
    КонецПроцедуры // КаПередОткрытием() 
    
    // Процедура - обработчик события "ПриИзменении" элемента формы "Склад".
    //
    Процедура КаПланВидовРасчетаСписокПриАктивизацииСтроки(Элемент)
        
        Выполнить(КаПолучитьСтароеДействиеФормы(ЭтаФорма, "ПриАктивизацииСтроки", "ПланВидовРасчетаСписок"));
    	
    	лТекСтрока = ЭлементыФормы.ПланВидовРасчетаСписок.ТекущаяСтрока;
    	лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю2;
    	КА_АктуальностьПВР.УточнитьНаименованиеИДоступностьКомандыИзменитьАктуальность(лТекСтрока, ЭлементыФормы, лПодменю);
    
    КонецПроцедуры // КаСкладПриИзменении()
    
    // Процедура - обработчик события "НачалоВыбора" элемента "Товары.ЗаказПокупателя".
    // (Событие "НачалоВыбора" поля ввода "ЗаказПокупателя"
    // в строке табличной части "Товары")
    //
    Процедура КаПланВидовРасчетаСписокПриПолученииДанных(Элемент, ОформленияСтрок)
        
        Выполнить(КаПолучитьСтароеДействиеФормы(ЭтаФорма, "ПриПолученииДанных", "ПланВидовРасчетаСписок"));
    	
    	КА_АктуальностьПВР.ПВР_ПриПолученииДанных(ОформленияСтрок);
    	
    КонецПроцедуры // КаТоварыЗаказПокупателяНачалоВыбора()
    
    КаУстановитьДействиеФормы(ЭтаФорма, "ПередЗакрытием");
    КаУстановитьДействиеФормы(ЭтаФорма, "ПередОткрытием");
    КаУстановитьДействиеФормы(ЭтаФорма, "ПриАктивизацииСтроки"  , "ПланВидовРасчетаСписок");
    КаУстановитьДействиеФормы(ЭтаФорма, "ПриПолученииДанных"  	, "ПланВидовРасчетаСписок");
    

    Теперь, если такие же кнопки мы захотим добавить в форму выбора, нужно поменять инициализацию лПодменю на лПодменю = ЭлементыФормы.ДействияФормы.Кнопки.Подменю;, а если захотим добавить для других ПВР, то также необходимо заменить наименование сохраняемых настроек "сохранить/восстановить значение" на имя ваших пвр.

  6. Не забываем про комментарии вида «//{{ДОБАВЛЕНО» «//}}ДОБАВЛЕНО»

По сути все, но когда вы откроете форму списка необходимого вида расчета, то там будет совершенно пусто. Дело в том, что сейчас все ПВР имеют Актуальность = Ложь, чтобы это исправить используйте мою обработку или сделайте сами, нужно для каждого элемента проставить «актуальность = Истина»

Аналогичные действия нужно проделать для формы выбора.

И теперь вы можете скрывать эти ненавистные виды расчета. Ха-ха.

 

P.S. Аналогично можно сделать для показателей схем мотивации,  а также убрать их из редактора формул. Для этого пропишите в общей форме «Редактор формула расчета» в процедуре «ЗаполнитьТаблицуПоказателей» такое условие:

Если ВидПВР = "ПлановыеУдержанияРаботниковОрганизаций" Или ВидПВР = "ПлановыеУдержанияРаботников" Или ВидПВР = "ПлановыеДополнительныеНачисленияРаботниковОрганизаций" Тогда
    Запрос.Текст = Запрос.Текст + Символы.ПС + "И ПоказателиСхемМотивации.Актуальность";
Иначе
    Запрос.Текст = Запрос.Текст + Символы.ПС + "ГДЕ ПоказателиСхемМотивации.Актуальность"; 
КонецЕсли; 

Мои работы:

Общее

Перенос данных XML с Анализом и выборочной загрузкой.

Универсальный редактор таблиц и движения документа (LITE) (Обычная Форма)

Универсальный редактор таблиц и движения документа (PRO) (Обычная Форма)

Универсальный редактор Таблиц и Движений документов (Управляемая форма)

Запуск 1С под другим пользователем без пароля.

 

Управление торговлей 11

Установка цен в УТ11. Произвольный запрос к данным ИБ

 

ЗУП 2.5

Скрываем неиспользуемые виды расчета

Резервы отпусков в Документе "Отражение Зарплаты в Регламентированном Учете" (Оценочные Обязательства)

 

Комплексная И УПП

Форма работы с сотрудниками, как из зуп 2.5

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. karpik666 2812 22.07.15 12:48 Сейчас в теме
Если кому будет интересно могу выложить пример реализации
2. DoctorRoza 22.07.15 17:01 Сейчас в теме
Хм .. а на сколько это актуально? Скрывать уволенных сотрудников - это да, элементов то много. А вот элементы ПВР, сомнительно.
3. karpik666 2812 22.07.15 17:10 Сейчас в теме
(2) DoctorRoza, ну к примеру в торговой организации, где используется множество разных схем мотивации и они постоянно меняются. Да и просто, если база старая, то в ней очень большое количество разных видов расчета, как используемых так и нет. Почему бы не оставить расчетчикам только используемые виды расчета, что упростит подбор их в документы.
9. DoctorRoza 23.07.15 09:01 Сейчас в теме
(3) ИМХО, Ваша доработка хороша как лабораторная работа, не больше. Почему? Ну хотя бы потому, что спрятанные элементы могут быть востребованы в будущем! На дубли ФИО ЗУП еще среагирует, мол, есть уже такой, тут же нет! Значит, опять дорабатывать!? Хм .. сомнительно!
10. karpik666 2812 23.07.15 10:17 Сейчас в теме
(9) DoctorRoza, на такие случаи есть кнопка "показывать скрытые показатели". Никто не мешает, когда человек заводит новый вид расчета просто отобразить другие виды расчета из списка, при желании их можно восстановить.Некоторые программно правят формулы видов расчета, хотя по ним уже есть рассчитанные документы, а я их просто скрываю.
4. Константин С. 623 22.07.15 17:34 Сейчас в теме
Есть решение с минимальными доработками!

Столько букв, называется минимальные доработки !!!!!))))

Минимально, это добавил реквизит и при открытии формы списка сделал включение отбора по колонке (реквизиту).
5. karpik666 2812 22.07.15 17:43 Сейчас в теме
(4) Константин С., а вы прочли статью? по сути здесь тоже самое, но сделано так, чтобы минимизировать затраты при обновлении. Плюс мой вариант более навороченный, так как в вашем нужно писать код в обработчик события "при открытии", у меня же это отдельная процедура. Также я добавил возможность интерактивного скрытия вида расчета из списка, и возможность просмотра скрытых элементов, а также их графическое выделения и все это с минимальным изменением типового кода.
6. karpik666 2812 22.07.15 17:46 Сейчас в теме
(4) Константин С., наверное неправильное название, лучше написать" с минимальными затратами при последующих обновлениях". Кстати, такую реализацию можно экстраполировать и на другие справочники, например, скрытие неиспользуемых контрагентов, или скрытие номенклатуры.
7. Константин С. 623 22.07.15 18:08 Сейчас в теме
минимальными затратами при последующих обновлениях"

ага сравнить 12 пунктов по внесению изменений и 2-мя.
Описанное мной решение также не проблемно в обновлении.

более навороченный,

больше вероятности запутаться
8. karpik666 2812 22.07.15 18:35 Сейчас в теме
(7) Константин С., каждому свое, если вас устраивает ваш вариант пользуйтесь им, меня устраивает мой. тем более он уже проверен на реальных базах и с реальными обновлениями.
больше вероятности запутаться
- здесь-то уж точно не запутаться, от желающего внедрить данную возможность требуется только копировать и вставить свою базу.
11. karpik666 2812 23.07.15 11:41 Сейчас в теме
karpik666, для примера, выкладываю конфигурацию с выполненными изменениями. Из нее можно почерпнуть, как переопределять обработчики событий формы, и программно генерировать новые элементы формы
Прикрепленные файлы:
ПримерРеализацииАрхиваВПвр.cf
12. ccserg 38 31.07.15 10:26 Сейчас в теме
копируем алгоритм справочника Сотрудники и всё ))
спрятать в архив
у меня так сделано
13. karpik666 2812 31.07.15 12:46 Сейчас в теме
(12) ccserg, посмотрите прикрепленный файл в комментарии выше, у меня сделано также, как вы сказали, но при минимуме правки типовой конфигурации. В принципе этот алгоритм можно вставить и в справочник номенклатуры или для контрагентов
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    5386    ids79    25       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    7335    John_d    21       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    24011    ids79    45       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    15709    YPermitin    76       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    18238    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    33104    ids79    36       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    18325    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    27078    ids79    9       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    19577    ids79    27       

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    14813    YPermitin    12       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    12080    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    31704    ids79    17       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    16909    dmurk    144       

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    27220    YPermitin    27       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    17255    Eret1k    23       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    9287    m-rv    2       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    12418    m-rv    16       

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    23381    ellavs    125       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    18548    ellavs    83       

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    20404    YPermitin    53       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    24528    ids79    9