Ускорение отладки управляемых форм

Публикация № 359640

Разработка - Практика программирования

Отладка управляемые формы

Ускорение отладки управляемых форм в больших неповоротливых конфигурациях, когда заказчик просит что-то и сам не знает, что из этого получится.

При разработке/изменении форм для документов и справочников в больших конфигурациях встает вопрос о постоянном сохранении всей конфигурации.
Пользователь часто просит "давай добавим здесь так и так", а потом "нет, так не пойдет, давай вернем все назад и добавим вот так" :)
Для ускорения процесса работы в таких случаях предлагаю следующий вариант:

1. В конфигурацию надо добавить:

1.1. Константа.РежимВнешнихФорм (тип Число 1.0)
1.2. Константа.КаталогИБ (тип Строка 0)

КаталогИБ нужен только для серверного варианта работы БД, в файловом варианте он не используется. В этой константе должен быть расшаренный сетевой каталог доступный как для программиста, так и для пользователя, который тестирует форму.

1.3. ОбщийМодуль.ВнешниеФормы (Сервер,Вызов сервера)
 

код общего модуля:

// Используется для запуска и отладки внешних форм

Функция КаталогИБ() Экспорт
	
	Результат = НСтр(СтрокаСоединенияИнформационнойБазы(), "File") + "\";
	Если (Результат="\") Тогда
		Результат = СокрЛП(Константы.КаталогИБ.Получить());
	КонецЕсли;
	Возврат Результат;
	
КонецФункции

Функция РежимВнешнихФорм(ПолноеИмяФормы) Экспорт
	
	Если (Найти(ПолноеИмяФормы,"Внешн")=1) Тогда Возврат 0; КонецЕсли; // вызов из самой внешней формы, защита от зацикливания 
	Возврат Константы.РежимВнешнихФорм.Получить();
	
КонецФункции

Функция ВернутьИмяФайлаВнешнейФормы(ПолноеИмяФормы) Экспорт
	
	// Преобразуем имя формы в полный путь к внешней обработке с формами
	// здесь ПолноеИмяФормы = Документ.АвансовыйОтчет.Форма.ФормаДокумента
	Результат = "";
	Если (РежимВнешнихФорм(ПолноеИмяФормы)=1) Тогда
		ИмяМетаданных = Лев(ПолноеИмяФормы,Найти(ПолноеИмяФормы,".Форма")-1);
		Префикс  = "";
		Если      (Найти(ИмяМетаданных,"Документ")=1)   Тогда Результат = "МФД\"; Префикс = "Документ.";
		ИначеЕсли (Найти(ИмяМетаданных,"Справочник")=1) Тогда Результат = "МФС\"; Префикс = "Справочник.";
		КонецЕсли;
		Если (Префикс<>"") Тогда
			Результат = КаталогИБ() + "Epfs\" + Результат + СтрЗаменить(ИмяМетаданных,Префикс,"") + ".epf";
		КонецЕсли;
	КонецЕсли;
	Возврат Результат;
	
КонецФункции

Функция ПодключитьВнешнююОбработку(мАдресХранилища,ПолноеИмяФормы) Экспорт
	
	Результат = ВнешниеОбработки.Подключить(мАдресХранилища,,Ложь);
	Стр       = Прав(ПолноеИмяФормы,СтрДлина(ПолноеИмяФормы) - Найти(ПолноеИмяФормы,".Форма.") + 1);
	Возврат "ВнешняяОбработка." + Результат + Стр;
	
КонецФункции

2. Открываем Форму элемента справочника (покажу на примере справочника Контрагенты) , и добавляем немного кода в начало двух процедур. Если процедур нет, то их надо создать.

В начало процедуры ПриСозданииНаСервере добавляем:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	// вставка для режима отладки с помощью внешних форм
	Если (ВнешниеФормы.РежимВнешнихФорм(ИмяФормы)=1) Тогда Возврат; КонецЕсли;

В начало процедуры ПриОткрытии добавляем:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	// вставка для режима отладки с помощью внешних форм
	ИмяФайла = ВнешниеФормы.ВернутьИмяФайлаВнешнейФормы(ИмяФормы);
	Если (ИмяФайла<>"") Тогда
	    мАдресХранилища   = ""; ПоместитьФайл(мАдресХранилища, ИмяФайла, , Ложь, Новый УникальныйИдентификатор);
	    ПутьКВнешнейФорме = ВнешниеФормы.ПодключитьВнешнююОбработку(мАдресХранилища,ИмяФормы);
		ПараметрыФормы    = Новый Структура("Ключ", Объект.Ссылка);
		ОткрытьФорму(ПутьКВнешнейФорме, ПараметрыФормы,,Истина);
		Отказ = 1;
		Возврат;
	КонецЕсли;


3. Создаем новую внешнюю обработку, сохраняем ее так как изображено на первом рисунке к публикации.

Копируем форму элемента в обработку так как изображено на втором рисунке к публикации. Сохраняем обработку и конфигурацию.

4. Теперь программист с помощью константы РежимВнешнихФорм может подменять запуск формы для пользователя и для себя.

Если РежимВнешнихФорм=1 , то при открытии элемента справочника будет запускаться форма из внешней обработки.

После отладки внешней управляемой формы и урегулирования вопросов с заказчиком, можно просто скопировать форму назад в конфигурацию, выбрать ее основной и сохранить конфигурацию. При копировании из обработки в конфигурацию и обратно надо учитывать что форма будет иметь другое название, я просто удаляю старую форму и вставляю новую.
Данный подход удобен когда нововведения оказались не нужны, просто меняем РежимВнешнихФорм=0 и пользователь видит прежнюю форму.

5. Хочу обратить ваше внимание на работу с отладчиком при данном подходе. Отладчик не будет срабатывать, т.к. на клиенте запускается обработка из хранилища. Для решения данной проблемы я запускаю обработку через файл-открыть и точки останова работают. Но форма элемента будет запускаться как для нового объекта. Чтобы открытие формы сработало с тестируемым элементом справочника или определенным документм надо добавить такой код:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	// вставка для режима отладки с помощью внешних форм
	Если (ВнешниеФормы.РежимВнешнихФорм(ИмяФормы)=1) Тогда Возврат; КонецЕсли;
        Если (Найти(ИмяФормы,"ВнешняяОбработка")=1) Тогда
		// для отладки установим конкретный документ
		Док = Документы.Счет.НайтиПоНомеру("000000026",ТекущаяДата());
		Если (ЗначениеЗаполнено(Док)) Тогда
			ЗначениеВРеквизитФормы(Док.ПолучитьОбъект(), "Объект");
		КонецЕсли;
	КонецЕсли;

6. В ходе эксплуатации данного подхода выявлено два важных момента:


   а.) "РежимОткрытияОкна" должен быть равен "Независимый", иначе не будет открываться форма из внешней обработки.

   б.) Событие "ПриЧтенииНаСервере" не срабатывает при запуске формы из внешней обработке.

 

Вот и весь метод ускорения отладки управляемых форм.
Аналогично можно тестировать и формы списов и другие формы. Главное, чтобы имя формы в конфигурации совпадало именем формы в обработке.

Спасибо за внимание.

Надеюсь, данный метод поможет программистам 1С в наших рутинных делах. :)

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. jobkostya1c8 25.05.15 07:49 Сейчас в теме
Что-то новенькое и интересное. Все-таки хотелось бы спросить знающих людей имеет ли смысл на практическое применение подобной методики.
Пока вот ерундой занят, а не крупным проектом с использованием хранилища значений. УПП мельком попадалось, но там что-то встраивать, думаю, еще дороже по времени.
3. moolex 818 25.05.15 10:14 Сейчас в теме
(1) kostyaomsk, У нас в одной компании все пользователи работают на внешних обработках в реальной базе (правда там 8.1 обычные формы, но зато даже проведение вынесено во внешние обработки). При таком подходе обновления проходит быстро, пользователю просто надо переоткрыть конкретную форму (что им удобно), изменения именно в конфигурации бывают редко, а вот изменения в формах (особенно отчетов) происходит постоянно.
А вообще работа с большим количество внешних файлов - так работают многие IDE.
Думаю и 1С наконец-то это скоро поймет при их планах скрещивания 1С с Eclipse.
4. Зеленоград 13.07.15 17:30 Сейчас в теме
(1) kostyaomsk, в УПП (минимум на 90%) используются нормальные формы. УФ если и есть, то редко.
2. vitaliy1911 30 25.05.15 09:53 Сейчас в теме
Если речь идет только о разработке, без обновления основной рабочей базы, то мне кажется удобнее использовать просто внешнюю обработку. Добавляем форму в обработку и в обработчике формы ПриСозданииНаСервере пишем:
ЗначениеВРеквизитФормы(Документы.Документ1.НайтиПоНомеру("<Номер>").ПолучитьОбъект(), "Объект");

Просто и сердито, без единой строки в самой конфигурации. Разрабатываем, тестируем, отлаживаем. Потом перед помещением формы в конфу главное не забыть эту строчку удалить :)
А предложенный метод хорошо подойдет если требуется проанализировать работу пользователей в новой форме. Например можно сделать AB тест - часть пользователей будет работать в новой форме, а часть - в старой (или в другой новой). Далее собирать статистику и принимать решение какую форму использовать
murenysh; budunovmv; ffgnebel; Marik; sanja; Rego1337h; +6 Ответить
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    4480    John_d    18       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    8120    YPermitin    71       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    21013    ids79    45       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    13058    YPermitin    70       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    16377    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    26973    ids79    34       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    16481    avalakh    21       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    22850    ids79    8       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    17345    ids79    27       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    13461    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11517    SeiOkami    49       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    28940    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    15898    dmurk    144       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    25039    YPermitin    27       

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    15945    Eret1k    23       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    8841    m-rv    2       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11835    m-rv    16       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    21613    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    17493    ellavs    83       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    19098    YPermitin    53