Пример работы с заголовками HTTP-запросов: загрузка версий программ с users.v8.1c.ru

Публикация № 255881

Разработка - Системная интеграция - Интеграция с WEB

HTTP-запросы заголовки users.v8.1c.ru релизы версии rest

Узнайте больше о HTTP-запросах и о программной работе с сайтами, требующими авторизацию

На написание этой статьи сподвигли два фактора:

1. Весной 2013 в версии платформы 8.2.18 появились новые возможности языка:

Реализована возможность работы с заголовками HTTP-запросов, обработки кодов возврата, получения и установки тела запроса в виде строки или двоичных данных. Реализованы объекты HTTPЗапрос, HTTPОтвет.
В объекте HTTPСоединение реализованы следующие изменения:
Методы Записать(), ОтправитьДляОбработки(), Получить(), Удалить() возвращают значение типа HTTPОтвет;
Для методов Записать(), ОтправитьДляОбработки(), Получить(), Удалить() реализован синтаксис, позволяющий использовать программно сформированный HTTP-запрос.

2. В декабре 2013 из 1С-зазеркалья вышли две новости:

Автоматический REST интерфейс прикладных решений http://v8.1c.ru/o7/201312rest/index.htm и HTTP-сервисы в прикладном решении http://v8.1c.ru/o7/201312http/index.htm

Т.е. скоро мы получим инструмент с возможностями COM-соединения и WEB-сервисов одновременно. Задачи интеграции станут интереснее, появятся новые возможности, а это не может не радовать true-программиста! Поскольку для  работы со сторонними REST сервисами можно использовать имеющиеся в платформе средства работы с HTTP: объекты HTTPСоединениеHTTPЗапрос и HTTPОтвет, предлагаю рассмотреть эти методы чуть подробней, а в конце решить прикладную задачку: программно авторизоваться на страничке https://users.v8.1c.ru/distribution/total, распарсить ее и заполнить справочники Программы и Версии. Результат прикреплен к этой статье в виде конфигурации. Запускать ее можно на платформе не ниже 8.2.18.

Что такое HTTP - запросы? Мы с ними сталкиваемся каждый день.

Для начала предлагаю открыть Инструменты разработчика в браузере Yandex - кнопками Ctrl-Shift-I и перейти на закладку Network - именно здесь можно увидеть содержимое HTTP-запросов

Например, когда в браузере вводим адрес сайта https://login.1c.ru/loginна сервер уходит HTTP-запрос типа GET:

Request URLhttps://login.1c.ru/login
Request Method: GET

Request Headers:
Host: login.1c.ru
Connection: keep-alive 
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.12785 YaBrowser/13.12.1599.12785 Safari/537.36 
Accept-Encoding: gzip,deflate,sdch Accept-Language: ru,en;q=0.8

В 1С у HTTP-запроса типа GET есть вполне конкретный аналог: метод объекта HTTPСоединение.Получить(<HTTPЗапрос>)
А у объекта HTTPЗапрос есть свойства:
АдресРесурса типа Строка (он же 
Request URL)
и Заголовки типа Соответствие (он же 
Request Headers)

В ответ на этот запрос сервер возвращает браузеру HTTP-ответ:

Status Code: 200
Responce Headers:
Server: nginx

Date: Tue, 04 Feb 2014 07:36:25 GMT
Content-Type: text/html;charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Pragma: no-cache
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Cache-Control: no-cache
Cache-Control: no-store
Set-Cookie: JSESSIONID=AAEB3E82351662F43E37CE3F64B7795E.login1c8010; Path=/; Secure; HttpOnly
Content-Language: ru
Content-Encoding: gzip

И тело ответа, в котором содержится код запрошенной страницы на HTML (см закладку Response в Инструментах разработчика Yandex браузера)

В 1С метод HTTPСоединение.Получить(<HTTPЗапрос>) возвращает объект типа HTTPОтвет, у которого соответственно есть свойства:
КодСостяния (он же Status Code)
Заголовки (он же Responce Headers)
и метод ПолучитьТелоКакСтроку() (он же тело ответа - Response)

Когда на страничке https://login.1c.ru/login вводим логин/пароль и нажимаем кнопку Войти, то на сервер уходит HTTP-запрос типа POST:

Request URL: https://login.1c.ru/login;jsessionid=AAEB3E82351662F43E37CE3F64B7795E.login1c8010
Request Method: POST
Request Headers:
POST /login;jsessionid=AAEB3E82351662F43E37CE3F64B7795E.login1c8010 HTTP/1.1

Host: login.1c.ru
Connection: keep-alive
Content-Length: 122
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Origin: https://login.1c.ru
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.12785 YaBrowser/13.12.1599.12785 Safari/537.36
Content-Type: application/x-www-form-urlencoded
Referer: https://login.1c.ru/login
Accept-Encoding: gzip,deflate,sdch
Accept-Language: ru,en;q=0.8
Cookie: JSESSIONID=AAEB3E82351662F43E37CE3F64B7795E.login1c8010
Form Data или Request Body или Тело запроса:
inviteCode=&lt=LT-43557-KdRxeZdJGp2n25STSoj6meIPL09eYv&execution=e1s1&_eventId=submit&username=Barelpro&password=123

В 1С у HTTP-запроса типа POST есть вполне конкретный аналог: метод объекта HTTPСоединение.ОтправитьДляОбработки(<HTTPЗапрос>)
А у объекта HTTPЗапрос, кроме свойств АдресРесурса и Заголовки можно задать тело запроса (Request Body) с помощью метода УстановитьТелоИзСтроки()

 
Во всех этих нагромождениях полей заголовков нас интересуют только некоторые поля в контексте нашей задачки. 
 
Что происходит при первом входе на страничку https://login.1c.ru/login
сервер открывает Java-сессию и присваивает ей идентификатор JSESSIONID, значение которого передает через поле Set-Cookie в заголовке ответа. 
 
Что происходит при заполнении полей Логин и Пароль и нажатии на кнопку Войти:
Браузер передает серверу идентификатор сессии JSESSIONID через параметр Cookie, а логин и пароль через параметр inviteCode
 
Если авторизация сессии прошла удачно, то во всех следующих запросах достаточно использовать только идентификатор JSESSIONID. А если таймаут между запросами будет больше установленного на сервере, то время сессии истечет и придется повторять авторизацию заново.
 
Конечно при практической реализации нашей задачки пришлось встретиться с небольшими сложностями, которые в итоге удалось преодолеть:
 
Так, чтобы пройти от страницы авторизации  https://login.1c.ru/login до целевой страницы https://users.v8.1c.ru/distribution/total пришлось выполнить целых 8 HTTP-запросов (см процедуру НайтиJSESSIONID()). Но эту задачу сильно упростила еще одна особенность: в заголовке ответа сервер присылает поле Location, в котором содержится адрес следующего необходимого запроса, своего рода редирект на следующую страницу, в некоторых случаях с дополнительными параметрами, например:
 
В итоге надо выполнять запросы по адресу, указанному в Location до тех пор, пока не придет ответ без Location. В данном случае такова особенность реализации защиты сайта 1С: пройти 8 запросов и в трех местах создать три различные Java-Сессии.
 
Еще одна особенность: в теле HTML-кода на страничке https://login.1c.ru/login заключены скрытые параметры, которые надо распарсить и включить в тело POST-запроса при передаче логина/пароля в inviteCode=&lt=LT-43557-KdRxeZdJGp2n25STSoj6meIPL09eYv&execution=e1s1&_eventId=submit&username=Barelpro&password=123 (см процедуры РаспарситьinviteCode() и РекурсивныйПарсингСтраницыЛогина())

Дальнейший парсинг странички https://users.v8.1c.ru/distribution/total я делал через объект ПостроительDOM в рекурсивной процедуре РекурсивныйПарсингСпискаКонфигураций(), а парсинг страниц с версиями делал в рекурсивной процедуре РекурсивныйПарсингСпискаВерсий().

Для запуска обработки ЗагрузкаПрограммИВерсий используйте кнопку "Загрузить" в командной панели справочника Программы. В обработке заполните поля логин/пароль для доступа к сайту 1С и нажмите по очереди кнопки "Загрузить программы" и "Загрузить версии".

В общем, как видите, в доступе к запароленным сайтам нет ничего сложного, пользуйтесь на здоровье, удачи!

 
DISCLAIMER:
 
1. Не пытайтесь для доступа к сайту 1С использовать логин Barelpro и пароль 123. Я его привел для примера. У вас должен быть свой доступ:
- или у вас есть официальный 1С-продукт и доступ к обновлениям 1С через регистрационный номер и пароль
- или вы сотрудник компании-партнера 1С, у вас есть хотя бы один сертификат типа Спец и вам руководство открыло доступ почти ко всем к обновлениям (кроме некоторых специфических, типа "Корпоративный инструментальный пакет 8")
 
2. Конечно, существует механизм получения обновлений, встроенный во все современные типовые конфигурации 1С. Например, для "1С:Конвертация данных" скачиваем архив http://downloads.1c.ru/ipp/ITSREPV/V8Update/Configs/Conversion/21/82/v8upd11.zip, в нем лежит файлик v8cscdsc.xml, в котором указаны названия и пути скачивания всех обновлений данного продукта. Но, во-первых, не для всех программ выложены такие файлики. А во-вторых, надо еще где-то узнать адреса к v8upd11.zip для всех 466 конфигураций!
 
3. Зачем это может быть нужно? Ну, например, в моей компании есть служба Регулярного сопровождения (в просторечье ИТС). Сервис-инженеры при установке обновлений типовых конфигураций у клиентов должны в обязательном порядке указывать в своей учетной базе релиз конфигурации до и после обновления. Для этого можно использовать справочник Версии из моей конфигурации. А обновлять этот справочник можно ежедневно через регламентные задачи, исключив таким образом человеческий фактор.


PS от 01.09.2014. Выпущена версия 2. 1С слегка изменила алгоритм авторизации, пришлось слегка переписать код, попутно удалось уменьшить количество запросов с 8 до 4.

PS от 27.08.2015. Выпущена версия 3. 1С изменила дизайн и адреса.

PS от 02.09.2015. Выпущена версия 4. 1С изменила авторизацию.

PS от 08.09.2015. Выпущена версия 5. Оптимизирован код. Заменены методы рекурсивных парсингов на конструкции ПолучитьЭлементПоИдентификатору и ПолучитьЭлементыПоИмени. Старые функции остались закоментированными.

PS от 12.02.2018. Выпущена версия 6. 1С изменила авторизацию.

PS от 27.12.2019. Выпущена версия 8. 1С изменила авторизацию.

Скачать файлы

Наименование Файл Версия Размер
загрузка версий программ с users.v8.1c.ru v8.cf

.cf 24,15Kb
646
.cf 8 24,15Kb 646 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. artspeed 178 05.02.14 05:26 Сейчас в теме
Скачал, развернул конфу, открыл, ввел логин и пароль. Загрузка версий - кнопочка просто не работает. Загрузка - программ - долго думает и заканчивает свое действие без результата((

В общем не работоспособная конфа((
Очень жаль

Испытывал на 8.2.19.80
2. barelpro 1201 05.02.14 08:36 Сейчас в теме
(1) artspeed,

Что-то с вашим логином и паролем не так. В браузере со страницы login.1c.ru куда он приводит? Отладчиком на какой строке зависает? Дайте больше информации!
6. barelpro 1201 05.02.14 11:14 Сейчас в теме
(1) artspeed, (3) arteast,

Проблема решена, выложено обновление от 05.02.2014 11:54
Повторная закачка не списывает стартмани :)
73. info@itshkola.com 21.03.16 21:37 Сейчас в теме
3. arteast 106 05.02.14 09:53 Сейчас в теме
Не работает.
В режиме Предприятия вообще никаких действий не производит.
Пробовал на платформе 1С:Предприятие 8.3 (8.3.4.389).

В отладке:
Соединение проходит удачно, авторизация тоже...а вот дальше
http://joxi.ru/xNHxUv3JTJBmeSOOWH4
5. barelpro 1201 05.02.14 10:20 Сейчас в теме
(3) arteast,

мне чтобы понять, что не так, нужен ваш логин-пароль. Пришлите в личку, потом поменяете.
4. StaticUnsafe 05.02.14 10:19 Сейчас в теме
7. pahich 617 05.02.14 16:30 Сейчас в теме
Спасибо, забрал в личную коллекцию )
8. barelpro 1201 05.02.14 16:32 Сейчас в теме
Люди, скачали уже 23 человека, скажите хоть работает? успокойте меня! )))))
9. John_d 3148 05.02.14 16:49 Сейчас в теме
Спасибо за статью. Все работает.
Круто можно методом пост отправлять данные из 1с на сайт без посредников)
Alexoniq; barelpro; +2 Ответить
10. John_d 3148 05.02.14 17:48 Сейчас в теме
Можете подсказать как правильно указать параметры post? чтобы они в глобальный массив post пришли на сайте
так:
HTTPЗапрос1.Заголовки.Вставить("name=" + name + "&col=" + kol);
11. barelpro 1201 05.02.14 18:29 Сейчас в теме
(10)
Если запрос Post, то обязательно должно быть заполнено тело запроса через УстановитьТелоИзСтроки. Например, так:

HTTPЗапрос2 = Новый HTTPЗапрос;
HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
HTTPЗапрос2.УстановитьТелоИзСтроки("name=" + name + "&col=" + kol);
HTTPЗапрос2.АдресРесурса = "/login";

Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
ОтветHTTP = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);
15. John_d 3148 06.02.14 11:49 Сейчас в теме
12. almas 199 05.02.14 21:31 Сейчас в теме
Спасибо. Очень актуальная тема.
13. Aleksey.Bochkov 3454 05.02.14 23:36 Сейчас в теме
По поводу списка файлов обновлений - конфигуратор умеет искать нужные обновления на серверах 1С, т.е. общий список есть.
Вот он (конфигуратор к нему обращается) - http://downloads.v8.1c.ru/tmplts/v8cscdsc.lst
Раньше точно работало, сейчас пишет что файла нет. Или я не те логин-пароль использую, или ошибка у 1С из-за перестройки ресурсов.
Прикрепленные файлы:
14. barelpro 1201 06.02.14 00:24 Сейчас в теме
(13) Aleksey.Bochkov,

если найдете путь к файлу с общим списком обновлений - получите огромный респект от всего сообщества 1С :)
72. biformatus 20.02.16 21:50 Сейчас в теме
(14) Чтобы качнуть этот файл нужна в качестве UserAgent указать 1с:Предприятие.
16. artspeed 178 06.02.14 15:08 Сейчас в теме
Отлично. Действительно после обновления загрузка стала работать.
За это вам жирный "+"
По мне так: Что бы развивать программу можно сделать так:

Вместо одного логина/пасса от личного кабинет users.v8.1c.ru - сделать несколько учетных данных.
Т.е. я подписан, например на бюджет, хозрасчет, УТ под разными личными кабинетами.
Ваша программа последовательно открывает все учетки, скачивает заголовки, затем в таблице значений сворачивает по точным наименованиям. Ну как то так.
Таким образом мы получим более точный список ВСЕХ (тех, на которые есть подписка в одном/нескольких личных кабинетах) конфигураций

НУ и наверное последнее: Осталось включить возможность скачивать конфигурации, или на крайний случай получать "КОНЕЧНУЮ ПРЯМУЮ ССЫЛКУ НА ОБНОВЛЕНИЕ", а не рыскать каждый раз по сайту.
т.е. отметили галочками, какие конфигурации необходимо скачать и пошли чай пить. В программе предварительно в настройках в справочнике задаем конечные пути скачки.
По нажатию "скачать" скачиваем обновления, которые уже рассованы по нужным папкам, и спокойно едем обновляться.

Извиняюсь за извращения, люблю это дело))
17. barelpro 1201 06.02.14 19:16 Сейчас в теме
(16) artspeed,

Алексей, не вижу никаких извращений, вполне дельные требования к разработке. Надо только правильно спозиционироваться на целевой аудитории - кому такая разработка будет интересна - и вперед!
Что касается меня - я писал статью из просветительских побуждений. Если найдется смельчак доработать мою конфу - с удовольствием передам ему неисключительные права на нее (достаточно просто сослаться на меня) :)
18. artspeed 178 07.02.14 04:20 Сейчас в теме
(17) проанализировал вашу конфу и запрос HTML. 1С-ники очень хитро генерируют ссылку на скачивание. Предполагаю java скриптом... С разных сторон подходил, но так конечную ссылку не получилось выудить...
19. slavik27 14 08.02.14 15:21 Сейчас в теме
(16) artspeed, есть такой функционал http://infostart.ru/public/197576/
сейчас дорабатываем на переделанный сайт 1с, немного изменили пути
35. buganov 157 29.05.14 19:56 Сейчас в теме
(19) slavik27, за две тысячи? Есть бесплатные аналоги не хуже )
20. opx 677 09.02.14 12:21 Сейчас в теме
А может знает кто как реализовать автоматический редирект. Например при Oauth авторизации осуществляется редирект, а HTTPОтвет возвращает код 302. Было бы неплохо реализовать редирект автоматически. Как это сделать вручную я не сообразил.
21. barelpro 1201 09.02.14 12:46 Сейчас в теме
(20) opx,

В моем примере как раз редирект отрабатывается. На скриншоте посмотрите, код ответа 302, сервер возвращает в шапке ответа поле Location, в котором указан адрес редиректа
22. fuxic 294 10.02.14 12:30 Сейчас в теме
Тема отличная, только начал веб-программированием увлекаться. Спасибо
23. iov 410 10.02.14 14:55 Сейчас в теме
Спасибо. очень доходчиво.
24. DrAku1a 1418 11.02.14 10:18 Сейчас в теме
Все работает. Спасибо!
Осталось сделать загрузчик новых вышедших обновлений и информер =)
26. barelpro 1201 13.02.14 12:30 Сейчас в теме
(24) DrAku1a,
не хочу ломать бизнес тем, кто берет за информер деньги :)
27. DrAku1a 1418 13.02.14 18:40 Сейчас в теме
(26) за информер - да, а за загрузчик?
кстати, можно сделать иерархический список (как на картинке)

1. Справочник "Программы" делаем иерархическим (нужен один уровень иерархии).

2. Немного корректируем процедуру в форме обработки "ЗагрузкаПрограммИВерсий":
Процедура РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)
	
	ТекИмяГруппы = "";
	ТекГруппа = Справочники.Программы.ПустаяСсылка();
	Для Каждого ЭлДок Из ДокументHTML.ДочерниеУзлы Цикл
		
		Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
				
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество()=1 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);
				КонецЕсли;
				
				ТекЯчейка = СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0];
				Если ТипЗнч(ТекЯчейка) = Тип("ЭлементЯкорьHTML") Тогда
					
					Если ТекИмяГруппы<>"" Тогда
						Если СокрЛП(ТекГруппа.Наименование)<>ТекИмяГруппы Тогда
							Запрос = Новый Запрос;
							Запрос.УстановитьПараметр("Название", ТекИмяГруппы);
							Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
							               |	Программы.Ссылка
							               |ИЗ
							               |	Справочник.Программы КАК Программы
							               |ГДЕ
							               |	Программы.НазваниеПолное ПОДОБНО &Название
							               |	И Программы.ЭтоГруппа";
							Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
							Если Выборка.Следующий() Тогда
								ТекГруппа = Выборка.Ссылка;
							Иначе
								НовГруппа = Справочники.Программы.СоздатьГруппу();
								НовГруппа.Наименование = ТекИмяГруппы;
								НовГруппа.Записать();
								ТекГруппа = НовГруппа.Ссылка;
							КонецЕсли;
						КонецЕсли;
					КонецЕсли;
					
					Название = СокрЛП(ТекЯчейка.ТекстовоеСодержимое);
					ГиперСсылка = ТекЯчейка.ГиперСсылка;
					
					Запрос = Новый Запрос;
					Запрос.УстановитьПараметр("Название", Название);
					Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
					               |	Программы.Ссылка,
					               |	Программы.Родитель
					               |ИЗ
					               |	Справочник.Программы КАК Программы
					               |ГДЕ
					               |	Программы.НазваниеПолное ПОДОБНО &Название
					               |	И НЕ Программы.ЭтоГруппа";
					Выборка = Запрос.Выполнить().Выбрать();
					Если Выборка.Количество() = 0 Тогда
						
						НовыйСправочник = Справочники.Программы.СоздатьЭлемент();
						НовыйСправочник.Наименование = Название;
						НовыйСправочник.НазваниеПолное = Название;
						НовыйСправочник.ГиперСсылка = ГиперСсылка;
						НовыйСправочник.Родитель = ТекГруппа;
						НовыйСправочник.Записать();
						
						Загружено = Загружено + 1;
					Иначе
						
						Выборка.Выбрать();
						Пока Выборка.Следующий() Цикл
							Если Выборка.Родитель<>ТекГруппа Тогда
								НовыйСправочник = Выборка.Ссылка.ПолучитьОбъект();
								НовыйСправочник.Родитель = ТекГруппа;
								НовыйСправочник.Записать();
							КонецЕсли;
						КонецЦикла;

					КонецЕсли;
					
				КонецЕсли;
			КонецЦикла;
			Возврат;
		КонецЕсли;
			
		Если ЭлДок.ЕстьДочерниеУзлы() Тогда
			
			РекурсивныйПарсингСпискаКонфигураций(ЭлДок);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
Показать


3. В самой форме перенастроить список - режим вывода: дерево, разворачивать все уровни.
Прикрепленные файлы:
25. soap 61 13.02.14 12:22 Сейчас в теме
Спасибо ОЧЕНЬ информативно. Будем использовать!
28. DrAku1a 1418 13.02.14 18:58 Сейчас в теме
(0) Да, и ещё вопрос автору: Чем пользовались для составления процедур парсинга?
Т.е. вижу по коду, что с помощью ЧтениеHTML и ПостроительDOM создавали объектную модель HTML-документа и дальше с ней работали...
Вопрос в том - с помощью какого вьювера просматривали DOM?
29. barelpro 1201 13.02.14 22:34 Сейчас в теме
(28) DrAku1a, хороший вопрос!

был бы вьюер, сэкономил бы 15 минут жизни :)
А так все по наитию
30. seermak 662 05.03.14 08:22 Сейчас в теме
31. x_under 14 26.03.14 17:04 Сейчас в теме
Супер! Встраиваем в свою конфигурацию для ИТСников.
32. laeg 13 18.04.14 20:53 Сейчас в теме
Огромное спасибо за вашу работу. Взял за основу вашу разработку, переделал конечно структуру, версии перенес в РС, переделал справочник Программ, сделал функцию обновления, подцепил к регламенту - в итоге свои идеи воплотил в вашу разработку :)

Прикрепленные файлы:
33. lnnd 8 08.05.14 13:50 Сейчас в теме
Можно еще больше оптимизировать, в место рекурсии обработать ДокументHTML одним циклом c получением всех данных
В цикле заполняется: Название, гиперссылка, номер версии, дата выхода, планируемый номер версии, планируемая дата выхода, планируемая дата обновления данных, ознакомительный номер версии, дата выхода ознакомительной версии

В место процедуры РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)

Процедура ЗаполнитьДанные(ДокументHTML, ТаблицаДанных)
	
	ТекГруппа = "";
	
	ЭлементыDOM = ДокументHTML.ПолучитьЭлементыПоИмени("td");
		
	Для Каждого Элемент Из ЭлементыDOM Цикл
				
		Если Элемент.ИмяКласса = "groupColumn" Тогда
						
			ИндексКолонки = 1;
			ТекГруппа = СокрЛП(Элемент.ТекстовоеСодержимое);
			
			Продолжить;
			
		КонецЕсли;
		
		Если Элемент.ИмяКласса = "nameColumn" Тогда
			
			НоваяСтрока = ТаблицаДанных.Добавить();
			
			НоваяСтрока.Группа = ТекГруппа;
			НоваяСтрока.Название = СокрЛП(Элемент.ТекстовоеСодержимое);
			
			Если ТипЗнч(Элемент.ДочерниеУзлы[0]) = Тип("ЭлементЯкорьHTML") Тогда
			    НоваяСтрока.Гиперcсылка = СокрЛП(Элемент.ДочерниеУзлы[0].Гиперссылка);
			КонецЕсли;	
										
			ИндексКолонки = 3;
			
			Продолжить;
			
		КонецЕсли;	
		
		ИндексКолонки = ИндексКолонки + 1;
		НоваяСтрока[ТаблицаДанных.Колонки[ИндексКолонки].Имя] = СокрЛП(Элемент.ТекстовоеСодержимое);
		
	КонецЦикла;	
		
КонецПроцедуры
Показать
34. x_under 14 19.05.14 09:27 Сейчас в теме
Добрый день.
Внедрили вашу систему в рабочую базу, все отлично. Потом решили перевести в регламентное задание и тут начались сложности: база в клиент серверном варианте. Регламентное задание запускается. Система получает JSESSIONID, но при получении страницы со списком конфигурации система ничего уже не возвращает. Подскажите куда смотреть
36. ssokolov1 10.06.14 13:13 Сейчас в теме
Не работает.
Не грузит список программ.
До какого то момента работало, потом перестало. Выдавало ошибку, после скачал исправленную.
Ошибка исчезла, но программы не грузит
37. barelpro 1201 01.09.14 18:08 Сейчас в теме
(36) Спасибо за замечание!
Выпущена версия 2. 1С слегка изменила алгоритм авторизации, пришлось слегка переписать код, попутно удалось уменьшить количество запросов с 8 до 4.
maXon777; laeg; +2 Ответить
38. Патриот 271 05.09.14 21:42 Сейчас в теме
(0) +
Статья супер, хороший толчок для новичка, чтобы освоить новую для себя технологию 1С. Вы когда писали конфу, то пользовались только платформой 1С и инструментами разработчика браузера, чтобы распутать эту хитрую регистрацию на сайте 1С?
40. barelpro 1201 05.09.14 23:27 Сейчас в теме
(38) Спасибо за оценку! Я пользовался советами своего брата, работающего в Яндексе, поэтому использовал инструменты Яндекс-браузера. А вообще, как мне подсказали здесь, есть инструменты не хуже, например, Firebug для Firefox.
39. Патриот 271 05.09.14 21:44 Сейчас в теме
(0), Сам вашу конфу не использовал, т.к. не зареган на сайте 1С, но использовал её, как пример
41. deevil 146 06.09.14 03:46 Сейчас в теме
Статья зачетная для изучения механизмов 1с для веб
42. RustamTurn 09.09.14 23:54 Сейчас в теме
Спасибо за статью. У меня возник вопрос, а как выполнить метод PATCH в объекте Httpсоединение, есть методы PUT,POST,DELETE,GET, а метод PATCH я не обнаружил и не смог воспроизвести его, хоть 1с пишет что к REST можно обращаться с помощью метода PATCH.
43. barelpro 1201 11.09.14 16:27 Сейчас в теме
(42) Да, так и есть, метод PATCH не наблюдается. А зачем он вам?
44. RustamTurn 11.09.14 22:18 Сейчас в теме
(43) ОН используется для замены только указанных свойств, при этом остальные свойства остаются не тронутыми, его можно заменить методом PUT , но он очищает все незаполненные поля.
Плюс еще в объекте HTTPсервисы, появилась куча методов,которыми из 1с никак не обратиться.

● GET;

● POST;

● PUT;

● DELETE;

● PATCH;

● MERGE;

● CONNECT;

● OPTIONS;

● TRACE;

● PROPFIND;

● PROPPATCH;

● MKCOL;

● COPY;

● MOVE;

● LOCK;

● UNLOCK.
47. stegantsov 07.11.14 10:27 Сейчас в теме
(43)
Расскажите поподробнее как изменился порядок авторизации в новых релизах
scandal2; +1 Ответить
45. husky 6 23.10.14 23:12 Сейчас в теме
А как для обычных форм переделать пожалуйста, нужно под УПП 1.3. Заранее спасибо.
46. husky 6 29.10.14 00:02 Сейчас в теме
Как определить какие строки для запроса на сервер включать в заголовки, а какие нет, а также как определить возможно какие-то еще параметры нужно задать?
48. Insanity 69 26.01.15 11:32 Сейчас в теме
Спасибо за статью. Обработка работает. Но не это главное, мне очень пригодился сам метод работы с сайтами, требующими аутентификации. Я оказывается всё делал не совсем правильно. Сэкономили мне массу времени. Ещё раз спасибо.
49. xsazar 3 08.08.15 18:55 Сейчас в теме
Как теперь получить страницу, после обновления сайта???
50. xsazar 3 09.08.15 00:11 Сейчас в теме
Разобрался! Теперь так!

&НаСервере
Функция НайтиJSESSIONID()
	
	Попытка
		
		//для GET-запросов
		HTTPЗапрос1 = Новый HTTPЗапрос;
		HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");
		
		//для POST-запросов
		HTTPЗапрос2 = Новый HTTPЗапрос;
		HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
		HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
		
		Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		//Соединение2 = Новый HTTPСоединение("users.v8.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		  //portal.1c.ru
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		
		//Запрос 1
		HTTPЗапрос1.АдресРесурса = "/releases.1c.ru/total";
		ОтветHTTP1 = Соединение2.Получить(HTTPЗапрос1);
		результат = ОтветHTTP1.КодСостояния;
		JSESSIONID = ОтветHTTP1.Заголовки.Получить("Set-Cookie");
		JSESSIONID = Лев(JSESSIONID, Найти(JSESSIONID, ";") - 1);
		Объект.JSESSIONID = JSESSIONID;
		LOCATION1 = СтрЗаменить(ОтветHTTP1.Заголовки.Получить("Location"), "https://login.1c.ru", "");
		
		//Запрос 2
		HTTPЗапрос1.АдресРесурса = LOCATION1;
		ОтветHTTP2 = Соединение1.Получить(HTTPЗапрос1);
		JSESSIONID1 = ОтветHTTP2.Заголовки.Получить("Set-Cookie");
		JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1);
		inviteCode = РаспарситьinviteCode(ОтветHTTP2.ПолучитьТелоКакСтроку());
		
		//Запрос 3
		HTTPЗапрос2.АдресРесурса = "/login;" 
		+ СтрЗаменить(JSESSIONID1, "JSESSIONID=", "jsessionid=") 
		+ "?service=https%3A%2F%2Fusers.v8.1c.ru%2Fdistribution%2Fpublic%2Fsecurity_check%3Bjsessionid%3D"­ 
		+ СтрЗаменить(JSESSIONID, "JSESSIONID=", "");
		HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
		HTTPЗапрос2.УстановитьТелоИзСтроки(inviteCode);
		ОтветHTTP3 = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);
		LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("Location"), "https://releases.1c.ru", "");
		
		//Запрос 4
		HTTPЗапрос1.АдресРесурса = LOCATION3;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID);
		ОтветHTTP4 = Соединение2.Получить(HTTPЗапрос1);
		
		
	Исключение    
		Возврат Ложь;
	КонецПопытки;	
		
	Возврат Истина;
	
КонецФункции

&НаСервере
Функция ЗагрузитьПрограммыНаСервере()
	
	Попытка
		
		Загружено = 0;
		Запрос = Новый HTTPЗапрос;
		Запрос.Заголовки.Вставить("Connection", "keep-alive");
		Запрос.Заголовки.Вставить("Cookie", JSESSIONID);
		Запрос.АдресРесурса = "/total";
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		ОтветHTTP = Соединение2.Получить(Запрос);
		
		ЧтениеHTML = Новый ЧтениеHTML;
		ЧтениеHTML.УстановитьСтроку(ОтветHTTP.ПолучитьТелоКакСтроку());
		
		Построитель = Новый ПостроительDOM;
		ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
		
		РекурсивныйПарсингСпискаКонфигураций(ДокументHTML);
		
	Исключение
		
		Возврат Ложь;
		
	КонецПопытки;
	
	Возврат Истина;
	
КонецФункции
Показать
51. markovki 19 17.08.15 16:02 Сейчас в теме
(50) xsazar, объясните чайнику пожалуйста, как подобным методом программно авторизоваться на login.1c.ru, затем с той же авторизацией попасть на страницу https://releases.1c.ru/total
Далее таким же методом хочу добраться до страницы (там 4 перехода):
https://releases.1c.ru/version_file?nick=Accounting30&ver=3.0.34.10&path=Accounting\3_0_34_10\updsetup.exe
К сожалению, не могу понять, тема для меня новая, а ваш пример не работает, возможно, что-то не так сделал, после нажатия немного думает и ничего не происходит.
52. xsazar 3 19.08.15 00:05 Сейчас в теме
(51) markovki, по вашим словам, можно понять, что вы ни чего не меняли в процедуре, где идет парсинг страницы релиза, а она обновилась, там то же нужно менять, поэтому и ни чего не происходит, у меня пока только есть регламентное задание, могу показать как идет парсинг страницы, но он для обработки не подойдет.
53. markovki 19 21.08.15 08:21 Сейчас в теме
(52) xsazar, вы правы, не менял.
Просто пытаюсь более детально разобраться как происходит переход на releases.1c.ru после авторизации.
Мне казалось, что для этого необходимы только логин/пароль и кукисы c login.1c.ru.
Зачем например, парсить страницу и собственно сама переменная inviteCode...
54. NcSteel 21.08.15 13:55 Сейчас в теме
1С изменила сайт и естественно данная конфигурация перестала работать. Будет ли доработана ?
55. barelpro 1201 27.08.15 22:04 Сейчас в теме
Внимание! Выпущена версия 3. Учтен новый дизайн сайта 1С.
56. hibico 260 01.09.15 11:17 Сейчас в теме
Здорово!
Прошу разрешение на использование Вашего кода для авторизации в моей разработке для скачивания файлов обновлений "updsetup.exe". Ссылки в коде и публикации гарантирую.
59. barelpro 1201 02.09.15 22:43 Сейчас в теме
(56) Не возражаю. Но если 1С так часто будет менять сайт и авторизацию, то это нифига не enterprise solution! Замучаетесь выпускать заплатки... Я уже замучался...
57. Avrobus 02.09.15 14:34 Сейчас в теме
На 1С слегка изменилась авторизация. Помогли такие костыли:
В функции НайтиJSESSIONID()
1. Запрос 2
Перед JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1); вставить
JSESSIONID1 = Прав(JSESSIONID1, СтрДлина(JSESSIONID1) - Найти(JSESSIONID1, "SESSION") + 1);

2. Запрос 3
HTTPЗапрос2.АдресРесурса заменить на
HTTPЗапрос2.АдресРесурса = "/login?service=https%3A%2F%2Freleases.1c.ru";
barelpro; hibico; +2 Ответить
58. barelpro 1201 02.09.15 22:40 Сейчас в теме
(57) Да, что-то они зачастили... Сейчас поправлю и выложу v4
60. mcfearson 07.09.15 23:57 Сейчас в теме
Подскажите, пожалуйста. У нас здесь есть домены releases.1c.ru и login.1c.ru. Мы авторизуемся на login.1c.ru, шлем туда имя пользователя и пароль, а затем получаем страницу с releases.1c.ru. Куки разные. Как нас идентифицируют как одного и того же пользователя и дают доступ к releases.1c.ru?
61. barelpro 1201 08.09.15 18:17 Сейчас в теме
(60)
Смотрим функцию НайтиJSESSIONID()
В первом запросе к releases.1c.ru нам присваивается JSESSIONID
Во втором запросе к login.1c.ru нам присваиваются параметры inviteCode
В третьем запросе мы отправляем inviteCode с логином-паролем и получаем ticket
В четвертом запросе мы связываем JSESSIONID и ticket
63. mcfearson 09.09.15 15:55 Сейчас в теме
62. barelpro 1201 08.09.15 18:38 Сейчас в теме
Внимание! Выпущена версия 5. Оптимизирован код. Заменены методы рекурсивных парсингов на конструкции ПолучитьЭлементПоИдентификатору и ПолучитьЭлементыПоИмени. Старые функции остались закоментированными.
Спасибо коллеге Avrobus за идею! :)
64. azazana 64 21.09.15 18:30 Сейчас в теме
А подскажите, каким образом можно посмотреть какой именно post запрос формируется при когда на сайте вводишь логин и пароль?
65. azazana 64 22.09.15 10:31 Сейчас в теме
Если смотреть в Хроме, то там формируется куча различных запросов. Как отобрать нужный?
67. pihy 45 03.10.15 13:32 Сейчас в теме
(65) azazana, я искал по статусу "302". POST запрос. Внизу раздел "Form data" переключить на "View source". Эту строку и добавляю в тело запроса.
66. pihy 45 03.10.15 13:06 Сейчас в теме
Знающие люди, подскажите, пожалуйста.

Пытаюсь авторизироваться на сайте средствами 1с:

Соединение = Новый HTTPСоединение("toysland.crimea.ua");			
Заголовки = Новый Соответствие;
Заголовки.Вставить("host", "toysland.crimea.ua");
Заголовки.Вставить("Connection", "keep-alive");
Заголовки.Вставить("Accept","text/html");
Заголовки.Вставить("Accept-Language", "ru");
	
Заголовки.Вставить("Content-Length",СтрДлина(СтрЗаменить(СтрЗаменить(action=secure-login&login="$ЛОГИН$"&passwd="$ПАРОЛЬ$","$ЛОГИН$",Объект.Пользователь),"$ПАРОЛЬ$",Объект.Пароль)));
Запрос = Новый HTTPЗапрос(ТекАдрес, Заголовки);
Запрос.УстановитьТелоИзСтроки(СтрЗаменить(СтрЗаменить(Объект.ШаблонПОСТ,"$ЛОГИН$",Объект.Пользователь),"$ПАРОЛЬ$",Объект.Пароль));
Ответ = Соединение.ОтправитьДляОбработки(Запрос);
Показать


Строку action=secure-login&login="$ЛОГИН$"&passwd="$ПАРОЛЬ$" подсмотрел снифером во время отправки данных на сервер браузером.
В
Ответ.ПолучитьТелоКакСтроку();

попадает заблокированная страница. Т.е. авторизацию не проходит...
68. Arxxximed 9 30.10.15 14:43 Сейчас в теме
Подскажите, пожалуйста , как все таки получать текст страницы полученной в сжатом виде gzip. Устанавливаю Заголовок "Accept-Encoding : gzip"
По итогу HTTPОтвет.ПолучитьТелоКакСтроку() Возвращает сжатые данные

Поднял вопрос в теме http://forum.infostart.ru/forum26/topic140086/
69. tormozit 6286 23.01.16 21:20 Сейчас в теме
У меня ОтветHTTP3.КодСостояния = 200, а нужен 302. Почему такое может быть?
Ответ: в моем случае был неверный логин или пароль
70. Denois1333 17.02.16 08:11 Сейчас в теме
Здравствуйте, подскажите пожалуйста, не получается авторизоваться на сайте интернет банка. Там то тоже используется HTTPS, но если при авторизации на users.v8.1c.ru в теле POST запроса отправляются незашифрованные логин/пароль, то в интернет банк отправляется шифрованный пароль, причем всегда разный. Как сформировать POST запрос на авторизацию?
71. Denois1333 19.02.16 11:15 Сейчас в теме
Разобрался со своей проблемой, там действительно при каждой авторизации происходит шифрование пароля. Я разобрал алгоритм шифрования и на авторизацию отправляю шифрованный пароль. HTTPS соединение и сертификаты здесь не причем. Кодирование идет встроенными процедурами сайта.
74. info@itshkola.com 21.03.16 21:39 Сейчас в теме
Валерий, здравствуйте!
Можно Вас попросить эту обработку скинуть на business.kavun@gmail.com
Уж очень нужна, а нет возможности скачать.
Спасибо большое за статью - очень грамотно написана
75. biformatus 25.10.16 18:45 Сейчас в теме
Сломалось что-то.
Функция РаспарситьinviteCode(Текст)
	
	ЧтениеHTML = Новый ЧтениеHTML;
	ЧтениеHTML.УстановитьСтроку(Текст);
	
	Построитель = Новый ПостроительDOM;
	ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
	
	loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
	
	inviteCode = "inviteCode=<=" + loginForm.Элементы[1].Значение 
				+ "&execution=" + loginForm.Элементы[2].Значение 
				+ "&_eventId=" + loginForm.Элементы[3].Значение
	 			+ "&username=" + КонстантыНабор.username 
				+ "&password=" + КонстантыНабор.password;
				
	//РекурсивныйПарсингСтраницыЛогина(ДокументHTML, inviteCode);
	//inviteCode = inviteCode + "&username=" + КонстантыНабор.username + "&password=" + КонстантыНабор.password;
	
	Возврат inviteCode;
	
КонецФункции
Показать


Здесь ошибка - не получает элемент по идентификатору loginForm. Логин и пароль рабочие.
77. barelpro 1201 24.05.17 22:32 Сейчас в теме
(75) Проверил только что, был удивлен, что до сих пор работает! )))
76. Yashazz 3735 24.05.17 16:27 Сейчас в теме
Как разработка - возможно, неплохо. Как статья - хуже некуда. Собственно, статьи нет, есть пара цитат из СП и нихрена не понятно, как этим пользоваться. Разочарован.
baracuda; +1 Ответить
78. barelpro 1201 24.05.17 22:34 Сейчас в теме
(76) Если что-то не понятно, это еще не повод разочаровываться! ;)
79. baracuda 2 21.08.17 15:00 Сейчас в теме
1С наверное никогда не додумается дать доступ к обновлениям через человеческий API, потому и возникают такие костыли как данная разработка.
murat_; u_n_k_n_o_w_n; Nicholas; Sergafan10; VitaliyCeban; markovki; barelpro; +7 Ответить
80. Nicholas 760 13.11.17 15:49 Сейчас в теме
На третьем шаге, при выполнении ОтправитьДляОбработки() стало возвращать код 500. Что это может означать?
83. DimaShapovaloff 22.03.19 18:48 Сейчас в теме
(80) Исправьте ошибочку в РаспарситьinviteCode(). &execution индекс 4, а не 3
81. realchel 23.10.18 12:14 Сейчас в теме
Код закрытый или открытый?
Мы тогда купили.
82. DimaShapovaloff 22.03.19 18:25 Сейчас в теме
Исправьте ошибочку в парсилке. &execution индекс 4, а не 3

&НаСервере
Функция РаспарситьinviteCode(Текст)
	
	ЧтениеHTML = Новый ЧтениеHTML;
	ЧтениеHTML.УстановитьСтроку(Текст);
	
	Построитель = Новый ПостроительDOM;
	ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
	
	loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
	
	inviteCode = "inviteCode=&username=" + КонстантыНабор.username 
				+ "&password=" + КонстантыНабор.password
				+ "&execution=" + loginForm.Элементы[4].Значение
				+ "&_eventId=submit"
				+ "&geolocation="
				+ "&submit=Войти"
				+ "&rememberMe=on"
				;
				
	//РекурсивныйПарсингСтраницыЛогина(ДокументHTML, inviteCode);
	//inviteCode = inviteCode + "&username=" + КонстантыНабор.username + "&password=" + КонстантыНабор.password;
	
	Возврат inviteCode;
	
КонецФункции
Показать
84. barelpro 1201 22.03.19 19:49 Сейчас в теме
(82) Что-то поменялось на сайте 1С?
85. barelpro 1201 22.03.19 20:00 Сейчас в теме
(84) Да действительно поменялось, поправил, спасибо!
86. DimaShapovaloff 23.03.19 01:03 Сейчас в теме
(85) Не за что. Спасибо за публикацию
89. Gamm 13 17.06.19 14:46 Сейчас в теме
(85)
Опять поменялось) Теперь &execution индекс 6
(84)
suepifanov; warrior1985; DimaShapovaloff; +3 Ответить
90. warrior1985 67 17.07.19 12:44 Сейчас в теме
91. RocKeR_13 903 14.01.20 16:09 Сейчас в теме
(85) чтобы отвязаться от индексов можно сделать перебор элементов:
	loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
	Элементы 	= loginForm .Элементы;
	Для Каждого Элемент Из Элементы Цикл
		Если Элемент.Имя = "inviteCode" Тогда
			inviteCode = Элемент.Значение;
		ИначеЕсли Элемент.Имя = "execution" Тогда 
	    	execution = Элемент.Значение;
		ИначеЕсли Элемент.Имя = "_eventId" Тогда 
	    	eventId = Элемент.Значение;
		КонецЕсли;
	КонецЦикла;
Показать
92. barelpro 1201 14.01.20 19:25 Сейчас в теме
(91)

ага, в последней версии так и сделано:

	loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
	execution = "";
	Для Каждого Итератор Из loginForm.Элементы Цикл
		Если Итератор.Имя = "execution" Тогда
	    	execution = Итератор.Значение;
			Прервать;
		КонецЕсли;
	КонецЦикла;
Показать
RocKeR_13; +1 Ответить
88. alf2006x 25 07.05.19 11:29 Сейчас в теме
Статья отличная!
Особенно порадовало то, что пример загрузки в базе был рабочий. ИТС легко открылся.
Очень долго не мог понять как работает вся эта пост- и гет- шняга в 1С83.
Посмотрел пример ИТС и нарисовал подобное для своей задачи.
Теперь спокойно захожу и скачиваю всё что необходимо на нужный мне сайт (https).
Гораздо быстрее и надежнее, чем собирался сделать при помощи InternetExplorer.Application.
По тому пути я дошел почти до конца, упёрся в сохранение файла, понял что окошко в IE11, предлагающее "Вы
хотите сохранить..." красивыми методами непобедимо, плюнул и пошёл разбираться с интернет запросами.
Попалась эта статья, один вечер и готово.
Единственное, маловато написано про то, как в яндекс.браузере правильно читать заголовки: откуда что брать
и куда что ложить в новом запросе. Думаю для тех кто впервые сталкивается с задачей подобного рода это лишним не было бы.
sergo5; Romario_; +2 Ответить
93. clev 28 03.03.20 12:45 Сейчас в теме
Спасибо за разработку, помогла разобраться, как сделать получение релизов на питоне.
Вот функции для получения html-страницы с релизами:

import requests
from bs4 import BeautifulSoup

def getParamExecution(html_text):
    soup = BeautifulSoup(html_text, 'lxml')
    inputItem = soup.find('input',{'name':'execution'})
    if (inputItem!=None) and ('value' in inputItem.attrs):
        res = inputItem.attrs['value']
    else:
        res = None
    return res

def getHtmlTable():
    login = 'login'
    passw = 'passw'

    # Первый запрос для получения временных параметров.
    # 1.cookie SESSION сохраняется в сессии newSession
    # 2.парамер execution нужен для отправки во втором запросе
    adrLogin = 'https://releases.1c.ru/total'
    headersLogin = {'Connection': 'keep-alive'}
    newSession = requests.Session()
    r = newSession.get(adrLogin, headers = headersLogin)
    #session_id = r.cookies['SESSION']
    paramExecution = getParamExecution(r.text)
    if paramExecution == None:
        return ''

    # Второй запрос, происходит авторизация через форму на сайте.
    # Затем выполняется редирект на страницу с релизами
    # возвращает текст страницы с релизами в r.text
    adrPost = 'https://login.1c.ru/login'
    formData = {'inviteCode':'', 
            'inviteType':'',
            'username': login,
            'password': passw,
            'rememberMe': 'on',
            'execution': paramExecution,
            '_eventId': 'submit',
            'geolocation': '',
            'submit': 'Войти'}
    r = newSession.post(adrPost, data=formData)
    return r.text
Показать
94. Ibrogim 1186 12.05.20 20:47 Сейчас в теме
(93)
inputItem!=Non

На питоне мне кажется проще каким нибудь Selenium воспользоваться для авторизации.
95. clev 28 13.05.20 10:14 Сейчас в теме
В питоне я новичок, только начал осваивать.
(94)
Selenium

Спасибо за совет, посмотрю, что это.
96. Ibrogim 1186 13.05.20 10:34 Сейчас в теме
(95)
В питоне я новичок

Я тоже там не далеко от "hello world" ушел )

Будет идея для совместной поделки для самообразования, пишите !
97. delta 384 23.08.20 08:04 Сейчас в теме
Доброго дня!
Никто не сталкивался с проблемой, что в в последние несколько дней информация по обновлениям версий конфигураций 1С не загружается?
Логин и пароль на портал releases.1c.ru внесены верно (на самом портале обновления есть), а вот в функции ЗагрузитьВерсииНаСервере
переменная versionsTable = ДокументHTML.ПолучитьЭлементПоИдентификатору("versionsTable") сейчас всегда принимает значение Неопределено.
98. petya73 25.08.20 10:29 Сейчас в теме
(97) со стороны сайта изменились заголовки, в 2-х местах изменили заглавные буквы на строчные
Надо изменять НайтиJSESSIONID()


&НаСервере
Функция НайтиJSESSIONID()
		
	Попытка
			
		//для GET-запросов
		HTTPЗапрос1 = Новый HTTPЗапрос;
		HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");
		
		//для POST-запросов
		HTTPЗапрос2 = Новый HTTPЗапрос;
		HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
		HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
		
		Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		
		//Запрос 1
		HTTPЗапрос1.АдресРесурса = "/total";
		ОтветHTTP1 = Соединение2.Получить(HTTPЗапрос1);
		JSESSIONID = ОтветHTTP1.Заголовки.Получить("Set-Cookie");
		JSESSIONID = Лев(JSESSIONID, Найти(JSESSIONID, ";") - 1);
		LOCATION1 = СтрЗаменить(ОтветHTTP1.Заголовки.Получить("Location"), "https://login.1c.ru", "");
		
		//Запрос 2
		HTTPЗапрос1.АдресРесурса = LOCATION1;
		ОтветHTTP2 = Соединение1.Получить(HTTPЗапрос1);
		JSESSIONID1 = ОтветHTTP2.Заголовки.Получить("set-cookie");
		JSESSIONID1 = Прав(JSESSIONID1, СтрДлина(JSESSIONID1) - Найти(JSESSIONID1, "SESSION") + 1); 
		JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1);
		inviteCode = РаспарситьinviteCode(ОтветHTTP2.ПолучитьТелоКакСтроку());

		//Запрос 3
		//HTTPЗапрос2.АдресРесурса = "/login;" 
		HTTPЗапрос2.АдресРесурса = "/login?service=https%3A%2F%2Freleases.1c.ru";
		//+ СтрЗаменить(JSESSIONID1, "JSESSIONID=", "jsessionid=") 
		//+ "?service=https%3A%2F%2Freleases.1c.ru%2Fdistribution%2Fpublic%2Fsecurity_check%3Bjsessionid%3D"­ 
		//+ СтрЗаменить(JSESSIONID, "JSESSIONID=", "");
		HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
		HTTPЗапрос2.УстановитьТелоИзСтроки(inviteCode);
		ОтветHTTP3 = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);
		LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("location"), "https://releases.1c.ru", "");
		
		//Запрос 4
		HTTPЗапрос1.АдресРесурса = LOCATION3;
		HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID);
		ОтветHTTP4 = Соединение2.Получить(HTTPЗапрос1);
		
	Исключение
		
		Возврат Ложь;
		
	КонецПопытки;
	
	Возврат Истина;
	
КонецФункции
Показать
AnufrievYakov; tormozit; +2 Ответить
99. delta 384 25.08.20 13:22 Сейчас в теме
(98) Огромное спасибо! Проблема действительно заключалась в этом.
Lord_Kingovich; +1 Ответить
102. barelpro 1201 31.10.20 00:15 Сейчас в теме
(98)

Да, Поменяли Set-Cookie на set-cookie, и Location на location.
А поскольку HTTPОтвет.Заголовки имеет тип Соответствие, а не Структура, регистр имеет значение при обращении к заголовкам.

Я не знаю, надо ли выкладывать исправленную версию под статьёй?
Оставьте свое сообщение

См. также

Интеграция с бонусной программой лояльности ManyBonus Промо

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    2793    4    Anton64    0    

Расширение конфигурации для Web-доступа к 1С (1С в роли back-end)

WEB v8 1cv8.cf Россия Абонемент ($m)

Для реализации того, чтобы 1С формировала и отдавала страницу, которую можно было бы открыть через браузер было написано расширение, которое позволяет публиковать из 1С произвольные ресурсы, будь то API, сайт или изображения / прочие файлы.

1 стартмани

01.04.2021    2994    4    SaschaG    3    

Работа с картами в 1С на примере бесплатной библиотеки Leaflet

Практика программирования Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Разработка функционала отображения и выбора пунктов доставки на карте прямо в 1С с помощью бесплатной библиотеки Leaflet. Тестирование производилось на платформе 8.3.15.1534 на тонком клиенте.

1 стартмани

31.03.2021    2432    6    Parsec1C    8    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    4507    9    quazare    16    

BIM: взаимодействие с платформой Autodesk Forge Промо

WEB v8 1cv8.cf Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    15207    4    kandr    2    

Продажи со склада поставщика WildBerries. Взаимодействие с АПИ из 1С

WEB Розничная торговля v8 УТ11 УУ Абонемент ($m)

Взялся я тут делать интеграцию с АПИ нового проекта Диких Ягод - Продажи со склада поставщика (ПССП). Это было нелегко. Никто же не читает инструкцию (уже аж 7 версии!), а зря! Для начала сделал получение списка товаров и обмен остатками.

5 стартмани

06.11.2020    14218    120    kiv1c    115    

Чатбот WhatsApp

WEB v8 1cv8.cf Абонемент ($m)

Внешняя обработка для написания чат-бота WhatsApp

1 стартмани

21.10.2020    6009    23    ripreal1    20    

1С + react native

WEB v8 1cv8.cf Абонемент ($m)

Пример реализации клиента для 1С на react native.

1 стартмани

09.10.2020    6434    6    van_za    6    

Односторонний файловый обмен с сайтом по ftp (1C 2 Web) Промо

Обмен данными 1С Файловые протоколы обмена, FTP WEB v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Подходит под любую конфигурацию на управляемом интерфейсе на базе БСП 2.4.4 и выше. Позволяет гибко настроить выгрузку, практически любых, данных по расписанию на сервер ftp вашего ресурса. Ведение лога процесса выгрузки также предусмотрено.

3 стартмани

09.12.2019    6599    8    LamerSoft    0    

Учимся создавать http сервис (часть третья). Передача нескольких параметров в http сервис

WEB Практика программирования v8 1cv8.cf Абонемент ($m)

Пошаговое руководство по созданию http сервиса (часть третья). Передача нескольких параметров в http сервис, a также формирование сложных JSON строк.

1 стартмани

02.10.2020    7474    2    hpi    16    

Подключаем WhatsApp к 1С

WEB v8 1cv8.cf Абонемент ($m)

Обработка для быстрого подключения WhatsApp к любой конфигурации 1С.

1 стартмани

30.09.2020    6955    36    andrew_shamin    58    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    10659    9    shmalevoz    20    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3 Промо

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    12104    18    capitan    11    

Конструктор HTTP-соединений в 1С (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникают мысли о том, чтобы прикрутить сервисы, связанные с HTTP-соединениями, в 1С. Необходимо писать обработку и анализировать результат.

1 стартмани

02.06.2020    6118    25    Denr83    0    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    6197    8    zavsom    2    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    8914    11    zhichkin    16    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    30321    38    Ditron    90    

Обмен данными между OZON и 1С

Оптовая торговля WEB v8 v8::ОУ УТ11 УУ Абонемент ($m)

Данная подсистема позволяет загружать отправления «с моего склада» из OZON (в статусе «Ожидают сборки») в 1с Управление торговлей 11 по API. Так же есть возможность выгружать статусы отправлений «awaiting_deliver, т.е. Ожидает отгрузки» и «cancelled, т.е. Отменен» из 1с в OZON по API.

10 стартмани

09.04.2020    20272    190    vex2865    124    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    13467    47    terrorion    14    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    10072    28    Deniskinr83    0    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    16711    52    RocKeR_13    35    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    12050    35    zykov_vitaliy    26    

Автозаполнение адреса по КЛАДР в УПП при выгрузке контрагента с портала компании (API dadata)

WEB v8 1cv8.cf Абонемент ($m)

Заведение, согласование контрагентов организовано на портале компании. Далее по web-сервису контрагенты выгружаются в УПП (юр.адрес и факт.адрес выгружаются строкой). Задача автоматизировать заполнение адреса в УПП по КЛАДР.

1 стартмани

03.12.2019    8249    1    John_d    10    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    15006    134    Denr83    0    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14860    3    wtlz    1    

Пример взаимодействия HTML (COM объект, WebKit) с 1С (динамический отбор) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования WebKit в 1С (8.3).

2 стартмани

18.11.2019    11602    16    Denr83    0    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    12962    10    noprogrammer    12    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    19477    40    budidich    19    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    29280    38    Smaylukk    3    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    17634    56    kaliuzhnyi    48    

Путеводитель по истории релизов

WEB v8 1cv8.cf Абонемент ($m)

Отчет по истории выпуска релизов и анализа информации по обновлениям.

5 стартмани

13.08.2019    15733    13    YPermitin    18    

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

WEB v8 1cv8.cf Абонемент ($m)

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    19632    37    MaxPowerr    5    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    21031    8    vipchep    0    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    15654    33    miha-28    17    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    22080    81    MarkoSokolov    48    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    34460    83    mi1man    58    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    111204    2696    Smaylukk    365    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    30353    115    Ditron    94    

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4

Обработка документов WEB Оптовая торговля Оптовая торговля v8 УТ11 Россия УУ Абонемент ($m)

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    12634    12    ret    7    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    16603    82    John_d    33    

Пример использования REST API Яндекс Диска Промо

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    28892    46    MKFreeUser    15    

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С

WEB v8 1cv8.cf Абонемент ($m)

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    21123    28    Бэнни    22    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    24497    40    echo77    73    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    63759    51    dusha0020    19    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    24326    13    RocKeR_13    16    

Конфигурация для просмотра публичных телеграм каналов Промо

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19905    13    DO_WHILE_LOOP    7