Функция получения даты из текста по форматной строке

Публикация № 200111

Разработка - Инструментарий разработчика

Преобразует текст в дату при условии наличия форматной строки

Несколько громоздская, но полезная функция.

Добавил распознование строковых месяцев, но только на русском языке.

Очень красивое решение предоставил ildarovich, советую использовать сразу его код:

Функция СтрокаВДату(Знач ФорматДаты, Знач Дано, Ошибка = Ложь) Экспорт 
	Попытка 
		ё = Формат('00010101', "ДФ=" + ФорматДаты) // - необязательная проверка первого правильности параметра 
	Исключение 
		Ошибка = Истина; 
		Возврат '00010101' 
	КонецПопытки; 
	Ч = Новый Соответствие; 
	Для ё = 1 По СтрДлина(ФорматДаты) + 7 Цикл 
		Ч[Сред(ФорматДаты + "dMyHhms", ё, 1)] = 0	// - инициализация частей даты 
	КонецЦикла; 
	Для ё = 1 По 12 Цикл 
		Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами 
		Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMМ" ), Формат(ё, "ЧЦ=3; ЧВН=")) 
	КонецЦикла; 
	Для ё = 1 По СтрДлина(ФорматДаты) Цикл 
		Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Дано, ё, 1)); // - накопление частей даты 
		Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, ё, 1)) И НЕ Найти("0123456789", Сред(Дано, ё, 1)) // - необязательная проверка на цифры 
	КонецЦикла; 
	Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех 
	Попытка 
		Возврат Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"]) 
	Исключение 
		Ошибка = Истина; 
		Возврат '00010101' 
	КонецПопытки 
КонецФункции

Моя функция:

Функция ПолучитьДатуИзТекста(Текст,ФорматнаяСтрока) Экспорт
	Перем Значение;
	
	ПустаяДата = '00010101';
	Год = 1; Месяц=1; День = 1; час = 0; Мин=0; Сек=0;
	тмпТекст = Текст;
	ЗначащиеСимволы = "dMyHhms";
	СтрокаПараметра = "";
	ФорматнаяСтрока = СокрЛП(ФорматнаяСтрока)+" ";
	ПредСимв = Лев(ФорматнаяСтрока,1);
	Для к=1 по СтрДлина(ФорматнаяСтрока) Цикл
		Симв = Сред(ФорматнаяСтрока,к,1);
		Если ПредСимв<>Симв Тогда
			Если Найти(ЗначащиеСимволы,ПредСимв)>0 Тогда
				//ЭтоПараметр
				Если СтрДлина(СтрокаПараметра)=2 Тогда
					Попытка
						Значение = Число(Лев(тмпТекст,2));
					Исключение
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецПопытки;
					
					тмпТекст = Сред(тмпТекст,3);
				ИначеЕсли СтрокаПараметра="yyyy" Тогда
					Попытка
						Значение = Число(Лев(тмпТекст,4));
					Исключение
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецПопытки;
					тмпТекст = Сред(тмпТекст,5);
				ИначеЕсли СтрДлина(СтрокаПараметра)=1 Тогда
					дл = "";
					Попытка
						Значение = Число(Лев(тмпТекст,2));
					Исключение
						Попытка
							Значение = Число(Лев(тмпТекст,1));
							дл=1;
						Исключение
							#Если Клиент Тогда
								Предупреждение("Не удалось выполнить преобразование!");
							#КонецЕсли
							Возврат ПустаяДата;
						КонецПопытки;
					КонецПопытки;
					
					Если дл="" Тогда
						Если (СтрокаПараметра = "d" и Значение>31)ИЛИ(СтрокаПараметра = "M" и Значение>12)ИЛИ(СтрокаПараметра = "H" и Значение>23)
							ИЛИ(СтрокаПараметра = "h" и Значение>12)ИЛИ(СтрокаПараметра = "m" и Значение>59)ИЛИ(СтрокаПараметра = "s" и Значение>59) Тогда
							Попытка
								Значение = Число(Лев(тмпТекст,2));
								дл=2;
							Исключение
								#Если Клиент Тогда
									Предупреждение("Не удалось выполнить преобразование!");
								#КонецЕсли
								Возврат ПустаяДата;
							КонецПопытки;
						Иначе
							Попытка
								Значение = Число(Лев(тмпТекст,1));
								дл=1;
							Исключение
								#Если Клиент Тогда
									Предупреждение("Не удалось выполнить преобразование!");
								#КонецЕсли
								Возврат ПустаяДата;
							КонецПопытки;
						КонецЕсли;	
					КонецЕсли;	
					
					тмпТекст = Сред(тмпТекст,дл+1);
				ИначеЕсли СтрокаПараметра="MMM" или СтрокаПараметра="MMMM" Тогда
					Значение = 0;
					Для м=1 по 12 Цикл
						ТекстМесяца = Сред(Формат(Дата(2000,м,1),"ДФ=d."+СтрокаПараметра),3);
						Если Найти(тмпТекст,ТекстМесяца)>0 Тогда
							Значение = м;
							Прервать;
						КонецЕсли;
					КонецЦикла;
					Если Значение = 0 Тогда
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецЕсли;
					тмпТекст = Сред(тмпТекст,СтрДлина(ТекстМесяца)+1);
				Иначе
					#Если Клиент Тогда
						Предупреждение("Не верный формат даты или форматной строки!");
					#КонецЕсли
					Возврат ПустаяДата;
				КонецЕсли;
				
				//Установим параметры
				Если ПредСимв = "d" Тогда
					День = Значение;
				ИначеЕсли ПредСимв = "M" Тогда
					Месяц = Значение;
				ИначеЕсли ПредСимв = "y" Тогда
					Если СтрокаПараметра = "yy" Тогда
						ТекВек = 100*Цел(Год(ТекущаяДата())/100);
						год = ?(Значение>=Год(ТекущаяДата())-текВек+50,ТекВек-100,ТекВек)+Значение;
					Иначе
						Год = Значение;
					КонецЕсли;
				ИначеЕсли ПредСимв = "H" Тогда
					час = Значение;
				ИначеЕсли ПредСимв = "h" Тогда
					час = Значение;
					#Если Клиент Тогда
						Сообщить("Вычисление часа не гарантировано.");
					#КонецЕсли
				ИначеЕсли ПредСимв = "m" Тогда
					Мин = Значение;
				ИначеЕсли ПредСимв = "s" Тогда
					Сек = Значение;
				КонецЕсли;
				
			Иначе
				//Это Разделитель
				тмпТекст = Сред(тмпТекст,СтрДлина(СтрокаПараметра)+1);
			КонецЕсли;
			СтрокаПараметра = Симв;
		Иначе
			СтрокаПараметра=СтрокаПараметра+Симв;
		КонецЕсли;
		ПредСимв = Симв;
	КонецЦикла;
	Возврат Дата(Год,Месяц,День,час,Мин,Сек);
КонецФункции		

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Поручик 4375 09.09.13 01:35 Сейчас в теме
(0) Вместо Предупреждение() лучше использовать Сообщить().
2. kapustinag 09.09.13 08:36 Сейчас в теме
(0) Вот в этом месте нужно более интеллектуально:
Если СтрокаПараметра = "yy" Тогда
Год = 2000+Значение;

Если Значение="99", то год должен быть 1999, а если ="13", то год 2013. Часто применяют сравнение с 50. Если значение меньше 50, то считаем нынешний век, а если больше - двадцатый век. Впрочем, это уже зависит от смысла ожидаемых данных. Может быть, на Ваших данных именно Ваше условие правильное.
6. Crazy Professor 19 24.09.13 08:58 Сейчас в теме
(2) kapustinag,
Кстати да, но я не знаю по какому принципу 1с сама это дело конвертирует у меня переключает на прошлый век с 30 включительно, но я не уверен, что это как-то зависит от текущей даты.

Сделал так:

ТекВек = 100*Цел(Год(ТекущаяДата())/100);
год = ?(Значение>=Год(ТекущаяДата())-текВек+50,ТекВек-100,ТекВек)+Значение;
3. ildarovich 6941 09.09.13 17:19 Сейчас в теме
В статье Выразить строку как число и строку как дату в запросе показано, как тоже самое можно сделать в запросе. Ну а данное решение нужно сократить раз в десять - объем кода не соответствует сложности решаемой задачи.
7. Crazy Professor 19 24.09.13 09:07 Сейчас в теме
(3) ildarovich,
Предложите готовое решение, пожалуйста - я с радостью его применю для своих целей.
Статья занятная, но не уверен, что универсальное решение будет менее громоздким чем обычный код. Однако, для больших объемов данных применение запроса может увеличить производительность.
11. ildarovich 6941 25.09.13 00:42 Сейчас в теме
(7) Вот готовое решение
//
Функция СтрокаВДату(Знач ФорматДаты, Знач Дано, Ошибка = Ложь) Экспорт
    Попытка 
        ё = Формат('00010101', "ДФ=" + ФорматДаты) // - необязательная проверка первого правильности параметра
    Исключение
        Ошибка = Истина;
        Возврат '00010101'
    КонецПопытки;
    Ч = Новый Соответствие;
    Для ё = 1 По СтрДлина(ФорматДаты) + 7 Цикл
        Ч[Сред(ФорматДаты + "dMyHhms", ё, 1)] = 0	// - инициализация частей даты
    КонецЦикла;
    Для ё = 1 По 12 Цикл
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMМ" ), Формат(ё, "ЧЦ=3; ЧВН="))
    КонецЦикла;
    Для ё = 1 По СтрДлина(ФорматДаты) Цикл
        Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Дано, ё, 1)); // - накопление частей даты
        Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, ё, 1)) И НЕ Найти("0123456789", Сред(Дано, ё, 1)) // - необязательная проверка на цифры
    КонецЦикла;
    Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех
    Попытка  
        Возврат Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"])
    Исключение
        Ошибка = Истина;
        Возврат '00010101'
    КонецПопытки
КонецФункции
//
Показать
ELInfinito; Simonov_NPM; rise; Valkiriyaaaa; Crazy Professor; bulpi; +6 Ответить
12. Crazy Professor 19 02.10.13 10:02 Сейчас в теме
(11) ildarovich,
Ну да, я ламмер, очень изящно - преклоняю колено.
15. kuzyara 983 30.08.16 06:24 Сейчас в теме
(12) код (11) с ошибками.
Январь прописью не проходит, зачем-то "h" парсит и т.д.
13. Crazy Professor 19 02.10.13 10:03 Сейчас в теме
(11) ildarovich,
Можно вынести в шапку с указанием авторства? Вдруг кому нужно будет.
14. ildarovich 6941 02.10.13 11:05 Сейчас в теме
(13) Да, конечно, пожалуйста. Только просьба стандартные отступы восстановить (они пропали при вставке кода в комментарий).
25. rise 12.07.19 10:56 Сейчас в теме
(11) Круто, но к сожалению некорректно обрабатывает форматы "d" и "M", когда число знаков переменное. d.M.yyyy дает 12.7.2019

И в этой строке кажется надо в формат числа добавить ЧГ=0
Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН="));
4. spetzpozh 10.09.13 14:35 Сейчас в теме
Сообщить(), если учитывать рекомендации 1С, использовать не стоит вообще никогда :) СообщениеПользователю есть.
5. diver.sun 21 11.09.13 11:13 Сейчас в теме
Почитал, подумал, написал свой вариант, жутко не экономично, но зато абсолютно универсально
Процедура КнопкаВыполнитьНажатие(Кнопка)
	лФорматнаяСтрока = "Л=en; ДФ='yyyy МММ dd HH/mm/s'";
	лСтрокаДаты = "2013 Sep 11 09/58/5";
	
	
	лМассивДатНачальный = Новый Массив;
	лМассивДатНачальный.Добавить(1900);
	лМассивДатНачальный.Добавить(1);
	лМассивДатНачальный.Добавить(1);
	лМассивДатНачальный.Добавить(0);
	лМассивДатНачальный.Добавить(0);
	лМассивДатНачальный.Добавить(0);

	
	лДиапазонГода = ВернутьДиапазонЗначимыхЗначений(0,1999,2001,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,0,1900,2100,лФорматнаяСтрока,лДиапазонГода,лСтрокаДаты);
	
	лДиапазонМесяца = ВернутьДиапазонЗначимыхЗначений(1,1,12,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,1,1,12,лФорматнаяСтрока,лДиапазонМесяца,лСтрокаДаты);
	
	лДиапазонДаты = ВернутьДиапазонЗначимыхЗначений(2,1,31,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,2,1,31,лФорматнаяСтрока,лДиапазонДаты,лСтрокаДаты);
	
	лДиапазонЧаса = ВернутьДиапазонЗначимыхЗначений(3,0,23,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,3,0,23,лФорматнаяСтрока,лДиапазонЧаса,лСтрокаДаты);
	
	лДиапазонМинуты = ВернутьДиапазонЗначимыхЗначений(4,0,59,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,4,0,59,лФорматнаяСтрока,лДиапазонМинуты,лСтрокаДаты);
	
	лДиапазонСекунды = ВернутьДиапазонЗначимыхЗначений(5,0,59,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,5,0,59,лФорматнаяСтрока,лДиапазонСекунды,лСтрокаДаты);
	
	РезДата = Дата(лМассивДатНачальный[0],лМассивДатНачальный[1],лМассивДатНачальный[2],лМассивДатНачальный[3],лМассивДатНачальный[4],лМассивДатНачальный[5]);	
КонецПроцедуры

Процедура ПодобратьЗначение(пМассивПараметровДаты,лНомерПараметра,пСтарт,пСтоп,пФорматнаяСтрока,пСтрПоложения,пРазбираемаяСтрока)
	Если пСтрПоложения.С = -1 Тогда
		Возврат;
	КонецЕсли;
	Для Ном = пСтарт по пСтоп Цикл
		пМассивПараметровДаты[лНомерПараметра] = Ном;
		лДата = Дата(пМассивПараметровДаты[0],пМассивПараметровДаты[1],пМассивПараметровДаты[2],пМассивПараметровДаты[3],пМассивПараметровДаты[4],пМассивПараметровДаты[5]);
		лСтрПредставленияДаты = Формат(лДата,пФорматнаяСтрока);
		Если Сред(пРазбираемаяСтрока,пСтрПоложения.С,пСтрПоложения.По-пСтрПоложения.С+1) = Сред(лСтрПредставленияДаты,пСтрПоложения.С,пСтрПоложения.По-пСтрПоложения.С+1) Тогда
			Прервать;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Функция ВернутьДиапазонЗначимыхЗначений(лНомерПараметра,пСтарт,пСтоп,пФорматнаяСтрока)
	лМассивПараметров = Новый Массив;
	лМассивПараметров.Добавить(1900);
	лМассивПараметров.Добавить(1);
	лМассивПараметров.Добавить(1);
	лМассивПараметров.Добавить(0);
	лМассивПараметров.Добавить(0);
	лМассивПараметров.Добавить(0);
	лДатаНачальная = Дата(лМассивПараметров[0],лМассивПараметров[1],лМассивПараметров[2],лМассивПараметров[3],лМассивПараметров[4],лМассивПараметров[5]);
	лСтрПредставление = Формат(лДатаНачальная,пФорматнаяСтрока);
	
	лСтрРазностная = Новый Структура("С,ПО",10000,-1);
	
	Для лНом = пСтарт по пСтоп Цикл
		лМассивПараметров[лНомерПараметра] = лНом;
		лСтрНовая = Формат(Дата(лМассивПараметров[0],лМассивПараметров[1],лМассивПараметров[2],лМассивПараметров[3],лМассивПараметров[4],лМассивПараметров[5]),пФорматнаяСтрока);
		Если лСтрПредставление <> лСтрНовая Тогда
			СтрРазличий = ВернутьСтрРазличияВСтроках(лСтрПредставление,лСтрНовая);
			лСтрРазностная.С = Мин(лСтрРазностная.С,СтрРазличий.С);
			лСтрРазностная.ПО = Макс(лСтрРазностная.ПО,СтрРазличий.ПО);
		КонецЕсли;
	КонецЦикла;
	Если лСтрРазностная.С = 10000 Тогда
		лСтрРазностная.С = -1;
	КонецЕсли;
	Возврат лСтрРазностная; 
КонецФункции

Функция ВернутьСтрРазличияВСтроках(пСтрока1,пСтрока2)
	пПервыйРазличныйСимвол = -1;
	пПоследнийРазличныйСимвол = -1;
	Для Ном = 1 по СтрДлина(пСтрока1) Цикл
		Если Сред(пСтрока1,Ном,1) =  Сред(пСтрока2,Ном,1) И пПервыйРазличныйСимвол <> -1 Тогда
			пПоследнийРазличныйСимвол = Ном - 1;
			Прервать;
		ИначеЕсли Сред(пСтрока1,Ном,1) <>  Сред(пСтрока2,Ном,1) И пПервыйРазличныйСимвол = -1 Тогда
			пПервыйРазличныйСимвол = Ном;
		КонецЕсли;
	КонецЦикла;
	Если пПоследнийРазличныйСимвол = -1 Тогда
		пПоследнийРазличныйСимвол = СтрДлина(пСтрока1);
	КонецЕсли;
	Возврат Новый Структура("С,ПО",пПервыйРазличныйСимвол,пПоследнийРазличныйСимвол);
	
КонецФункции
Показать
8. Crazy Professor 19 24.09.13 09:37 Сейчас в теме
(5) diver.sun,
Чего-то я не понял как эта обработка должна отрабатывать при изменении порядка элементов форматной строки или вообще при исчезновении некоторых (например такой "yyMMdd", из данных с которыми я работаю). Но идея занятная - от обратного. В упрощенном варианте можно было перебирать все значения с точностью до секунды от -50 до +50 лет от текущей даты и искать подходящее через запрос :).
9. diver.sun 21 24.09.13 10:43 Сейчас в теме
Тогда она не находит позиции старта стопа изменяемого значения.
10. Crazy Professor 19 24.09.13 10:58 Сейчас в теме
(9) diver.sun, твой метод дал идею по распознаванию месяцев строкового формата.
16. Xershi 923 20.04.18 16:46 Сейчас в теме
Кому интересно повозиться сервер вернул дату формата: "Tue, 10 Oct 2017 15:25:00 +0300".
Форматная строка выходит "Л=en; ДФ='ddd, dd MMM yyyy HH:mm:ss'" плюс часовой пояс.
17. smaharbA 08.11.18 17:14 Сейчас в теме
(16)
"Tue, 10 Oct 2017 15:25:00 +0300"


Пока СтрНайти(Стр,"  ")>0 Цикл
	Стр=СтрЗаменить(Стр,"  ","");
КонецЦикла;
МассивДаты=СтрРазделить(Стр," ");
Для ч=1 По 12 Цикл
	Стр=Прав("0"+ч,2);
	Если ВРег(МассивДаты[2])=ВРег(Формат(Дата("2018"+Стр+"01000000"),"Л=en; ДФ='MMM'")) Тогда
		Сообщить(Дата(МассивДаты[3]+Стр+МассивДаты[1]+СтрЗаменить(МассивДаты[4],":",""))+(60*60*5));
		Возврат;
	КонецЕсли;
КонецЦикла;
Показать
18. spacecraft 08.11.18 17:18 Сейчас в теме
(17)
Пока СтрНайти(Стр," ")>0 Цикл
Стр=СтрЗаменить(Стр," ","");
КонецЦикла;
МассивДаты=СтрРазделить(Стр," ");

Вот это можно описать одной строкой:
МассивДаты=СтрРазделить(Стр," ", Ложь);
19. smaharbA 14.11.18 15:57 Сейчас в теме
Можно, но лучче заменять все двойные пробелы на один.
20. spacecraft 14.11.18 16:40 Сейчас в теме
21. dobrynin.i.s 93 19.11.18 02:42 Сейчас в теме
функцию привожу из https://infostart.ru/public/886103/

Функция ПолучитьДатуВремяИзСтроки(ДатаВремя) Экспорт
	
	Результат = Неопределено;
	ДатаВремя = СтрЗаменить(ДатаВремя, "-", "");
	ДатаВремя = СтрЗаменить(ДатаВремя, ":", "");
	Если СтрДлина(ДатаВремя) - Найти(ДатаВремя, " ") = 5 Тогда // время в формате Ч:ММ:СС
		ДатаВремя = СтрЗаменить(ДатаВремя, " ", "0");
	ИначеЕсли Найти(ДатаВремя, "T") > 0 Тогда //время в формате ГГГГММДДTЧЧММСС
		ДатаВремя = СтрЗаменить(ДатаВремя, "T", "");
	Иначе // время в формате ЧЧ:ММ:СС
		ДатаВремя = СтрЗаменить(ДатаВремя, " ", "");
	КонецЕсли;
	
	ОписаниеТипа = Новый ОписаниеТипов("Дата");
	Результат = ОписаниеТипа.ПривестиЗначение(ДатаВремя);  // дата и время в виде "ГГГГММДДЧЧММСС"
	Если Не ЗначениеЗаполнено(Результат) Тогда
		Результат = ОписаниеТипа.ПривестиЗначение(Лев(ДатаВремя, 8));  // только дата "ГГГГММДД"
	КонецЕсли;

	Возврат Результат;
	
КонецФункции
Показать
22. user1040271 23.11.18 11:50 Сейчас в теме
(21)
Что-то не уверен, что эта функция универсальна, поскольку не задается ожидаемый формат.
Как он интерпретирует 11.11.11? Или 11.11 или 11?
Думаю, что она работает только с фиксированными форматами, используемыми в конкретно той задаче для работы с http
23. dobrynin.i.s 93 25.11.18 03:00 Сейчас в теме
(22)
в коде есть пояснения

11.11 или 11 - это вообще не даты.
11.11 ещё можно догадатся что 11.11.2018 - текущий год (2018), а
11 - что такое год , месяц, день или секунда
24. user1040271 26.11.18 10:25 Сейчас в теме
(23)
Об этом и речь - только по данным не всегда можно точно определить формат, особенно по единичному элементу этих данных.
Если есть ограниченный набор вариантов - то тут, конечно, не проблема: в коде отработать исключения (убрать "Т", например). Уверен, что большинство тут решало такие задачи в ходе своей практики.
Но универсальные методы на то и универсальные, что бы не привязываться к конкретным случаям.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    9202    ids79    26       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    10669    John_d    22       

Последовательности событий. Шпаргалка

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    6880    kuzyara    33       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    30742    ids79    50       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    19107    YPermitin    80       

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    21863    ids79    16       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    42858    ids79    36       

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    21848    avalakh    21       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    33650    ids79    11       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    23394    ids79    27       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    17825    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    14485    SeiOkami    49       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    36312    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Производительность и оптимизация (HighLoad)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    18959    dmurk    144       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    31299    YPermitin    30       

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    20460    Eret1k    23       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    11697    m-rv    2       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    15082    m-rv    16       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    26033    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    20812    ellavs    83       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    23121    YPermitin    53       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    27348    ids79    9