"WebCam" - ActiveX-компонента для 1С

Публикация № 16446

Программирование - Внешние компоненты

108
Компонента работает с устройствами, поддерживающими Twain32 драйвер (вебкамеры, фотоаппараты и др.)

*** Для работы компоненты потребуется установленный Microsoft .NET Framework 2.0, который можно скачать отсюда.
http://www.microsoft.com/downloads/details.aspx?displaylang=ru&FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5

Чтобы зарегистрировать компоненту в Windows - запустить reg.bat
(для удаления информации о компоненте в Windows - запустить unreg.bat)
или использовать совместно с хранилищем внешних компонент: //catalog.mista.ru/projects/2863/

*** Приложены демо-примеры для 1С 7.7 и 8.1

*** Добавление на форму 1С:

v7: Использовать 1С++:

Перем Вебкамера;

Процедура ПослеОткрытия()
    Вебкамера = СоздатьОбъект("АктивИкс"); 
    Вебкамера.УстановитьАтрибут(Форма, "АктХ"); 
    //"АктХ" - идентификатор элемента диалога, на месте которого будет создан элемент ActiveX.
    //только для реквизитов диалога типа "Текст".
    Вебкамера.СоздатьЭУ("Душелов.WebCam"); 
    Вебкамера.УстановитьФокус();
КонецПроцедуры

Процедура АктХ_ПослеСохраненияКартинки(Файл)
    Сообщить(Файл);  
КонецПроцедуры

v8: Меню "Форма" - "Вставить ActiveX..." - Выбрать элемент "Душелов.WebCam"

*** Методы:

  • Запустить видео:
    Старт();

  • ОСТАНОВИТЬ ВИДЕО:
    Стоп();

  • ПОЛУЧИТЬ КАРТИНКУ
    СохранитьКартинку(Файл, Текст);

*** События:

  • ПослеСохраненияКартинки(Файл);
108

Скачать файлы

Наименование Файл Версия Размер
-
.1235035799 220,83Kb
25.09.09
1014
.1235035799 220,83Kb 1014 Скачать бесплатно

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Душелов 3899 28.09.08 15:19 Сейчас в теме
Ах да, требуется директ-икс, не ниже 8.1
2. coder1cv8 3437 28.09.08 18:34 Сейчас в теме
3. CheBurator 28.09.08 19:44 Сейчас в теме
4. artem666 28 28.09.08 23:54 Сейчас в теме
На сколько помню вебкамеру можно подхатить через COM... но все равно клево!
5. luns 3 30.09.08 09:59 Сейчас в теме
Прикольно. Фотки в базу добавлять..
6. MaxiSoft 60 30.09.08 12:25 Сейчас в теме
Супер как можно получить добро на использование компоненты в своей разработке, довольно удобно вводить фотографий клиентов в базу, достаточно просто подключить камеру и сделать снимок! Большой респект за разработку.!!!
cmax; sCHTASS; +2 Ответить
7. Душелов 3899 30.09.08 12:58 Сейчас в теме
(6) все мои разработки можно использовать в своих разработках. можно где-нить в коде в комменте меня упомянуть и все :)
nurik727; +1 Ответить
8. gavril 43 30.09.08 15:31 Сейчас в теме
Зачет.
Так же новый товар можно добавлять ;)
9. Дуб 69 01.10.08 09:10 Сейчас в теме
А видео оно показывает? В своё время прикручивал систему ввода в БД фотографий пользователей. Прикрутил, работает, но в режиме видео не пашет. Т.е. чтобы "прицелиться", использую отдельную программку (запускается из 1С, но как Active-X не прикрутить её никак), а потом уже перехватываю камеру ВК и ловлю снимок..
10. Душелов 3899 01.10.08 09:13 Сейчас в теме
(9) Пример советую посмотреть. Видео в левом окошке, скриншот полученный - в правом.
13. Дуб 69 02.10.08 14:42 Сейчас в теме
(10) посмотрел. Прикольно. Но через раз выдаёт "Не удалось настроить графические параметры. Значение не попадает в ожидаемый диапазон". В принципе, если 1С (Предприятие) перезапустить - то запускается.
В целом - мне понравилось. Тем более, что до этого искал - ничего похожего не находил.
11. alexpa2005 01.10.08 19:11 Сейчас в теме
Что-то не скачивается. :(( Может, ссылку удалили, или с сервером проблемы. Пишет - "не удается загрузить download.php". Попробую завтра. А плюсик ставлю сегодня!!!
12. kabanoff 41 02.10.08 11:52 Сейчас в теме
Молодца! Интересная разработка.
14. Fisherru 78 02.10.08 15:16 Сейчас в теме
Наверное, возможно такое прикрутить к ЧеБурашкиной "[КОНТРОЛЬ] Охрана 1.0 - пропускной пункт"
Она бы тогда ещё и сотояние сотрудников на вползании/выползании фиксировала. :)))))
15. pioneex 03.10.08 11:40 Сейчас в теме
Интересно! Вопрос: как мне добавить в произвольной форме элемент управления "Душелов.WebCam", кроме копирования с демо примера?
16. JohnyDeath 293 03.10.08 12:08 Сейчас в теме
(15) наверное так: v8: Меню "Форма" - "Вставить ActiveX..." - Выбрать элемент "Душелов.WebCam"
17. pioneex 03.10.08 13:11 Сейчас в теме
Спасибо. Всё получилось!
18. pioneex 03.10.08 16:47 Сейчас в теме
Всё хорошо, но второй раз в одной сессии v8 открыть не получается...
19. seermak 659 02.11.08 14:41 Сейчас в теме
я тоже уже прикрутил обработку в программу - а ошибку (18) нельзя никак исправить?!
21. Душелов 3899 08.11.08 16:04 Сейчас в теме
(18) Ошибку воспроизвести не удалось. При закрытии формы точно вызываете команду Стоп(); ?
22. seermak 659 08.11.08 16:17 Сейчас в теме
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
Если НЕ ВебКамера = Неопределено Тогда
ВебКамера.Стоп();
КонецЕсли;
КонецПроцедуры
(21) - из программы
20. Душелов 3899 05.11.08 09:44 Сейчас в теме
Я посмотрю, почему второй раз нельзя открыть, видимо придется добавить команду очистки буфера и отключения от девайсов, и вызывать ее при закрытии обработки.
23. Душелов 3899 08.11.08 16:26 Сейчас в теме
А мой пример как отрабатывает?
24. seermak 659 08.11.08 16:42 Сейчас в теме
(23) специально еще раз поставил - одинаково Картинку выложил: http://infostart.ru/projects/2817/ рис 4 - тоже самое и на Вашей обработке
25. Душелов 3899 08.11.08 22:43 Сейчас в теме
(24) Давай конфигурацию, посмотрю ;)
26. seermak 659 09.11.08 07:20 Сейчас в теме
(25) обработка на : http://infostart.ru/projects/2817/ - еще заметил что после закрытия обработки камера остается подключенной и больше ни на какие программы работы с камерой не реагирует, отключается только тогда, когда закрываешь сессию. я на viste, но (по комментариям) проблема не в ней. Дрова: Sonix / 24.04.2007 / 5.7.28.500 /Acer Crystal Eye webcam
27. Душелов 3899 09.11.08 12:13 Сейчас в теме
(26) Скачал, посмотрю. А мой детектор движений как с камерой твоей работает? Там технология другая используется.
29. seermak 659 09.11.08 13:58 Сейчас в теме
(27) ага, во всяком случае, закрывается и стартует без ошибок.
30. Душелов 3899 13.11.08 13:12 Сейчас в теме
(29) Попробуйте теперь, и тест камеры тоже. Как это работает? (в тесте камера запускается 2 кнопкой слева, останавливается 3-ей)
31. seermak 659 13.11.08 18:25 Сейчас в теме
(30) по TestCam - по 2 кнопке - подключается +, по 3 - выключается, но только изображение с камеры, сама же камера остается включенной (сигнализирует светодиод возле камеры) Камера полностью отрубается только тогда, когда "положу" Form1. Ну и, соответственно, пример демо работает также. Ладно, Василь, видать так мой бук работает. :-( (Хотя детектор движения работает же нормально - а нельзя никак туда слить нужные функции?). У меня в конторе еще пока не купили камеру, (может на их камере пойдет без затыков) так что время терпит. Все равно, большое спасибо!
28. Душелов 3899 09.11.08 12:23 Сейчас в теме
(26) Твоя обработка у меня нормально работает, закрыл, открыл, заново запустил - все ок.
Ладно, попробую пошаманить в "Остановить()"...
32. Gens76 29.12.08 23:21 Сейчас в теме
33. arjuna 07.01.09 03:14 Сейчас в теме
Реально ли сделать просмотр видео из файла???
34. Душелов 3899 07.01.09 03:20 Сейчас в теме
(33) Берем АктивХ Windows Media Player и вперед.
36. dmam 11.02.09 10:13 Сейчас в теме
У меня тоже выскакивает ошибка при повторном открытии обработки и запуске.
Сделал то-же самое с помощью wiaaut.dll:

Перем ВебКамера;

Процедура ПослеОткрытия()
ВебКамера = СоздатьОбъект("АктивИкс");
ВебКамера.УстановитьАтрибут(Форма, "АктХ");
ВебКамера.СоздатьЭУ("WIA.VideoPreview");
КонецПроцедуры
//******************
Процедура ПолучитьКартинку()

Item = ВебКамера.Объект.Device.ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
Если ФС.СуществуетФайл("C:\WebCam.jpg") = 1 Тогда
ФС.УдалитьФайл("C:\WebCam.jpg");
КонецЕсли;
Image.SaveFile("C:\WebCam.jpg");
КартинкаКамеры.Загрузить("C:\WebCam.jpg");

КонецПроцедуры
37. Душелов 3899 13.02.09 19:36 Сейчас в теме
Для получения демо-версии или покупки обращайтесь по контактам, указанным в профиле.
38. Martyn 01.04.09 11:54 Сейчас в теме
Плюс ставлю чичас - смотрю потом! Долго искал нечто подобное.... Автору БОЛЬШОЙ респект!
39. ev-kov 5 17.04.09 20:20 Сейчас в теме
Компонента WIA не использует случаем ?
40. Душелов 3899 18.04.09 11:24 Сейчас в теме
41. ev-kov 5 18.04.09 11:55 Сейчас в теме
Душелов

WIA это Microsoft® Windows® Image Acquisition (WIA) Automation Library version 2.0

какая то ошибочка есть в ВК скрин ошибки(http://slil.ru/27461401). на тестовом примере и ловится, после того как получили картинку и закрыли форму обработки в 1с, открываем по новой обработку, жмем старт, в появившемся активиксе выбираем параметры потока, нажимаем ОК и дальше не работает ничего - ошибка.

Хотелось бы ускорить отладку ошибки, плюс есть некоторые вопросы, не бесплатно, можно обсудить в асе (62-387-523).
42. Душелов 3899 18.04.09 11:58 Сейчас в теме
Эту компоненту я более не развиваю.
43. ev-kov 5 18.04.09 12:47 Сейчас в теме
(42) очень жаль, а как насчет исходников ?
44. Душелов 3899 19.04.09 00:31 Сейчас в теме
(43) Исходники не распространяю.
49. Душелов 28.03.10 21:32 Сейчас в теме
50. anig99 2682 29.03.10 07:58 Сейчас в теме
(49) но это не значит, что другие ими не пользуются и не читают комменты?
45. Skobelev 02.06.09 09:46 Сейчас в теме
Классно, хочу прикрутить к системе пропусков
46. Jejer 20.06.09 01:30 Сейчас в теме
Супер, спа.
А можно сделать, чтобы при старте каждый раз не появлялось окно Properties?
pashoid; yurir; +2 Ответить
71. Desteny-life 15.09.17 08:27 Сейчас в теме
(46) (54) (62)
Автор исходников не распространяет, поэтому в самой компоненте наверное не отключишь при старте окно "Свойство", но можно сделать так - если подключена одна камера:
ВебКам = ЭлементыФормы.ЭлементУправления1;
Shell = Новый COMОбъект("WScript.Shell");
Shell.SendKeys("{ENTER}");
ВебКам.Старт();
Программное нажатие клавиши ENTER.
Окно будет появляться на несколько секунд, и не нужно будет от пользователя никаких действий.
47. CAIN 12 06.08.09 16:42 Сейчас в теме
У меня при запуске выдал ошибку: "не удалось нгастроить графические параметры"
48. anig99 2682 28.03.10 04:10 Сейчас в теме
Такая же фигня что и у многих с повторным стартом после остановки. Пробовал на ноуте со встроенной камерой на XP. Если выбирать прямой драйвер к камере, то повторно запустить не получается. Если же выбирать virtual driver (ноут asus поставляется с утилитами, в т.ч. и драйвером для пост-обработки), то стартует заново нормально.
51. mirco 72 30.11.10 21:23 Сейчас в теме
А под 8.2 существует способ использовать компоненту ?
52. Душелов 3899 01.12.10 07:03 Сейчас в теме
(51) Управляемые формы? Читайте мою статью.
53. rus_2403 03.12.10 11:00 Сейчас в теме
Компонента работает в демо-режиме или нет.Если да то в чем он выражается.Спасибо
54. Lokky 15.01.11 05:20 Сейчас в теме
Автору БОЛЬШУЩЕЕ СПАСИБО!!
Только вопрос.. А можно ли как-нибудь при старт() чтоб она запускалась не спрашивая настройки камеры?
55. yus12 13.10.11 16:54 Сейчас в теме
А скажите пожалуйста а в 8.2 упр. приложении будет работать?
56. yus12 13.10.11 21:20 Сейчас в теме
57. gorneev 12.11.11 18:25 Сейчас в теме
Огромное спасибо автору, на управляемом приложении работает.
58. ronron 24.11.11 22:48 Сейчас в теме
Автору спасибо и уважуха! Если заработаю на этом деньжат (что сделать постараюсь) - приду поделиться.
60. freek 28.12.11 14:06 Сейчас в теме
На основе данной компоненты сделали конфу по учету рабочего времени сотрудников
61. serpisal 10.03.12 15:32 Сейчас в теме
62. yoyoman 04.04.12 05:08 Сейчас в теме
Я был бы несказано рад, если бы можно было отключить появление настроек :(
63. Dansur 261 18.10.12 11:01 Сейчас в теме
(62) yoyoman, Автора уже нет в живых. светлая память.
64. eugen91 04.01.13 13:18 Сейчас в теме
Супер, работает! Спасибо большое! тестировали на УТ 10.3
65. Alex_241 04.01.13 13:50 Сейчас в теме
Добрый день, а откуда можно скачать вашу разработку желательно с описанием и примером, хотел потестировать. Заранее благодарен)))
66. Diversus 1952 01.08.13 14:11 Сейчас в теме
Внешняя компонента аналогичной направленности, только Native API для 1С 8.2 и 8.3: Внешняя компонента MediaBuild (создание фото и видео с веб-камер и IP-камер) для 1С:Предприятие 8.2, 8.3 (NativeAPI).
Умеет:
- делать фото с пред просмотром и без него
- снимать видео
- делать скриншоты
- поддерживает работу с веб-камерами и IP-камерами
- поддерживает наложение на видео дополнительного текста
67. 7OH 33 21.10.13 12:34 Сейчас в теме
Спасибо за компоненту - локально работает на 5+.
Кто подскажет, можно ли и как сделать работу через RDP-APP ?
68. 7OH 33 27.12.13 16:56 Сейчас в теме
А не поможете с проблемой ?
Создал ПолеHtmlДокумента на форме (толстый клиент пока - для отладки).
Далее
ЭлементыФормы.Актив.УстановитьТекст("<HT ML><body><OB JECT id=vk classid=CLSID:2F29718C-BA95-3F0D-A1E5-F75CBF88285D width=""100%"" height=""100%""></OBJECT></body></HTML>");

На форме сначала запрос на разрешение использования ActiveX - потом появляется черное окно.
Но при попытке доступа к свойствам
ЭлементВК = ЭлементыФормы.Актив.Документ.getElementById("vk");
	Если ЭлементВК = Неопределено Тогда
		Сообщить("Не найден объект компоненты!");
		Возврат;
	КонецЕсли;

виснет и всё.
Если уираю проверку и делаю стразу Старт() - тоже виснет.
Похоже не может показать запрос окна свойств камеры.
69. Иной 23.04.14 00:24 Сейчас в теме
А получать изображение с камер к которым доступ по IP никто не пробовал?
70. zsergey_ 14.12.15 20:04 Сейчас в теме
Оставьте свое сообщение