Факсимиле вместо подписи руководителя

Публикация № 1262611

Разработка - Печать - Печатные формы документов

Расширение добавляет подпись в справочнике "Физические лица" и позволяет использовать ее в печатных формах.

Всем доброго времени суток.

Столкнулся с вопросом использовать функционал факсимиле в БП 3.0 (3.0.77.106) и вот незадача как оказалось использовать можно только подпись ответственных лиц организации, а как быть с сотрудниками с правом подписи? тем более что их можно указывать в документах в поле руководитель или ответственный??

На ИТС есть описание, что такой механизм есть, но в моем релизе почему-то он отсутствует, и пришлось немного покопаться и поискать его в базе.

Но почему-то не нашел такого функционала в базе, хотя подбор изображения подписи указанного руководителя присутствует, но сама подпись способна быть присвоена только у организации во всем известном пункте.

Есть замечательный общий модуль: «УправлениеПечатьюБП» и в ней есть функция для формирования соответствия Факсимиле ( ПолучитьДанныеФаксимиле), но вот незадача в нее не попадает документ, только карточка организации и получить из ее тела документ или указанных в нем физических лиц не представляется возможным, хотя при выводе изображений на печатные формы в универсальном механизме происходит попытка получения подписи из переменной «СоответствиеФаксимиле», другое дело что попасть ей туда неоткуда и негде.

Как не искал, так и не нашел где привязать изображение к физлицу и ничего лучше не придумал как использовать справочник «Файлы», тем более, что он прекрасно работает с изображениями и есть к нему даже целый общий модуль «РаботаСФайлами», нам с него понадобится только одна функция: «РаботаСФайлами.ДанныеФайла(СсылкаНаСправочникФайлы)».

Как решение предлагаю добавить явный реквизит, в котором хранить ссылку на «файл» с хранящемся факсимиле, и по его заполненности использовать для печатных форм.

Но для такого решения у пользователя должны быть права на работу со справочником «Файлы».

В модуле «УправлениеПечатьюБП» есть интересное место где можем выполнить недостающее требование, и загрузить изображения, подписи использованных в документе физ. лиц, процедура «ДополнитьДокументПодписьюИПечатью» где мы и можем получить ситуацию одновременно присутствия самого документа, и заполненной переменной «СоответствиеФаксимиле». Которую тут же можно дополнить.

 

 

&НаСервере
Функция ПолучитьСсылкуНаВременноеХранилищеИзображенияИзВложенногоФайла(ОбъектВладелецФайла,ИмяПоляПрисоединенногоФайла)
	
	ПрисоединенныйФайл = ОбъектВладелецФайла[ИмяПоляПрисоединенногоФайла];
	
	Если ЗначениеЗаполнено(ПрисоединенныйФайл) Тогда
		ДанныеКартинки = РаботаСФайлами.ДанныеФайла(ПрисоединенныйФайл);
		ДвоичныеДанныеКартинки = ПолучитьИзВременногоХранилища(ДанныеКартинки.СсылкаНаДвоичныеДанныеФайла);
	КонецЕсли;
	
	СсылкаНаВременноеХранилище = ПоместитьВоВременноеХранилище(Новый Картинка(ДвоичныеДанныеКартинки), Новый УникальныйИдентификатор);
	
	Возврат СсылкаНаВременноеХранилище;
	
КонецФункции

&ИзменениеИКонтроль("ДополнитьДокументПодписьюИПечатью")
Процедура ТРМедия_ДополнитьДокументПодписьюИПечатью(ОбластьМакета, СведенияОДокументе, ОбъектыПечати, ПараметрыПечати)

	КлючевыеДанные = Новый Структура("Документ, Организация,
	|Предприниматель, Руководитель, ГлавныйБухгалтер,
	|ОтветственныйЗаОформление, Исполнитель, Кладовщик");

	// Заполняем по данным печатной формы
	Если ТипЗнч(СведенияОДокументе) = Тип("ВыборкаИзРезультатаЗапроса") Тогда
		ЗаполнитьЗначенияСвойств(КлючевыеДанные, СведенияОДокументе);
		Колонки = СведенияОДокументе.Владелец().Колонки;
	ИначеЕсли ТипЗнч(СведенияОДокументе) = Тип("СтрокаТаблицыЗначений") Тогда
		Колонки = СведенияОДокументе.Владелец().Колонки;
		Если Колонки.Найти("ДанныеШапки") <> Неопределено Тогда
			ЗаполнитьЗначенияСвойств(КлючевыеДанные, СведенияОДокументе.ДанныеШапки);
		Иначе
			ЗаполнитьЗначенияСвойств(КлючевыеДанные, СведенияОДокументе);
		КонецЕсли;
	Иначе
		УдалитьВсеОбластиФаксимиле(ОбластьМакета);
		Возврат;
	КонецЕсли;

	// Если не нашлось одноименных полей, ищем похожие
	Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Документ) Тогда
		Если Колонки.Найти("Ссылка") <> Неопределено Тогда
			КлючевыеДанные.Документ = СведенияОДокументе.Ссылка;
		Иначе
			УдалитьВсеОбластиФаксимиле(ОбластьМакета);
			Возврат;
		КонецЕсли;
	КонецЕсли;

	ИсключаемыеТипыДокументов = ИсключаемыеТипыДокументов(ПараметрыПечати);
	Если ИсключаемыеТипыДокументов.Найти(ТипЗнч(КлючевыеДанные.Документ)) <> Неопределено Тогда

		ДанныеОбласти      = ОбъектыПечати.НайтиПоЗначению(КлючевыеДанные.Документ);
		ОбластьВладелец    = ДанныеОбласти.Представление;
		МассивИменПоказателей = МассивИменПоказателейФаксимиле();
		Для Каждого ЗначениеПоказателя ИЗ МассивИменПоказателей Цикл
			ОчиститьОбластьФаксимиле(ОбластьМакета, ЗначениеПоказателя);
		КонецЦикла;
		Возврат;
	Иначе
		// Организация не всегда хранится в реквизите Организация
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация) И Колонки.Найти("Поставщик") <> Неопределено Тогда
			КлючевыеДанные.Организация = СведенияОДокументе.Поставщик;
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация) И Колонки.Найти("Грузоотправитель") <> Неопределено Тогда
			КлючевыеДанные.Организация = СведенияОДокументе.Грузоотправитель;
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация) И Колонки.Найти("ДанныеШапки") <> Неопределено Тогда
			Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация) И СведенияОДокументе.ДанныеШапки.Свойство("Поставщик") <> Неопределено Тогда
				КлючевыеДанные.Организация = СведенияОДокументе.ДанныеШапки.Поставщик;
			КонецЕсли;
			Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация) И СведенияОДокументе.ДанныеШапки.Свойство("Грузоотправитель") <> Неопределено Тогда
				КлючевыеДанные.Организация = СведенияОДокументе.ДанныеШапки.Грузоотправитель;
			КонецЕсли;			
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Организация)
			ИЛИ ТипЗнч(КлючевыеДанные.Организация) <> Тип("СправочникСсылка.Организации") Тогда
			УдалитьВсеОбластиФаксимиле(ОбластьМакета);
			Возврат;
		КонецЕсли;

		// Ситуация, когда в документе подписанты явно не указаны
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Руководитель)
			ИЛИ НЕ ЗначениеЗаполнено(КлючевыеДанные.ГлавныйБухгалтер) Тогда

			ДатаДокумета = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(КлючевыеДанные.Документ, "Дата");
			Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(КлючевыеДанные.Организация, ДатаДокумета);

			Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Руководитель) Тогда
				КлючевыеДанные.Руководитель = Руководители.Руководитель;
			КонецЕсли;
			Если НЕ ЗначениеЗаполнено(КлючевыеДанные.ГлавныйБухгалтер) Тогда
				КлючевыеДанные.ГлавныйБухгалтер = Руководители.ГлавныйБухгалтер;
			КонецЕсли;

		КонецЕсли;

		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Исполнитель) Тогда
			Если Колонки.Найти("ПредставительОрганизации") <> Неопределено Тогда
				КлючевыеДанные.Исполнитель = СведенияОДокументе.ПредставительОрганизации;
			Иначе
				КлючевыеДанные.Исполнитель = КлючевыеДанные.Руководитель;
			КонецЕсли;
		КонецЕсли;

		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Кладовщик) Тогда
			Если Колонки.Найти("ОтпускПроизвел") <> Неопределено Тогда
				КлючевыеДанные.Кладовщик = СведенияОДокументе.ОтпускПроизвел;
			Иначе
				Если ЗначениеЗаполнено(КлючевыеДанные.Исполнитель) Тогда
					КлючевыеДанные.Кладовщик = КлючевыеДанные.Исполнитель;
				ИначеЕсли ЗначениеЗаполнено(КлючевыеДанные.Руководитель) Тогда
					КлючевыеДанные.Кладовщик = КлючевыеДанные.Руководитель;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;

		// Предприниматель - он же руководитель
		Если НЕ ЗначениеЗаполнено(КлючевыеДанные.Предприниматель) Тогда
			КлючевыеДанные.Предприниматель = КлючевыеДанные.Руководитель;
		КонецЕсли;
	КонецЕсли;

	ДанныеОбласти      = ОбъектыПечати.НайтиПоЗначению(КлючевыеДанные.Документ);
	ОбластьВладелец    = ДанныеОбласти.Представление;
	ПозицияРазделителя = СтрНайти(ОбластьВладелец, ";", НаправлениеПоиска.СКонца);
	Если ПозицияРазделителя <> 0 Тогда
		ОбластьВладелец = СокрЛП(Прав(ОбластьВладелец, СтрДлина(ОбластьВладелец) - ПозицияРазделителя));
		ДанныеОбласти.Представление = ОбластьВладелец;
	КонецЕсли;

	СоответствиеФаксимиле          = Новый Соответствие;
	МассивИменПоказателей          = Новый Массив;
	МассивУдаляемыхИменПоказателей = Новый Массив;
	ОрганизацияЮридическоеЛицо     = Истина;

	ПолучитьДанныеФаксимиле(СоответствиеФаксимиле,
	МассивИменПоказателей,
	МассивУдаляемыхИменПоказателей,
	ОрганизацияЮридическоеЛицо,
	КлючевыеДанные.Организация,
	ПараметрыПечати);
	#Вставка
	
	СсылкаНаВременноеХранилище = Неопределено;
	
	Если ЗначениеЗаполнено(КлючевыеДанные.Руководитель) Тогда 
		Если ЗначениеЗаполнено(КлючевыеДанные.Руководитель.TRMedia_ФайлПодписьФизЛица) Тогда 
			
			СсылкаНаВременноеХранилище = ПолучитьСсылкуНаВременноеХранилищеИзображенияИзВложенногоФайла(КлючевыеДанные.Руководитель,"TRMedia_ФайлПодписьФизЛица");
			СоответствиеФаксимиле.Вставить(КлючевыеДанные.Руководитель,
				СсылкаНаВременноеХранилище);
  
		КонецЕсли;
	КонецЕсли;
	
	#КонецВставки	

	// Удаляем заведомо лишние картинки из табличного документа
	Для Каждого ЗначениеПоказателя ИЗ МассивУдаляемыхИменПоказателей Цикл
		ОчиститьОбластьФаксимиле(ОбластьМакета, ЗначениеПоказателя);
	КонецЦикла;

	// В некоторых случаях на форме есть взаимоисключающие реквизиты.
	// Например, подпись руководителя и подпись предпринимателя в счете-фактуре
	Если ОрганизацияЮридическоеЛицо Тогда
		ОчиститьОбластьФаксимиле(ОбластьМакета, "ФаксимилеПредприниматель");
	Иначе
		ОбластьФаксимиле = ОбластьМакета.Области.Найти("ФаксимилеПредприниматель");
		Если ОбластьФаксимиле <> Неопределено Тогда
			ОчиститьОбластьФаксимиле(ОбластьМакета, "ФаксимилеРуководитель");
		КонецЕсли;
	КонецЕсли;

	РасшифровкаФаксимилеМакета = Новый Структура();

	Для Каждого ЗначениеПоказателя ИЗ МассивИменПоказателей Цикл

		// Печать нельзя привязать к ответственному лицу
		Если СтрНайти(ЗначениеПоказателя, "ФаксимилеПечать") > 0
			ИЛИ СтрНайти(ЗначениеПоказателя, "ФаксимильнаяПечать") > 0 Тогда
			КлючСоответствия = "Организация";
		Иначе
			КлючСоответствия = СтрЗаменить(ЗначениеПоказателя, "Факсимиле", "");
			КлючСоответствия = СтрЗаменить(КлючСоответствия,   "Накладная", "");
			КлючСоответствия = СтрЗаменить(КлючСоответствия,   "Услуги",    "");
			КлючСоответствия = СтрЗаменить(КлючСоответствия,   "Материалы", "");
		КонецЕсли;

		ОбработатьОбластьФаксимиле(РасшифровкаФаксимилеМакета,
		ОбластьВладелец,
		ОбластьМакета,
		ЗначениеПоказателя,
		КлючевыеДанные,
		КлючСоответствия,
		СоответствиеФаксимиле);

	КонецЦикла;

	// Измененный макет, не содержащий области факсимиле
	Если РасшифровкаФаксимилеМакета.Количество() = 0 Тогда
		УдалитьВсеОбластиФаксимиле(ОбластьМакета);
		Возврат;
	КонецЕсли;

	// Расшифровка в первой колонке последней строки
	АдресПараметровРасшифровки = ПоместитьВоВременноеХранилище(РасшифровкаФаксимилеМакета, Новый УникальныйИдентификатор);

	ОбластьРасшифровки = ОбластьМакета.Область("R" + Формат(ОбластьМакета.Области[ОбластьВладелец].Низ, "ЧГ=")
	+ "C1:R" + Формат(ОбластьМакета.Области[ОбластьВладелец].Низ, "ЧГ=") + "C1");

	ОбластьРасшифровки.Имя = "РасшифровкаФаксимилеМакета_" + ОбластьВладелец;
	ОбластьРасшифровки.Расшифровка = АдресПараметровРасшифровки;
	ОбластьРасшифровки.ИспользованиеРасшифровки = ИспользованиеРасшифровкиТабличногоДокумента.БезОбработки;

КонецПроцедуры

&ИзменениеИКонтроль("НастройкиПодписиИПечати")
Функция ТРМедия_НастройкиПодписиИПечати(ИмяМакета)

	Настройки = Новый Структура;
	Настройки.Вставить("ВыводитьФаксимиле", Ложь);
	Настройки.Вставить("ФаксимилеДоступноДляВывода", Истина);

	НастройкиВыводаФаксимиле = ХранилищеОбщихНастроек.Загрузить("УправлениеФаксимиле", "НастройкиВыводаФаксимиле");
	Если НастройкиВыводаФаксимиле <> Неопределено
		И НастройкиВыводаФаксимиле.Свойство("ФаксимилеДоступноДляВывода") Тогда

		Настройки.ФаксимилеДоступноДляВывода = НастройкиВыводаФаксимиле.ФаксимилеДоступноДляВывода;
		Если Не Настройки.ФаксимилеДоступноДляВывода Тогда
			Возврат Настройки;
		КонецЕсли;

		ВыводитьФаксимиле = Неопределено;
		НастройкиВыводаФаксимиле.Свойство("ВыводитьФаксимиле" + ИмяМакета, ВыводитьФаксимиле);
		Если ВыводитьФаксимиле <> Неопределено Тогда
			#Удаление
			Настройки.ВыводитьФаксимиле = ВыводитьФаксимиле;
			#КонецУдаления
			#Вставка
        	Настройки.ВыводитьФаксимиле = ?(НастройкиВыводаФаксимиле.ФаксимилеДоступноДляВывода,Истина,ВыводитьФаксимиле);
			#КонецВставки
		КонецЕсли;

	КонецЕсли;

	Возврат Настройки;

КонецФункции


Как-то так. Надеюсь, кому-нибудь поможет.

Тестировалось на Бухгалтерия предприятия, редакция 3.0 (3.0.77.106) .

Скачать файлы

Наименование Файл Версия Размер
факсимиле вместо руководителя:

.cfe 25,73Kb
09.07.20
0
.cfe 25,73Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Trucker 6 15.07.20 12:57 Сейчас в теме
На ИТС есть описание, что такой механизм есть, но в моем релизе почему-то он отсутствует, и пришлось немного покопаться и поискать его в базе.


Функционал "Факсимиле подписи уполномоченного сотрудника" доступен начиная с релиза 3.0.78
https://its.1c.ru/db/updinfo#content:764:1:issogl1_9
Оставьте свое сообщение

См. также

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы документов Пакетная печать Email Оптовая торговля Оптовая торговля v8 БП2.0 КА1 УПП1 УТ10 Россия БУ Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    51346    32    trendy    20    

Ошибка Метод объекта не обнаружен (ПолучитьНомерНаПечать)

Печатные формы документов Адаптация типовых решений v8 1cv8.cf Абонемент ($m)

Исправление Ошибки "Метод объекта не обнаружен (ПолучитьНомерНаПечать)" для УТ 11.4 и других конфигураций, использующих БСП

1 стартмани

05.08.2020    500    0    aksyoma    1    

Выгрузка данных в формат CSV для загрузки в Сбербанк Онлайн

Печатные формы документов Зарплата Обмен с банком v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма для выгрузки данных о суммах заработной платы в формате CSV для Сбербанк Онлайн. Зарплата и управление персоналом, редакция 3.1

1 стартмани

07.07.2020    1202    1    Anton_83    0    

Вывод кодов маркировки в CSV файл из документа "Заказ на эмиссию кодов маркировки СУЗ ИСМП"

Печатные формы документов Розничная торговля v8 Розница УНФ БП3.0 УТ11 УУ Абонемент ($m)

Внешняя обработка позволяет вывести полученные коды маркировки в CSV файл.

2 стартмани

14.06.2020    1076    3    rosi    2    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом Промо

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    22753    13    stvorl    0    

Обработка печати ТТН без вызова формы. Печать ТТН 1208

Печатные формы документов Оптовая торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Печатает все три печатные формы обработки Печать ТТН 1208 прямо в модуле объекта. Все процедуры вынесены в модуль новой обработки.

1 стартмани

25.05.2020    823    0    unknown181538    0    

Перевод сотрудников на удаленную работу (расширение для ЗУП 3.1)

Печатные формы документов Зарплата v8 v8::СПР v8::УФ ЗУП3.x БУ Абонемент ($m)

Реализована возможность массового формирования необходимых юридических документов для перевода сотрудников на удалённую работу. Для конфигурации "Зарплата и управление персоналом 3.1".

1 стартмани

06.05.2020    1361    1    Ant10    0    

Нумерация счетов-фактур для печати для Бухгалтерии предприятия 3.0

Печатные формы документов Оптовая торговля v8 v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

Небольшая доработка для типовой конфигурации Бухгалтерия предприятия 3.0 - предназначена для коррекции вывода на печать номеров счетов-фактур в печатной форме документа "Счет-фактура выданный" и отчетов "Книга продаж" и "Книга покупок". Обработка выводит номер на печать неизменным, с префиксом и нулями.

1 стартмани

05.05.2020    1287    3    Юля789    0    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме Промо

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    28570    4    denmax    2    

Печать договоров из присоединенных файлов

Печатные формы документов v8 v8::ОУ УТ11 УУ Абонемент ($m)

Обработка для печати присоединенных файлов договоров.

1 стартмани

28.04.2020    752    1    ICeZm    0    

Отладка и создание дополнительной печатной формы на основе шаблона

Печатные формы документов v8 БП3.0 УТ11 ЗУП3.x Россия Абонемент ($m)

Шаблон/заготовка, для отладки внешней печатной формы.

2 стартмани

18.04.2020    1172    3    ah7777777    0    

http сервис, возвращающий печатную форму

Печатные формы документов Прочие инструменты разработчика v8 УТ11 Россия Абонемент ($m)

Расширение, которое по get запросу в виде: http:///hs/WSPrint/Download/?UUID=&IDPF=&format= возвращает указанную печатную форму.

1 стартмани

09.04.2020    2277    4    user1350020    0    

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов Промо

Печатные формы документов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    35356    18    GusevNA    6    

Заполнение "Требования-накладной" остатками на складе

Печатные формы документов Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Позволяет заполнить документ "Требования-накладная" остатками на выбранном складе по всем счетам учета.

2 стартмани

30.03.2020    945    4    kotka74    4    

Заполнение работ по схеме интеркампани для типовой конфигурации "Управление торговлей" 11.4 для документа Передача товаров

Печатные формы документов Учет ТМЦ v8 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка - заполнение работ по схеме интеркампани (переброска положительных остатков одной организации на другую организацию при продаже "в минус") для типовой конфигурации "Управление торговлей" 11.4 в документе Передача товаров между организациями. Схема интеркампани не предусматривает вариант переброски номенклатуры с типом "работа" с одной организации на другую. Данная обработка закрывает данный вопрос.

1 стартмани

29.02.2020    928    0    MadJhey    0    

Шаблон для разработки внешних печатных форм с возможностью тестирования и отладки программного кода, печати непроведенных документов и открытия формы обработки перед печатью (на примере печати Расходной накладной)

Универсальные печатные формы Печатные формы документов v8 УТ11 Россия УУ Абонемент ($m)

Внешняя печатная форма печати Расходной Накладной из документа "Реализация Товаров и Услуг" с возможностью тестирования и отладки программного кода, печати непроведенных документов и открытия формы обработки перед печатью . Обработка полезна программистам, можно использовать как шаблон для создания собственных внешних печатных форм с отладкой кода при разработке.

3 стартмани

26.02.2020    1270    0    putnikvp    3    

Печать и подпись на счете. Авто отправка по электронной почте для Бухгалтерии и УТ Промо

Печатные формы документов Оптовая торговля Email Оптовая торговля v8 БП2.0 УТ10 Россия Абонемент ($m)

Подключаемая внешняя обработка позволяет формировать и отправлять счет с цветными печатью и подписями на электронную почту клиента

1 стартмани

10.04.2012    48809    100    PiterPen    92    

Формирование и печать закрывающих документов для УНФ 1.6

Печатные формы документов Обработка документов Оптовая торговля Производство готовой продукции (работ, услуг) v8 УНФ БУ УУ Абонемент ($m)

Расширение для автоматического формирования и печати закрывающих документов ("Акт выполненных работ" или "Расходная накладная" и "Счет-фактура).

5 стартмани

18.12.2019    2279    2    dour-dead    0    

Формирование УПД для ЭДО (электронного документооборота) БП 3.0, УНФ 1.6, УТ 11, КА 2, УТ 10.3 обновлено 06.05.20

Печатные формы документов Документооборот и делопроизводство Оптовая торговля v8 v8::БУ v8::ОУ УТ10 УНФ БП3.0 УТ11 КА2 БУ Абонемент ($m)

Обработка для создания файла XML универсального передаточного документа (далее УПД) для отправки в электронный документооборот (ЭДО). Опробовал основные системы ЭДО (СБИС, ДИАДОК, Synerdocs) ошибок нет, отправляет. Для конфигураций БП 3.0, УНФ 1.6, УТ 11, КА 2, УТ 10.3 последних версий.

2 стартмани

11.12.2019    4528    57    program345    20    

Пример сохранения печатной формы в WORD (обычные и управляемые формы)

Печатные формы документов Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает, как можно сохранить, например, договор, в WORD с последующей передачей его клиенту на подпись.

1 стартмани

03.12.2019    2817    6    Denr83    0    

Шаблоны для создания внешних печатных форм с авторегистрацией (3.0.1.1) Промо

Печатные формы документов Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Шаблоны для создания за 5 минут внешних печатных форм с авторегистрацией на основе типовых печатных форм встроенных в конфигурации 1С:Предприятия 8. А также примеры готовых внешних печатных форм и в пятимитнутная видео-инструкция.

1 стартмани

12.03.2010    68999    179    alexk-is    117    

Печать непроведенных документов в 1С: УТ, КА, ERP, Розница

Печатные формы документов v8 ERP2 УТ11 КА2 Россия Абонемент ($m)

Бывают ситуации, когда необходимо печатать непроведенные документы.

3 стартмани

22.11.2019    3352    12    Denr83    0    

Разбивка отпускных дней по рабочим периодам в приказе на отпуск в УПП 1.3

Управление персоналом (HRM) Печатные формы документов v8 УПП1 Россия БУ Абонемент ($m)

Внешняя печатная форма для документа "Отпуска организаций" в 1С УПП. В приказе на предоставление отпуска сотруднику необходима разбивка отпускных дней по рабочим периодам.

1 стартмани

11.11.2019    2413    1    blem    0    

Бухгалтерия предприятия 3.0, счет с произвольными реквизитами получателя

Печатные формы документов v8 БП3.0 Абонемент ($m)

Расширение для формирования счета с произвольными реквизитами получателя в Бухгалтерии предприятия 3.0.

1 стартмани

28.10.2019    3930    0    kassbar    0    

Печать и подпись на счете. Отправляем на электронную почту для УТ 11. Бета-версия Промо

Печатные формы документов Управление взаимоотношениями с клиентами (СRM) Email Управление взаимоотношениями с клиентами (СRM) v8 УТ10 Россия БУ УУ Абонемент ($m)

Программа для отправки счета, со вставленными печатью и подписями должностных лиц на почту клиента для УТ 11

1 стартмани

07.03.2013    26277    15    PiterPen    20    

Почтовый или фактический адрес организации в документах вместо юридического

Печатные формы документов v8 БП3.0 Россия БУ Абонемент ($m)

Расширение для БП 3.0 (и конфигураций на её основе) изменяет алгоритм формирования текстового представления Организации/Контрагента, которое выводится на печать в документы, не снимая конфигурацию с поддержки и с минимальными затратами на поддержку и обновления. Помогает, когда адрес фактической деятельности предприятия не совпадает с адресом постановки на учет в налоговой или ИП не хочет "светить" свой домашний адрес в документах.

2 стартмани

24.10.2019    3839    2    Kostenelo    0    

Создание текстов договоров по шаблонам Word и организация их хранения в присоединенных файлах

Расширения Печатные формы документов v8 БП3.0 Россия Абонемент ($m)

Публикация посвящена реализации механизма создания текстов договоров из шаблонов, хранимых в справочнике «Файлы», с последующим сохранением этих текстов в присоединенных к договорам файлах. Используется механизм расширений.

1 стартмани

07.10.2019    3010    12    vikhrov53    1    

Шаблон разработки печатных форм и подключения к конфигурациям на БСП 2.х и БСП 3.0

Печатные формы документов БСП (Библиотека стандартных подсистем) Расширения v8 1cv8.cf Абонемент ($m)

«Вместо поставки внешних печатных форм в виде внешних обработок рекомендуется вести их разработку с помощью расширений конфигурации.» [ИТС, БСП гл. 3.38 Печать] У меня задачи типа «Требуется разработать печатную форму …» появляются регулярно, но с временными интервалами. Что бы вести разработку единообразно, для конфигураций на БСП, я заготовил шаблон для таких задачек, который позволяет мне сразу приступить к разработке макета и алгоритма формирования печатной формы, а «обертка» из БСП уже готова.

1 стартмани

04.10.2019    26140    45    tolX5    18    

Сохранение и передача документов по E-mail. Счет, Акт, ТОРГ-12, Счет-Фактура 1137, Акт сверки. XLS, PDF, MXL, HTM Бухгалтерия 2.0 (КОРП) Промо

Печатные формы документов Email v8 БП2.0 Россия Абонемент ($m)

Обработка позволяет выбирать документы за период (Счет, Реализация товаров и услуг, Счет Фактура), добавлять печати, подписи, логотип (только в счет), сохранять документы в различных форматах (XLS, PDF, MXL, HTM) и отправлять по электронной почте. Существует отбор по контрагентам.

1 стартмани

03.09.2012    20256    29    gsmirnov    12    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    23923    20    sapervodichka    14    

Заказ поставщику для УНФ 1.6

Оптовая торговля Печатные формы документов Оптовая торговля v8 УНФ УУ Абонемент ($m)

Внешняя печатная форма Заказ поставщику для УНФ 1.6 к одноименному документу.

1 стартмани

17.06.2019    3117    2    prime9    0    

УПД и УКД для Диадок из УТ 10.3

Печатные формы документов Внешние источники данных Оптовая торговля Оптовая торговля v8 v8::ОУ УТ10 БУ Абонемент ($m)

УПД (Универсальный передаточный документ) и УКД (универсальный корректировочный документ) - внешние печатные формы для передачи в ДИАДОК, из конфигурации УТ 10.3.

1 стартмани

07.06.2019    2933    26    Skana    4    

Счет на оплату покупателю + отправка по электронной почте Промо

Печатные формы документов Email Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Внешняя печатная форма для документа "Счет на оплату покупателю". Отправляет по электронной почте сформированный файл печатной формы в формате *.xls.

1 стартмани

13.11.2012    26526    15    siranush    9    

Обработка для формирования списка отпусков, распечатки приказов отпусков, создания документов "Приказ на отпуск" по сотрудникам в Камин 3.5

Обработка документов Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 1cv8.cf Россия БУ Абонемент ($m)

Создана обработка для формирования списка отпускников из документов график отпусков, распечатки приказов на отпуск по форме Т- 6 выбранных сотрудников, создание документов по выбранным сотрудникам, а также отбор из списка по выбранному периоду и точной дате начала отпусков в КАМИН:Расчет заработной платы для бюджетных учреждений. Версия 3.5.

1 стартмани

11.05.2019    3326    0    dendzu    0    

Расширение для печати номеров ГТД из реквизитов номенклатуры в печатных формах счета-фактуры и УПД в БП 3.0

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 БУ Абонемент ($m)

Заполнение значений номера ГТД и страны (в печатных формах Счет-фактура и УПД) из реквизитов справочника номенклатуры, если они не заполнены в документе.

2 стартмани

03.03.2019    3575    1    Sergant    2    

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016. Полная автоматизация

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Визуализация ЭЦП по ГОСТу Р 7.0.97-2016, предложенная в предыдущей статье (https://infostart.ru/public/931674/) на данную тему, очень прижилась у меня в организации. Начальник часть писем повелел подписывать ЭЦП и не тревожить его по пустякам. Но механизм подписи требовал некоторого количества ручных действий, а хочется полной автоматизации. Итак, постановка задачи: штамп должен позиционироваться сам, pdf-файл со штампом ЭЦП должен создаваться сам и в карточку исходящего документа тоже должен сам загружаться.

1 стартмани

19.02.2019    14665    48    soulner    45    

Пример пакетной печати Торг-12, счет-фактуры и счета на оплату с штрихкодами в типовой конфигурации УТ11 Промо

Пакетная печать Инструментарий разработчика Печатные формы документов v8 УТ11 Абонемент ($m)

1. Пакетная печать (ТОРГ-12 + Счет фактура + Счет на оплату) 2. Штрихкодирование (для УТ11) 3. Отладка внешней печатной формы управляемого приложения (для БСП) 4. Пример внешней печатной формы для УТ11 5. Пример вызова одной формы внешней обработки из другой, с передачей параметров в открываемую форму.

1 стартмани

15.12.2011    27268    15    Leo_A    14    

Печать документов другой базы, используя web сервисы

Печатные формы документов WEB v8 1cv8.cf Россия Абонемент ($m)

Обработка позволяет подключиться к другой базе по WEB Сервису и распечатать выбранный документ с выбранной печатной формой.

2 стартмани

29.01.2019    5207    7    user5300    2    

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Электронный документооборот шагает по стране, стали проходить в организацию мою электронные письма, даже 1С побаловала обновлением Документооборота с исправлением некоторых ошибок ЭДО. Однако совершенно непонятно, как с использованием 1С Документооборот выполнить пункт 5.23 ГОСТа Р 7.0.97-2016, а именно визуализировать электронную подпись (далее ЭП) на документе. Очень надеюсь, что в при следующих обновлениях 1С реализуют данную возможность, но пока предлагаю временное решение.

1 стартмани

28.10.2018    12887    35    soulner    16    

Отправка печатных форм документов на почту в pdf. Без изменения конфигурации

Печатные формы документов Email v8 БП2.0 УТ10 УПП1 БП1.6 Абонемент ($m)

Пример внешней печатной формы с отправкой в pdf.

2 стартмани

03.08.2018    9144    14    SITR-utyos    1    

Подключаемые печатные формы с .DOCX макетом без Word'а

Универсальные обработки Печатные формы документов v8 1cv8.cf Абонемент ($m)

Данная обработка является подключаемой печатной формой в docx, своего рода шаблоном для удобного и быстрого выпуска новых печатных форм на основе docx макета. При этом не требуется установленный word.

1 стартмани

25.07.2018    9855    45    🅵🅾️🆇    31    

Акт списания материальных запасов

Печатные формы документов Учет ТМЦ Учет ТМЦ v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешний отчет, позволяющий печатать акты списания материалов по требованиям-накладным.

1 стартмани

24.07.2018    2493    19    Ефремов    1    

Создание пачки/пакета печатных документов (WORD) и сохранение их в базе данных

Обработка документов Печатные формы документов Управление персоналом (HRM) Пакетная печать Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Казахстан БУ Абонемент ($m)

Обработка создает документы Уведомление и Дополнительное соглашение для сотрудника(ов) и сохраняет файлы по указанному пути. После чего (проверив правильность сформированных файлов) можно загрузить их в БД, привязав к соответственному сотруднику.

2 стартмани

25.06.2018    6708    9    LeoKeyn    0    

Формирование и рассылка по электронной почте уведомлений об отпусках (УПП 1.3 / КА 1.1)

Печатные формы документов Email Управление персоналом (HRM) Управление персоналом (HRM) v8 КА1 УПП1 Россия БУ Абонемент ($m)

Создание рассылки информационных писем для конфигурации УПП 1.3 и КА 1.1 о начале отпуска. Рассылка ведется согласно данных Графика отпусков организации, на электронную почту сотрудника и руководителя сотрудника, или только на почту руководителя сотрудника, если у сотрудника отсутствует электронная почта.

1 стартмани

18.06.2018    6491    9    Farsis    0    

Отправка печатных форм по Email (БП 3.0) - Печатные формы для БП 3.0: Акт, Счет на оплату, УПД, ТОРГ-12, Счет-фактура

Email Документооборот и делопроизводство Оптовая торговля Документооборот и делопроизводство Оптовая торговля Печатные формы документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка журнал-список документа "Реализация (акты, накладные)" с функцией отправки печатных форм подчиненных документов, т.е. возможно отправить по Email печатные формы реализации и подчиненных документов. Тестирование проводилось на релизе БП 3.0.58.26 - 3.0.73.50 (на релизах выпущенных с ноября ошибок в работе не замечено). Осенние изменения наименования объектов в бухгалтерии учтены. После релиза 3.0.64 изменился механизм вывода печати и подписей, что в большинстве своем отключило вывод их во внешних печатных формах.

1 стартмани

30.05.2018    7952    14    izidakg    0    

Включение печатной формы счета-фактуры, используемой при реализации сырых шкур и лома металлов. Для Бухгалтерии 3.0

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

Включение штатного функционала для печати СФ при продаже сырых шкур животных, лома и отходов черных и цветных металлов, алюминия вторичного и его сплавов.

1 стартмани

26.01.2018    8282    20    SkrAn    4    

Счёт на оплату с разными заказчиком и плательщиком. БП 3.0

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Россия Абонемент ($m)

При подобной трёхсторонней схеме взаимодействия заказчик требует именно такой счёт, который мне не удалось получить в типовой бухгалтерии (не исключаю, что плохо искал).

5 стартмани

25.12.2017    4443    4    ATwice    1    

БП 3.0 и 54-ФЗ: расширение для печати чека онлайн ККТ из Расходного кассового ордера на основании Поступления товаров и услуг

Печатные формы документов ККМ Кассовые операции Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Расширение для печати чека на онлайн ККМ в 1С:Бухгалтерия 3.0 (3.0.52.42) из документа Расходный кассовый ордер, который введен на основании документа Поступление товаров и услуг.

1 стартмани

10.10.2017    12014    14    rozer    17