Исправление резервов. Сверка остатков с резервами. Проверка на зависшие резервы. Заполнение документа списком кодов товаров. 1С 7.7

Публикация № 1122002

Администрирование - Администрирование данных 1С - Обработка документов

Предлагаю технологию выявления ошибок в резервах отчетами "Сверка остатков с резервами" и "Проверка на зависшие резервы". Предлагаю способ автоматизированного исправления резервов заполнением документа списком кодов товаров. 1С 7.7. Вручную это делать очень кропотливо.

Если резервы больше остатков по какой-то позиции, документы заявки покупателей и реализации проводиться не будут до исправления ошибки. Данное сообщение подскажет, как исправить ситуацию, если их несколько.

1) Отчет "Сверка остатков с резервами" выявляет разницу между остатками и резервами. Если он не пустой, значит ошибки есть и их необходимо устранить.

2) Сохраняем файл в Эксель и удаляем из него все строки и колонки кроме значений колонок код и разница. В зависимости от способа исправления может понадобиться умножить количество на минус единицу.

3) Удалить лишние значения (подготовить данные для загрузки в документ) можно и в табличном редакторе 1С, но все же в Эксель нагляднее. Сохраняем оставшиеся значения в CSV-файл, чтобы в виде текста загрузить его в документ 1С7.7.

4) Затем открываем обработку "Заполнения табличной части документа кодами товаров из текстового файла" и переносим содержимое CSV в многострочное поле ввода этой обработки.

Данная обработка очень простая, но очень полезная и нужная, она содержит поле выбора произвольного документа и многострочное текстовое поле ввода для нескольких строк значений в формате "код_товара;количество" и позволяет просто и быстро заполнить номенклатурой с количеством множество различных документов. В зависимости от способа исправления в поле документа можно выбрать заявку, реализацию, поступление, снятие резерва. В заявках или реализациях после заполнения можно проставить цены стандартным функционалом по виду цен.

 
 Код процедуры заполнения документа товарами

5) Конечно, сделать корректировку (например оприходовать разницу между остатками и резервами) не выход а только временное решение и с ошибками все равно надо разбираться. В этом поможет следующий отчет "Поиск заявок, от которых не списаны резервы".

6) По итогу данного отчета надо заполнить документ "Снятие резерва" или "сторнирование резерва".

Заполнить его можно тоже так же, как я выше показал, с поступлением в пункте 4.

7) Снятие резерва по складу. В отчете "Резервы ТМЦ" сделана кнопка "Снятие резерва", которая формирует соответствующий документ и заполняет его остатками резерва.

Заявки старого периода от которых не сформированы накладные имеет смысл контролировать отдельно.

Отчеты написаны в комплексной конфигурации 4.2 (7.70.424). Версия платформы 7.70.027.

Скачать файлы

Наименование Файл Версия Размер
Сверка остатков с резервами 1С 7.7
.ert 117,00Kb
12.09.19
0
.ert 117,00Kb Скачать
Проверка на зависшие резервы 1С 7.7
.ert 113,00Kb
12.09.19
0
.ert 113,00Kb Скачать
Заполнение документа списком кодами товаров 1С 7.7
.ert 111,50Kb
12.09.19
0
.ert 111,50Kb Скачать
Заполнение документа Снятие резерва остатком резерва. Снятие резерва по складу 1С 7.7
.ert 292,00Kb
13.09.19
0
.ert 292,00Kb Скачать
Заявки покупателей без реализаций 1С 7.7:
.ert 100,00Kb
15.09.19
0
.ert 100,00Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 3420 20.12.19 01:33 Сейчас в теме
следует отметить что документ "снятие резерва" - закроет только резерв (Регистр резервов). При этом Заявка покупателя - останется активной (регистр заявок). Если заявки не закрывать - будут пухнуть таблички итогов (что приводит к лишним затратам при приведении документов), замедлению каждого открытия месяца (замедление до какого то момента проявляется слабо, потом - нарастает лавинообразно).
.
Поэтому - если вам не нужна ЗАЯВКА ЦЕЛИКОМ (она устаревшая, неактуальная, резервы по ней - верные или неверные без разницы) - для закрытия таких заявок следует воспользоваться штатным документом "Отмена заявок" - он и заявку закроет и резервы тоже закроет.
.
Уточняю - закрытие заявок (оно может выполняться как минимум двумя способами) - надо делать ДЛЯ ВСЕХ ЗАЯВОК. Даже для Неподтвержденных.
.
Вдобавок документ "Снятие резерва" чувствителен к указанному количеству для снятия резерва и если при исправлениях задним числом резерв поменялся, то при восстановлении ГП документ "Снятие резерва" может не перепровестись, что (в зависимости от дальнейших действий) может снова породить неверные резервы (у себя я модифицировал алгоритм "Снятие резервов" так, что если указано в документе 100 шт, например, а текущи резерв всего 90 (ну вот так вот получилось) - то снимается все доступное количество резерва, не превышающее указанное в документе, это упрощает восстановление ГП (хотя у меня этим документом не пользуются, все заявки закрываются менеджерами полуавтоматом через "Отмену заявок"
.
И помогалка: разу уж тут речь в публикации о резервах.
В типовых есть "ошибка" в алгоритме операций с резервами (писалось, это видимо, для тех кто работает безошибочно) . Проявляется ошибка неявно (если есть работа задним числом постоянная с корректировкой документов поступления\отгрузки заявок, при нормальной работе в ТА вероятность такой ошибки практически нулевая). Ошибка ведет к тому что менеджеры успешно принимают заявки и резервируют товар, а склад этого не находит. Расписывать особо не буду, суть в том, что вычисляется
СвободныйОстаток=Остаток-Резерв, 70=100-30
При отрицательных резервах (что есть ненормально), внезапно из ниоткуда появляется свободный остаток
Остаток=100, Резерв=-30, СвободныйОстаток=100-(-30)=130.
Рекомендуется поправить код во избежание таких ситуаций.
.
Вроде все изложил что помнил навскидку.
Для тех кому интересна данная публикация - возможно будет интересна у меня в профиле обработка "Автозакрытие просроченных заявок".
.
Всем успехов.
2. ksnik 386 20.12.19 06:19 Сейчас в теме
(1) нет времени обдумывать и дискутировать пока, спасибо за дополнение но по началу поста сразу возникает такое желание, вот лишь - снятие делается документом "сторнирование резервов заявок" и по всем 3м регистрам делаются одинаковые движения - заявки, резервы и выполнение. В даанном случае комментарий дополняет тему, за что я благодарен оппоненту, но мой пост вообще не подтверждает и не опровергает его правоту.
3. CheBurator 3420 20.12.19 15:16 Сейчас в теме
просто я в типовой Комплексной не помню\не знаю такого докумена "сторнирование резервов заявок"
4. ksnik 386 20.12.19 17:20 Сейчас в теме
это я сам делал такой документ из документа сторно, отличная штука вышла, у него движения противоположное движению заявки, но только исключительно по не-списаным, вот такое у него движение:
Процедура ОбработкаПроведения()
	Если ПустоеЗначение(СторнируемыйДокумент) = 1 Тогда
		глНеПроводить(Контекст, "Не выбран сторнируемый документ.");
		Возврат;
	КонецЕсли;
	ВыбДата = НачМесяца(ТекущаяДата());//Резервы зависшие ранее
	ВыбДокумент = СторнируемыйДокумент;
	Если СторнироватьТолькоЗависшийРезервНаДатуСторно=1 Тогда
		Запрос = СоздатьОбъект("Запрос");
		ТекстЗапроса = 
		"НомКод = Регистр.РезервыТМЦ.Номенклатура.Код;
		|Штрихкод = Регистр.РезервыТМЦ.Номенклатура.ОсновнаяЕдиница.Штрихкод;
		|Номенклатура = Регистр.РезервыТМЦ.Номенклатура;
		|ЗаявкаПокупателя = Регистр.РезервыТМЦ.ЗаявкаПокупателя;
		|Количество = Регистр.РезервыТМЦ.Количество;
		|Функция КонОстКоличество = КонОст(Количество);
		|Группировка ЗаявкаПокупателя;
		|Группировка Номенклатура без групп;
		|Условие(ЗаявкаПокупателя В (ВыбДокумент));";
		Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
			СтатусВозврата(0);
			Возврат;
		КонецЕсли;
		ТЗ = СоздатьОбъект("ТаблицаЗначений");
		Запрос.Выгрузить(ТЗ,3,0);
		Если ТЗ.КоличествоСтрок()=0 Тогда
			Возврат;
		Иначе
			ТЗ.ВыбратьСтроки();
			Пока ТЗ.ПолучитьСтроку()=1 Цикл
				Если СокрЛП(ТЗ.Номенклатура.ОсновнаяЕдиница.Штрихкод)="" Тогда
				    Сообщить("Нет ШК основной единицы товара "+СторнируемыйДокумент.Номенклатура.Код+" "+СторнируемыйДокумент.Номенклатура.Наименование);
					ТЗ.Штрихкод = "";
				Иначе
					ТЗ.Штрихкод = СокрЛП(ТЗ.Номенклатура.ОсновнаяЕдиница.Штрихкод);
				КонецЕсли;
			КонецЦикла;
			ТЗ.УдалитьКолонку("ЗаявкаПокупателя_2");
			ТЗ.УдалитьКолонку("Номенклатура_1");
			ТЗ.УдалитьКолонку("Количество");
			глПечатьТаблицы(ТЗ,"Не списано по "+СокрЛП(ВыбДокумент));
		КонецЕсли;
	КонецЕсли;
	// Проверка сторнированности документа.
	Объект = СоздатьОбъект("Документ");
	Объект.ВыбратьПодчиненныеДокументы(,, СторнируемыйДокумент);
	Пока Объект.ПолучитьДокумент() = 1 Цикл
		Если (Объект.Вид() = "СторноЗаявокРезервов") И (Объект.Проведен() = 1) И (Объект.ТекущийДокумент() <> ТекущийДокумент()) Тогда
			глНеПроводить(Контекст, "Сторнируемый документ уже сторнирован документом № "+Объект.НомерДок+" от "+Объект.ДатаДок);
			Возврат;
		КонецЕсли;
	КонецЦикла;                                      
	Если Метаданные.Документ(СторнируемыйДокумент.Вид()).ОперативныйУчет = 1 Тогда
		Для Сч = 1 По Метаданные.Регистр() Цикл
			Рег = СоздатьОбъект("Регистр." + Метаданные.Регистр(Сч).Идентификатор);
			РегСторно = Регистр.ПолучитьАтрибут(Метаданные.Регистр(Сч).Идентификатор);
			Если не((РегСторно.Вид()="Заявки") или (РегСторно.Вид()="РезервыТМЦ") или (РегСторно.Вид()="ВыполненыеЗаказы")) Тогда
				продолжить;
			КонецЕсли;                   
			Если Рег.ВыбратьДвиженияДокумента(СторнируемыйДокумент)=1 Тогда
				Пока Рег.ПолучитьДвижение()=1 Цикл 
					Если СторнироватьТолькоЗависшийРезервНаДатуСторно=1 Тогда
						НомСтр = 0;
						ТЗ.НайтиЗначение(Рег.Номенклатура.ТекущийЭлемент(),НомСтр,"Номенклатура");
						Если НомСтр = 0 Тогда
						    Продолжить;
						КонецЕсли;
						КоличествоСпишем = ТЗ.ПолучитьЗначение(НомСтр,"КонОстКоличество");
						//добавить строку в заявку
						МДОперация = ?(Рег.Приход=1,"Приход","Расход");
						// заполняем измерения
						Для Сч2 = 1 По  Метаданные.Регистр(Сч).Измерение() Цикл                     
							РегСторно.УстановитьАтрибут(Метаданные.Регистр(Сч).Измерение(Сч2).Идентификатор, Рег.ПолучитьАтрибут(Метаданные.Регистр(Сч).Измерение(Сч2).Идентификатор));
						КонецЦикла;
						// заполняем реквизиты
						Для Сч2 = 1 По  Метаданные.Регистр(Сч).Реквизит() Цикл                     
								ЗначениеРеквизита = - КоличествоСпишем;
							РегСторно.УстановитьАтрибут(Метаданные.Регистр(Сч).Реквизит(Сч2).Идентификатор, ЗначениеРеквизита);
						КонецЦикла;
						// Номер строки документа-основания
						РегСторно.ПривязыватьСтроку(Рег.НомерСтроки());   
						// заполняем ресурсы
						Для Сч2 = 1 По  Метаданные.Регистр(Сч).Ресурс() Цикл                     
						    РегСторно.УстановитьАтрибут(Метаданные.Регистр(Сч).Ресурс(Сч2).Идентификатор, -КоличествоСпишем);
						КонецЦикла; 
						Если Рег.Приход = 1	Тогда					
							РегСторно.ДвижениеПриходВыполнить();
						Иначе
							РегСторно.ДвижениеРасходВыполнить();
						КонецЕсли;	 
					Иначе	
						...	
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
		КонецЦикла;	
	КонецЕсли;
КонецПроцедуры // ОбработкаПроведения()

Показать
5. CheBurator 3420 20.12.19 18:30 Сейчас в теме
(4) все движения, подвисшие по заявке, прекрасно закрывает штатный документ "Отмена заявок". Никаких дополнительных нештатных документов для этого городить не надо. Если только нужно не всю заявку по всем регистрам закрыть, а выборочно позиции по заявке.
6. CheBurator 3420 20.12.19 18:32 Сейчас в теме
.. и если закрывать только резервы - высока вероятность что и минуса и прочие непотребства остаются висеть по регистру заявок(обрабатывается в вышеприведоде, ок) и заказов-заявок (не обрабатывается). За ними тоже надо следить\чистить. И вполне возможна ситуация, когда "проблемных" резервов нет, но сама заявка не закрыта, хотя давно уже "мертвая".
.
но это все советы.
каждый сам кузнец своих баз.
7. CheBurator 3420 20.12.19 18:44 Сейчас в теме
чисто попутно незначимые наблюдения, чисто поворчать
.
 Если СокрЛП(ТЗ.Номенклатура.ОсновнаяЕдиница.Штрихкод)="" Тогда
                    Сообщить("Нет ШК основной единицы товара "+СторнируемыйДокумент.Номенклатура.Код+" "+СторнируемыйДокумент.Номенклатура.Наименование);
                    ТЗ.Штрихкод = "";
                Иначе
                    ТЗ.Штрихкод = СокрЛП(ТЗ.Номенклатура.ОсновнаяЕдиница.Штрихкод);
                КонецЕсли;

- много излишнего кода и лишней нагрузки на базу внутри транзакции. Штрихкод тянется в запросе.
.
ТЗ.НайтиЗначение(Рег.Номенклатура.ТекущийЭлемент() - излишнее обращение к ТекущийЭлемент().

.
хотя может я чего и не понял\не уловил
.
8. ksnik 386 20.12.19 22:41 Сейчас в теме
(7) во-первых отмены заявок у нас нету, возможно старая комплексная. Во-вторых Вы отлично умеете найти какашку даже в маленьком зернышке, всегда придираетесь к коду который работает несколько секунд в году. Спасибо что объяснили, что я никому не помог, выходит тема на которую я отреагировал здесь лишняя.
9. CheBurator 3420 20.12.19 22:57 Сейчас в теме
(8) ну это очень старая комплексная должна быть чтобы там не было того, что штатно года с 2006 как минимум.
.
насчет какашек - зря.
я вполне понимаю, что работает - и хорошо. у самого тоже разного неоптимального хватает.
.
однако если кто смотреть будет из несильно подкованных (что, конечно маловероятно) - то лучше все-таки дать еще и какой-то минимальный набор знаний - пригодится. и учить пользоваться штатным инструментарием по-возможности, а кнештатным прибегать при недостатках штатных интрументов
.
успехов!
10. ksnik 386 20.12.19 23:07 Сейчас в теме
(9) по коду видно что он не для отмены заявки целиком. Код предназначен для решения проблем, возниуающих при работе задним числом по выполненным заявкам. Релиз в публикации указан, отмена заявок покупателей в нем действительно есть, но она не обладает функционалом моего документа и описанных в публикации проблем не решает.
11. CheBurator 3420 21.12.19 01:41 Сейчас в теме
(10)
отмена заявок покупателей в нем действительно есть, но она не обладает функционалом моего документа и описанных в публикации проблем не решает.

м.б. я не совсем понял, какие проблемы возникают при работе задним числом по выполненным заявкам..?
.
если заявка выполнена, но по ней задним числом "проехались" и выполненная заявка поплыла - то есть стала незакрытой - по ней будут в общем случае висеть незакрытые остатки по 3 регистрам: резервы, заявки и заказы-заявки. Эти подвисшие хвосты надо закрыть. С закрытием всех подвисших хвостов прекрасно справляется штатный документ "Отмена заявок" (исходим все-таки из того что в комплексной конфигурации таковой документ есть, с ходу дату выпуска озвученной конфигурации не нашел).
.
Какие еще проблемы озвучены и решены в публикации - я с ходу что-то не уловил.
Да, есть отчеты (заявлены в публикации) для выявления таких незакрытых заявок - это хорошо.
.
Но привлекать какие-то самописные документы для закрытия хвостов по заявкам - мне это странновато при наличии штатных возможностей. Я завтреца постораюсь посмотреть древний релиз комплексной, который у меня есть, на наличие типового документа "Отмена заявок". Если такового документа нет (я сомневаюсь, но допускаю) - тогда да, смысл есть в самописном документе. Хотя и без "отмены заявок" подвисшие заявки можно закрыть корректировочной заявкой (с пустой табличной частью) - хотя, надо признать, не всегда это удается (определяется тем что зависло)
12. ksnik 386 21.12.19 08:57 Сейчас в теме
1) делаем проверку на зависшие резервы;
картинка1
2) делаем поиск заявки от которой завис резерв
картинка2
3) делаем отмену заявки
картинка 3
4) смотрим движения - оказывается ненужные нам позиции сторнировались которые не вызывали проблем, делаем вывод что документ не пригоден
картинка4
извините меня за нервозность, ответ на замечания оппонента заставляет тратить непредусмотренное время, ведь он пишет по своему желанию а я отвечаю подневольно, мне сложнее вести переписку чем ему и я не могу тщательно подготовиться к ответу рассмотрев все факторы
Прикрепленные файлы:
Оставьте свое сообщение

См. также

[Обновлено] Внешняя обработка 1С 7.7 работы с УТМ ЕГАИС Промо

Обработка документов WEB Розничная торговля Розничная торговля v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Россия УУ Акцизы Абонемент ($m)

Данная внешняя обработка позволит розничному магазину полноценно работать в системе ЕГАИС.

1 стартмани

16.10.2015    37266    355    amoarok    79    

Групповая обработка документов и справочников v.7.7

Универсальные обработки Обработка документов Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

1. Обработка позволяет совершать следующие действия над объектами: а. СПРАВОЧНИКИ: удаление; пометка на удаление; снятие пометки на удаление. б. ДОКУМЕНТЫ: удаление; пометка на удаление; снятие пометки на удаление; проведение; отмена проведения; выключить проводки; включить проводки. 2. Действия могут быть ограничены некоторыми условиями. 3. Существует отбор по видам объектов. 4. Есть возможность обработать подчиненные справочники.

1 стартмани

30.04.2017    10698    41    DUH    0    

Универсальные обработки документов и справочников для 1С: Предприятие 7.7

Обработка документов Универсальные обработки Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

Обработки можно использовать в любой конфигурации 1С-Предприятия 7.7. Обработки позволяют просмотреть/изменить значения любого реквизита документов/справочников, существующих в базе. В обработках реализован множественный отбор по значениям реквизитов (для табличной части документов тоже). В обработке документов реализованы следующие действия: Перенумерация; проведение; отмена проведения; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; удаление строк табличной части; вывод на печать и в файлы *.xls,*.csv,*.dbf,*.xml реквизитов шапки и табличной части. В обработке справочников реализованы следующие действия: Перенумерация; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; очистка истории значений периодического реквизита; перенос справочника в другую базу подобной конфигурации по OLE; вывод на печать реквизитов и истории значений периодических реквизитов; вывод реквизитов в файлы *.xls,*.csv,*.dbf,*.xml; отчет по структуре справочников, вывод и обработка ссылок на выбранные элементы.

1 стартмани

23.11.2016    21926    145    SanchoD    15    

Деноминация в Беларуси. В помощь специалистам и обычным пользователям

Обработка документов Обработка справочников v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Инструмент для деноминации числовых реквизитов справочников, документов и операций в обороте за период.

1 стартмани

14.06.2016    11766    16    ge_ni    3    

Пример обмена 1С: 7.7 с ЕГАИС через УТМ

Обработка документов WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md УУ Акцизы Абонемент ($m)

Это пример внешней обработки для обмена между конфигурациями 1С: 7.7 и системой ЕГАИС через универсальный транспортный модуль УТМ . Реализованы все схемы (xsd) обменов. Распространяется как есть. Код полностью открыт. За основу взята публикация http://infostart.ru/public/409028/. Архив содержит доработку конфигурации 1С: "Торговля и склад ред. 9.2". Не требует доработки типовых объектов (кроме "Чека ККМ"), добавляются новые справочники, документы и пр., что позволяет легко интегрировать на аналогичные конфигурации, например, 1С:"Комплексная конфигурация ред. 4.5".

5 стартмани

14.12.2015    16323    60    Atom74    18    

Отчет по документам оперативного учета для "Торговля и Склад", "Комплексная" 1Сv7.7

Анализ учета Управленческие v77::ОУ 1С7:Комплекс 1С7:ТиС УУ Абонемент ($m)

Отчет, который собирает данные по проведенным документам оперативного учета, таким как "Реализация", "Поступление ТМЦ", "Списание ТМЦ" и пр.

1 стартмани

24.05.2015    14314    14    Tavalik    1    

Универсальная загрузка данных : Прыг-Скок...или из MS EXCEL в 1С (7.7) или как "забить товар" Промо

Загрузка и выгрузка в Excel Обработка документов v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Предыстория: постоянно на форуме спрашивают - "как загрузить из EXCEL в 1С нужную информацию?" и начинается... Готовый пример КАК...

1 стартмани

19.04.2010    50953    101    Tatitutu    96    

Универсальная загрузка из файла Excel в табличную часть документа

Загрузка и выгрузка в Excel Обработка документов v7.7 1cv7.md Абонемент ($m)

Загрузка остатков, инвентаризаций, заявок, требований из произвольных файлов формата Excel. Загрузка строк из файла Excel, в любой документ конфигурации по выбору, имеющий табличную часть. Установка на ПК MS Excel не требуется.

1 стартмани

11.02.2015    13821    25    LavinVadik    12    

Перепроведение документов с плюшками (логирование процесса и отправка по почте) 1С 7.7. (любая конфигурация)

Обработка документов v7.7 1cv7.md Абонемент ($m)

Обработка перепроводит документы в любой конфигурации 1С 7.7. - с помошью внешней комполненты записывает в файл окно сообщений перепроведения. - имеет возможность отправки этого файла по почте в конце обработки.

1 стартмани

18.04.2014    16692    15    dimisa    3    

Автоматическое создание заказов поставщику по статистическим данным продаж в 1С 7.7 ТиС

Обработка документов Рабочее место Розничная торговля Розничная торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

При большом количестве номенклатурных позиций составление правильного заказа поставщику становится проблемой, так как менеджеру по закупкам становится трудно учесть влияние различных факторов на количество заказываемого товара. К таким факторам относятся возможные изменения скорости продаж, учет текущего остатка, его изменение до даты поставки и т.д. Обработка позволяет на основе статистики продаж сформировать заказы поставщикам так, чтобы заказ, поставленный в установленные сроки, обеспечил наличие товара до следующей поставки.

1 стартмани

03.02.2014    23264    31    sonic112    26    

Загрузка поступлений из Excel Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Обработка для загрузки документов поступлений из накладных в формате Excel.

5 стартмани

19.12.2012    28394    23    @lexandr    11    

Копирование табличной части документов для 1С 7.7

Обработка документов Универсальные обработки v7.7 Абонемент ($m)

Обработка позволяет переносить табличную часть из одного документа в другой. Или же из нескольких документов в один.

1 стартмани

02.09.2013    21089    15    Tavalik    4    

Блокировка контрагента при просрочке платежа в днях

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v7.7 v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Абонемент ($m)

В Комплексе контроль просрочки стоит только суммовой, но понадобилось и блокировать контрагента при просрочке платежа в днях, даже если сумма лимита не превышена. Так и решил сделать, аналогичного ничего не нашел.

1 стартмани

13.03.2013    10308    2    11k65m    9    

Универсальный документ "Движение регистров" (опер.учёт) Промо

Обработка документов v77::ОУ 1С7:Комплекс 1С7:ТиС Россия БУ Абонемент ($m)

Документ предоставляет функционал для визуального редактирования произвольных движений любых имеющихся в конфигурации регистров, как с нуля, так и на основе движений уже имеющегося документа (можно скопировать движения этого документа). Есть режим "Сторно".

1 стартмани

04.02.2012    24724    20    andrewks    16    

Быстрое удаление документов после свертки ИБ с применением прямого доступа к БД

Чистка базы Обработка документов Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Закрытие периода Оборотно-сальдовая ведомость, Анализ счета v7.7 1cv7.md БУ НУ Абонемент ($m)

Сворачивал ИБ большого объема на SQL платформе. Столкнулся с проблемой удаления документов после формирования документов ввода начальных остатков. Средствами встроенного языка 1С не реально, потребовалось бы несколько суток. Вдохновила статья - http://dmitnik.narod.ru/article/article_3_1.html. Написал обработку с применением технологии прямых запросов, не устаю благодарить разработчиков 1С++. Удалил все, что требовалось за 1,5 часа.

1 стартмани

19.02.2013    11221    17    ray-xp    3    

Автоматическая отгрузка Заявок и распечатка комплекта документов (робот)

Обработка документов Пакетная печать Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) БУ УУ Абонемент ($m)

Автоматически отгружает документы "Заявка покупателя" с учётом остатка на складе и печатает готовый комплект документов. Предназначена для 1С 7.7.

3 стартмани

25.01.2013    23505    2    axxell    9    

Маршрутизация локальной доставки грузов в 1С 7.7

Обработка документов Обработка справочников v77::ОУ 1С7:ТиС Автомобили, автосервисы Транспорт, автопарки, такси УУ Абонемент ($m)

Простая и наглядная обработка помогает логисту маршрутизировать доставку грузов по городу и области (без карт)

5 стартмани

14.01.2013    23412    8    axxell    6    

Поиск ошибок в регистрах 7.7 Промо

Поиск данных Тестирование и исправление Анализ учета v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет найти ошибки в регистрах 7.7 в Вашей базе данных

1 стартмани

04.05.2010    23203    13    _Z1    31    

Прямое редактирование движений регистров и перепроведение документов по выбранным регистрам в 1С 7.7

Обработка документов v7.7 1cv7.md Абонемент ($m)

Механизм позволит вручную исправлять любые реквизиты документов, свободно редактировать любые значения в регистрах. Также проводить документы по некоторым регистрам, а не по всем, предусмотренным в обработке проведения - для ускорения перепроведения документов.

3 стартмани

13.01.2013    30263    12    axxell    4    

Обмен документами в формате CommerceML по схеме поставщик-покупатель между 1С 7.7 <=> 7.7 (конфигурация «Торговля + Склад», ред. 9.2) и 1С 7.7 <=> 8.x (конфигурация «Управление торговлей, ред. 10.3»)

Перенос данных из 1С7.7 в 1C8.X Оптовая торговля Розничная торговля Обработка документов 1С7.7<->1C7.7 Оптовая торговля Розничная торговля v7.7 v8 УТ10 1С7:ТиС Розница УУ Абонемент ($m)

Данная статья посвящена обмену документами в формате CommerceML по схеме поставщик-покупатель между конфигурациями «Торговля + склад, редакция 9.2» 1С 7.7 (далее ТиС) и «Управление торговлей, редакция 10.3» 1С 8.х (далее УТ 10.3). Рассматривается выгрузка документов «Реализация ТМЦ», «Заказ поставщику» и, соответственно загрузка документов «Поступление ТМЦ» и «Заявка покупателя», сопоставление собственной номенклатуры – номенклатуре поставщиков на стороне покупателей и преобразование между форматами различных версий.

1 стартмани

20.12.2012    58331    22    s.nek    3    

Перепроведение документов с формированием отчетов в MS Excel

Обработка документов v7.7 v77::ОУ v77::БУ 1cv7.md БУ УУ Абонемент ($m)

Обpaбoткa пoзвoляeт пepeпpoвecти дoкумeнты зa пepиoд и узнaть чтo измeнилocь пocлe иx пepeпpoвeдeния

1 стартмани

28.11.2012    5688    2    QbeeQ    1    

Сравнение 2х однотипных баз Промо

Анализ учета 1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет определить какие данные были внесены в 2 ОДНОТИПНЫХ базах, например, архивах за разные числа (проверка объектов в целом, не по реквизитам) Обновил: Добавил возможность выборочного сравнения :)

1 стартмани

19.08.2009    25437    9    DarkAn    24    

Анализ зависшего товара

Учет ТМЦ Анализ учета Учет ТМЦ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Показывает товар, который был на остатках на дату начала, на дату окончания и не продавался в период между этими датами. Если не выбирать какой-либо фильтр - будет считаться "по всем"

1 стартмани

11.11.2012    8225    7    dsdmsk    3    

Умный заказ ТМЦ для ТиС 9.2 с отправкой по электронной почте

Обработка документов Рабочее место Email v77::ОУ 1С7:ТиС Абонемент ($m)

Удобное средство для менеджера по закупкам, для определения объема заказа товара на основании продаж за предыдущий период, с отправкой заказа по e-mail (например поставщику) прямо из 1С. Возможность ручной корректировки, расчет общего тоннажа заказа, а также возможность одновременной выгрузки заказа для автоматической загрузки в учетную систему получателя (поставщика) делают его незаменимым помощником в оперативном учете.

1 стартмани

26.09.2012    11020    9    Qbik    11    

Автоматическое создание документов "Перечисление НДФЛ в бюджет" для ЗиК 7.7 Промо

Обработка документов Зарплата Зарплата v77::ОУ v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ТиС Россия БУ НДФЛ Абонемент ($m)

Уж недалек отчет, а документы распределения НДФЛ по работникам за 2011 год не введены. Можно ввести их вручную, а можно воспользоваться обработкой, выгрузить их в MS Excel и сформировать автоматически. Для этого подготовлен данный комплекс обработок.

1 стартмани

05.03.2012    22549    7    Krasnyj    44    

Акт сверки налоговых накладных

Обработка документов Бухгалтерские Анализ учета Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v7.7 1С7:Бух Украина НУ Абонемент ($m)

Акт сверки налоговых накладных. И выданных и полученных и сверка на двойные. Есть русский отчет и украинский.

1 стартмани

19.09.2012    11919    0    Ekstrem13    4    

Выгрузка документов, v7

1С7.7<->1C7.7 Обработка документов v7.7 1cv7.md 1С7:Бух 1С7:ПУБ Россия Абонемент ($m)

Велосипед. Но - для личного пользования, так что ультиматум: не пинать :)

1 стартмани

19.09.2012    14528    22    Дуб    4    

Алкогольная декларация 2012

Анализ учета Финансовые Учет доходов и расходов Регламентированная отчетность Учет доходов и расходов v77::ОУ 1С7:ТиС Россия БУ Акцизы Абонемент ($m)

Для тех кто не успел подготовить выгрузки для Алкогольной декларации 2012 Работающий вариант!!! Можно использовать в качестве заготовке в своей конфигурации

1 стартмани

06.08.2012    20023    1    Bosma    40    

Обработка выборки документов и выборочное перепроведение по видам движений для 1С-Предприятие-7.7 Промо

Обработка документов Сервисные утилиты v7.7 openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет выполнить над подобранным списком документов следующие действия: 1) "Провести"; 2) "Отменить проведение"; 3) "Пометить на удаление"; 4) "Снять пометку на удаление"; 5) "Удалить непосредственно"; 6) "Сменить фирму" (если есть общий реквизит 'Фирма'). Имеются удобные инструменты для подбора выборки документов (Подбор в обработках 'ПодборUChoice' и 'Консоль1CQA'). Реализованы различные опции обработки документов (в том числе 'выборочное проведение по видам движений'). Описана технология выборочного проведения документов по видам движений.

1 стартмани

04.01.2012    33251    12    yuraos    26    

Импорт данных из Excel в 1С

Загрузка и выгрузка в Excel Обработка документов v77::ОУ 1С7:ТиС Абонемент ($m)

Часто возникает задача по импорту данных в типовые документы (реализация, комплектация, перемещение и т.д.) подготовленных данных из Экселя в чистый заранее созданный документ. Что собственно и делается.

1 стартмани

31.07.2012    10601    12    gorleon    8    

Автоматизация расчета зарплаты водителей, работающих на доставке

Зарплата Обработка документов Зарплата v77::ОУ 1cv7.md Автомобили, автосервисы Россия УУ Абонемент ($m)

Обработка путевых листов по городу, меж-городу (вместе с бланками), расчет зарплаты водителей через стоимость километра и всевозможные коэффициенты.

1 стартмани

08.07.2012    9509    2    anmal    4    

Загрузки для УСН и Бухгалтерии из ТиС

1С7.7<->1C7.7 Обработка документов v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Абонемент ($m)

Используется OLE-соединение.

1 стартмани

03.07.2012    12261    11    aianitro    11    

Пример импорта из EXCEL в 1С7.7

Загрузка и выгрузка в Excel Обработка документов v7.7 1cv7.md Абонемент ($m)

Простой пример импорта из Excel в 1С7.7 всех листов книги Excel.

1 стартмани

02.07.2012    9941    7    Jlight    2    

Клиент-банк для Райффайзен Аваль, ПриватБанк, ПАТ Демарк

Обмен с банком Обработка документов Банковские операции Банковские операции v7.7 1cv7.md Украина БУ Абонемент ($m)

Обмен данными 1С:Предприятие 7.7 и клиент-банк Райффайзен Аваль, Приватбанк, ПАТ Демарк

1 стартмани

01.06.2012    14537    3    mact    12    

Универсальная загрузка табличных частей для 7.7 (из Excel)

Обработка документов Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Универсальная загрузка табличных частей из табличных документов Excel для 1С 7.7

1 стартмани

15.05.2012    27327    104    sanches2    27    

23:59:59 Исправление одним кликом для ТиС 9.2 (7.7)

Обработка документов Сервисные утилиты v77::ОУ 1С7:ТиС Абонемент ($m)

Нет возможности разместить документ после ТА! У кого случалось – объяснять не нужно. Обработка подойдёт также для комплексной конфигурации и любой другой на оперативном учёте.

5 стартмани

24.04.2012    17890    15    Yury1001    10    

Исправление документов в 1С 7.7

Инструментарий разработчика Администрирование данных 1С Обработка документов v77::ОУ v77::БУ 1cv7.md Россия Абонемент ($m)

Утилита для оперативного внесения изменений в любой документ базы данных, включая невидимые на форме реквизиты.

1 стартмани

29.03.2012    17399    8    alf2006x    5    

Перенумератор документов

Обработка документов v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Обработка позволяет автоматизировать перенумерацию документов любого вида в любой конфигурации 1с v 7.7 за определенный период

1 стартмани

27.03.2012    7361    5    PiterPrg    4    

Обработка для переноса документов и справочников 1с 7.7

1С7.7<->1C7.7 Обработка документов Обработка справочников v77::ОУ 1С7:ТиС Абонемент ($m)

Данная обработка предназначена для переноса документов между разными или одинаковыми 1С конфигурациями, возможно, между разными компонентами 1С, попутно она способна переносить и справочники. Синхронизация справочников осуществляется только по коду, для справочников, у которых нет кода - по наименованию.

1 стартмани

26.03.2012    14719    20    stu1112    4    

Универсальный ввод документов из аналогичной базы 1С 7.7

Обработка документов 1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv8.cf Абонемент ($m)

Данная обработка пригодится тем, кто хочет перенести документы в копию базы 1С 7.7 с аналогичными справочниками.

1 стартмани

20.03.2012    10210    2    dronrevx    11    

OLAP - это просто!

Загрузка и выгрузка в Excel Анализ учета v77::ОУ v77::БУ 1С7:Бух БУ Абонемент ($m)

Методика простого OLAP-подобного анализа данных в сводных таблицах Excel.

1 стартмани

14.02.2012    25766    4    fixin    12    

Обработка справочников и документов по условию 1С7

Универсальные обработки Обработка документов Обработка справочников v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Универсальная обработка справочников и документов по произвольному условию, написанному на языке 1С.

1 стартмани

31.01.2012    17859    6    fixin    3    

Копирование по OLE

Обработка документов 1С7.7<->1C7.7 v7.7 1cv7.md Абонемент ($m)

Внешняя обработка для переноса данных(справочников, документов) между похожими конфигурациями. Используется механизм OLE и рекурсивное чтение/запись данных. Кода немного, по силам разобраться даже начинающим.

1 стартмани

26.01.2012    7104    4    Gluk    6