Шифрование текста и файлов с помощью 1С. Используется хеш-код SHA256, Без Capicom, Архиваторов и сторонних служб

Публикация № 1083158

Разработка - Защита и шифрование

Шифрование Sha256

Данная статья описывает простейший собственный алгоритм шифрования средствами 1С. Без Capicom, Архиваторов и сторонних служб. Данный метод работает на Платформе 8.3 и т.п. 09.07.19 Добавлена обработка шифрования файлов

Сам по себе шифратор с открытым кодом дает несомненное преимущество перед продуктами с закрытым кодом, которые имеют потенциальные риски умышленной уязвимости. 
К примеру библиотека Capicom может долго время храниться ключи в файле подкачки Windows.
Сам метод можно бесконечно усложнять и модифицировать.

При сложном варианте расшифровать файл назад без пароля (от 8 символов) -станет практически невозможным.

Минусы данного метода - крайне низкая скорость работы.

Так же разработчиков прошу не использовать это во вред: вымогая деньги у пользователей  шифруя их файлы. Имейте к себе уважение.

 

Сначала мы получаем массивы из текста - которые необходимо зашифровать.

Далее из пароля делаем хеш код в формате SHA256 для надежности

Процедура КнопкаВыполнитьНажатие(Кнопка)
	массивТекста = РазложитьТекстВМассивПодстрок(СокрЛП(ИсходныйТест),символы.ПС);
	
	
	Хеш=Новый ХешированиеДанных(ХешФункция.SHA256);
	Хеш.Добавить(КодШифра); //Код Шифра - это наш пароль
	КлючШифра = Хеш.ХешСумма;
    //КлючШифра	 - это хеш от пароля в формате (SHA256) На котором работает Биткоин 
	МассивХеша = новый Массив;
	КлючШифра = СтрЗаменить(КлючШифра," ","");
	МассивХеша = РазложитьСтрокуВМассивзнаков(КлючШифра,МассивХеша);
	ЗашифрованныйТекст = ЗашифроватьТекст(массивТекста, МассивХеша);

КонецПроцедуры

 

Ниже приведен код текста шифрования:

//МассивСимволов - это текст переведенный в Массив
//КлючШифра - это хеш ключ переведенный массив
Функция ЗашифроватьТекст(МассивСимволов,КлючШифра)
	ЗашифрованнаяСтрока = "";
	ГСЧ = Новый ГенераторСлучайныхЧисел(1);

	ПозицияСимволаХэша = 0;
	ДлинаХэша = МассивХеша.количество();
	для каждого ном из МассивСимволов Цикл
		//Извлекаем номр шифруемого символа  UTF-8
		НомерСимвола = КодСимвола(ном);
		Если  ПозицияСимволаХэша >= ДлинаХэша-1 тогда
			ПозицияСимволаХэша = 0;
		КонецЕсли;
		//Позиция суммируемого хеша
		ПозицияСимволаХэша = ПозицияСимволаХэша+1;
		//Извлекаем номр символа хеша UTF-8
		СимволаХэша = КодСимвола(МассивХеша[ПозицияСимволаХэша]); 
		
		//Суммируем СуммыПозиций кодов 
		Код_Зашифрованный_символ =  НомерСимвола+СимволаХэша;
		Зашифрованный_символ = Символ(Код_Зашифрованный_символ);
		ЗашифрованнаяСтрока= ЗашифрованнаяСтрока+Зашифрованный_символ;
		
		//Усложним шифр добавляя тенического мусора при условие что КодСимвола хеша четный;
		Если Цел(СимволаХэша/2) = СимволаХэша/2 тогда
			
			СлучайноеЧисло = ГСЧ.СлучайноеЧисло(100, 1000); 
			ЗашифрованнаяСтрока= ЗашифрованнаяСтрока+Символ(СлучайноеЧисло);
		КонецЕсли;	
	КонецЦикла;
	возврат ЗашифрованнаяСтрока; 
	
	
КонецФункции	

Теперь сам код расшифровки 

Функция РасшифроватьТекст(МассивСимволов,КлючШифра)
	РасшифроватьТекст = "";
	ПозицияСимволаХэша = 0;
	ДлинаХэша = МассивХеша.количество();
	пропуск = ложь;
	для каждого ном из МассивСимволов Цикл
		
		Если пропуск тогда
			пропуск=ложь;
			продолжить;
		КонецЕсли;	

		
		НомерСимвола = КодСимвола(ном);
		Если  ПозицияСимволаХэша >= ДлинаХэша-1 тогда
			ПозицияСимволаХэша = 0;
		КонецЕсли;
		ПозицияСимволаХэша = ПозицияСимволаХэша+1;
		СимволаХэша = КодСимвола(МассивХеша[ПозицияСимволаХэша]); 

		Код_Зашифрованный_символ =  НомерСимвола-СимволаХэша;
		Зашифрованный_символ = Символ(Код_Зашифрованный_символ);
		
		
		РасшифроватьТекст= РасшифроватьТекст+Зашифрованный_символ;
		
		//Отсекаем мусор
		Если Цел(СимволаХэша/2) = СимволаХэша/2 тогда
			//пропускаем следующий символ;
			пропуск = истина;
		КонецЕсли;	

	КонецЦикла;
	возврат РасшифроватьТекст; 
	
	
КонецФункции	

Ну а также прочие функции по преобразованию текста в массив

Функция РазложитьТекстВМассивПодстрок(Знач Стр, Разделитель = "") Экспорт
	
	МассивСтрок = Новый Массив();
	ДлинаРазделителя = СтрДлина(Разделитель);
	Пока 1=1 Цикл
		Поз = Найти(Стр,Разделитель);
		Если Поз=0 Тогда
			МассивСтрок.Добавить(Стр);
			прервать;
		КонецЕсли;
		МассивСтрок.Добавить(Лев(Стр,Поз-1));
		Стр = Сред(Стр,Поз+ДлинаРазделителя);
	КонецЦикла;
	//Возврат МассивСтрок;
	МассивТекста = новый массив;
	для каждого ном из МассивСтрок Цикл
		Если  ном <> "" тогда
			МассивТекста = РазложитьСтрокуВМассивзнаков(ном,МассивТекста);
		КонецЕсли;
		МассивТекста.добавить(символы.ПС);
	КонецЦикла;	 
	
	возврат  МассивТекста;
	
КонецФункции



Функция РазложитьСтрокуВМассивзнаков(Знач Стр,МассивСтрок) Экспорт
	
	//МассивСтрок = Новый Массив();
	Длинастроки = СтрДлина(Стр);
	Поз=0;
	Пока 1=1 Цикл
		Поз = Поз+1;
		Если Длинастроки=0 Тогда
			Если Стр <> "" тогда
				МассивСтрок.Добавить(Лев(Стр,1));
			КонецЕсли;
			Возврат МассивСтрок;
		КонецЕсли;
		Если Стр <> "" тогда
			МассивСтрок.Добавить(Лев(Стр,1));
		КонецЕсли;
		
		Стр = Прав(Стр,Длинастроки-1);
		Длинастроки= Длинастроки-1;
	КонецЦикла;
	
	
КонецФункции 

Теперь мы получили инструмент к шифрации данных, тем не шифр имеет уязвимости в связи с повторяющимся ключом шифрации. Усложним ее перехешируя хеш-ключ при каждом повторении. Код с изменяющимся хешом-ключом представлен в сложной обработке (текст, файл). После чего получаем шифр стойкий к дешифровке. При пароле более 8 символов вероятность взлома шифра на сегодняшний день невозможна, так как необходим интеллектуальный анализ результата который потребует минимум 4-8 Гиг памяти платы(Asic устройства их не имеют.) и бесконечно много тактово-процессорных ресурсов для морфологического анализа полученного результата.

UPD 09.07.19 Добавлена обработка шифрования файлов

Скачать файлы

Наименование Файл Версия Размер
Простое шифрование текста с помощью 1С.(Работает на всех конфигурациях на платформе 8.3, тестировалось на платформе 8.3.10.2753) Толстый клиент
.epf 10,04Kb
09.07.19
2
.epf 10,04Kb 2 Скачать
Сложное шифрование текста с помощью 1С.(Работает на всех конфигурациях на платформе 8.3, тестировалось на платформе 8.3.10.2753) Толстый клиент
.epf 9,36Kb
09.07.19
3
.epf 9,36Kb 3 Скачать
Обработка шифрует файлы сквозным способом
.epf 9,92Kb
19.07.19
1
.epf 9,92Kb 1 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. astracrypt 66 26.06.19 13:29 Сейчас в теме
Просто круто. Это гениально?
3. Indgo 26.06.19 14:07 Сейчас в теме
(1) это просто, может сам шифр и не сильно устойчив к шифрованию, но если немного изменить алгоритм, на индивидуальный, то на мой взгляд расшифровка станет невозможна ближайшие столетия, даже имея мощные Асики.
К примеру RSA алгоритмы, уже под угрозой расшифровки. 18 значный пароль, имея Хэндшейк(ключ согласования RSA) подбирается за 20 дней на Asic устройстве
2. SerVer1C 247 26.06.19 14:06 Сейчас в теме
Шифровать строки модуля обработки и хранить в ней же пароль?
4. Indgo 26.06.19 14:13 Сейчас в теме
(2)
Шифровать строки модуля обработки и хранить в ней же пароль?

Достаточно хранить хеш-код SHA256. С обрезанными пробелами он очень тяжело вытаскивается декомпилятором.
К примеру если пользоваться сторонними приложениями он легко вытаскивается как обращение 1С-ом к Capicom например.

Если именить код на
        Хеш=Новый ХешированиеДанных(ХешФункция.SHA256);
	Хеш.Добавить(КодШифра); //Код Шифра - это наш пароль
	КлючШифра = Хеш.ХешСумма;
    //КлючШифра	 - это хеш от пароля в формате (SHA256) На котором работает Биткоин 
	МассивХеша = новый Массив;
	КлючШифра = СтрЗаменить(КлючШифра," ","");
	МассивХеша = РазложитьСтрокуВМассивзнаков(КлючШифра,МассивХеша);

      //Добавляем код 
    Хеш.Добавить("111111111111");
   КлючШифра = Хеш.ХешСумма;
   ///Конец добавки

	ЗашифрованныйТекст = ЗашифроватьТекст(массивТекста, МассивХеша);
Показать


Так же массив хеша можно добавить 1-10 мусорных символа. К примеру.
Если использовать обработку в чистом виде то можно. А если индивидуально допишите, то сложнее будет перехватывать
5. Indgo 26.06.19 15:00 Сейчас в теме
А если все это писать на C++. То можно вместа sha-256, Ethash Бутерина использовать с даг файлом на 2-4 гигабайта. Только тогда надо будет видеокарту задействовать.
6. wowik 771 26.06.19 15:41 Сейчас в теме
+1. Напишите мессенджер на андроид!
7. Indgo 26.06.19 16:41 Сейчас в теме
(6)
+1. Напишите мессенджер на андроид!

можно пользоваться телеграмм + плагин с доп шифрацией. Без RSA с передачей ключей лично в руки
8. wowik 771 26.06.19 17:58 Сейчас в теме
(7) не понял про плагин. Это в телеграм уже есть?
9. Indgo 26.06.19 18:05 Сейчас в теме
(8)еще нет надо сделать :-)
Месяц назад продал, машину. Ко мне приехал черовек из деревни с распечаткой где и когда я парковался, со всеми моими штрафами, неуплаченными налогами и временем прохождения то, и информацией об ОСАГО итп. Говорит в телеграмм канале за 500р купил.
И тут я решил пошифроваться.

ПыСы: Ты понимаешь Карл, человек из деревни знает обо мне почти все - куда это годится... если в гос органах информация льется как из душа.
Мало им того что фотки приходят жене со штрафами, а если я Бухгалтера подвез до банка - как жене это объяснить?!
Skripatch; for_sale; +2 Ответить
19. for_sale 857 30.06.19 09:46 Сейчас в теме
(9)
вэлкам ту зе рил ворлд))
10. Borisqa 27.06.19 09:58 Сейчас в теме
Никогда больше не лезьте в криптографию. Ваш алгоритм ломается за 1 секунду, т.к. "ключ" повторяется. Да это даже не ключ, а просто хэш от пароля, который даже перебирать не надо. Пожалуйста, оставьте эту затею и не вводите людей в заблуждение
Vovan1975; Perfolenta; SerVer1C; A_Max; +4 Ответить
12. Indgo 27.06.19 12:29 Сейчас в теме
(10)
Никогда больше не лезьте в криптографию. Ваш алгоритм ломается за 1 секунду, т.к. "ключ" повторяется. Да это даже не ключ, а просто хэш от пароля, который даже перебирать не надо. Пожалуйста, оставьте эту затею и не вводите людей в заблуждение

А если ключ при каждом повторе будет в степень "X" кратно соответсвующего символа? Вы не читали в тексте где написано - что алгоритм можно усложнять?
К примеру ту зависимость что на картинке картинке.
Или просто каждый раз хешировать ключевой хеш повторно при повторе? при таком раскладе думаю до конца галактической зимы будете расшировывать

За секунду он подберет., это вы в секундах световых лет ведете времяисчисление?
Ну в целом ваше невежество принято и зачтено.
Прикрепленные файлы:
14. SerVer1C 247 28.06.19 08:18 Сейчас в теме
(12) Месье хотел сказать, что не комильфо хранить и алгоритм, и пароль (или его аналог, который и будет использоваться для расшифровки) в открытом виде, а внешняя обработка 1с как раз и имеет открытый вид. А то, что Вы пытаетесь запутать алгоритм шифрования не усложнит стойкость ко взлому! Сравните свою поделку с реализацией AES.
15. Indgo 28.06.19 10:28 Сейчас в теме
(14) реализация AES хороша, главная проблема всех известных алгоритмов - та что он известна. И под них имеются Asic устройства.
Хранить ключи к шифру вас никто не заставляет.
Это так сказать ваше дело где хранить: в голове, на бумаге флешке или в облаке...
13. Indgo 27.06.19 19:49 Сейчас в теме
Добавлен сложный метод шифровки.
16. vsesam80 29.06.19 20:36 Сейчас в теме
(13)Интересно, а предложенный вами вариант более устойчив к взлому чем этот?: https://infostart.ru/public/518576/
18. Неопределено 67 30.06.19 06:31 Сейчас в теме
(16), (17), не понимаю в чём дело: я никогда не был в этой статье до текущего момента, но получил уведомления о ваших сообщениях как будто они были ответом на моё сообщение.
20. vsesam80 01.07.19 01:20 Сейчас в теме
(18)Может Инфостарт перевели на 1С движок. А у нас в 1С и не такое бывает, сами знаете)))
23. Indgo 01.07.19 01:31 Сейчас в теме
(20)да он изначально на. 1с битрексе
21. Indgo 01.07.19 01:22 Сейчас в теме
(18)может это знак к тому — что пора шифроваться
vsesam80; +1 Ответить
22. Indgo 01.07.19 01:24 Сейчас в теме
(16) изучу то что вы указали на днях напишу. Но лучше всего придумать свой принцип и держать его в голове. Даже зная пароль и не зная алгоритм — хрен кто что расшифрует. Я не претендую на то чтобы кто то использовал алгоритм для шифра, статья для шевеления мозга
17. Fox-trot 113 29.06.19 20:47 Сейчас в теме
(13) покажи еще скорость шифрования
24. Indgo 01.07.19 01:33 Сейчас в теме
(17) скорость на 1с? Откуда такое счастье, если только на 16 движке сделают реализацию OpenGL или Cuda
25. Неопределено 67 01.07.19 03:41 Сейчас в теме
Если интересно, могу скинуть как я делал sha-512 года 3 назад. Там, правда, подключался js скрипт и использовалась какая-то виндовая компонента.
27. Indgo 01.07.19 09:04 Сейчас в теме
28. Неопределено 67 01.07.19 09:38 Сейчас в теме
(27) Может быть, но я своё не выкладывал. Кстати, вспомнил: код js я переписал под 1С, так что там из стороннего использовалась только виндовая компонента криптографии.
29. Indgo 01.07.19 10:25 Сейчас в теме
(28)
нил: код js я переписал под 1С, так что там из стороннего использовалась только виндовая компонента криптографии.

может стоит выложить?
30. Неопределено 67 01.07.19 10:26 Сейчас в теме
(29) Вечером доберусь до домашнего компа и кину здесь в комментариях. Оно не стоит отдельной публикации.
31. Неопределено 67 01.07.19 10:35 Сейчас в теме
(29) Нашёл копию в облаке. Шифруемая строка называется ТекстЗапроса т.к. шифровался текст HTTP запроса к API. Переменная Секрет это API-ключ, он же соль.
Функция ЗашифроватьHMACSHA512(ТекстЗапроса, Секрет) 
	
	Текст = Новый COMОбъект("System.Text.UTF8Encoding");
	Криптография = Новый COMОбъект("System.Security.Cryptography.HMACSHA512");
	Криптография.Key = Текст.GetBytes_4(Секрет);
	ХешБайт = Криптография.ComputeHash_2(Текст.GetBytes_4(ТекстЗапроса)).Выгрузить();
	Шифр = "";
	Для Каждого Байт Из ХешБайт Цикл
	    База = 16;
	    Символ = "";
	    Пока Байт <> 0 Цикл
	       Поз = Байт % База;
	       Символ = Сред("0123456789ABCDEF", Поз + 1, 1) + Символ;
	       Байт = Цел(Байт / База);
	    КонецЦикла;
	    Шифр = Шифр + ?(СтрДлина(Символ) = 2, Символ, "0" + Символ);
	КонецЦикла;
	
	Шифр = нРег(Шифр);
	
	Возврат Шифр;
	
КонецФункции
Показать
32. Fox-trot 113 01.07.19 10:35 Сейчас в теме
(29) а сравнение скорости со штатной можешь выложить? просто интересно
34. Indgo 01.07.19 11:06 Сейчас в теме
(32) Вот пример реализации CUDA SHA256. Можете сделать внешнюю компоненту и передавать туда массив с данными необходимые к хешированию.
GPU карта распределит и быстро все посчитает. Для выполнения необходима Видеокарта GTX.

#ifndef SHA256_H
#define SHA256_H

#include <cstdint>


/****************************** MACROS ******************************/
#define SHA256_BLOCK_SIZE 32            // SHA256 outputs a 32 byte digest

#define ROTLEFT(a,b) (((a) << (b)) | ((a) >> (32-(b))))
#define ROTRIGHT(a,b) (((a) >> (b)) | ((a) << (32-(b))))

#define CH(x,y,z) (((x) & (y)) ^ (~(x) & (z)))
#define MAJ(x,y,z) (((x) & (y)) ^ ((x) & (z)) ^ ((y) & (z)))
#define EP0(x) (ROTRIGHT(x,2) ^ ROTRIGHT(x,13) ^ ROTRIGHT(x,22))
#define EP1(x) (ROTRIGHT(x,6) ^ ROTRIGHT(x,11) ^ ROTRIGHT(x,25))
#define SIG0(x) (ROTRIGHT(x,7) ^ ROTRIGHT(x,18) ^ ((x) >> 3))
#define SIG1(x) (ROTRIGHT(x,17) ^ ROTRIGHT(x,19) ^ ((x) >> 10))

#define checkCudaErrors(x) \
{ \
    cudaGetLastError(); \
    x; \
    cudaError_t err = cudaGetLastError(); \
    if (err != cudaSuccess) \
        printf("GPU: cudaError %d (%s)\n", err, cudaGetErrorString(err)); \
}
/**************************** DATA TYPES ****************************/
typedef unsigned char BYTE;             // 8-bit byte
typedef uint32_t  WORD;             // 32-bit word, change to "long" for 16-bit machines

typedef struct {
	BYTE data[64];
	WORD datalen;
	unsigned long long bitlen;
	WORD state[8];
} SHA256_CTX;

__constant__ WORD dev_k[64];

static const WORD host_k[64] = {
	0x428a2f98,0x71374491,0xb5c0fbcf,0xe9b5dba5,0x3956c25b,0x59f111f1,0x923f82a4,0xab1c5ed5,
	0xd807aa98,0x12835b01,0x243185be,0x550c7dc3,0x72be5d74,0x80deb1fe,0x9bdc06a7,0xc19bf174,
	0xe49b69c1,0xefbe4786,0x0fc19dc6,0x240ca1cc,0x2de92c6f,0x4a7484aa,0x5cb0a9dc,0x76f988da,
	0x983e5152,0xa831c66d,0xb00327c8,0xbf597fc7,0xc6e00bf3,0xd5a79147,0x06ca6351,0x14292967,
	0x27b70a85,0x2e1b2138,0x4d2c6dfc,0x53380d13,0x650a7354,0x766a0abb,0x81c2c92e,0x92722c85,
	0xa2bfe8a1,0xa81a664b,0xc24b8b70,0xc76c51a3,0xd192e819,0xd6990624,0xf40e3585,0x106aa070,
	0x19a4c116,0x1e376c08,0x2748774c,0x34b0bcb5,0x391c0cb3,0x4ed8aa4a,0x5b9cca4f,0x682e6ff3,
	0x748f82ee,0x78a5636f,0x84c87814,0x8cc70208,0x90befffa,0xa4506ceb,0xbef9a3f7,0xc67178f2
};

/*********************** FUNCTION DECLARATIONS **********************/
char * print_sha(BYTE * buff);
__device__ void sha256_init(SHA256_CTX *ctx);
__device__ void sha256_update(SHA256_CTX *ctx, const BYTE data[], size_t len);
__device__ void sha256_final(SHA256_CTX *ctx, BYTE hash[]);

__device__ void mycpy12(uint32_t *d, const uint32_t *s) {
#pragma unroll 3
	for (int k = 0; k < 3; k++) d[k] = s[k];
}

__device__ void mycpy16(uint32_t *d, const uint32_t *s) {
#pragma unroll 4
	for (int k = 0; k < 4; k++) d[k] = s[k];
}

__device__ void mycpy32(uint32_t *d, const uint32_t *s) {
#pragma unroll 8
	for (int k = 0; k < 8; k++) d[k] = s[k];
}

__device__ void mycpy44(uint32_t *d, const uint32_t *s) {
#pragma unroll 11
	for (int k = 0; k < 11; k++) d[k] = s[k];
}

__device__ void mycpy48(uint32_t *d, const uint32_t *s) {
#pragma unroll 12
	for (int k = 0; k < 12; k++) d[k] = s[k];
}

__device__ void mycpy64(uint32_t *d, const uint32_t *s) {
#pragma unroll 16
	for (int k = 0; k < 16; k++) d[k] = s[k];
}

__device__ void sha256_transform(SHA256_CTX *ctx, const BYTE data[])
{
	WORD a, b, c, d, e, f, g, h, i, j, t1, t2, m[64];
	WORD S[8];

	//mycpy32(S, ctx->state);

#pragma unroll 16
	for (i = 0, j = 0; i < 16; ++i, j += 4)
		m[i] = (data[j] << 24) | (data[j + 1] << 16) | (data[j + 2] << 8) | (data[j + 3]);

#pragma unroll 64
	for (; i < 64; ++i)
		m[i] = SIG1(m[i - 2]) + m[i - 7] + SIG0(m[i - 15]) + m[i - 16];

	a = ctx->state[0];
	b = ctx->state[1];
	c = ctx->state[2];
	d = ctx->state[3];
	e = ctx->state[4];
	f = ctx->state[5];
	g = ctx->state[6];
	h = ctx->state[7];

#pragma unroll 64
	for (i = 0; i < 64; ++i) {
		t1 = h + EP1(e) + CH(e, f, g) + dev_k[i] + m[i];
		t2 = EP0(a) + MAJ(a, b, c);
		h = g;
		g = f;
		f = e;
		e = d + t1;
		d = c;
		c = b;
		b = a;
		a = t1 + t2;
	}

	ctx->state[0] += a;
	ctx->state[1] += b;
	ctx->state[2] += c;
	ctx->state[3] += d;
	ctx->state[4] += e;
	ctx->state[5] += f;
	ctx->state[6] += g;
	ctx->state[7] += h;
}

__device__ void sha256_init(SHA256_CTX *ctx)
{
	ctx->datalen = 0;
	ctx->bitlen = 0;
	ctx->state[0] = 0x6a09e667;
	ctx->state[1] = 0xbb67ae85;
	ctx->state[2] = 0x3c6ef372;
	ctx->state[3] = 0xa54ff53a;
	ctx->state[4] = 0x510e527f;
	ctx->state[5] = 0x9b05688c;
	ctx->state[6] = 0x1f83d9ab;
	ctx->state[7] = 0x5be0cd19;
}

__device__ void sha256_update(SHA256_CTX *ctx, const BYTE data[], size_t len)
{
	WORD i;

	// for each byte in message
	for (i = 0; i < len; ++i) {
		// ctx->data == message 512 bit chunk
		ctx->data[ctx->datalen] = data[i];
		ctx->datalen++;
		if (ctx->datalen == 64) {
			sha256_transform(ctx, ctx->data);
			ctx->bitlen += 512;
			ctx->datalen = 0;
		}
	}
}

__device__ void sha256_final(SHA256_CTX *ctx, BYTE hash[])
{
	WORD i;

	i = ctx->datalen;

	// Pad whatever data is left in the buffer.
	if (ctx->datalen < 56) {
		ctx->data[i++] = 0x80;
		while (i < 56)
			ctx->data[i++] = 0x00;
	}
	else {
		ctx->data[i++] = 0x80;
		while (i < 64)
			ctx->data[i++] = 0x00;
		sha256_transform(ctx, ctx->data);
		memset(ctx->data, 0, 56);
	}

	// Append to the padding the total message's length in bits and transform.
	ctx->bitlen += ctx->datalen * 8;
	ctx->data[63] = ctx->bitlen;
	ctx->data[62] = ctx->bitlen >> 8;
	ctx->data[61] = ctx->bitlen >> 16;
	ctx->data[60] = ctx->bitlen >> 24;
	ctx->data[59] = ctx->bitlen >> 32;
	ctx->data[58] = ctx->bitlen >> 40;
	ctx->data[57] = ctx->bitlen >> 48;
	ctx->data[56] = ctx->bitlen >> 56;
	sha256_transform(ctx, ctx->data);

	// Since this implementation uses little endian byte ordering and SHA uses big endian,
	// reverse all the bytes when copying the final state to the output hash.
	for (i = 0; i < 4; ++i) {
		hash[i] = (ctx->state[0] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 4] = (ctx->state[1] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 8] = (ctx->state[2] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 12] = (ctx->state[3] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 16] = (ctx->state[4] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 20] = (ctx->state[5] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 24] = (ctx->state[6] >> (24 - i * 8)) & 0x000000ff;
		hash[i + 28] = (ctx->state[7] >> (24 - i * 8)) & 0x000000ff;
	}
}

#endif   // SHA256_H
Показать
26. dj_tol 95 01.07.19 05:06 Сейчас в теме
Молодец. Я тоже как-то занимался шифрованием ярлыков 1С. Тема интересная.
33. Indgo 01.07.19 10:46 Сейчас в теме
(26)Хм это не ваш код нашим клиентам все данные зашифровал и просил червонец? ;-)
35. dj_tol 95 01.07.19 14:01 Сейчас в теме
Нет. Я ярлыки запуска шифровал, что бы не понятно было где база лежит
36. vsesam80 01.07.19 21:10 Сейчас в теме
было бы здорово, если бы кто нибудь выложил пример шифрования на JS. Это нужно для мобильной платформы. Там виндовой компоненты нет и с шифрованием всё грустно. А между тем мобильное приложение на 1С весьма востребовано
37. Indgo 03.07.19 10:07 Сейчас в теме
(36) а как же объект System.Security.Cryptography? На JS не работает?
38. vsesam80 03.07.19 20:07 Сейчас в теме
(37)Работает, но я хотел это применить на мобильной платформе, а там ДотНета не имеется
39. Indgo 04.07.19 10:11 Сейчас в теме
(38) А что шифровать будете? Текстовые поля?
40. vsesam80 04.07.19 16:10 Сейчас в теме
(39)Именно! Идея такая - юзер в офлайне шифрует свои данные.
Есть конечно вариант через HTTPS. например юзер вносит данные по "безопасному каналу", они даже не хранятся на смартфоне. Скачиваются по мере необходимости - по запросу. И даже если смарт украдут или потеряют, данные всё равно на серваке.
А есть вариант офлайн, когда строковые поля справочника шифруются. А пароль для дешифровки вводится пр запуске приложения. И даже можно пустить злоумышленика далее в приложение - он всё равно получит билеберду, вместо осмысленного текста.
41. mrsmrv 59 01.05.20 21:00 Сейчас в теме
(40) Так в публикации же как раз и описывается механизм шифрации, его и можно по идее прикрутить, можно вот этим воспользоваться: https://infostart.ru/public/518576/. Или вам по AES нужно шифровать?
42. vsesam80 07.05.20 16:12 Сейчас в теме
(41)по AES желательно. Вижинер легко ломается. На хабре утилита была
Оставьте свое сообщение

См. также

Цифровая подпись Cades-BES для XML средствами 1С с помощью КриптоПро Промо

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка иллюстрирует возможность подписания XML SOAP-конверта по стандарту Cades-BES средствами 1С с помощью внешней компоненты КриптоПРО "CAdESCOM" с учетом ГОСТ 2001 и ГОСТ 2012. Стандарт используется в различных механизмах государственных сайтов России, в том числе в СМЭВ и ГИС ЖКХ. Код не привязан к прикладному решению может быть встроен куда угодно, но только на платформе Windows.

1 стартмани

13.05.2019    8595    35    PythonJ    41    

Алгоритм шифрования AES ECB 128/192/256

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Реализация алгоритма симметричного шифрования AES (Advanced Encryption Standard) в режиме ECB (Electronic codebook) с различной длиной ключа 128/192/256 без использования внешних компонент и zip-файлов.

1 стартмани

20.04.2020    1008    5    NikitaXa    12    

Мобильная платформа. Шифрование строк в Android при помощи внешней компоненты

Разработка внешних компонент Защита и шифрование v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Шифруем строки.

3 стартмани

15.04.2020    1035    0    kinan    0    

1C и защищенное хранение данных на блокчейне: модуль интеграции от Acryl Platform

Защита и шифрование Блокчейн Расширения Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Модуль интеграция 1С и блокчейн платформы "Acryl Platform" без использования внешних компонент. Под катом реализация механизмов Base58, Blake2b, Keccak, Curv25519 (the elliptic curve Diffie–Hellman) в подсистеме "Crypt", примеры генерации ключей, адресов, подписи транзакций, запись данных в блокчейн, чтение и восстановление данных из блокчейн. Код открыть. Лицензия MIT.

1 стартмани

21.01.2020    3983    2    ArtemSerov    17    

Изменение конфиденциальной информации (обработка, управляемые формы) Промо

Обработка документов Обработка справочников Защита и шифрование v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет полностью заменить в базе все конфиденциальные данные - все поля справочников, суммы в документах и прочие значения объектов. Идентична по функционалу обработке с ИТС "Изменение конфиденциальной информации", но работает под управляемыми формами и в интерфейсе "Такси". Есть гибкая настройка тех данных, которые необходимо удалять.

1 стартмани

17.05.2015    31437    129    primat    23    

Кодирование / декодирование в Base58 без использования внешних компонент

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Функции кодирование / декодирование строки в Base58 без использования внешних компонент. Код алгоритмов доступен в полном описании статьи.

1 стартмани

14.11.2019    3569    1    ArtemSerov    23    

Компонента аутентификации и шифрования с помощью биометрической информации для Андроид

Разработка внешних компонент Мобильная разработка Защита и шифрование v8::Mobile Абонемент ($m)

Компонента для мобильной платформы, позволяющая идентифицировать пользователя и шифровать данные с помощью биометрических сканеров.

5 стартмани

17.09.2019    4291    1    IgorKissil    7    

Криптографическое шифрование файлов

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка шифрует и дешифрует файлы. 

1 стартмани

03.09.2019    2366    2    shell_maxim    0    

Создание "обезличенной" демо базы 8,1,8.2 и 8.3 Управляемые и обычные формы. Промо

Защита и шифрование Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда нужно продемонстрировать работу базы посторонним людям, которым совершенно нет необходимости видить реальные наименования контрагентов, номенклатуры, договоров, пользователей и организаций.

1 стартмани

03.12.2010    29627    40    milkers    10    

Запутывание кода 1С

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка запутывания (обфускации) исходного кода 1С с помощью регулярных выражений.

2 стартмани

02.09.2019    7618    37    leoxz    66    

Защищаем конфигурацию. Один ключ СЛК для всех клиентов

Защита и шифрование v8 Абонемент ($m)

Пользователь защищенной конфигурации вводит регистрационный номер и код доступа. Установка сервера СЛК у пользователя не требуется. Управляем лицензиями удаленно.

1 стартмани

30.08.2019    8528    9    mvxyz    62    

Электронный документооборот для украинских конфигураций

Защита и шифрование Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Украина Абонемент ($m)

Подсистема электронного документооборота (в дальнейшем ЭД) является конфигурацией 1С:Предприятие, выполняющей базовые функции регистрации НН/РК и загрузки их из Реестра и способной встраиваться с минимальными изменениями в любые, в том числе нетиповые конфигурации 1С. ЭД представляет собой несколько независимых регистров сведений, справочников, документов и обработок, которые можно встроить в любую конфигурацию. «Сердцем» ЭД является обработка «ЭД: Криптопровайдер», которая экспортирует методы взаимодействия 1С с криптобиблиотекой ИИТ

1 стартмани

30.06.2019    2956    7    Asdam    0    

Подписываем файлы с помощью ЭЦП средствами 1с Промо

Универсальные обработки Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка для подписи с помощью сертификата (ЭЦП) произвольных файлов, только средствами платформы 1с. Работает на всех конфигурациях, но только на последних платформах 8.2 и 8.3, где есть менеджер криптографии.

1 стартмани

05.09.2013    59489    249    anig99    25    

Проверка пинкода для мобильного приложения

Защита и шифрование v8::Mobile Абонемент ($m)

Простая проверка с помощью пинкода на вход в мобильное приложение.

3 стартмани

16.04.2019    2905    2    bashinsky    2    

Кодирование Base64

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка кодирования декодирования строки алгоритмом Base64 через использования потоков.

1 стартмани

18.02.2019    3997    5    BigTaur    6    

Подписываем отчёт об исполнении контрактов ГОЗ или приказ №554

Защита и шифрование v8 v8::УФ 1cv8.cf Государственные, бюджетные структуры Россия Абонемент ($m)

Внешняя обработка, упрощающая подпись файла и генерацию архива с отчётом об исполнении госконтракта по Приказу №554 МО РФ

1 стартмани

06.02.2019    8814    30    semagin@gmail.com    8    

Защита конфигурации 1С (без внешних компонент, супер легкая и быстрая) Промо

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Возможность автоматизации легкой и быстрой защиты конфигурации от распространения неблагонадежными клиентами. Работает только в режиме обычного приложения. Защита не полноценная (в случае если не применять обфускатор к спец.модулям), но позволяет снять проблему.

3 стартмани

11.05.2012    39984    27    Kyrales    45    

Генератор ФИО, ИНН, СНИЛС и дат рождения

Защита и шифрование Обработка справочников v8 1cv8.cf Абонемент ($m)

Понадобилась мне обезличенная база биллинга на полтора миллиона лицевых счетов. Забивать существующие ФИО символом "Х" ("Иванов Иван Иванович" -> "Хххххх Хххх Хххххххх") было не интересно. Взял из существующей базы собрал мужские, женские фамилии, имена и отчества и написал генератор случайных ФИО. Также в обработке есть возможность генерировать ИНН физических лиц, СНИЛС и дат рождения.

1 стартмани

03.12.2018    8025    7    BigB    10    

Применение цифровой подписи при организации учёта ТМЦ и ГСМ

Защита и шифрование Управление бизнес-процессами (BPM) Мобильная разработка v8::Mobile v8::Бизнес-процессы 1cv8.cf Абонемент ($m)

Статья о том, как внедрение мобильного приложения в бизнес-процессы компании сократило оборот бумажных документов, а простая электронная подпись - заменила аналоговую.

1 стартмани

25.10.2018    6652    2    ikekoval    2    

"Открыть нельзя защищать!" - Где поставить запятую?

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Если Вам интересна эта тема, то вы уже знаете, какие есть возможности по защите кода модулей, внешних обработок и отчетов. Это расширение конфигурации для защиты внешних обработок от просмотра и редактирования кода.

1 стартмани

16.02.2018    12003    14    adam26    9    

Шифрование перестановкой символов

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Простое шифрование строки перестановкой символов.

1 стартмани

14.12.2017    6381    3    unregisteret    3    

ЭЦП по гостам Украины в 1С - Внешняя компонента BilboSign.dll

Разработка внешних компонент Защита и шифрование v8 1cv8.cf Украина Абонемент ($m)

Причиной данной разработки послужило отсутствие на данный момент криптопровайдера ЭЦП, который может работать по гостам Украины и использоваться в 1С. Для этого разработана внешняя компонента по технологии NativeAPI.

1 стартмани

11.12.2017    10396    14    Zahary    5    

Обработка шифрования ключом

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка шифрования введенной строки. Платформа 8.3 (обычное приложение). В обработке реализован механизм XOR шифрования на платформе 8.3. Может быть полезна при решении задач с шифрованием паролей или текстов или чисел.

1 стартмани

05.12.2017    7839    16    timothy_    3    

Обфускация кода 1С

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обфускация кода 1С как вариант защиты кода.

10 стартмани

09.10.2017    31042    76    VsHome    5    

Обезличивание базы данных для КАМИН:Зарплата для бизнеса 4

Обработка справочников Защита и шифрование Управление персоналом (HRM) Управление персоналом (HRM) v8 1cv8.cf БУ Абонемент ($m)

Данная обработка обезличивает Вашу информационную базу данных. Это значит, что все фамилии, имена, отчества, ИНН, СНИЛС, серии и номера документов, будут заменены случайным набором символов.

1 стартмани

26.06.2017    8428    3    juricher    2    

"Набор юного строителя" для реализации внутреннего шифрования и ЭЦП

Универсальные обработки Документооборот и делопроизводство Защита и шифрование Документооборот и делопроизводство v8 1cv8.cf Абонемент ($m)

Набор процедур и функций для организации внутрикорпоративного документооборота и согласования.

1 стартмани

09.06.2017    12932    28    eskor    7    

Обезличивание базы данных средствами скрипта для MSSQL

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для сотрудников, которым необходимо подготовить обезличенную базу для передачи ее сторонним лицам. Для пользования обработкой необходимо запустить 1С: предприятие в режиме тонкого клиента управляемого приложения. Тестировалась обработка на 1С:Предприятие 8.3 (8.3.8.2088) Обработка генерирует SQL - скрипт на основе структуры метаданных.

10 стартмани

28.02.2017    11867    27    ZadachNik1C    1    

HMAC на встроенном языке 1С

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Внешняя обработка хеширования данных HMAC (SHA-1, MD5, SHA-256, CRC-32) без использования внешних компонент.

1 стартмани

25.02.2017    23678    63    Knup    35    

Шифрование и расшифровка строковых полей справочников методом Виженера (с улучшениями)

Защита и шифрование Обработка справочников v8 1cv8.cf Абонемент ($m)

Обработка по шифрованию и расшифровке строковых полей справочников модифицированным методом Виженера - реализация без внешних компонент, без com-объектов, чистый 1С.

1 стартмани

27.04.2016    29031    37    NikitaXa    17    

Защита разработок от копирования (Обычная и Управляемая форма)

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Вы разработчик, и разработали чудесный алгоритм, но не хотите ни с кем с ним делиться - используйте данную разработку, и тогда предполагаемый злоумышленник, глядя на такой код, просто плюнет и начнет писать свой.

1 стартмани

28.03.2016    36415    319    karpik666    123    

Двухфакторная аутентификация в 1С

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Двухфакторная аутентификация (2FA) — это механизм, который позволяет защитить ваш аккаунт надежнее, чем традиционный пароль. Пароль должен быть сложным, при этом его нужно всегда помнить, хранить от посторонних глаз и достаточно часто менять. Но даже если вы принимаете все меры, пароль все равно остается уязвимым — например, для вирусов, которые могут перехватить то, что вы набираете на клавиатуре.

1 стартмани

16.02.2016    32752    136    Юрий-К    20    

Генератор сертификатов

Универсальные обработки Защита и шифрование v8 1cv8.cf Абонемент ($m)

Недавно пришлось организовывать обмен шифрованными сообщениями в 1С, при этом кучу времени заняла процедура создания сертификатов для работы с "Менеджером криптографии". Как итог сделал небольшую обработку для генерации разных типов сертификатов.

3 стартмани

27.01.2016    18108    28    eskor    5    

Обфускация кода 1С (приведение в нечитаемый вид) для платформы 1С:Предприятие 8.3.7

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка для обфуксации (приведения в нечитаемый вид) кода 1С, это может использоваться как один из способов защиты программных модулей.

1 стартмани

20.12.2015    37999    308    masterkio    106    

Обфускация данных в 1С

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Часто возникает ситуация, когда программист просит предоставить базу данных. Но по соображениям безопасности не хочется показывать ему какую-то информацию. Эта обработка перетасует случайным образом строковые реквизиты справочников. Информация станет нечитаемой.

1 стартмани

03.11.2015    15286    41    kser87    25    

Двухфакторная аутентификация с помощью мессенджера Telegram

Информационная безопасность Защита и шифрование Внешние источники данных v8 Россия Абонемент ($m)

Повесть о том, как приручить бота из Telegram для аутентификации пользователей при входе в приложение 1С.

1 стартмани

29.10.2015    25971    67    id-mt    12    

Подсистема шифрования данных + пример реализации: решение Keystore для хранения паролей

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Настоящая публикация представляет собой одновременно подсистему функциональности шифрования данных и готовое к использованию решение для хранения паролей в качестве примера реализации работы подсистемы.

3 стартмани

23.06.2015    16958    9    alex271    3    

Ключ защиты из USB накопителя для 8.3

Информационная безопасность Защита и шифрование v8 1cv8.cf Абонемент ($m)

Ключ защиты конфигурации из обычной USB-флешки для платформы 8.3. Можно внедрить на любой конфигурации, и ключик не привязывается к определенному рабочему месту. Реализовано в Такси.

5 стартмани

31.05.2015    34214    24    Naposaram    57    

Шифрование текста, хеш сумма

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Этот пример показывает, что использование шифрования и получение хеш суммы очень просто. В обработке реализовано шифрование по алгоритму AES и получение хеш суммы MD5. Все делается динамически, без использования файлов.

2 стартмани

15.04.2015    21756    45    MherArsh    22    

Сжатие текстов исключительно средствами языка 1С

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка упаковывает текст и делает его в виде исполняемого SFX. Область применения: Just for fun Побаловался на досуге, размял мозг. Можно применять для упаковки и нечитаемости текстов процедур и функций, или запросов

1 стартмани

25.11.2014    13403    7    eugeniezheludkov    5    

Простое симметричное шифрование табличным смещением

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Данные шифруются одним из самых простых симметричных алгоритмов, в котором зашифрованный символ получается путем смещения исходного символа на дельту.

1 стартмани

06.10.2014    12995    5    insidex    3    

Шредер - не удобочитаемый код 1с

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Нужно сделать текст 1с нечитабельным - не вопрос!

1 стартмани

21.08.2014    15694    33    ivn75    18    

Элементарное шифрование

Защита и шифрование v8 Абонемент ($m)

Алгоритм шифрования - простая перестановка

1 стартмани

11.02.2014    14678    3    sdn-1    3    

Удаление информации по сотрудникам

Чистка базы Обработка документов Защита и шифрование Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 УПП1 Абонемент ($m)

4 обработки для удаления (обезличивания) данных по зарплате сотрудников из информационной базы

1 стартмани

09.01.2014    12959    8    FullMoon    2    

Пример асимметричного шифрования(RSA) 1С:Предприятие 8

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка является примером работы с RSA.

1 стартмани

02.03.2013    23051    54    windows98a    7    

Пример использования электронной цифровой подписи(RSA) 1С:Предприятие 8

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Обработка является примером работы с RSA.

1 стартмани

02.03.2013    17814    23    windows98a    2