Выбор даты

Публикация № 1043386

Разработка - Обработки - Универсальные обработки

дата секунда минута день выбор

5
Обработка для удобного выбора даты и времени.

Основные параметры выбора даты:

  • Заголовок
  • Дата - дата по умолчанию, ели не заполнена, то будет текущая
  • МинПорогЧаса - минимально выводимый час
  • МаксПорогЧаса - максимально выводимый час
  • ШагМинут - шаг с которым будут выводится минуты
  • ШагСекунд - шаг с которым будут выводится секунды
  • ОтображатьЧасы - признак отображения элемента часов
  • ОтображатьМинуты - признак отображения элемента минут
  • ОтображатьСекунды - признак отображения элемента секунд

Пример использования:

&НаКлиенте
Процедура ДатаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	СтандартнаяОбработка=Ложь;
	
	ПараметрыВыбораДаты=Новый Структура;
	ПараметрыВыбораДаты.Вставить("Заголовок","Выберите дату");
	ПараметрыВыбораДаты.Вставить("Дата",Объект.Дата);
	ПараметрыВыбораДаты.Вставить("МинПорогЧаса",8);
	ПараметрыВыбораДаты.Вставить("МаксПорогЧаса",20);
	ПараметрыВыбораДаты.Вставить("ШагМинут",10);
	ПараметрыВыбораДаты.Вставить("ОтображатьСекунды",Ложь);	
	
	ОповещениеОЗакрытии=Новый ОписаниеОповещения("ВыборДатыЗавершение",ЭтаФорма);
	
	ОткрытьФорму("Обработка.ВыборДаты.Форма",ПараметрыВыбораДаты,Элемент,,,,ОповещениеОЗакрытии,РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
КонецПроцедуры

&НаКлиенте
Процедура ВыборДатыЗавершение(РезультатЗакрытия,ДополнительныеПараметры) Экспорт
	Если РезультатЗакрытия<>Неопределено Тогда
		Объект.Дата=РезультатЗакрытия;		
	КонецЕсли;	
КонецПроцедуры

Некоторые особенности:

  • При интерактивном выборе даты и ее частей, автоматически заполняется поле с датой рядом с кнопкой "Принять". Именно дата из этого поля и будет в итоге возвращена. Ее можно, при желании, отредактировать вручную.
  • Переданная в обработку дата заполняется в поле рядом с кнопкой "Принять", заполняется полностью и не зависит от порогов и прочих параметров.
  • При открытии формы, значения элементов выбора частей даты подстраиваются под переданную в обработку дату. При этом берется ближайшее значение: либо равное, либо ДО переданной даты. Скажем передали дату 14.04.2019 16:25:00, в параметрах указали шаг для минут = 10, в итоге значение элемента с позиционируется на 20 минутах.

Обработка разрабатывалась и тестировалась на версии платформы 8.3.12, на конфигурации без режима совместимости и под управляемым приложением.

5

Скачать файлы

Наименование Файл Версия Размер
Выбор даты:
.epf 8,43Kb
14.04.19
0
.epf 8,43Kb Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. blindcat2006 67 16.04.19 08:12 Сейчас в теме
(1) Тут вариант удобнее ИМХО
Оставьте свое сообщение