Доработка конфигурации Конвертация Данных (вер. 2.1.5.1)

Публикация № 103008

Программирование - Инструментарий

39
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1): 1) появляющиеся подсказки по обработчикам 2) аналог "Найти в списке" 3) историю переходов по объектам ПКО

Собственную адаптацию конфигурации Конвертация Данных я проводил на уже доработанной конфигурации, взятой из статьи Totoro //catalog.mista.ru/public/72813/. Поэтому мой cf-шник содержит разработки Tormozit и Totoro

Теперь отдельно о небольших моих доработках.

1) Добавил в конфигурацию измененную обработку "Информация об обработчиках_2", в которой изменил цветовое выделение слов в отличие от типовой. Изменил вызов обработки: теперь при открытии любого обработчика события появляется окно, информирующее о доступных параметрах обработчика.

Реализовано так: в процедурах "...АлгоритмыПриСменеСтраницы" прописал вызов обработки "Информация об обработчиках_2":

Процедура ПанельАлгоритмыПриСменеСтраницы(Элемент, ТекущаяСтраница)

   
ОбновитьПиктограммыАлгоритмов(мМассивОбработчиков, ЭлементыФормы.ПанельАлгоритмы, ЭлементыФормы);
   
//гумеров
   
ОткрытьОписаниеОбработчикаСобытия("ПравилаВыгрузкиДанных", ЭлементыФормы.ПанельАлгоритмы.ТекущаяСтраница.Имя, ЭтаФорма);

КонецПроцедуры
// ПанельАлгоритмыПриСменеСтраницы()

Процедура ОткрытьОписаниеОбработчикаСобытия имеет следующий код:

Процедура ОткрытьОписаниеОбработчикаСобытия(ИмяОбъекта, ИмяОбработчика, ФормаВладелец = Неопределено) Экспорт

   
ФормаПросмотра = Обработки.ИнформацияОбОбработчиках_2.ПолучитьФорму("Форма",ФормаВладелец);
   
//Если ФормаПросмотра.Открыта() Тогда
    //    ФормаПросмотра.Закрыть();
    //КонецЕсли;
   
ФормаПросмотра.РазделДляОткрытия = ИмяОбъекта + ИмяОбработчика;
   
ФормаПросмотра.Открыть();

КонецПроцедуры
// ОткрытьОписаниеОбработчиковСобытий()

2) Добавил в конфигурацию аналог "Найти объект в списке" - когда из любого окна обработчика события можно перейти в окно правил обмена,например, на соответствующий объект ПКО.

Реализовано по кнопке "Конвертация":

Процедура КоманднаяПанель1Действие4(Кнопка)

   
ОбщаяФорма = ПолучитьОбщуюФорму("ПравилаОбмена");
   
ОбщаяФорма.Конвертация = ЭтотОбъект.Владелец;
   
ОбщаяФорма.Открыть();

   
ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.ТекущаяСтраница = ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.Страницы.ПВД;
   
ОбщаяФорма.ЭлементыФормы.ПравилаВыгрузкиДанных.ТекущаяСтрока = Ссылка;

КонецПроцедуры

3) Добавил историю переходов по объектам ПКО - теперь не приходится искать объекты ПКО перелистыванием строк списка ПКО, достаточно выбрать объект ПКО в окне истории.

//ведение истории
Процедура ПравилаКонвертацииОбъектовПриАктивизацииСтроки(Элемент)

    Если
Элемент.ТекущиеДанные = Неопределено Тогда
        Возврат;
    КонецЕсли;

   
// гумеров начало блока
   
Если НЕ Элемент.ТекущиеДанные.Ссылка.ЭтоГруппа И История.Найти(Элемент.ТекущиеДанные.Ссылка, "СсылкаПКО") = Неопределено Тогда
       
История.Добавить().СсылкаПКО = Элемент.ТекущиеДанные.Ссылка;
    КонецЕсли;

   
// гумеров конец блока

   
...

КонецПроцедуры


//позиционирование на нужном ПКО
Процедура ИсторияПриАктивизацииСтроки(Элемент)
   
ЭлементыФормы.ПравилаКонвертацииОбъектов.ТекущаяСтрока = ЭлементыФормы.История.ТекущиеДанные.СсылкаПКО;
КонецПроцедуры


См. также:

Как эффективно использовать Инфостарт NEW!

Список реализаций + структура подчиненности + реестр документов SALE'1sm

Список заказов поставщикам + структура подчиненности SALE'1sm

Список заказов покупателей + структура подчиненности SALE'1sm

Договоры для 1с-ника ТОП-скачиваний

Сетка расписания (Планировщик) нестанДАрт

Два механизма, которые ускорили работу бухгалтеров в 1С нестанДАрт

Мини-CRM для УТ 10.3

Расчет банковских (рабочих) дней нестанДАрт

Шаблоны кода в режиме 1С:Предприятие SALE'1sm

Доработка конфигурации Конвертация Данных

Планирование платежей. Прогнозирование прибылей и убытков

Ввод показателей план-факта БП 3.0 Know-how

Инвентаризация личного опыта Для новичков 1С

Большие запросы: взгляд на проблему нестанДАрт

Технология создания коммерческих разработок Know-how

Андроид-решение для создания заказов в 1С Know-how + нестанДАрт

Отчет Остатки и цены

Печать ценников с одной и двумя ценами 55х40, 100х60, 140х200

Загрузка данных о розничных продажах из магазинов Intimissimi (Интимиссими) и Calzedonia (Кальцедония)

Доработки обмена "УТ 10.3 - интернет-магазина Shop-Script"

39

Скачать файлы

Наименование Файл Версия Размер
Информация об обработчиках_2.epf
.epf 220,39Kb
06.03.18
97
.epf 220,39Kb 97 Скачать
cf-шник для адаптации
.cf 8,00Mb
06.03.18
80
.cf 8,00Mb 80 Скачать

См. также

Специальные предложения

Лучшие комментарии
0. Rustig 1166 24.12.11 21:35 Сейчас в теме
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО


Перейти к публикации

21. Rustig 1166 27.11.18 15:31 Сейчас в теме
(20) сравнивать и обновлять надо только на версию 2.1.5.1.
Я кстати тестировал сравнить/объединить на версию 2.1.8.2 - у меня получилось.
22. Rustig 1166 27.11.18 15:39 Сейчас в теме
(20) на новую версию КД 3.0 обновлять нельзя!!!
Остальные комментарии
Избранное Подписка Сортировка: Древо
0. Rustig 1166 24.12.11 21:35 Сейчас в теме
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО


Перейти к публикации

1. Поручик 4277 24.12.11 21:35 Сейчас в теме
(0) Вещь полезная. Для релиза КД 2.1.5.1 пойдёт?
2. Rustig 1166 24.12.11 21:38 Сейчас в теме
(1) у меня как раз релиз 2.1.5.1.
5. fomix 26 26.12.11 11:44 Сейчас в теме
(2) Что-то я не понял для чего эта штука в КД?! Может поподробнее опишете... Заранее спасибо!
6. Rustig 1166 26.12.11 13:14 Сейчас в теме
(5) Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД. А если соответственно не работаете вплотную, например, через раз или вообще чаще используете типовые сценарии обмена, тогда возможно не стоит тратить время на доработку КД.
10. KliMich 05.02.12 20:30 Сейчас в теме
(6)
Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД
Прямо в точку! Респект! Очень нужная доработка.

P.S. Как дополнение (может кому пригодиться), для КД типа 77 -> 82 использую
"Запись текста модуля ерт-файла из текстового файла" http://infostart.ru/public/78941/ от Абадонна (за что ему огромный респект)
3. ogeniv 25.12.11 11:07 Сейчас в теме
Интересная штука, подсказки и переход по объектам будут полезны
4. Kochevnic 25.12.11 18:54 Сейчас в теме
Спасибо! Попробуем на практике
7. Модератор раздела artbear 23.01.12 17:45 Сейчас в теме
Хорошие доработки.
Пожалуйста, добавь в название и в описание инфу о конкретной версии КД, для которой подходит публикация.
2.1.5.1
8. Мощный 23.01.12 21:22 Сейчас в теме
Даж заманчиво, попробовать что ле ?
9. WendyH 28.01.12 08:30 Сейчас в теме
Тогда, желательно, в описании перечислить ВСЕ отличия от типовой. Измменения tormizit и Ваши.
11. Мощный 10.02.12 10:27 Сейчас в теме
Есть ли какая нибудь возможность настройки для выскакивающих при переходе на обработчики по свойствам описаний.. Наверное, иногла это и бывают удобным, но когда попрыгаешь по свойствам десятки, сотни раз, то тут вот количество клацеы увеличивается в два раза.. Зайти в свойства-выйти из описания.. Не предусмотрена ли у вас где-нибудь настройка для включения и отключения..
Конечно и сам могу отцепить, но м.быть есть настройка..
13. Rustig 1166 13.02.12 11:11 Сейчас в теме
(11), (12) добрый день, Мощный! видел все ваши сообщения, спасибо за обратную связь.
По поводу доработок, увы, на них нет времени. Все в ваших руках. Я даже в последнее время занимаюсь всеми задачами кроме связанных с КД. Поэтому специально переключаться на КД, доработку КД, новое выкладывание на ИС - нет планов. А вообще, разве нельзя через правую кнопку закрыть все соединяемые окна единоразово? Аналогичная ситуация с окнами возникает, когда вы открываете расшифровки в рег.отчетах в конфигурации по бухгалтерии. И в этих конфах нет настройки, которую вы просите. Так что, может "оно и не надо".
15. Мощный 13.02.12 19:30 Сейчас в теме
(13) Ок, траблы Ваши понятны, буду сам..
касаемо "нужно или не нужно" отвечу однозначно "нужно".. Переходы по свойствам даже за день в обьеме достигают нескольких сотен.. Можно конечно, сбрасывать через ESC, но предел терпения достигается слишком быстро.. увы..
12. Мощный 12.02.12 13:31 Сейчас в теме
И как же достучаться до автора
14. a4a 13.02.12 11:50 Сейчас в теме
Пытаюсь работать с конфигурацией "Конвертация данных", очень востребован ее функционал. Но не могу похвастать, что удается так сразу в ней разобраться как следует, а очень хочется. Поэтому очень приветствую разработку, усиливающую ее возможности. Спасибо!
16. AlexKoso 17 27.02.12 09:42 Сейчас в теме
Сначала накатил изменения, поюзал...и понял что ни к чему мне автоматически выскакивающее окно со справкой. В итоге в типовую обработку Информация об обработчика вставил макеты Рустема, а вызов справки сделал по Ctrl + F1. На том и спасибо :)
17. tehas 47 10.03.12 21:19 Сейчас в теме
Ща гляну, кстати ни кто не посоветует учебник с примерами по КД 2.1 желательно в электронном виде, а если у кого есть буду благодарен
19. AlexO 126 19.03.13 16:10 Сейчас в теме
(17) tehas,
кстати ни кто не посоветует учебник с примерами по КД 2.1

По КД нет учебников.
Есть куцая книжка Бояркина и немного инфы в инете.
Ну и да, различные веселые супер-пупер курсы.
18. tehas 47 08.08.12 11:16 Сейчас в теме
удобно, ни чего не скажешь )
20. dave2000 91 27.11.18 13:25 Сейчас в теме
Как её правильно обновлять? Просто сравнить/объединить на на свою КД?
21. Rustig 1166 27.11.18 15:31 Сейчас в теме
(20) сравнивать и обновлять надо только на версию 2.1.5.1.
Я кстати тестировал сравнить/объединить на версию 2.1.8.2 - у меня получилось.
22. Rustig 1166 27.11.18 15:39 Сейчас в теме
(20) на новую версию КД 3.0 обновлять нельзя!!!
Оставьте свое сообщение